OPRO X Designer (OXD) とは

OPRO X Designer

OPRO X Designer (略称 OXD) は、ドキュメントデザインを設計する GUI ツールです。OXD を使用すると、OXS の生成するドキュメントのベースとなるテンプレートを開発することができます。OXS は、このテンプレートの設計に従って、OXS に接続されたデータベースや CSV ファイルなど、様々なソースから情報を読み込み、ドキュメントを作成します。

概要
OXDの特徴、および、略称などについて説明しています。
セットアップ
OXDのシステム要件、および、インストール・アンインストール方法について説明しています。
インターフェイス
OXDのメニューやダイアログなどのインターフェイスについて説明しています。
テンプレートとコンポーネント
OXDのテンプレート及びコンポーネントについて説明しています。
よくある質問(FAQ)
よくある質問とその回答をまとめています。


概要

ここでは、OXDの特徴やOPRO X Designer、および、略称などについて説明します。

特徴
OXDの特徴的な機能について説明しています。
OXDチュートリアル
OXDのチュートリアルです。
計算式と条件式
OXDで使用可能な計算式と条件式について説明しています。
略称一覧
ヘルプファイル等で使用する略称の一覧です。


OPRO X Designer の特徴

OPRO X Designer には、以下に示すユニークな機能があります。

OPRO File Manager Service アドミニストレータ (OFMSA)

OFMSは、プラットフォームが混在する環境でテンプレートを保存するためのOXSの機能です。OFMSAは、OFMSを管理するためのツールです。

クエリビルダ

OXS に接続されたデータベースを抽象化して、GUI による操作でクエリを作成することができるツールです。

テンプレート ウィザード

SubReport、テーブルのグループ化、グラフ作成、Datasetの変更等、複雑なコンポーネント、フォームの作成プロセスを容易にします。

マルチレイアウト

ひとつのテンプレートに複数のレイアウトページを作成できます。

縦書きラベル

横書きのテキストだけでなく、縦書きのテキストを表示できます。

ドキュメントのプレビュー

テンプレート設計の途中でも、簡単にドキュメントのプレビューが行えます。

OXSに完全準拠

OXDで作成するテンプレートは、OXSが提供するすべての機能を利用できます。


チュートリアル

このチュートリアルでは、OXD の初期設定、OXS が適切にインストールされているかどうかの確認方法、および、簡単なテンプレートの作成手順について説明します。

OXD の初期設定を行なうには

  1. 製品 CD に含まれているファイル「oxd270xx.exe」（xx はパッチ番号）を実行すると、OXD がインストールされます。
  2. OXD は、Windows の「スタート」メニューの「プログラム」から起動できます。
  3. OXD を初めて実行すると、シリアルキーの入力を求めるダイアログが表示されます。シリアルキーは、製品 CD のファイル「serial.txt」に記述されています。
  4. ドキュメントを生成するには、OXS の CGI、または、サーブレットを指定する必要があります。「オプション」メニューの「環境設定／全般」タブを選択し、「OXS CGI／サーブレット」の URL に CGI、または、サーブレットの URL を指定します。

上記手順で、OXD の基本設定は完了します。

OXS が適切にインストールされているかどうかを確認するには

  1. OXD を起動し、新規テンプレートを作成します。
  2. 「Label」コンポーネントをテンプレートに配置します。
  3. 「Label」プロパティの「内容」に任意のテキストを入力します。
  4. 「ファイル」メニューの「上書き保存」オプションを選択し、テンプレートを保存します。
  5. 保存したテンプレートをサーバのテンプレートフォルダ(※1)にコピーします。これで、このテンプレートを OXS から使用できます。
  6. 「オプション」メニューから「サンプルHTMLの作成」オプションを選択し、「表示」ボタンをクリックしてサンプルHTMLを作成します。「操作」( ダウンロード等 )を選択し、必要な「出力形式」にチェックを入れて「作成」ボタンをクリックします。
  7. リクエストした形式で表示(※2)されれば、OXS は適切に動作しています。

※1 : OXS のインストールディレクトリ以下の conf ディレクトリにある設定ファイル「ODCAW.xml」内で設定されているテンプレートフォルダに保存します( デフォルトでは odcawtemplates )。

※2 : テンプレートを OPR 形式で表示するには、OXB をインストールする必要があります。PDF のみのライセンスがあるため、ライセンス契約書を確認してください。

DatasetTable を含む簡単なテンプレートを作成するには

  1. OXD を起動し、新規テンプレートを作成します。
  2. 「Dataset」コンポーネントを配置し、コンポーネントをダブルクリックします。
  3. OSMS ログインダイアログが表示されるので、ユーザ名とパスワードを入力し、ログインします(※3)。
  4. クエリビルダが起動し、OXS に接続された全データベースが左枠に表示されます。
  5. データベースを選択し、データベース内にあるテーブルの一覧から、使用するテーブルをダブルクリック、または、右枠の作業領域にドラッグします。
  6. 「すべてのフィールドの追加」ボタン [image] をクリックし、すべてのフィールドを Dataset に追加します( 「結果の表示」ボタン [image] をクリックすると、テーブルデータの内容を確認表示できます )。
  7. クエリの作成が完了したらクエリビルダを「OK」ボタンで閉じ、テンプレートの作業領域に戻ります。
  8. 「DatasetTable」コンポーネントを選択し、テンプレートに配置します。
  9. DatasetTable を選択し、「カスタム」プロパティの「Dataset」ドロップダウンから「Dataset1」を選択します。
  10. 次に、テンプレート上で Dataset を選択すると、プロパティエディタに選択可能フィールドが「フィールドの情報」にツリー形式で表示されます。
  11. フィールドを DatasetTable 内のカラムへ直接ドラッグ＆ドロップするか、カラムに「Label」コンポーネントを配置してプロパティエディタで「内容／タイプ」を「Database」に指定し、「Dataset」と「フィールド」を選択します。
  12. ローとカラムの境界線は、DatasetTable の「罫線」プロパティで設定できます。
  13. 「プレビュー」ボタン [image] をクリックしてドキュメントを生成します。

※3 : OSMS ( OPRO Schema Management Service )は、OXS のサービスの一つで、データベースのスキーマ情報を管理しています。ユーザ名とパスワードは「ODCAW.xml」で設定します。


計算式と条件式

TextDatasetとURLTextDatasetのフィールドで使用できる計算式と条件式について説明します。関数の一部はDatasetでも使用できますが、その場合は、式が個々のデータベースのSQLで使用可能であることが前提になります。

計算式

{USERINPUT} | ユーザによる入力値が必要な部分には {USERINPUT} を使用します。{USERINPUT} を使用した場合は、リクエスト時に入力値を指定する必要があります。
'P' | 文字列が関数名やフィールド名として扱われないようにします。TextDatasetとURLTextDatasetでは、文字列中に「'」が含まれる場合は二重化「''」してください。Datasetの場合は、個々のデータベースの仕様を参照してください。
P + Q | 値 P に値 Q を加算します。
P - Q | 値 P から値 Q を減算します。
P * Q | 値 Q を値 P に乗算します。
P / Q | 値 P を値 Q で除算します。
P || Q | P と Q の二つの文字列を結合します。TextDatasetとURLTextDatasetでは「P & Q」という表現も使用できます。
CONCATENATE(string1, string2, ..., stringN) | 文字列 string1, string2, ..., stringN を結合した文字列を返します。
LEN(string) | 文字列 string の文字数を取得します。
LENB(string) | 文字列 string のシフトJISでのバイト数を取得します。
ISEMPTY(string) | 文字列 string が空であるかどうかをブール値で返します。
CONTAINS(string1, string2) | 文字列 string1 が文字列 string2 を含むかどうかをブール値で返します。
STARTSWITH(string1, string2) | 文字列 string1 が文字列 string2 で始まるかどうかをブール値で返します。
ENDSWITH(string1, string2) | 文字列 string1 が文字列 string2 で終わるかどうかをブール値で返します。
SUBSTRING(string, x, y) | 文字列 string の位置 x から長さ y の文字列を取り出します。先頭の文字の位置が 1 です。
MID(string, x, y) | 文字列 string の位置 x から長さ y の文字列を取り出します。先頭の文字の位置が 1 です。
LEFT(string, y) | 文字列 string の先頭から長さ y の文字列を取り出します。
RIGHT(string, y) | 文字列 string の末尾から長さ y の文字列を取り出します。
SUBSTRINGB(string, x, y) | 文字列 string の位置 x からシフトJISで y バイトの文字列を取り出します。先頭の文字の位置が 1 です。
MIDB(string, x, y) | 文字列 string の位置 x からシフトJISで y バイトの文字列を取り出します。先頭の文字の位置が 1 です。
LEFTB(string, y) | 文字列 string の先頭からシフトJISで y バイトの文字列を取り出します。
RIGHTB(string, y) | 文字列 string の末尾からシフトJISで y バイトの文字列を取り出します。
SEARCH(string1, string2) | 文字列 string1 内で文字列 string2 を検索し、見つかった先頭の位置を返します。見つからない場合は 0 を返します。
SUBSTITUTE(string1, string2, string3) | 文字列 string1 内の文字列 string2 を文字列 string3 ですべて置換します。
FIND(string1, string2) | 文字列 string1 が正規表現 string2 にマッチするかどうかをブール値で返します。
REPLACEALL(string1, string2, string3) | 文字列 string1 の正規表現 string2 にマッチする部分を文字列 string3 ですべて置換します。
REPLACEFIRST(string1, string2, string3) | 文字列 string1 の正規表現 string2 に最初にマッチする部分を文字列 string3 で置換します。
REPT(string, n) | 文字列 string を n 回繰り返した文字列を返します。
TRIM(string) | 文字列 string の先頭と末尾の空白を削除した文字列を返します。
LOWER(string) | 文字列 string の内容をすべて小文字にした文字列を返します。
UPPER(string) | 文字列 string の内容をすべて大文字にした文字列を返します。
CHAR(c) | 数値 c をコードポイントとする Unicode 文字を返します。
IF(condition, value1, value2) | 条件 condition の値がブール値で真のとき value1 を返し、偽のとき value2 を返します。
ISNUMBER(string) | 文字列 string が数値を表わすかどうかをブール値で返します。
CEILING(x, n) | 数値 x を小数点第 n 位で切り上げた数値を返します。
FLOOR(x) | 数値 x を小数点第 n 位で切り下げた数値を返します。
ROUND(x) | 数値 x を小数点第 n 位で四捨五入した数値を返します。
ROUNDEVEN(x) | 数値 x を小数点第 n 位で偶数への丸め (銀行方式の丸め) をした数値を返します。
ABS(x) | 数値 x の絶対値を返します。
SIGN(x) | 数値 x の符号値 (正のとき 1、負のとき -1、0 のとき 0) を返します。
MOD(x, y) | 数値 x を数値 y で割ったときの剰余を返します。
POWER(x, n) | 数値 x を n 乗した数値を返します。
SQRT(x) | 数値 x の平方根を返します。
EXP(x) | 自然対数の底を x 乗した数値を返します。
LN(x) | 数値 x の自然対数を返します。
LOG(x) | 数値 x の 10 を底とする対数を返します。
TO_NUMBER(string) | 文字列 string を数値とみなしたときの数値を返します。
FORMAT_NUMBER(x, format) | 数値 x をフォーマット format で文字列化した文字列を返します。
ISDATE(string) | 文字列 string が日時を表わすかどうかをブール値で返します。
YEAR(d) | 日時値 d の年の値を数値で返します。
MONTH(d) | 日時値 d の月の値を数値で返します。
DAY(d) | 日時値 d の日の値を数値で返します。
HOUR(d) | 日時値 d の時の値を数値で返します。
MINUTE(d) | 日時値 d の分の値を数値で返します。
SECOND(d) | 日時値 d の秒の値を数値で返します。
TO_DATE(string) | 文字列 string を日時とみなしたときの日時値を返します。
FORMAT_DATE(d, format) | 日時値 d をフォーマット format で文字列化した文字列を返します。
NOW() | 現在日時の日時値を返します。
TODAY() | 現在日の午前 0 時の日時値を返します。

条件式

P = Q | P と Q を比較して、等しいかどうかをチェックします。TextDatasetとURLTextDatasetでは「P == Q」という表現も使用できます。
P > Q | P と Q を比較して、P が Q より大きいかどうかをチェックします。
P >= Q | P と Q を比較して、P が Qより大きいか、または、等しいかをチェックします。
P < Q | P と Q を比較して、P が Q より小さいかどうかをチェックします。
P <= Q | P と Q を比較して、P が Q より小さいか、または等しいかをチェックします。
P <> Q | P と Q を比較して、等しくないかどうかをチェックします。TextDatasetとURLTextDatasetでは「P != Q」という表現も使用できます。
P AND Q | P と Q がともに真のとき真を、それ以外は偽を返します。
P OR Q | P と Q のともに偽のとき偽を、それ以外は真を返します。
NOT P | P が真のとき偽を、偽のとき真を返します。
P LIKE Q | (Datasetのみ) P が Q に適合をするかどうかをチェックします。

※フィールド名に記号文字が含まれる場合は、ダブルクォテーションマーク「"」でフィールド名を括ってください。

※記述中の「シフトJIS」は、Windows コードページ 932 (Windows-31J) を指します。


略称一覧

略称 | 正式名称
CGI | Common Gateway Interface
CSV | Comma Separated Values
HTML | Hyper Text Markup Language
OCCS | OPRO Content Control Service
OFD | OPRO Form Data
OFMS | OPRO File Manager Service
OPR | OPRO Print Report
OXR | OPRO XML Report
OXB | OPRO X Browser
OXD | OPRO X Designer
OXS | OPRO X Server
OXT | OPRO XML Template
OXV | OPRO X Viewer
PDF | Adobe Portable Document Format
XML | Extensible Markup Language
XSL | Extensible Stylesheet Language
XSLT | Extensible Stylesheet Language Transformations
ODP | OPRO Direct Print


セットアップ

ここでは、OXDのセットアップに必要なシステム要件、および、インストール方法・アンインストール方法について説明します。

システム要件
OXDのセットアップに必要なハードウェア要件、ソフトウェア要件について説明しています。
インストール
OXDのインストール方法について説明しています。
アンインストール
OXDのアンインストール方法について説明しています。


システム要件

ハードウェア要件

ハードウェア | 要件
メモリ | 256MB 以上
CPU | Intel Pentium III, 500MHz 以上 （1 GHz以上を推奨）
ハードディスクの空き容量 | インストールには 40MB 以上の空き容量が必要。 動作には 100MB 以上の空き容量を推奨。

ソフトウェア要件

ソフトウェア | 要件
OS | Windows 7 Professional, Windows Server 2008 Standard/Enterprise Edition (SP1), Windows Vista Business (SP1), Windows Server 2003 Standard/Enterprise Edition (SP1, SP2, R2), Windows XP Professional (SP1, SP2, SP3), Windows 2000 Professional/Server/Advanced Server (SP4 以上) 但し、Internet Explorer 5.5 以上が必要です。


OXDのインストール

システム要件を満たしていれば、OXDのインストールを開始できます。ダウンロードした、または、OXDの製品CDにあるセットアッププログラム(例：oxd27000.exe)を実行し、インストーラの指示に従って作業を進めてください。セットアップ開始前にすべてのアプリケーションを終了しておくことを推奨します。インストールを実行するユーザにはインストールフォルダへの書き込み権限が必要です。

以降は、インストールガイドの画面について記述しています。実際の画面は、インストールするマシン環境やOXDのバージョンによって異なる場合があります。

1. ウィザードへようこそ

セットアッププログラムを実行し、インストーラが起動すると、「OPRO X Designer用のInstallShieldウィザードへようこそ」画面が開かれます。

「次へ」ボタンをクリックして、進めます。

2. 使用許諾契約

「使用許諾契約」画面で、製品の使用許諾契約の内容をすべて読み、同意する場合は「使用許諾契約の条項に同意します」オプションにチェックを入れ、「次へ」ボタンをクリックして先へ進めます。

3. ユーザ情報

「ユーザ情報」画面で、「ユーザ名」と「所属」を入力します。OSから取得された情報をインストーラがあらかじめ表示しています。必要なら変更し、「次へ」ボタンをクリックします。

4. インストール先のフォルダ

「インストール先のフォルダ」画面で、OXDのインストール先を指定します。変更する場合は「変更」ボタンをクリックし、インストール先フォルダを指定します。通常はデフォルトのまま、「次へ」ボタンをクリックします。

「変更」ボタンをクリックすると、「インストール先のフォルダの変更」ダイアログが現れます。インストールしたいフォルダを選択するか、フォルダ名を入力して新規フォルダを作成することもできます。

5. インストール準備完了

「プログラムをインストールする準備ができました」画面で、ここまでに指定したインストール設定を確認し、問題なければ、「インストール」ボタンをクリックして、インストールを開始します。

6. ウィザードの完了

無事インストール完了すると、「InstallShield ウィザードを完了しました」画面になります。「完了」ボタンをクリックし、終了してください。

セットアップを完了すると、Windowsのスタートメニューから、「プログラム」⇒「OPRO X Designer」に、次の３つのショートカットメニューが登録されます。

  • OPRO X Designer
  • OPRO X Designer Help
  • Read me

7. シリアル番号の入力

スタートメニューから「OPRO X Designer」を起動します。シリアル番号の入力を求めるダイアログが表示されますので、製品CDの「serial.txt」からシリアル番号をコピーして入力してください。

※シリアル番号はあとから変更することができます。「ヘルプ」メニューの「バージョン情報」を参照してください。


OXD のアンインストール

OXD は、コントロールパネルの「プログラムの追加と削除」からアンインストールできます。

「現在インストールされているプログラム」一覧から「OPRO X Designer」を選択し、「削除」ボタンをクリックします。

削除の確認ダイアログが現れ、「はい」ボタンをクリックすると、OXD が削除されます。


インターフェイス

OXDのインターフェイスは、大きく六つのエリアに機能が分かれています。

アプリケーションメニューバー
利用可能なすべてのコマンドが用意されています。
ツール バー
一般的に使用頻度の高いコマンドが配置され、それらの機能をクリック一つで呼び出せます。
コンポーネントパレット
テンプレート上に配置したいコンポーネントを選択するコンポーネント選択エリアです。
テンプレートウィンドウ
コンポーネントを配置し、生成するドキュメントのテンプレートとなるレイアウトを作成するウィンドウです。
プロパティエディタ
テンプレートに配置したコンポーネントのプロパティ値を編集するのに使用します。
テンプレートエクスプローラ
テンプレートに配置されたコンポーネントの一覧をツリー表示します。


インターフェイスについて

アプリケーションメニューバー

アプリケーションメニューバーには七つの主要なメニューがあり、それぞれにサブメニューが用意されています。

主要なメニュー

  • 「ファイル」メニュー
  • 「編集」メニュー
  • 「表示」メニュー
  • 「コンポーネント」メニュー
  • 「オプション」メニュー
  • 「ウィンドウ」メニュー
  • 「ヘルプ」メニュー


「ファイル」メニュー

「ファイル」メニューには、テンプレートに対する操作(新規作成、開く、閉じる、保存)および OXD の終了等があります。

新規作成

新規テンプレートを作成します。

新規テンプレートを作成するには

  1. ツールバーにある「新規作成」ボタン [image] をクリックするか、「ファイル」メニューの「新規作成／新規テンプレート」オプションを選択します。

ショートカットキー： Ctrl + N

メニューから「新規テンプレート」を選択すると、「新規テンプレート」ダイアログが表示されます。このダイアログでは、新規テンプレートのプロパティを指定することができます。このダイアログは「環境設定」オプションで「新規テンプレート ダイアログ」をチェックしておくと現れるようになります。

また、既存テンプレートから新たなテンプレート(フォームのテンプレート、結果のテンプレート)を作成するテンプレート ウィザードを使用することもできます。テンプレート ウィザードは、現在開いているテンプレートを元に、新しいテンプレートを生成するシンプルなコンバータです。

フォームのテンプレート
現在開いているテンプレートから、このテンプレートでドキュメントを生成するためのリクエストを送信するフォーム型テンプレートを生成します。Submit ボタン、Reset ボタンのほかに、OXS へリクエストする際の必須パラメータ DO, OP, FM, TP, ES 等のパラメータを表す Invisible コンポーネント、および、Request タイプのデータへの入力値を与える Text コンポーネント等が追加されます。
結果のテンプレート
現在開いているフォーム型のテンプレートから、同じデザインの静的ドキュメントを生成するためのテンプレートを生成します。このテンプレートに含まれる Text コンポーネント等の入力欄を Label 等の静的コンポーネントに変換し、ボタン類を取り除いたテンプレートが生成されます。

既存テンプレートから新規テンプレートを作成するには

  1. 「ファイル」メニューの「新規作成／現在のテンプレートから作成」オプションを選択します。
  2. ダイアログにしたがって、パラメータの対応関係を設定します。

※テンプレート ウィザードを利用するには、元となるテンプレートがあらかじめ保存されている必要があります。また、テンプレートに使用されているコンポーネントのいずれかのデータタイプが「Request」である必要があります。

レイアウトの追加

既存テンプレートに新規レイアウトを追加します。

レイアウトを追加するには

  1. 「ファイル」メニューの「レイアウトの追加」オプションを選択します。

または

  1. テンプレートの「レイアウト」タグをマウスボタンで右クリックし、ポップアップから「レイアウトの追加」オプションを選択します。

レイアウト名の変更

既存レイアウトに新しく名前をつけます。

レイアウト名を変更するには

  1. 新規または既存のテンプレートを開きます。
  2. ファイルメニューの「レイアウト名の変更」を選択します。
  3. 「レイアウト名の変更」ダイアログに新しい名前を入力し、「OK」ボタンをクリックします。

または

  1. テンプレートの「レイアウト」タブを右クリックし、ポップアップから「レイアウト名の変更」を選択します。
  2. 「レイアウト名の変更」ダイアログに新しい名前を入力し、「OK」ボタンをクリックします。

レイアウトの削除

テンプレートから既存レイアウトを削除します。

レイアウトを削除するには

  1. 複数のレイアウトを含む既存のテンプレートを開きます。
  2. 削除するレイアウトを選択します。
  3. ファイルメニューの「レイアウトの削除」を選択します。
  4. 確認ダイアログで「はい」をクリックすると、選択されたレイアウトが削除されます。

または

  1. 削除したいレイアウトの「レイアウト」タグを右クリックし、ポップアップから「レイアウトの削除」を選択します。
  2. 確認ダイアログで「はい」をクリックすると、選択されたレイアウトが削除されます。

開く

保存されているテンプレートを開きます。テンプレートは、ローカルフォルダまたは OFMS から開くことができます。

保存テンプレートをローカルフォルダから開くには

  1. ツールバーにある「開く」ボタン [image] をクリックするか、「ファイル」メニューの「開く／ローカルから開く」オプションを選択します。

ショートカットキー： Ctrl + O

保存テンプレートを OFMS から開くには

  1. 「ファイル」メニューの「開く／OFMSから開く」オプションを選択します。

ショートカットキー： Ctrl + F

開き直す

以前に保存したテンプレートの一覧から、再度テンプレートを開きます。この一覧の表示数は、「オプション」メニューにある「環境設定」で変更することができます。

テンプレートを開き直すには

  1. 「ファイル」メニューの「開き直す」オプションを選択します。
  2. 開き直すテンプレートを選択します。

※表示可能なテンプレート一覧の最大数は 35 件です。

閉じる

現在選択中のテンプレートを閉じます。

テンプレートを閉じるには

  1. テンプレートの「閉じる」ボタン [image] をクリックするか、「ファイル」メニューの「閉じる」オプションを選択します。

※ 開いているテンプレートが保存されていない場合、OXD から保存を求められます。

ショートカットキー： Ctrl + F4

すべて閉じる

開いているすべてのテンプレートを閉じます。

すべてのテンプレートを閉じるには

  1. 「ファイル」メニューの「すべて閉じる」オプションを選択します。

※開いているテンプレートが保存されていない場合、OXD から保存を求められます。

上書き保存

開いているテンプレートを上書き保存します。

テンプレートを上書き保存するには

  1. ツールバーにある「上書き保存」ボタン [image] をクリックするか、「ファイル」メニューの「上書き保存」オプションを選択します。

ショートカットキー： Ctrl + S

名前を付けて保存

テンプレートをローカルまたは OFMS に保存します。

名前を付けてローカルフォルダに保存するには

  1. 「ファイル」メニューの「名前を付けて保存／ローカルに保存」オプションを選択します。

名前を付けて OFMS に保存するには

  1. 「ファイル」メニューの「名前を付けて保存／OFMSに保存」オプションを選択します。

すべて保存

開かれているすべてのテンプレートを保存します。

すべてのテンプレートを保存するには

  1. テンプレートを編集後、ツールバーにある「すべてのテンプレートを保存」ボタン [image] をクリックするか、「ファイル」メニューの「すべて保存」オプションを選択します。

※一度も保存されていない作成中のテンプレートがある場合、そのテンプレートの保存を要求されます。保存ダイアログが現れるので、ファイル名を入力し、テンプレートを保存します。

プレビュー

編集中のテンプレートを画面上でプレビューします。ユーザは、プレビューするドキュメント形式( OPR、PDF、 HTML、XDW )を選択できます。

テンプレートをプレビューするには

  1. ドキュメントを開きます。
  2. ツールバーにある「プレビュー」ボタン [image] をクリックするか、「ファイル」メニューの「プレビュー」オプションを選択します。

ショートカットキー： Ctrl + P

終了

OXD を終了します。作成中のテンプレートが保存されていない場合、テンプレートの保存を求めるダイアログが表示されます。

OXD を終了するには

  1. 「ファイル」メニューの「終了」オプションを選択します。

ショートカットキー： Alt + F4


「編集」メニュー

「編集」メニューには、開かれたテンプレートの編集に関するオプションがあります。

参考：テンプレート ポップアップメニュー

元に戻す

テンプレート上で最後に行われた変更操作を取り消して、一つ前の状態に戻します。

操作を元に戻すには

  1. ツールバーにある「元に戻す」ボタン [image] をクリックするか、「編集」メニューの「元に戻す」オプションを選択します。

または、

  1. テンプレート上で右クリックして、ポップアップから「元に戻す」オプションを選択します。

ショートカットキー： Ctrl + Z

やり直し

最後に取り消された変更操作を、再度適用します。

操作をやり直すには

  1. ツールバーにある「やり直し」ボタン [image] をクリックするか、「編集」メニューの「やり直し」オプションを選択します。

または、

  1. テンプレート上で右クリックして、ポップアップから「やり直し」オプションを選択します。

ショートカットキー： Shift + Ctrl + Z

切り取り

選択されたコンポーネントを現在の位置から削除し、クリップボードに格納します。

コンポーネントを切り取るには

  1. 切り取りたいコンポーネントを選択します。
  2. ツールバーにある「切り取り」ボタン [image] をクリックするか、「編集」メニューの「切り取り」オプションを選択します。

または、

  1. コンポーネントを右クリックして、ポップアップから「切り取り」オプションを選択します。

ショートカットキー： Ctrl + X

コピー

テンプレート上にある どんなアイテムやコンポーネント、あるいはプロパティ値でもコピーすることが可能です。

コピーするには

  1. コピーしたいコンポーネントを選択します。
  2. ツールバーにある「コピー」ボタン [image] をクリックするか、「編集」メニューの「コピー」オプションを選択します。

または、

  1. コンポーネントを右クリックして、ポップアップから「コピー」オプションを選択します。

ショートカットキー： Ctrl + C

貼り付け

クリップボードにある内容を、選択した領域に貼り付けます。

クリップボードの内容を貼り付けるには

  1. ツールバーにある「貼り付け」ボタン [image] をクリックするか、「編集」メニューの「貼り付け」オプションを選択します。

または、

  1. コピー先で右クリックして、ポップアップから「貼り付け」オプションを選択します。

ショートカットキー： Ctrl + V

※「貼り付け」オプションを使用する前に、コンポーネントをクリップボードにコピーしておく必要があります。

貼り付けポインタ

コピーしたコンポーネントを複数の方法で、「貼り付け」及び「移動する」ことができます。

コピーしたコンポーネントを貼り付けるには

  1. テンプレート上でコンポーネントを選択し、コピーします。
  2. ツールバーにある「貼り付けポインタ」ボタン [image] をクリックするか、「編集」メニューの「貼り付けポインタ」オプションを選択します。
  3. マウスポインタをコピー先に移動してクリックするか、右クリックしてポップアップから「ここに貼り付け」オプションを選択します。

マウスポインタを移動するには

  1. テンプレート上でコンポーネントを選択し、コピーします。
  2. ツールバーにある「貼り付けポインタ」ボタン [image] をクリックするか、「編集」メニューの「貼り付けポインタ」オプションを選択します。
  3. マウスポインタをコンポーネント上で右クリックしてドラッグし、必要な位置まで移動します。
  4. マウスの右ボタンを離して、ポップアップから「ここに移動」オプションを選択します。

※「貼り付けポインタ」をキャンセルするには、マウスボタンを右クリックして「キャンセル」オプションを選択します。

書式のコピー／貼り付け

一つのコンポーネントから別のコンポーネントに共通プロパティをコピーします。

共通プロパティをコピーするには

  1. コンポーネントを選択し、「書式のコピー／貼り付け」ボタン [image] をクリックするか、「編集」メニューから「書式のコピー／貼り付け」オプションを選択します。
  2. 最初のコンポーネントの共通プロパティを適用したい二つ目のコンポーネントを選択します。

※一つ目のコンポーネント選択後に「書式のコピー／貼り付け」をクリックすると、そのコンポーネントの全プロパティが選択されます。次に、二つ目のコンポーネントを選択すると、一つ目のコンポーネントのプロパティのうち、双方に共通するプロパティが、二つ目のコンポーネントに適用されます。

削除

選択されているコンポーネントをレイアウト上から削除します。削除したコンポーネントを復活させるには、「編集」メニューの「元に戻す」オプションを使用します。

コンポーネントを削除するには

  1. 削除するコンポーネントを選択します。
  2. 「編集」メニューの「削除」オプションを選択します。

または、

  1. コンポーネントを右クリックしてポップアップから「削除」オプションを選択します。

ショートカットキー： Delete

クイック削除

選択されたコンポーネントを完全に削除します。「クイック削除」オプションによって削除されたコンポーネントは、「元に戻す」オプションを使っても元に戻せないので注意してください。

コンポーネントをクイック削除するには

  1. 削除したいコンポーネントを選択します。
  2. 「編集」メニューの「クイック削除」オプションを選択します。

ショートカットキー： Shift + Delete

すべて選択

テンプレートのすべてのコンポーネントを選択します。

すべてを選択するには

  1. 「編集」メニューの「すべて選択」オプションを選択します。

または、

  1. テンプレート上で右クリックして、ポップアップから「すべて選択」オプションを選択します。

ショートカットキー： Ctrl + A

整列

複数選択されているコンポーネントを、水平または垂直に位置合わせします。位置合わせは、テンプレート エクスプローラで強調表示されているコンポーネント(クリックで選択可能)の位置に従って行われます。アクティブ コンポーネントを替えるには、テンプレート エクスプローラで選択するか、プロパティ エディタのドロップダウンで選択してください。

コンポーネントを整列させるには

  1. 複数のコンポーネントを選択します。
  2. ツールバーにある「整列」ボタン [image] をクリックするか、「編集」メニューの「整列」オプションから、整列のタイプを選択します。

または、

  1. 複数選択したコンポーネント上で右クリックし、ポップアップの「整列」オプションから、整列のタイプを選択します。
整列のタイプ
 | 左辺 | 選択しているコンポーネントを左に揃えます。
 | 右辺 | 選択しているコンポーネントを右に揃えます。
 | 上辺 | 選択しているコンポーネントを上に揃えます。
 | 下辺 | 選択しているコンポーネントを下に揃えます。
 | 縦の中線 | 選択しているコンポーネントを垂直の中心に揃えます。
 | 横の中線 | 選択しているコンポーネントを水平の中心に揃えます。

サイズを揃える

複数選択されたコンポーネントの高さや幅が同一になるようにサイズの変更を行います。サイズは、テンプレート エクスプローラで選択(強調表示)されているコンポーネントのサイズが基準となります。テンプレート エクスプローラまたはプロパティ エディタのコンボボックスで、サイズの基準とするコンポーネントを変更できます。

サイズを揃えるには

  1. 複数のコンポーネントを選択します。
  2. ツールバーにある「サイズを揃える」ボタン [image] をクリックするか、「編集」メニューの「サイズを揃える」オプションから、サイズを揃えるタイプを選択します。

または、

  1. 複数選択したコンポーネント上で右クリックし、ポップアップの「整列」オプションから、サイズを揃えるタイプを選択します。
サイズを揃えるタイプ
 | 幅 | 選択されたコンポーネントを同じ幅に揃えます。
 | 高さ | 選択されたコンポーネントを同じ高さに揃えます。
 | 幅と高さ | 選択されたコンポーネントを同じ幅および同じ高さに揃えます。

※最後に選択されたコンポーネントに合わせてサイズが変更されます。

最前面へ移動

選択中のコンポーネントを、レイアウト上にある全コンポーネントの中で最前面になるように移動します。

コンポーネントを最前面へ移動するには

  1. 最前面へ移動させたいコンポーネントを選択します。
  2. ツールバーにある「最前面へ移動」ボタン [image] をクリックするか、「編集」メニューの「最前面へ移動」オプションを選択します。

または、

  1. コンポーネントを右クリックして、ポップアップから「最前面へ移動」オプションを選択します。

最背面へ移動

選択中のコンポーネントを、レイアウト上にある全コンポーネントの中で最背面になるように移動します。

コンポーネントを最背面へ移動するには

  1. 最背面へ移動させるコンポーネントを選択します。
    2. ツールバーにある「最背面へ移動」ボタン [image] をクリックするか、「編集」メニューの「最背面へ移動」オプションを選択します。

または、

  1. コンポーネントを右クリックして、ポップアップから「最背面へ移動」オプションを選択します。

データベースの更新

OXDが保持しているOXSのデータベース接続情報をクリアします。次回、クエリビルダを開いたときにOXSからデータベース接続情報を取得しなおすことができます。OSMSユーザを変更したい場合にも、この「データベースの更新」を行ってください。

データベース接続情報をクリアするには

  1. 「編集」メニューの「データベースの更新」オプションを選択します。

または、

  1. テンプレート上で右クリックして、ポップアップから「データベースの更新」オプションを選択します。

ショートカットキー： F5


「表示」メニュー

「表示」メニューには、各種ウィンドウ、ツールバー、テンプレートの表示に関する機能があります。

テンプレートエクスプローラ

テンプレートエクスプローラは、コンポーネントの選択操作などを簡単するのに使用します。矢印ボタンを使用すると、テンプレート内でのコンポーネントの順序を変更することができます。

テンプレートエクスプローラを表示するには

  1. 「表示」メニューの「テンプレートエクスプローラ」オプションをクリックします。

ショートカットキー： F10

プロパティエディタ

プロパティエディタは、テンプレート設計の際に配置したコンポーネントのプロパティ値を編集するのに使用します。

プロパティエディタを選択するには

  1. 「表示」メニューの「プロパティエディタ」オプションをクリックします。

または、

  1. テンプレート上で右クリックして、ポップアップから「プロパティ エディタ」オプションを選択します。

ショートカットキー： F11

ツールバー

表示するツールバーの種類をカスタマイズします。

ツールバーを選択するには

  1. 「表示」メニューの「ツールバー」オプションから、ツールバーのタイプを選択します。

虫眼鏡

「虫眼鏡」オプションは、マウスポインタが示す位置を拡大表示します。

拡大表示するには

  1. 「表示」メニューの「虫眼鏡」オプションを選択します。

「虫眼鏡」ウィンドウ上で右クリックし、ポップアップから「常に最前面」「ズーム」および「隠す」を選択できます。

「常に最前面」オプションを有効にすると、「虫眼鏡」ウィンドウを常にデスクトップの最前面に表示できます。このオプションのチェックを外して別の場所を選択すると、「虫眼鏡」ウィンドウは、選択した場所の背後に移動します。

「常に最前面」オプションを選択するには

  1. 「虫眼鏡」ウィンドウ上で右クリックし、ポップアップメニューを表示します。
  2. 「常に最前面」オプションをクリックしてチェックまたは未チェックにします。

「ズーム」オプションは、選択されたエリアを「虫眼鏡」ウィンドウで拡大表示するために使用します。

「虫眼鏡」ウィンドウの拡大率を変更するには

  1. 「虫眼鏡」ウィンドウ上で右クリックし、ポップアップメニューを表示します。
  2. 「ズーム」オプションを選択し、拡大率( 200%, 300%, 400% )を選択します。

「隠す」オプションは、「虫眼鏡」ウィンドウを隠すために使用します。

「虫眼鏡」ウィンドウを隠すには

  1. 「虫眼鏡」ウィンドウ上で右クリックし、ポップアップメニューを表示します。
  2. 「隠す」オプションを選択します。

トラッカー

「トラッカー」オプションは、テンプレート全体を小さなウィンドウに縮小表示します。このウィンドウを使用して、テンプレートの特定の領域を簡単に選択することができます。

トラッカーを表示するには

  1. 「表示」メニューの「トラッカー」オプションを選択します。

「トラッカー」ウィンドウ上で右クリックし、ポップアップから「常に最前面」および「隠す」を選択できます。

「常に最前面」オプションを有効にすると、「トラッカー」ウィンドウを常にデスクトップの最前面に表示できます。このオプションのチェックを外して別の場所を選択すると、「トラッカー」ウィンドウは、選択した場所の背後に移動します。

「常に最前面」オプションを選択するには

  1. 「トラッカー」ウィンドウ上で右クリックし、ポップアップメニューを表示します。
  2. 「常に最前面」オプションをクリックしてチェックまたは未チェックにします。

「隠す」オプションは、「トラッカー」ウィンドウを隠すために使用します。

「トラッカー」ウィンドウを隠すには

  1. 「トラッカー」ウィンドウ上で右クリックし、ポップアップメニューを表示します。
  2. 「隠す」オプションを選択します。


「コンポーネント」メニュー

「コンポーネント」メニューには、配置するコンポーネントおよび それに対する操作等のオプションが用意されています。

グルーピング

同タイプの2個以上のコンポーネントをグループ化し、ひとつづきのデータを異なる位置のコンポーネント間で共有することができます。グルーピングは、「Label」「URLLabel」「DatasetTable」「HorizontalDatasetTable」コンポーネントに対して有効です。グルーピングの効果は、最初のコンポーネントに入力されたデータがその境界を超えた場合に確認することができます。境界を超えたデータは、2番目以降のコンポーネントに引き続き、表示されます。コンポーネントがグループ化された場合、「フォント」「カスタム」「ハイパーリンク」等のプロパティは、最初のコンポーネントの設定が以降のコンポーネントにも適用されます。

コンポーネントをグルーピングするには

  1. グルーピング可能な同タイプのコンポーネントをテンプレートに複数配置します。
  2. Shiftキーを使用し、同タイプのコンポーネントをすべて選択します。
  3. 「コンポーネント」メニューの「グルーピング」オプションを選択するか、右クリックしてポップアップから「グルーピング」オプションを選択します。
  4. 「グルーピング」ウィンドウが表示されたら、グループの「グループID」を指定します。
  5. ウィンドウでコンポーネントの「グループ順序」番号を入力するか、「自動」をクリックして番号を自動生成します。
  6. 「OK」をクリックします。

※グルーピングの効果は、テンプレートの設計時には確認できませんので、ご注意ください。

上記以外にも、テンプレート下にある「グルーピングポインタ」ボタンを使用した簡単なグルーピング方法があります。この場合の手順は、次の通りです。

  1. グルーピング可能な同タイプのコンポーネントをテンプレートに複数配置します。
  2. テンプレート下の「グルーピングポインタ」ボタンをクリックします。
  3. 「グルーピング」ダイアログが現れたら「グループID」を指定し、「OK」をクリックします。
  4. マウスポインタをコンポーネント上に移動してクリックします。コンポーネント上に移動すると、マウスポインタの形が変わります。番号は自動採番されるため、コンポーネントは必ず順番通りにクリックしてください。
  5. コンポーネントをクリックし終わったら、「グルーピングポインタ」ボタンを再度クリックしてグルーピングを完了します。

既にグルーピング済みのコンポーネントを再度クリックすると、グルーピングされているコンポーネント内で「グループ順序」番号が変更され、クリックしたコンポーネントの「グループ順序」番号が最後の番号になります。さらに別のグループを作成する場合は、「グルーピング」ダイアログで「新しいID」を選択し、他のコンポーネントをクリックしていきます。既存グループにコンポーネントを追加する場合は、指定済みのグループIDを「グルーピング」ダイアログで選択し、コンポーネントをクリックします。

※別々のレイアウト上に配置されているコンポーネントのグルーピングはできません。

既定値として設定

選択したコンポーネントと同じプロパティ値を、以後作成する同タイプのコンポーネントに適用するために、デフォルトとなるプロパティ値を設定します。

既定値を設定するには

  1. テンプレートに任意のコンポーネントを配置します。
  2. コンポーネントのプロパティ値を変更します。
  3. 「コンポーネント」メニューの「既定値として設定」オプションを選択するか、コンポーネントを右クリックし、ポップアップの「既定値として設定」オプションを選択します。
  4. テンプレートに同タイプのコンポーネントを新規に配置します。
  5. 新規に配置されたコンポーネントの既定値は、前のコンポーネントで変更されたプロパティ値になっているはずです。

標準

「標準」オプションは、テンプレートに配置可能な「標準」コンポーネントを含んでいます。

「標準」コンポーネントを選択するには

  1. 「コンポーネント」メニューの「標準」オプションから、「標準」コンポーネントのタイプを選択します。

または、

  1. コンポーネント パレットの「標準」タブをクリックし、「標準」コンポーネントのタイプを選択します。

拡張

「拡張」オプションは、テンプレートに配置可能な「拡張」コンポーネントを含んでいます。

「拡張」コンポーネントを選択するには

  1. 「コンポーネント」メニューの「拡張」オプションから、「拡張」コンポーネントのタイプを選択します。

または、

  1. コンポーネント パレットの「拡張」タブをクリックし、「拡張」コンポーネントのタイプを選択します。

フォーム

「フォーム」オプションは、電子フォームを設計するための「フォーム」コンポーネントを含んでいます。

「フォーム」コンポーネントを選択するには

  1. 「コンポーネント」メニューの「フォーム」オプションから、「フォーム」コンポーネントのタイプを選択します。

または、

  1. コンポーネント パレットの「フォーム」タブをクリックし、「フォーム」コンポーネントのタイプを選択します。

データアクセス

「データアクセス」オプションは、データベース アクセス用の「データアクセス」コンポーネントを含んでいます。

「データアクセス」コンポーネントを選択するには

  1. 「コンポーネント」メニューの「データアクセス」オプションから、「データアクセス」コンポーネントのタイプを選択します。

または、

  1. コンポーネント パレットの「データアクセス」タブをクリックし、「データアクセス」コンポーネントのタイプを選択します。

セキュリティ

「セキュリティ」オプションは、ドキュメントを保護するための「セキュリティ」コンポーネントを含んでいます。

「セキュリティ」コンポーネントを選択するには

  1. 「コンポーネント」メニューの「セキュリティ」オプションから、「セキュリティ」コンポーネントのタイプを選択します。

または、

  1. コンポーネント パレットの「セキュリティ」タブをクリックし、「セキュリティ」コンポーネントのタイプを選択します。

ウィザード

「ウィザード」オプションは、SubReport、DatasetTable の設計、グラフ生成等、複雑な仕事を簡単な手順で行える「ウィザード」コンポーネントを含んでいます。

「ウィザード」コンポーネントを選択するには

  1. 「コンポーネント」メニューの「ウィザード」オプションから、「ウィザード」コンポーネントのタイプを選択します。

または、

  1. コンポーネント パレットの「ウィザード」タブをクリックし、「ウィザード」コンポーネントのタイプを選択します。

ポインタ

新規追加用に選択されているコンポーネントを解除して、レイアウト上にあるコンポーネントを選択するためのポインタに変更します。

ポインタを選択するには

  1. コンポーネント パレットの「ポインタ」トグルをクリックします。

または、

  1. 「コンポーネント」メニューの「ポインタ」オプションを選択します。


「オプション」メニュー

「オプション」メニューには、サンプルHTMLの作成ツールや、OXDの環境設定、OFMSアドミニストレータの呼び出し等のオプションがあります。

サンプルHTMLの作成

作成されるサンプルHTMLからは、OXSにリクエストし、指定したテンプレートのプレビューを行うことができます。「サンプルHTMLの作成」ダイアログでは、使用するCGIまたはサーブレットへのパス、リクエストメソッドのタイプ、動作、出力形式などを指定する必要があります。ダイアログは、「全般」「Datasetキー」「DBExecuteキー」「リクエスト値」「リクエストURL値」の５つのタブで構成されています。

「サンプルHTMLの作成」ダイアログを呼び出すには

  1. 「オプション」メニューの「サンプルHTMLの作成」オプションを選択します。

ショートカットキー： Ctrl + G

「全般」タブ

サンプルHTMLページを作成するための基本設定を設定します。使用するCGIまたはサーブレットへのパス、リクエストメソッドのタイプ、動作、出力形式などを指定する必要があります。

「OXS CGI/サーブレットURL」
OXSのCGIまたはサーブレットのURLを入力します。
「メソッド」
リクエストの送信方法として、「POST」または「GET」メソッドを選択します。
「動作」
「ダウンロード」
ドキュメントのダウンロードをOPR、PDF、OXR、HTML形式で指定できます。
「直接印刷」
ドキュメントをプリンタに直接印刷するオプションを、生成するサンプルHTMLページに付加します。
「生成」
このオプションだけを指定した場合、ドキュメントの生成のみを行います。あらかじめドキュメント生成しておくと、テンプレートをオフラインでも利用できます。
「メール送信」
ドキュメントをOPR、PDF、OXR、HTML形式でメール送信できます。
「FAX送信」
ドキュメントをFAX送信するオプションを、生成するサンプルHTMLページに付加します。
「サーバ印刷」
サーバ側の印刷機能を使用するオプションを、生成するサンプルHTMLページに付加します。
「PrintXchangeを使用して印刷」
富士ゼロックス株式会社のサービス「PrintXchange」を使用して印刷できます。
「出力形式」
OPR、PDF、OXR、OXV、HTML、XDW形式でリクエストするオプションを、生成するサンプルHTMLページに付加します。
「エンコード」
フォームデータ送信時のエンコードタイプを指定します。

「Datasetキー」タブ

リクエストにレコードの抽出処理を付加します。この機能を使用するには、Datasetの条件にユーザ入力キー{USERINPUT}を指定する必要があります。サンプルHTMLページに表示される表題と初期値を指定することができます。

「Dataset」
Datasetを選択します。
「ユーザ入力キー」
抽出条件で指定されているユーザ入力キーがすべて表示されます。
「条件」
抽出条件で指定されている条件式が表示されます。
「表題」
選択したユーザ入力キーの表題を入力します。
「初期値」
選択したユーザ入力キーの初期値を入力します。

「DBExecuteキー」タブ

「DBExecute」コンポーネントで指定されたユーザ入力キー{USERINPUT}の表題と初期値を指定できます。この機能を使うと、データベースを更新することも可能です。

「DBExecute」
DBExecuteを選択します。
「ユーザ入力キー」
スクリプトで指定されているユーザ入力キーがすべて表示されます。
「条件」
スクリプトで指定されている条件式が表示されます。
「表題」
選択したユーザ入力キーの表題を入力します。
「初期値」
選択したユーザ入力キーの初期値を入力します。

「リクエスト値」タブ

コンポーネント（URL*コンポーネントを除く）の内容タイプが「Request」の場合、表題と初期値を設定できます。

「コンポーネント」
内容タイプに「Request」を選択しているすべてのコンポーネント（URL*コンポーネントを除く）が表示されます。
「リクエスト名」
選択したコンポーネントのリクエストパラメータ名が表示されます。
「表題」
選択したリクエストパラメータ名の表題を入力します。
「初期値」
選択したリクエストパラメータ名の初期値を入力します。

「リクエストURL値タブ」

URLコンポーネントのURLデータタイプが「Request」の場合、表題と初期値を設定できます。

「コンポーネント」
URLデータタイプに「Request」を選択しているすべてのURLコンポーネントが表示されます。
「リクエスト名」
選択したURLコンポーネントのリクエストパラメータ名が表示されます。
「表題」
選択したリクエストパラメータ名の表題を入力します。
「初期値」
選択したリクエストパラメータ名の初期値を入力します。

すべてのタブに共通のコントロール

「表示」ボタン
既定のブラウザを使用してサンプルHTMLページを表示します。
「作成」ボタン
サンプルHTMLページを作成し、保存します。
「作成後に表示」チェックボックス
サンプルHTMLを作成後、既定のブラウザで表示します。
「閉じる」ボタン
「サンプルHTMLの作成」ウィンドウを閉じます。

環境設定

OXD の環境設定を行います。「環境設定」ウィンドウは、「全般」と「レイアウトの既定値」の二つのタブで構成されています。「全般」タブでは、ドキュメントのプレビューや生成に関する設定を、「レイアウトの既定値」タブでは、新規テンプレートや、レイアウト追加時に適用される 既定の外観の設定等を行ないます。

環境設定を表示するには

  1. 「オプション」メニューの「環境設定」オプションを選択します。

ショートカットキー： Ctrl + E

「全般」タブ

「OXS CGI/サーブレット」
「URL」
OXSのCGIまたはサーブレットへのパスを指定します。OXDからのリクエストはすべてこのパスを通じて行われます。
「OXSのバージョン」
指定したURLにOXSのバージョンチェックリクエストを送ります。レスポンスはダイアログ表示されます。
「インターネット接続」
プロキシサーバ アドレスやポート番号等の設定を行う「インターネットのプロパティ」ダイアログを開きます。
「新規テンプレート」
「「ファイル」メニューの「新規テンプレート」を選択したときにダイアログを開く」
有効に設定すると、「ファイル」メニューの「新規テンプレート」選択時に「新規テンプレート」ダイアログが開くようになります。
最近開いたファイル
「「開き直す」の履歴に表示する件数」
「ファイル」メニューの「開き直す」選択時や、「開く」ボタンの選択時に表示される履歴件数を指定します。
「プレビューの形式」
プレビューの形式を「OPR」「PDF」「HTML」「XDW」に設定します。
「サンプルHTMLのHTMLテンプレート」
サンプルHTML生成時に使用するHTMLテンプレートへのパスを指定します。既定のファイルは、OXDインストールフォルダの「genhtml」フォルダにあり、「default-ja.html」が指定されています。このHTMLテンプレートは日本語表示となっています。英語表示したい場合は「default-en.html」を選択してください。HTMLテンプレートファイルは自由に編集することができます。

「レイアウトの既定値」タブ

「背景色」
新規テンプレート作成時、または、レイアウト追加時に使用される既定の背景色を指定します。「色の編集」ボタンをクリックすると、「色の編集」ダイアログが表示され、カラーパレットに無い色を既定の背景色として指定できます。
「グリッド」
「間隔」
新規テンプレート作成時、または、レイアウト追加時に使用される既定のグリッド間隔を指定します。
「スナップ」
コンポーネントをドラッグして移動させる際に、グリッド単位で移動するように指定します。
「可視」
グリッドの表示／非表示を指定します。
「スタイル」
グリッド スタイルを「Absolute」または「Relative」に指定します。
「色」
グリッドの既定色を指定します。
「用紙サイズ」
新規テンプレート作成時、または、レイアウト追加時に使用される既定の用紙サイズを指定します。
「高さ」
用紙サイズに「Custom」を指定した場合の、用紙の縦の長さを指定します。
「幅」
用紙サイズに「Custom」を指定した場合の、用紙の横の長さを指定します。
「単位」
用紙サイズの高さと幅の単位を指定します。
「用紙の向き」
新規テンプレート作成時、または、レイアウト追加時に使用される既定の用紙の向きを「縦」または「横」に指定します。
「マージン」
「左」「右」「上」「下」マージンを指定します。
「OPRの印刷方法」
「表示と印刷を合わせる」を有効にすると、このテンプレートから生成されたOPRドキュメントをOXBから印刷する際、文字等の位置を画面の表示と合わせます。「2.3と同じ方法」を有効にすると、2.5未満のバージョンで作成されたテンプレートと互換性のある印刷を行ないます。

OFMSアドミニストレータ

OFMSアドミニストレータ(OFMSA)は、OPRO File Manager Service(OFMS)の管理ツールです。OFMSAは、管理者が使用します。

OFMSAを呼び出すには

  1. 「オプション」メニューの「OFMSアドミニストレータ」オプションを選択します。

OFMSAの特徴を以下に示します。

ディレクトリの作成

ユーザごとにディレクトリを作成できます。ユーザは作成したテンプレートを各々のディレクトリに保存することができます。

ファイルの表示

任意のファイルを保存できます。ファイルをダブルクリックすると、関連付けられたアプリケーションで自動的にファイルを開きます。保存可能なファイルの最大サイズは2MBです。

ファイルのアップロード／ダウンロード

アップロードによって、ローカルファイルをOFMSに保存することができます。また、ダウンロードによって、ファイルをOFMSからローカルマシンにダウンロードすることができます。

ファイルのロック

ファイルをロックし、読取専用にすることができます。


「ウィンドウ」メニュー

OXD で開かれているテンプレートが一覧表示されます。一覧から一つのテンプレートを選択すると、そのテンプレートを最前面に表示します。一覧には最大30件表示可能です。

テンプレートを選択するには

  1. 「ウィンドウ」メニューからテンプレート名を選択します。


「ヘルプ」メニュー

「ヘルプ」メニューには、OXD の操作説明や解説を読むことのできるオンラインヘルプ、クイックヘルプ、バージョン情報等が用意されています。

目次とキーワード

OXD に関する あらゆる情報を提供するオンラインヘルプを開きます。ヘルプは「目次」「キーワード」「検索」の三つのタブで構成されています。

「目次」タブ
階層化された目次からトピックを参照できます。
「キーワード」タブ
リストアップされたキーワードからトピックを参照できます。
「検索」タブ
任意のキーワードを入力してヘルプを全文検索し、トピックを参照できます。

ヘルプを参照するには

  1. ツールバーにある「ヘルプ」ボタン [image] をクリックするか、「ヘルプ」メニューの「目次とキーワード」オプションを選択します。

ショートカットキー： F1

クイックヘルプ

OXD 画面内でクリックした部分についてのヘルプトピックを呼び出す機能です。

マウスカーソルが「矢印と疑問符」 [image] に変化し、そのまま OXD 画面内をクリックすると、クリックした部分についてのヘルプトピックが呼び出されます。この機能によって、アプリケーション ウィンドウ内にあるオプションについての説明を素早く参照することが可能です。

クイックヘルプを使うには

  1. ツールバーにある「クイックヘルプ」ボタン [image] をクリックするか、「ヘルプ」メニューの「クイックヘルプ」オプションを選択します。
  2. マウスカーソルの形状が「矢印と疑問符」 [image] に変化するので、そのまま OXD 画面内の任意のオプションをクリックします。
  3. クリックしたオプションに関するヘルプトピックが呼び出されます。

バージョン情報

OXDのバージョンとシリアル番号、および、著作権情報を表示します。

バージョン情報を確認するには

  1. 「ヘルプ」メニューの「バージョン情報」オプションを選択します。

シリアル番号を変更するには

  1. 開いているテンプレートをすべて閉じます。開いているテンプレートがあるとシリアル番号は変更できません。
  2. 「ヘルプ」メニューの「バージョン情報」オプションを選択します。
  3. 「Serial Number」ボタンを押し、表示されたダイアログで新しいシリアル番号を入力します。


ツールバー

OXD の主要な機能を、直接、使用できるメニューです。メインメニューからサブメニューへと選択していくアプリケーションメニューバーとは異なり、クリックするだけで、即その機能を使用することができるショートカットとなっています。

ツールバーのタイプ

ファイル

「新規作成」「テンプレートを開く」「上書き保存」「すべてのテンプレートを保存」「プレビュー」へのショートカット。

編集

「切り取り」「コピー」「貼り付け」「貼り付けポインタ」「書式のコピー／貼り付け」「元に戻す」「やり直し」へのショートカット。

ヘルプ

「ヘルプ」「クィックヘルプ」へのショートカット。

整列とサイズ

「整列 - 左辺」「整列 - 右辺」「整列 - 上辺」「整列 - 下辺」「整列 - 縦の中線」「整列 - 横の中線」「サイズを揃える - 幅」「サイズを揃える - 高さ」「サイズを揃える - 幅と高さ」へのショートカット。

前面/背面

「最前面へ移動」「最背面へ移動」へのメニューコマンドのショートカット。

コンポーネントパレット

各種コンポーネントへのショートカット。「標準」、「拡張」、「フォーム」、「データアクセス」、「セキュリティ」、「ウィザード」タブに分けられています。


テンプレートウィンドウ

テンプレートウィンドウは、ドキュメントを生成する際のテンプレートとなるレイアウトを作成するための作業用エリアです。

コンポーネントの移動とサイズ変更
キーを使用してコンポーネントを簡単に移動およびサイズ変更できます。コンポーネントを移動するには、Ctrlキーと矢印キーを押します。コンポーネントのサイズを変更するには、Shiftキーと矢印キーを押します。
AltキーとEscキー
「DatasetTable」や「Table」等のカラム、「DatasetTable Container」や「InterfaceGroup」等の他のコンポーネントの入れ物となるコンポーネントを選択するには、Altキーを押してからコンポーネントの内部をクリックします。Escキーを押すと、選択されているコンポーネントの親となるコンポーネントを選択できます。
テンプレート ポップアップメニュー
テンプレートウィンドウ上で右クリックすると、テンプレートおよびコンポーネントに対して可能な操作オプションがポップアップメニューで表示されます。
グリッドにあわせる
テンプレートウィンドウの左下コーナーにある「グリッドにあわせる」ボタン [image] をクリックすると、マウスドラッグでコンポーネントを移動させるときに、コンポーネントの位置をグリッドに合わせるかどうかを変更できます。
磁石モード
テンプレートウィンドウの左下コーナーにある「磁石モード」ボタン [image] をクリックすると、コンポーネントを移動して別のコンポーネントに近づけたときに、両方のコンポーネントを接着させるかどうかを変更できます。
グルーピングポインタ
テンプレートウィンドウの左下コーナーにある「グルーピングポインタ」ボタン [image] をクリックすると、同タイプのコンポーネントをグルーピングすることができます。


テンプレート ポップアップメニュー

テンプレート上で右クリックすると、テンプレートおよびコンポーネントに対して可能な操作オプションがポップアップメニューで表示されます。テンプレート ポップアップメニューは、「編集」メニューに「グルーピング」「既定値として設定」「プロパティエディタ」オプションが追加されたものです。


プロパティエディタ

プロパティエディタは、テンプレート設計の際に配置したコンポーネントのプロパティ値を編集するのに使用します。

プロパティエディタを選択するには

  1. 「表示」メニューの「プロパティエディタ」オプションを選択するか、右クリックしてポップアップから「プロパティエディタ」オプションを選択します。
「アクティブ」
F11キーを押すと、「アクティブ」タブにフォーカスを移動できます。選択したコンポーネントのすべてのプロパティが表示されます。
「ターゲット」
F12キーを押すと、「ターゲット」にフォーカスを移動できます。テンプレート上で選択されているコンポーネントに共通するプロパティのみが表示されます。


テンプレートエクスプローラ

テンプレートエクスプローラは、コンポーネントの選択操作などを簡単するのに使用します。矢印ボタンを使用すると、テンプレート内でのコンポーネントの順序を変更することができます。

テンプレートエクスプローラを選択するには

  1. 「表示」メニューの「テンプレートエクスプローラ」オプションを選択するか、F10キーを押します。
コンポーネントの順序の変更
テンプレートエクスプローラの矢印ボタンを使用すると、テンプレート内でのコンポーネントの順序を簡単に変更できます。


テンプレートとコンポーネント

ドキュメントの雛形を構成するテンプレートとコンポーネントについて説明します。

テンプレート
OXDのテンプレートついて説明しています。
コンポーネント
OXDのコンポーネントについて説明しています。


テンプレート

テンプレートとは、帳票のデザインやデータベースとのリンク設定を XML 形式で保存した帳票定義体ファイル(拡張子.OXT)です。 テンプレートには、異なる用紙サイズと向きの自由なレイアウトを複数もつことができ、一つのテンプレートファイルとして保存することができます。テンプレートファイルの拡張子は「.OXT(OPRO XML Template)」となっています。

「テンプレート」のプロパティ

「OPRの印刷方法」

このプロパティは、作成されるドキュメントの印刷方法について、OXDの下位バージョンとの互換性のとり方を指定します。


レイアウト

レイアウトは、生成するドキュメントのページデザインです。テンプレートには、レイアウトを複数追加することが可能で、レイアウト毎に異なる用紙設定を選択することができます。「ファイル」メニューから「レイアウトの追加」、「レイアウト名の変更」または「レイアウトの削除」を行うことができます。

「レイアウト」のプロパティ

「全般」

このプロパティは、テンプレートの「名前」と「外観」に関するプロパティです。

「操作」

このプロパティは、「磁石モード」や「グリッド」の設定など、レイアウトの操作モードに関する設定を行ないます。

「レイアウト設定」

このプロパティはレイアウトの詳細を設定します。

参考：用紙サイズと用紙の向き


コンポーネント

コンポーネントは、ドキュメントを構成する様々な機能を持つ部品で、六つのカテゴリーに大別されています。

  • 「標準」コンポーネント
  • 「拡張」コンポーネント
  • 「フォーム」コンポーネント
  • 「データアクセス」コンポーネント
  • 「セキュリティ」コンポーネント
  • 「ウィザード」コンポーネント


「標準」コンポーネント

コンポーネントパレットの「標準」タブにあります。主にテンプレート上にテキストや画像、または図形等を描画するコンポーネントがまとめられています。

  • Label
  • Image
  • Shape
  • Line
  • DateTime
  • Page Number
  • Total Page Number
  • Table
  • URLLabel
  • URLImage


Label

「Label」コンポーネントは、レイアウト上にテキストを表示します。テキストは、静的に指定( 直接記述 )するだけでなく、ドキュメント生成時にデータベースや URL から動的に適用することもできます。

「Label」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Label」には、「配置」、「背景色」、「縦書き」、自動サイズや折り返し等の指定をする「スタイル」、「文字幅と間隔」などのプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。

「条件付フォーマット」

このプロパティを利用すると、データベースから取得されるデータを指定条件で判定し、表示される内容を変更することができます。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Image

「Image」コンポーネントは、レイアウト上に画像を挿入します。使用可能な画像形式は、jpg, bmp, png, gif, tiff となっています。画像は、ファイルまたはURLを指定して読み込むか、またはスキャナから読み込むこともできます。

「Image」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Image」には、「配置」と「外観」に関するプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Shape

「Shape」コンポーネントは、レイアウト上に幾何学図形を描画します。

「Shape」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Shape」には、「タイプ」、「境界」、「背景」、「角の丸み調整」などのプロパティがあります。


Line

「Line」コンポーネントは、レイアウト上に多彩なスタイルの線を描画します。使用可能なスタイルは、Solid, Dash, Dot, DashDot, DashDotDot です。

「Line」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Line」には、描画する線に関する設定、「サイズ」、「色」、「スタイル」、「向き」などのプロパティがあります。


Date Time

「Date Time」コンポーネントは、ドキュメントの生成日時をサーバから取得して表示します。

「Date Time」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Label」には、「配置」、「背景色」、「縦書き」、自動サイズや折り返し等の指定をする「スタイル」、「文字幅と間隔」などのプロパティがあります。

「表示形式」

このプロパティは、日時の表示形式を指定するプロパティです。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。


Page Number

「Page Number」コンポーネントは、レイアウト／テンプレート／ドキュメント単位でページ番号を表示します。テンプレートに複数のレイアウトが存在する場合、Page Number はコンポーネント毎に、レイアウト／テンプレート／ドキュメント単位にとダイナミックに採番することが可能です。

「Page Number」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Page Number」には、「配置」、「背景色」、「縦書き」、自動サイズや折り返し等の指定をする「スタイル」、「文字幅と間隔」などのプロパティがあります。

「設定」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Page Number」には、「番号の割付」、「最初のページを表示する」、「最後のページを表示する」、「オフセット」、「内容」などのプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。


Total Page Number

「Total Page Number」コンポーネントは、レイアウト／テンプレート／ドキュメント単位の総ページ数を表示します。それぞれに 1 ページ以上のページが含まれている場合、Total Page Number は、レイアウト／テンプレート／ドキュメント単位に総ページ数を表示することができます。

「Total Page Number」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Page Number」には、「配置」、「背景色」、「縦書き」、自動サイズや折り返し等の指定をする「スタイル」、「文字幅と間隔」などのプロパティがあります。

「設定」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Page Number」には、「番号の割付」、「最初のページを表示する」、「最後のページを表示する」、「オフセット」、「内容」などのプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。


Table

「Table」コンポーネントは、バンドとカラムを使用してテーブル(表)を作成します。

「Table」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「罫線」

このプロパティは、コンポーネントの境界に実線を描画します。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Table」には、バンドやカラムの設定や、表の外観等に関するプロパティがあります。


URLLabel

「URLLabel」コンポーネントは、URL から読み込んだテキストをレイアウト上に表示します。

「URLLabel」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「URLLabel」には、「配置」、「背景色」、「縦書き」、自動サイズや折り返し等の指定をする「スタイル」、「文字幅と間隔」などのプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


URLImage

「Image」コンポーネント同様、指定された URL から取得した画像をレイアウト上に挿入します。使用可能な画像形式は、jpg, bmp, png, gif, tiff となっています。

「URLImage」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「URLImage」には、「配置」と「外観」に関するプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


「拡張」コンポーネント

コンポーネントパレットの「拡張」タブにあります。主にバーコード、グラフ出力等のコンポーネントがまとめられています。

  • URLExecute
  • BarCode
  • Graph
  • Chart
  • OCCS
  • SATOLabel


URLExecute

「URLExecute」コンポーネントは、指定された URL アドレスを実行します。主に CGI/サーブレットのパスを指定し、プロセスの実行に使用します。URL アドレスからの結果は表示されません。

「URLExecute」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


BarCode

「BarCode」コンポーネントは、内容に指定された値からバーコード画像を生成し、レイアウト上に表示します。内容タイプが「Static」の場合は、テンプレート設計中でも表示可能です。

「BarCode」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「BarCode」には、「配置」と「外観」に関するプロパティがあります。

「設定」

このプロパティは、個々のコンポーネント特有のプロパティです。

「BarCode」には、「バーコードタイプ」、「テキスト表示」、「チェックデジット」、「基準幅」、「回転」などのプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Graph

「Graph」コンポーネントは、内容に指定された値を使用してレイアウト上にグラフを表示します。内容タイプに「Static」を選択した場合は、X, Point, Series に値を直接入力します。「Database」を選択した場合は、X, Point, Series に、対応するフィールドを正しく指定する必要があります。下記手順を参照してください。

「Graph」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Graph」には、「配置」と「外観」に関するプロパティがあります。

「設定」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Graph」には、グラフの表題や配置、背景色など、外観の設定に関するプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。

※Linux環境、または、Solaris等のUNIX環境で「Graph」コンポーネントを使用するには、X-Window環境のもとでOXSを起動する必要があります。

例1：Database グラフ

テーブル：Sales

X | Point | Peter | Janet
1 | January | 120 | 110
1 | February | 74 | 82
1 | March | 160 | 57
  1. 「Dataset」コンポーネントをテンプレート上に配置します。
  2. クエリビルダを呼び出し、Dataset に「Sales」テーブルの全フィールドを適用します。
  3. 「Graph」コンポーネントを配置・選択し、F11キーを押してプロパティエディタの「アクティブ」タブを表示します。
  4. 「設定／ヘッダ」に「Sales」、「表題」に「Sales Rep」と入力します。
  5. 「内容／タイプ」で「Database」を選択し、「系列」に「2」と入力します。
  6. 「内容／X」カラムをクリックし、必要なフィールドを選択します。
  7. 「内容／Point」カラムをクリックし、必要なフィールドを選択します。
  8. 「内容／Series0」をクリックして「Peter」と入力し、「Series0」カラムから「Peter」フィールドを選択します。
  9. 「内容／Series1」をクリックして「Janet」と入力し、「Series1」カラムから「Janet」フィールドを選択します。
  10. 「プレビュー」ボタンをクリックします。

以下のグラフが表示されます。

例2：Static グラフ

  1. 「Graph」コンポーネントを配置・選択し、F11キーを押してプロパティエディタの「アクティブ」タブを表示します。
  2. 「設定／ヘッダ」に「Sales」、「表題」に「Sales Rep」と入力します。
  3. 「内容／タイプ」で「Static」を選択し、「系列」に「2」と入力します。
  4. 「内容／X」カラムに「1」と入力します。
  5. 「内容／Point」カラムに「January」を入力します。
  6. 「内容／Series0」をクリックして「Peter」と入力し、「Series0」カラムの最初の列に「120」と入力します。
  7. 「内容／Series1」をクリックして「Janet」と入力し、「Series1」カラムの最初の列に「110」と入力します。
  8. 「行の追加」ボタンをクリックすると、新しい列が追加されるので、2番目と3番目の列のレコードを、上記「Sales」テーブルに従って入力します。
  9. 「内容／グラフの表示」をクリックし、グラフを表示します。


Chart

「Chart」コンポーネントは、内容に指定された値を使用してレイアウト上にチャートを表示します。内容タイプに「Static」を選択した場合は、X, Point, Series に値を直接入力します。「Database」を選択した場合は、X, Point, Series に、対応するフィールドを正しく指定する必要があります。下記手順を参照してください。

「Chart」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Chart」には、「配置」と「外観」に関するプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。

「外観」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Chart」には、テキストの色、背景色、回転、解像度など、チャートの外観に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。

「Chart」には、プロットのタイプ、凡例の配置や定義域、値域のタイトルを指定するプロパティがあります。

例1：Database グラフ

テーブル：Sales

X | Point | Peter | Janet
1 | January | 120 | 110
2 | February | 74 | 82
3 | March | 160 | 57
  1. 「Dataset」コンポーネントをテンプレート上に配置します。
  2. クエリビルダを呼び出し、Dataset に「Sales」テーブルの全フィールドを適用します。
  3. 「Chart」コンポーネントを配置・選択し、F11キーを押してプロパティエディタの「アクティブ」タブを表示します。
  4. 「外観／タイトル」に「Sales」と入力します。
  5. 「内容／タイプ」で「Database」を選択し、「系列数」に「2」と入力します。
  6. 「内容／X」カラムをクリックし、必要なフィールドを選択します。
  7. 「内容／Point」カラムをクリックし、必要なフィールドを選択します。
  8. 「内容／Series0」をクリックして「Peter」と入力してEnterキーを押し、「Series0」カラムから「Peter」フィールドを選択します。
  9. 「内容／Series1」をクリックして「Janet」と入力してEnterキーを押し、「Series1」カラムから「Janet」フィールドを選択します。
  10. ツールバーの「プレビュー」ボタンをクリックします。

例2：Static グラフ

  1. 「Chart」コンポーネントを配置・選択し、F11キーを押してプロパティエディタの「アクティブ」タブを表示します。
  2. 「外観／タイトル」に「Sales」と入力します。
  3. 「内容／タイプ」で「Static」を選択し、「系列数」に「2」と入力します。
  4. 「内容／X」カラムに「1」と入力します。
  5. 「内容／Point」カラムに「January」を入力します。
  6. 「内容／Series0」をクリックして「Peter」と入力してEnterキーを押し、「Series0」カラムの最初の列に「120」と入力します。
  7. 「内容／Series1」をクリックして「Janet」と入力してEnterキーを押し、「Series1」カラムの最初の列に「110」と入力します。
  8. 「行の追加」ボタンをクリックすると新しい列が追加されるので、2番目と3番目の列のレコードも、上記「Sales」テーブルに従って入力します。
  9. ツールバーの「プレビュー」ボタンをクリックします。

例1、例2ともに以下のチャートが表示されます。


OCCS

「OCCS」コンポーネントは、OPRO Content Control Service ( OCCS ) から、画像、サウンド、動画等のバイナリデータを取得します。OCCS で取得できる画像形式は png, gif; jpg, bmp, ico, emf; wmf, tiff 、サウンド形式は mp3, m3u, wav, wma, rm, rmi, au, mid, aif, aiff 、動画形式は dat, mpg, mpa, mp2, m1v, mov, avi となっています。OCCS にデータファイルを追加するには、OCCS 管理者権限が必要です。

「OCCS」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「OCCS」には、「配置」と「外観」に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となる、OCCS内部のデータを指定します。


SATOLabel

「SATOLabel」コンポーネントは、高速感熱式 SATO バーコードラベルプリンタのデバイスフォントを使用して、バーコードとテキストを印刷します。この機能は OXB および OIPS ( OPRO Internet Print Service ) でのみ使用可能です。値をバーコード形式で印刷するには、バーコードタイプのフォントを選択する必要があります。

「SATOLabel」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「デバイスフォント」

このプロパティは、接続されているOIPSで使用可能なデバイスフォントを指定するプロパティです。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


「フォーム」コンポーネント

コンポーネントパレットの「フォーム」タブにあります。電子フォームを作成するためのコンポーネントがまとめられています。基本的にすべて「InterfaceGroup」コンポーネント内部に配置されます。

  • InterfaceGroup
  • Text
  • Password
  • Memo
  • DropDown
  • List
  • Check
  • Radio
  • Submit
  • Reset
  • Invisible
  • URLText
  • URLMemo
  • URLDropDown
  • URLList
  • URLInvisible
  • File
  • OFD I/O
  • DatasetDropDown
  • DatasetList


InterfaceGroup

「InterfaceGroup」コンポーネントは、Webページに電子フォームを生成するコンテナとして配置します。このコンポーネント内には、各種「フォーム」コンポーネントを配置することができ、プレビューすれば、電子フォームとして動作させることが可能です。多様な内容タイプ指定が可能で Multipart, OFD, OXR, OPR, XML, XFDF, FDF, PDF 等を URL-Encoded パラメータとして送信する機能があります。

「InterfaceGroup」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「グリッド」

このプロパティは、「InterfaceGroup」のグリッドの設定に関するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「InterfaceGroup」には、「外観」や、リクエストURLやメソッドの種類を指定する「アクション」、「OFD/XML変換」に関するプロパティなどがあります。

※ InterfaceGroupがDatasetTableのグループバンド、または、DatasetBandで使用されている場合、PDFはサポートされません。その場合は、InterfaceGroupの先頭のグループだけがPDFでは表示されます。

※ InterfaceGroup (ベースフォントが14でないもの)を含む PDF 出力テンプレートを表示するには、 Acrobat5.x 以降のバージョンを使用する必要があります。

※「InterfaceGroup」コンポーネントは PDF 用の EUDC フォントをサポートしません。


Text

「Text」コンポーネントは、電子フォームにテキスト入力枠を配置します。テキストを入力枠に表示、または、ユーザの入力したテキストを読み込むのに使用します。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「Text」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Text」には、「外観」と「属性」に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Password

「Password」コンポーネントは、電子フォームにパスワード入力枠を配置します。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「Password」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Password」には、「外観」と「属性」に関するプロパティがあります。


Memo

「Memo」コンポーネントは、電子フォームにテキストボックスを配置します。このコンポーネントは、複数行テキストによる長文の記述に適しており、電子フォームに大量テキスト情報を入力可能です。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「Memo」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Memo」には、「外観」と「属性」に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


DropDown

「DropDown」コンポーネントは、電子フォームにドロップダウンリストを配置します。このコンポーネントに設定したドロップダウンリスト選択項目は、テンプレート設計中に選択することはできません。クライアント側で表示、または、テンプレートプレビュー時に選択可能になります。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「DropDown」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「DropDown」には、「外観」と「属性」に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


List

「List」コンポーネントは、電子フォームにリストボックスを配置します。このコンポーネントに設定したリスト選択項目は、テンプレート設計中に選択することはできません。クライアント側で表示、または、テンプレートプレビュー時に選択可能になります。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「List」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「List」には、「外観」と「属性」に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Check

「Check」コンポーネントは、電子フォームにチェックボックスを配置します。チェックボックスは、オプション項目の選択／非選択を決めるコンポーネントです。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「Check」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Check」には、「パラメータ名」、「チェック済」、「選択不能」、「読取専用」、「タブ順」などのプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Radio

「Radio」コンポーネントは、電子フォームにラジオボタンを配置します。ラジオボタンは、複数のオプション項目から排他的な選択を行なうコンポーネントです。1グループ内のラジオボタンは常に一つだけが選択されます。別のラジオボタンを選択した時には、それまで選択されていたラジオボタンは解除されます。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「Radio」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Radio」には、「パラメータ名」、「チェック済」、「選択不能」、「読取専用」、「タブ順」などのプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Submit

「Submit」コンポーネントは、電子フォームに送信ボタンを配置します。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「Submit」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Submit」には、「パラメータ名」、「選択不能」、「タブ順」などのプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Reset

「Reset」コンポーネントは、電子フォームにリセットボタンを配置します。リセットボタンは、InterfaceGroup 内に配置された他のコンポーネントの値を初期値にリセットします。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「Reset」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Reset」には、「タブ順」プロパティのみがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


Invisible

「Invisible」コンポーネントは、電子フォームに非表示情報(値)を設置します。この機能は、input タグの type 属性の hidden にあたるものです。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「Invisible」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Invisible」には、「パラメータ名」と「選択不能」のプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。


URLText

「URLText」コンポーネントは、電子フォームにテキスト入力枠を配置します。URLから取得したテキストを入力枠に表示、または、ユーザの入力したテキストを読み込むのに使用します。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「URLText」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「URLText」には、「外観」と「属性」に関するプロパティがあります。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


URLMemo

「URLMemo」コンポーネントは、電子フォームにテキストボックスを配置します。URLから取得したテキストをテキストボックスに表示、または、ユーザの入力したテキストを読み込むのに使用します。このコンポーネントは、複数行テキストによる長文の記述に適しており、電子フォームに大量テキスト情報を入力可能です。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「URLMemo」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「URLMemo」には、「外観」と「属性」に関するプロパティがあります。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


URLDropDown

「URLDropDown」コンポーネントは、URLから取得した項目を使用して、電子フォームにドロップダウンリストを配置します。このコンポーネントに設定したドロップダウンリスト選択項目は、テンプレート設計中に選択することはできません。クライアント側で表示、または、テンプレートプレビュー時に選択可能になります。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「URLDropDown」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「URLDropDown」には、「外観」と「属性」に関するプロパティがあります。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


URLList

「URLList」コンポーネントは、URLから取得した項目を使用して、電子フォームにリストボックスを配置します。このコンポーネントに設定したリスト選択項目は、テンプレート設計中に選択することはできません。クライアント側で表示、または、テンプレートプレビュー時に選択可能になります。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「URLList」には、「外観」と「属性」に関するプロパティがあります。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


URLInvisible

「URLInvisible」コンポーネントは、URL から取得した値を使用して、電子フォームに非表示情報(値)を設置します。この機能は、input タグの type 属性の hidden にあたるものです。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「URLInvisible」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「URLInvisible」には、「パラメータ名」と「選択不能」のプロパティがあります。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


File

「File」コンポーネントは、電子フォームにファイルアップロード用のテキスト入力枠と参照ボタンを配置します。ファイルアップロードのリクエストには、「Submit」ボタンを使用してください。メッセージは、InterfaceGroup プロパティの「カスタム／メソッド」「カスタム／内容」で指定されるエンコード形式で送信されます。このコンポーネントは InterfaceGroup 内にのみ配置可能です。

「File」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「File」には、「パラメータ名」、「選択不能」、「タブ順」などのプロパティがあります。


OFD I/O

「OFD I/O」コンポーネントは、電子フォームに入力したデータを保存、または、読み込みます。このコンポーネントは、InterfaceGroupの内外どちらにも配置できます。InterfaceGroup内に配置した場合は、そのInterfaceGroupのデータを対象にし、InterfaceGroupテンプレート上にあるすべてのInterfaceGroupのデータを対象にします。

「OFD I/O」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「OFD I/O」には、コントロールの形態をボタンまたはポップアップにする「形態」を始め、保存または読込動作かを指定する「動作」、この機能の適用範囲を指定する「対象となるInterfaceGroup」や、「タブ順」などのプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、静的(直接入力)または動的(URL、データベース)に指定します。

※この機能は OXB 上でのみ有効です。


DatasetDropDown

「DatasetDropDown」コンポーネントは、Datasetから取得した項目を使用して、電子フォームにドロップダウンリストを配置します。このコンポーネントに設定したドロップダウンリスト選択項目は、テンプレート設計中に選択することはできません。クライアント側で表示、または、テンプレートプレビュー時に選択可能になります。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「DatasetDropDown」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「DatasetDropDown」には、「外観」と「属性」に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータをデータベースフィールドから指定します。


DatasetList

「DatasetList」コンポーネントは、Datasetから取得した項目を使用して、電子フォームにリストボックスを配置します。このコンポーネントに設定したリスト選択項目は、テンプレート設計中に選択することはできません。クライアント側で表示、または、テンプレートプレビュー時に選択可能になります。このコンポーネントはInterfaceGroup内にのみ配置可能です。

「DatasetList」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「DatasetList」には、「外観」と「属性」に関するプロパティがあります。

「内容」

このプロパティは、コンポーネントで使用する元となるデータをデータベースフィールドから指定します。


「データアクセス」コンポーネント

コンポーネントパレットの「データアクセス」タブにあります。主にデータベースフィールドをカプセル化して利用し易くするためのコンポーネントがまとめられています。

  • Dataset
  • TextDataset
  • URLTextDataset
  • DatasetTable
  • HorizontalDatasetTable
  • DatasetTable Container
  • AggregateFunction
  • DBExecute


Dataset

「Dataset」コンポーネントは、クエリビルダを使用してデータベースをカプセル化し、データベースフィールドへのアクセスを簡易化します。データベースは、Access, Cache, DB2, Lotus Domino, MySQL, Oracle, PostgreSQL, SQL Server, Sybase, OPROXML, ODBC 準拠データベース等がサポートされています。クエリビルダを起動するには、「Dataset」コンポーネントをダブルクリックするか、または、プロパティの「フィールド／編集」を選択します。

「Dataset」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フィールド」

このプロパティは、コンポーネントで使用する元となるデータベースフィールドまたはクエリを指定します。


TextDataset

「TextDataset」コンポーネントは「Dataset」コンポーネントと似ていますが、データベースではなく、テキスト／CSVファイル、または手動入力データを読み込み、「Dataset」同様の役割を果たします。データソースをカプセル化するには、「TextDataset」コンポーネントをダブルクリック、または、プロパティの「フィールド／編集」を選択し、テキストクエリビルダを起動してください。

「TextDataset」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フィールド」

このプロパティは、コンポーネントで使用する元となるCSVデータのフィールドを指定します。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、「サンプルデータ作成」、「ファイル」または「URL」のパスによるCSVファイルから指定します。


URLTextDataset

「URLTextDataset」コンポーネントは「Dataset」コンポーネントと似ていますが、データベースではなく、指定URLからテキスト/CSVファイルを読み込み、「Dataset」同様の役割を果たします。データソースをカプセル化するには、「TextDataset」コンポーネントをダブルクリック、または、プロパティの「フィールド／編集」を選択し、テキストクエリビルダを起動してください。

「TextDataset」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フィールド」

このプロパティは、コンポーネントで使用する元となるCSVデータのフィールドを指定します。

「URLデータ」

このプロパティは、コンポーネントで使用する元となるデータの読込先となるURLパスを指定します。


DatasetTable

「DatasetTable」コンポーネントは、データベースやCSVデータとリンクし、バンドとカラムを使用してテーブル(表)を作成します。DatasetTable内に、別のDatasetTableを配置してSubReportを作成することもできます。

「DatasetTable」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「罫線」

このプロパティは、コンポーネントの境界に実線を描画します。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「DatasetTable」には、表の「外観」や「配置」、バンドやカラム、ヘッダやフッタ等、表に関する詳細な設定のプロパティがあります。

※集計関数は、DatasetTableのサマリバンド（レポートヘッダ、レポートフッタ、グループヘッダ、グループフッタ）にのみ配置可能です。

DatasetTable のサイズを変更すると、レイアウト上で縦方向に表示可能なバンド数が表示されます。バンド数は、ページヘッダ、ページフッタ、カラムヘッダ、レポートヘッダの各バンドの高さを考慮して算出されます。レポートフッタ、グループヘッダ、グループフッタが選択されている場合、表示可能レコード数は、出力ページに一つだけバンドが存在するものとして算出されます。バンド数は、データベースのレコード数によっても変化します。


HorizontalDatasetTable

「HorizontalDatasetTable」コンポーネントは、「DatasetTable」コンポーネントと同様に、データベースとリンクし、バンドとカラムを使用してテーブル(表)を作成します。

「HorizontalDatasetTable」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「罫線」

このプロパティは、コンポーネントの境界に実線を描画します。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「HorizontalDatasetTable」には、表の「外観」や「配置」、バンドやカラム、ヘッダやフッタ等、表に関する詳細な設定のプロパティがあります。

※集計関数は、HorizontalDatasetTable のサマリバンド（レポートヘッダ、レポートフッタ、グループヘッダ、グループフッタ）にのみ配置可能です。

HorizontalDatasetTable のサイズを変更すると、レイアウト上で横方向に表示可能なバンド数が表示されます。バンド数は、ページヘッダ、ページフッタ、カラムヘッダ、レポートヘッダの各バンドの高さを考慮して算出されます。レポートフッタ、グループヘッダ、グループフッタが選択されている場合、表示可能レコード数は、出力ページに一つだけバンドが存在するものとして算出されます。バンド数は、データベースのレコード数によっても変化します。


DatasetTable Container

「DatasetTable Container」コンポーネントは、内部に複数 DatasetTable を配置可能なコンテナです。DatasetTable Container 内に二つの DatasetTable を配置して出力すると、最初の DatasetTable にテーブルの内容すべてを表示した後、二番目の DatasetTable にテーブルの内容を表示します。

「DatasetTable Container」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。


Aggregate Function

「Aggregate Function」コンポーネントは、 選択されたフィールドの集計結果(合計値、最大値、最小値、平均値、件数)を出力します。データベース用コンポーネントなので、結果を確認するにはテンプレートをプレビューする必要があります。

「Aggregate Function」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Aggregate Function」には、「配置」、「背景色」、「縦書き」、自動サイズや折り返し等の指定をする「スタイル」、「文字幅と間隔」などのプロパティがあります。

「ハイパーリンク」

このプロパティは、URL に指定されたアドレスをリクエストするリンク機能を提供します。

「内容」

このプロパティは、コンポーネントで使用する元となるデータを、データベースフィールドと集計関数から指定します。


DBExecute

「DBExecute」コンポーネントは、指定したデータベースに対し、複数行のSQL文を記述したデータベース スクリプトを実行できます。さらに、実行タイミングをドキュメント生成前か生成後に指定可能です。

「DBExecute」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「スクリプト」

このプロパティは、スクリプトの記述及び設定を行ないます。


「セキュリティ」コンポーネント

コンポーネントパレットの「セキュリティ」タブにあります。主にセキュアなドキュメントを生成するためのセキュリティ関連コンポーネントがまとめられています。

  • Document Security
  • Digital Signature
  • MistyGuard SignedPDF
  • VeriSign Digital Signature
  • DocuWorks Signature
  • TimeStamp


Document Security

「Document Security」コンポーネントは、ドキュメントを暗号化することによって、ドキュメントのセキュリティを確保します。ドキュメントの表示をパスワードで保護することによって制限したり、ドキュメントの印刷や内容のコピー・変更を許可しないように設定したりすることができます。

「Document Security」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「セキュリティ」

このプロパティは、作成されるドキュメントでの「操作の許可」、および、「動作の強制」を設定します。

「パスワード」

このプロパティは、作成されるドキュメントの表示をパスワードで保護するための設定を行ないます。


Digital Signature

「Digital Signature」コンポーネントは、署名によりドキュメントの正当性を認証します。テンプレート作者がドキュメントに一意な「署名」を付加し、その作者の作成したテンプレートであると保証するのに使用します。ドキュメント作成後にドキュメントが修正された場合、署名が有効になっていなかった場合、署名の有効期間が終了していた場合、ドキュメントは保証されません。

Digital Signature を配置するには

  1. 「Digital Signature」コンポーネントをテンプレートに配置します。
  2. 「Digital Signatureログイン」ダイアログで、「プロファイル名」を選択し、「パスワード」を入力して「ログイン」ボタンをクリックします。
  3. 「ドキュメントに署名」ダイアログで、必要な情報を入力し、「署名」ボタンをクリックします。

新規プロファイルを作成するには

  1. 「Digital Signature」コンポーネントをテンプレートに配置します。
  2. 「Digital Signatureログイン」ダイアログで、「新規ユーザ」ボタンをクリックします。
  3. 「新規ユーザプロファイル」ダイアログで、ユーザ登録情報およびプロファイル認証等、必要な情報を入力し、「OK」ボタンをクリックします。
  4. 「ドキュメントに署名」ダイアログで、必要な情報を入力し、「署名」ボタンをクリックします。

「Digital Signature」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「Digital Signature」には、署名の「画像」及び「テキスト」の「配置」などに関するプロパティがあります。

※「Digital Signature」コンポーネントは、一つのテンプレートに一つだけ配置可能です。この署名を含む PDF を表示するには、Acrobat 5.x 以降のバージョンを使用してください。


MGSigned PDF

「MGSigned PDF」コンポーネントは、署名により PDF ドキュメントの正当性を認証します。コンポーネント配置時にテンプレート作者は、初期化済・証明済のスロットに「スロット番号」と「スロット パスワード」でログインする必要があります。32個のスロットのうちテンプレートへの署名に使用できるのは、初期化済・証明済のスロットのみです。

「MGSigned PDF」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「MGSigned PDF」には、署名の背景色や「署名のプロパティ」に関するプロパティがあります。

※このコンポーネントを機能させるには、OXS管理者、または、ベンダからシリアルキーを入手する必要があります。


VeriSign Digital Signature

「VeriSign Digital Signature」コンポーネントは、より厳正なベリサイン社のデジタル署名を利用します。セキュアなメッセージ送信には、デジタルID が必要です。ユーザ毎に独自デジタルID をベリサイン社から取得し、インターネット上でユーザを識別します。デジタルID の拡張子は「.pfx」( IE )または「.p12」( Netscape )です。詳細は、http://www.verisign.com/ を参照してください。

VeriSign Digital Signature を配置するには

  1. 「VeriSign Digital Signature」コンポーネントをテンプレートに配置します。
  2. 「VeriSign Digital Signature ログイン」ダイアログで、「プロファイル名」を選択し、「パスワード」を入力して「ログイン」ボタンをクリックします。
  3. 「ドキュメントにベリサインの署名」ダイアログで、必要な情報を入力し、「署名」ボタンをクリックします。

「VeriSign Digital Signature」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「フォント」

このプロパティは、表示するテキストのフォントやスタイルを指定するプロパティです。

「カスタム」

このプロパティは、個々のコンポーネント特有のプロパティです。

「VeriSign Digital Signature」には、署名の「画像」及び「テキスト」の「配置」などに関するプロパティがあります。


DocuWorks Signature

「DocuWorks Signature」コンポーネントは、DocuWorks ドキュメントに公開鍵暗号をベースとした暗号化処理によるデジタル署名を付加します。テンプレートに「DocuWorks Signature」コンポーネントを配置すると、OXS より必要な情報を取得します。このデジタル署名に関する情報は、以下のようなダイアログに表示されます。

「DocuWorks Signature」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。


TimeStamp

「TimeStamp」コンポーネントは、OXS によって生成されるドキュメントにタイムスタンプトークンを埋め込む機能を提供します。タイムスタンプトークンは、ドキュメントが特定の時刻に存在し、その時刻以来、内容が変更されていないことを保証します。

TimeStamp は、以下の状況で不可欠なものです。

存在証明
「TimeStamp」コンポーネントは、ドキュメントが特定の時刻以前に存在したことを保証します。
完全性証明
「TimeStamp」コンポーネントは、ドキュメントの内容が特定の時刻以後に変更されていないことを保証します。

「TimeStamp」コンポーネントを配置すると、タイムスタンプサーバに関するダイアログが表示されます。

「名前」ドロップダウンから、使用可能なタイムスタンプサーバを選択し、「OK」ボタンをクリックすると、「TimeStamp」コンポーネントがテンプレートに配置されます。

「TimeStamp」のプロパティ

「全般」

このプロパティは、「名前」、「位置とサイズ」、コンポーネントの「枠線」など、すべてのコンポーネントに共通なプロパティです。

「タイムスタンプサーバ」

このプロパティには、タイムスタンプサーバの「名前」や、署名の「外観」に関するプロパティがあります。

※「外観」プロパティは PDF でのみ有効となります。


「ウィザード」コンポーネント

コンポーネントパレットの「ウィザード」タブにあります。「DatasetTable」コンポーネントを用いた帳票形式のレポートテンプレートを簡単に作成できるウィザードがまとめられています。

  • DatasetTable ウィザード
  • SubReport ウィザード
  • Graph ウィザード
  • Dataset 変更ウィザード


DatasetTable ウィザード

DatasetTable、または、HorizontalDatasetTableを容易な手順で作成できるウィザードです。最大四つまでのテーブルのグルーピングが可能です。

DatasetTable ウィザードを選択するには

  1. テンプレートに「Dataset」コンポーネントを配置し、データベースとリンクさせます。
  2. 「コンポーネント」メニューから「DatasetTable ウィザード」オプションを選択するか、ツールバーの [image] アイコンをクリックします。


SubReport ウィザード

SubReportを容易な手順で作成できるウィザードです。ウィザード実行前に、データベースにリンクされたDatasetをあらかじめ二つ以上テンプレートに配置しておく必要があります。ウィザードで、最初に選択するDatasetTableを親DatasetTable、二番目に選択するDatasetTableを子DatasetTableとします。親子それぞれのDatasetTableには、関連フィールドを持つDatasetを指定する必要があります。

SubReport ウィザードを選択するには

  1. テンプレートに二つ以上の「Dataset」コンポーネントを配置し、データベースとリンクさせます。
  2. 「コンポーネント」メニューから「SubReport ウィザード」オプションを選択するか、ツールバーの [image] アイコンをクリックします。


Dataset 変更ウィザード

「Dataset 変更ウィザード」は、Dataset の内容を 別の Dataset に転送します。新しいデータベースにリンクする必要のある Dataset を、古い Dataset から引き継がせたい場合に役立つウィザードです。使用可能なコンポーネントは、Dataset, TextDataset, URLTextDataset です。

Dataset 変更ウィザードを選択するには

  1. テンプレートに二つ以上の「Dataset」コンポーネントを配置し、データベースとリンクさせます。
  2. 「コンポーネント」メニューから「Dataset 変更ウィザード」オプションを選択するか、ツールバーの [image] アイコンをクリックします。


Graph ウィザード

グラフを容易な手順で作成できるウィザードです。このウィザードを使用すると、簡単なグラフ( Single )と高度なグラフ( Multi )の二種類のグラフを作成できます。データソースは、手動入力値／データベース／CSVファイルから取得可能です。

Graph ウィザードを選択するには

  1. テンプレートに「Dataset」コンポーネントを配置し、データベースとリンクさせます。
  2. 「コンポーネント」メニューから「Graph ウィザード」オプションを選択するか、ツールバーの [image] アイコンをクリックします。


よくある質問(FAQ)

カテゴリー

機能

  • OXDの便利な操作方法
  • OPRO File Manager Service (OFMS)について
  • サンプルHTMLを使用したOPRのダウンロード
  • リクエストパラメータ名に使用可能な文字
  • テンプレート名に制限はありますか？
  • ドキュメントにパスワードを付与する
  • 「内容」「URLデータ」のタイプについて
  • TextDatasetとURLTextDatasetの違いについて
  • (URL)TextDatasetでの抽出条件設定
  • URLTextDatasetのフィールド区切り記号について
  • 動的に1つのDatsetTableのデータをすべて表示してから、もう一つのDatasetTableを表示したい
  • 異なる2つのDBのデータでマッチングをして表を作成できますか？
  • 重複の削除
  • SubReport機能で、リンクされるレコードがない場合はどのようになりますか？
  • OXDのクエリビルダで、サブクエリは使えますか？
  • 表の連結について
  • (URL)TextDatasetでの抽出条件設定
  • 同一明細が続く場合に、カラムを結合したような表現をしたい
  • 「グルーピング」機能について
  • 集計を行う方法を教えてください
  • SQLを自由に編集することはできますか？
  • OXSからデータベースに書き込むことはできますか？
  • DBExecuteについて
  • CSVファイルの出力は可能ですか？
  • CSVを使用する場合、テンプレートにはどのように渡せばよいでしょうか？
  • WHERE句の動的指定について
  • 条件によって線や画像の表示/非表示を切り替えたい
  • 条件付フォーマットの演算子について
  • 連番の付与はできますか？
  • ページ番号と総ページ番号を表示させたい
  • TotalPageNumberを使用できる形式・機能
  • グラフの色を変更したい
  • 対応していないバーコードを使用したい
  • 日付・時間・数値のフォーマット
  • OXDとOXSで、禁則処理の方法が異なる

設定

  • 外字について
  • USERINPUTの指定方法
  • OSMSUSER について
  • Dataset Table を使用したときのデータの表示順について
  • グループごとに改ページしたいのですが･･･
  • SubReport機能で、リンクされるレコードがない場合はどのようになりますか？
  • 同一ページ内で、複数列連続したデータを出力する方法
  • 同一明細が続く場合に、カラムを結合したような表現をしたい
  • 集計を行う方法を教えてください
  • 多段階集計の方法
  • データベースの抽出条件として渡した値を、ドキュメント上にも表示したい
  • 「次の条件でレイアウトを隠す」機能について
  • クエリビルダで表示形式を変更したが、反映されない
  • Graph ウィザードの「3D表示」の設定
  • Graph を出力する際の注意
  • Tabボタンでのフォーカス移動について
  • プレビューボタンを押すことができない
  • OXB、OXDでスクロールバーが表示される
  • テンプレートのサイズ(ピクセル)
  • テンプレートを保存できない
  • パフォーマンスについて

操作

  • バージョンを確認する方法
  • 出力したドキュメントの左上に「OXS Trial Version」もしくは「OXS SDK Version」と表示される
  • DatasetTable の選択方法（ボックスコンポーネントについて）
  • DatasetTable の Column の高さが変更できない（DatasetTable の構造について）
  • データベースを開発から本番に変更すると、テンプレートも変更しないといけませんか？

その他

  • テンプレートの保存場所
  • 既存の帳票デザインに合わせてテンプレートを作成したい
  • 横に伸びる連続帳票は作れますか？
  • クエリビルダの「結果の表示」で、時間がかかる
  • クライアント側に必要なソフトウェアを教えてください。
  • 英語の開発環境はありますか？
  • バージョンの考え方


よくある質問 - 機能

OPRO X Designer - FAQ - 機能

OXDの便利な操作方法

質問

OXDの便利な操作方法

回答

[ ] で囲まれた文字は、キーボードのキーを表します。

操作 | 説明
[Ctrl] + [矢印 (↑↓←→)] | コンポーネントを 1px ずつ移動
[Ctrl] + [Shift] + [矢印 (↑↓←→)] | コンポーネントをグリッドの間隔単位で移動
[Ctrl] + ドラッグ | コンポーネントの移動方向を固定 (水平方向・垂直方向のうち、最初にドラッグし始めた方向に固定)
[Shift] + [矢印 (↑↓←→)] | コンポーネントのサイズを変更
[Alt] + ドラッグ | ボックスコンポーネント（※）を移動

（※）ボックスコンポーネント・・・Table、InterfaceGroup、DatasetTable、HorizontalDatasetTable、DatasetTableContainer

OPRO File Manager Service (OFMS)について

質問

OXDにてテンプレートの保存時に「OFMSに保存」というのがありますが、これは何をするものでしょうか。（機能・使用例）

回答

OFMS (OPRO File Manager Service) は、仮想的なディレクトリにテンプレートを保存し、使用するための機能です。
OXS Standard Edition においても使用できます。

設定方法・使用方法等は、下記の通りです。
また、必ず[注意事項]をお読みのうえでご利用ください。

[OXS の設定]
 ODCAW.xmlの ODCAW/OFMS 要素内で、下記の設定を行います。
(ODCAW.xml 変更後は、OXS を再起動してください。)

<OFMS active="YES">
OFMS を動作させる / 動作させないを、YES / NO で指定します。
(デフォルトでは YES ですので、特に変更する必要がありません。)

<XMLPATH>C:/Program Files/OPRO/OPRO X Server/works/ofmsApps/</XMLPATH>
OFMSFileAttri.xml のフォルダを指定します。
(OFMSFileAttri.xml は、OFMS に保存されたすべてのファイル、データ、およびフォルダ情報を記録するためのファイルです)

<FILEPATH>C:/Program Files/OPRO/OPRO X Server/works/ofmsApps/</FILEPATH>
OFM ファイルのフォルダを指定します。

OFMS は、OPRO X Designer がテンプレートを保存する時に OFM ファイルとしてこのフォルダに保存します。
また、OPRO X Designer がテンプレートを OFMS から開く時、OFMS は OFM ファイルを開きます。

<BACKUP count="3"/>
 OFMS が自動的にバックアップするファイルの数を設定します。
OFMS アドミニストレータ上で、「**.oxt-bkp1」という形式で表示されるのがバックアップファイルです。

<ADMIN>admin</ADMIN>
 OFMS アドミニストレータでログインする際の、ADMIN ユーザのパスワードを設定します。
（Administrator 権限のユーザ名は常に大文字の「ADMIN」です。）

<USER name="guest">guest</USER>
 OFMS を使用するユーザ名とパスワードを設定します。name 属性の値がユーザ名、値がパスワードとなります。

[テンプレートの保存]
 1. OPRO X Designer のオプションメニューから、「OFMS アドミニストレータ」を起動します。
2. ODCAW.xml で設定したユーザ名/パスワードでログインします(ADMIN/admin 等)。
3. OFMS アドミニストレータ上で、新規フォルダを作成し、一旦終了します。
4. 次に、テンプレートを保存します。ファイルメニュー → 「名前を付けて保存」 → 「OFMS に保存」を選択してください。
5. 再び OFMS アドミニストレータにログインします。
6. 3 で作成したフォルダを選択し、「ファイル名」にテンプレート名を入力し、「保存」ボタンを押します
(このときパスワードを聞かれますが、こちらはテンプレートを開く際のパスワードです。
必要無い場合は、何も入力しないでください)。

[実行時]
 リクエストする際は、下記のパラメータについてご注意ください。

・TP
「TP=OFMS://フォルダ名/テンプレート名」という形式で指定します。
「フォルダ名」は、OFMS アドミニストレータ上でのフォルダ名です。

その他のパラメータにつきましては、通常のテンプレートと変わりありません。

[一般的な使用例]
 通常のテンプレート保存方法 (テンプレート保存用ディレクトリに .oxt を保存する方法) と比べ、OFMS を使用した場合は、
下記のような機能を使用することができます。

・OFMS 上で開かれているテンプレートを、別の端末の OXD から開いた場合は読み取り専用になりますので、意図せず別の場所から上書き保存されるといったことを防ぐことが可能です。

・テンプレートを保存する際に、開くためのパスワードを設けることができます。

・ディレクトリの共有や、FTP 等を使用することなく、(OXD から OXS を使用できてさえいれば) OXS 側にテンプレートを保存することができます。

[注意事項]

1)通常のエクスプローラ等からは確認ができません。
OFMS を使用した場合、Windows のエクスプローラからテンプレートファイル (.oxt) を確認することはできません。
OFMS アドミニストレータ上でのみの確認となります。

2)OFMS に関連するファイルは、ODCAW.xml の OFMS 要素以下で設定されたパスに「.ofm」や XML の形式で保存されます。
これらが失われますと、テンプレートの復旧が不可能になりますので、サーバ移転や再インストールの際等に、誤って削除してしまわないよう、ご注意ください。

3)OFMS のテンプレートを使用するには、「TP=OFMS://」という形式で指定する必要がありますので、もし既存のシステムから変更されるということであれば、呼び出し側アプリケーションの変更が発生します。

4)通常の方法とは全く異なる方法になりますので、万が一何らかの問題が発生し、弊社サポートにお問い合わせいただく場合、必ず OFMS を使用している旨をお知らせください。

サンプルHTMLを使用したOPRのダウンロード

質問

サンプルHTMLを使用したOPRのダウンロード

回答

OPRO X Designerのオプションメニュー「サンプルHTMLの作成」から、OPRO X Serverを呼び出すHTMLのサンプルを作成することができます。

ここでは、OPRをダウンロードする場合の手順について説明します。

1. テンプレート（.oxt）を、IN_FILEフォルダに保存。
2. オプションメニュー → 「サンプルHTML」を選択。
3. 必要な項目にチェックを入れる。
4. 「表示」ボタンを押す。
5. 表示されたサンプルHTML上で、「送信」ボタンを押す。

リクエストパラメータ名に使用可能な文字

質問

OPRO X Designerのコンポーネントのプロパティで、タイプを「Request」とした際に指定できる「リクエストパラメータ名」では、どんな文字が使用できますか？

回答

以下の文字を使用することができます。
0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz_ -@{}.

尚、HTTPインターフェース（CGIまたはサーブレット）を使用してOPRO X Serverにリクエストを行う場合、リクエストパラメータをURLエンコードする必要があります。
上記使用可能な文字のうち、URLエンコードする必要がある文字は、

@ {}
（アットマーク、スペース、中括弧）

です。

テンプレート名に制限はありますか？

質問

テンプレート名に制限はありますか？

回答

OPRO X Server側で特に制限を設けているということはありませんので、OPRO X Designerで保存できる名前であれば基本的には使用可能です。

OPRO X DesignerはWindows上で動作しますので、保存可能なファイル名は、ファイルシステムに依存します。

※ 日本語等の2バイト文字を用いた場合、HTTP連携時にはURLエンコードが必要となります。

※ 日本語等の2バイト文字は、思わぬトラブルの原因になりかねませんので、半角英数字のご使用をおすすめいたします。

ドキュメントにパスワードを付与する

質問

ドキュメントにパスワードを付与する

回答

DocumentSecurityコンポーネントを使用することにより、OPR、OXR、PDFに対して下記2種類のパスワードを設定することができます。

マスタパスワード
 ドキュメントの権限を変更可能にするには、このパスワードを設定する必要があります。ドキュメントを開くときにこのパスワードが入力された場合、フルアクセス権限が与えられます。

ユーザパスワード
 ドキュメントを保護し、誰でも開くことができないようにするには、このパスワードを設定する必要があります。このパスワードは、ドキュメントを開こうとしたとき、OXB などのビューアから要求されます。

[設定手順]
1. OPRO X Designer「セキュリティ」タブで「DocumentSecurity」を選択し、レイアウト上に配置。（DocumentSecurityはドキュメントには表示されません。また、配置する位置によって機能が変化することはありません。）

2. DocumentSecurityのプロパティ「パスワード」で、マスタ、ユーザパスワードを設定。

※「マスタ」および「ユーザ」に入力するパスワードの最大長は15文字です。

＜ユーザパスワードのタイプについて＞
 ユーザパスワードは以下の3つのタイプから選択できます。

Static・・・値には、固定のユーザパスワードを設定します。

Request・・・値には、リクエストパラメータ名を設定します。
例えば「DocumentSecurity1」という設定の場合は、OXSへのリクエスト時に {DocumentSecurity1}=パスワード のように指定します。
これにより、リクエストごとに異なるパスワードを付与することが可能です。

Database・・・値には、Datasetとフィールドを設定します。これにより、データベースの値をパスワードとして使用することが可能です。

「内容」「URLデータ」のタイプについて

質問

コンポーネントのプロパティ「内容」または「URLデータ」で選択することができる「Static」「Request」「Database」について

回答

OPRO X Designerのコンポーネントの中には、「内容」または「URLデータ」というプロパティを持つものがあります。
これらのプロパティの「タイプ」で、値の指定方法を「Static」「Request」「Database」の中から選択することができます。
（コンポーネントによっては選択できないタイプもあります。）

以下に、各タイプについて説明します。

[Static]
固定で値を指定します。
例えばLabelコンポーネントの場合は固定の文字列を、Imageコンポーネントであれば固定の画像を指定します。
動的に変化させる必要がない場合等に使用します。

[Request]
OPRO X Serverへのリクエスト時に値を指定します。
テンプレート側では「リクエストパラメータ名」を指定し、実際に入る値はOPRO X Serverへのリクエスト時に、{リクエストパラメータ名}=値　という形式で指定します。（HTTPリクエストの場合（※））

（※）
Java APIの場合は、TemplateParameterのadd()メソッドで、パラメータ名と値を指定します。
Windows APIの場合は、OXSTemplate_AddParameter関数で、パラメータ名と値を指定します。

例えばLabelのリクエストパラメータ名を「Label1」とした場合に、リクエスト時に「value」という値を指定するには、{Label1}=valueとします。

[Database]
Dataset、TextDataset、URLTextDatasetを使用して値を指定します。
例えば下図のように、Datasetとフィールドを指定することにより、データベースやテキストデータ（CSV等）から値を取得することができます。

TextDatasetとURLTextDatasetの違いについて

質問

TextDataset と URLTextDataset の違いについて

回答

TextDataset と URLTextDataset では、入るデータの種類が異なります。
それぞれ、以下のようになります。

TextDataset
プロパティの「内容」には「data1,data2,data3・・」といった、テキストデータの内容が入ります。

URLTextDataset
プロパティの「内容」には、テキストファイル名、もしくは URL が入ります。
「test.csv」のように、ファイル名のみを指定した場合は、ODCAW.xml の ODCAW/ODDS/PATH/DATASOURCE/ で設定されているパス上のファイルを検索し、該当するファイルからデータを取得します。

「http:// ～ test.csv」のように URL を指定した場合は、URL 上のファイルからデータを取得します。

(URL)TextDatasetでの抽出条件設定

質問

「Datset」のクエリビルダの機能「抽出条件の設定」と同じようなことは、「URLTextDataset」や「TextDataset」でも可能でしょうか。

回答

「URLTextDataset」、「TextDataset」は「抽出条件の設定」には対応しておりません。
「抽出条件の設定」を行う場合、「Dataset」を使用してください。
「URLTextDataset」、「TextDataset」を利用する場合は、予め該当データのみを抽出しておいてください。

例えば、
  ・CSVデータがデータベースから出力されたものであれば直接データベースを参照する。
  ・CSVデータをデータベースに一旦格納する。

というような対応方法が考えられます。

URLTextDatasetのフィールド区切り記号について

質問

URLTextDatasetのフィールド区切り記号に、文字数や文字種等の制限はありますでしょうか？

回答

テキストクエリビルダにて定義できるフィールド区切り記号は、半角一文字のみとなります。

動的に1つのDatsetTableのデータをすべて表示してから、もう一つのDatasetTableを表示したい

質問

2つのDatasetTable（DatasetTable1とDatasetTable2）があります。
DatasetTable1のデータが表示され終わったらすぐ下からDatasetTable2を表示し始めることはできますか？
DatasetTable1のデータ件数は帳票生成するごとに変動します。

回答

はい。DatasetTableContainerを使用することで表示できます。

□設定手順例
DatasetTable1のデータがすべて表示されたとき、そのすぐ下からDatasetTable2のデータを表示します。
1. コンポーネントツールバー「データアクセス」タブの右から3番目「DatasetTable Container」を選択し、レイアウト上に配置します(この上にDatastTableを2つ配置しますので、十分な広さを確保してください)。
2. 最初に表示するDatasetTable1を、DatasetTableContainerの上部に配置します。
3. 次に表示したいDatasetTable2を、DatasetTable Containerの下部（DatsetTable1の下部）に配置します。

※注意点
1)DatasetTableContainerを使用した場合、その中にあるDatasetTableの高さは無視され、DatasetTableContainerの高さが表の高さになります。(幅は個々に設定できます)。
2)横に2つ並べた場合は、より上部にあるDatasetTableが先に表示されます。上からの座標が同じ場合は、より左側にあるものが先になります。
3)DatasetTableやDatasetTableContainerは単にクリックしただけでは選択できないようになっています。キーボードのAltキーを押しながらクリックすることにより選択することができます。

異なる2つのDBのデータでマッチングをして表を作成できますか？

質問

DBが異なるので、Datasetを2つ作成しています。
表（DatasetTable）のように表示するときに、2つのDatasetのデータをマッチングすることはできませんか？

回答

SubReport機能を利用することで実現できます。

[使用例]部署テーブル/社員テーブルがあり、部署の詳細情報として社員情報を出力するような場合
1. 部署テーブルでDataset1を作成し、社員テーブルでDataset2を作成
2. 親となるDatasetTableにDataset1を定義し、そのDatasetBand（連続領域）にDataset2を使用したDatasetTable（子）を配置
3. この段階で子となるDatasetTableのカスタムプロパティ「リンク」が使用可能になります。
  「親」と「子」で関連付けを行います（AUTOボタンを押すと、同じフィールド名が自動的に関連付けされます）。

注意：
SubReportでは、TextDataset・URLTextDatasetを使用できません。

重複の削除

質問

下図のように、重複したデータの削除を行いたいのですが、可能ですか？

回答

可能です。DatasetTableの「カスタム」プロパティで、「重複の削除」タブを選択し、削除を行いたいフィールドにチェックを入れてください。

SubReport機能で、リンクされるレコードがない場合はどのようになりますか？

質問

SubReport機能を使うときに、リンクされるレコードがない場合、どのようになりますか？

回答

2つのパターンに分けて回答いたします。

■子テーブルに、リンクされるレコードがない場合でも、親テーブルのレコードは表示されます。
例）
子テーブルに「部署番号」が30のレコードがありませんが、表示結果には親レコードは表示されます。

■親テーブルに、リンクされるレコードがない場合、子テーブルにのレコードは表示されません。
例）
親テーブルに「部署番号」が30のレコードがありませんので、子テーブルの「部署番号」が30のレコードは表示されません。

OXDのクエリビルダで、サブクエリは使えますか？

質問

例えば「式ビルダ」や「抽出条件の設定」で副問合せを使用したいのですが･･･。

回答

バージョン OXD 2.5.0 では、OXDのクエリビルダで、サブクエリを作成することはできません。
（クエリウィザードで作成される重複クエリを除きます。）
サブクエリを使用したビューを作成し、クエリビルダからはそのビューを参照ください。

表の連結について

質問

1つのテンプレート（1つのレイアウト）に、Dataset1 と、Dataset2 を配置して、Dataset1 の表示が終わり次第、Dataset2 をその続きで表示することはできますか？
例えば下図のように「商品名リスト」（ヘッダが青の表）のデータが表示された後に「商品種別リスト」（ヘッダがグレーの表）を表示するイメージです。「商品名リスト」と「商品種別リスト」のレコード件数は動的に変わります。

図: ContainerImage.png

回答

DatasetTable Containerコンポーネントを使用することにより可能です。
DatasetTable Containerコンポーネントは、DatasetTableコンポーネントを複数配置することができるコンテナコンポーネントで、内部で DatasetTableコンポーネントの出力結果を整列させて出力します。
1. コンポーネントパレットのデータアクセスタブの右から2番目「DatasetTable Container」を選択し、レイアウト上に配置します。
  この内部に DatastTableコンポーネントを2つ配置しますので、十分な広さを確保してください。
2. 最初に表示したい表(Dataset1に関連付いたDatasetTable)を、DatasetTable Containerの上部に配置します。
3. 次に表示したい表(Dataset2に関連付いたDatasetTable)を、DatasetTable Containerの下部に配置します。

DatasetTableコンポーネントやDatasetTable Containerコンポーネントは単にクリックしただけでは選択できないようになっています。キーボードのAltキーを押しながらクリックすることで選択することができます。

※以下の点にご注意ください
・DatasetTable Containerコンポーネントを使用した場合、その内部に配置されているDatasetTableコンポーネントの高さは無視され、DatasetTable Containerコンポーネントの高さが表の高さになります(幅は個々に設定できます)。
・DatasetTableコンポーネントを横に2つ配置した場合は、より上部にあるDatasetTableコンポーネントが先に表示されます。上からの座標が同じ場合は、より左側にあるものが先に表示されます。

(URL)TextDatasetでの抽出条件設定

質問

「Dataset」のクエリビルダの機能「抽出条件の設定」と同じようなことは、「URLTextDataset」や「TextDataset」でも可能でしょうか。

任意のCSVファイル全体を選ぶ操作は「Request」機能を用いれば可能でした。
さらにそのCSVファイルの中で「日付が2006/08/08のものだけを抽出する」ということができればと思っています。

もしくはこの場合、CSVファイルを作成するときに、欲しいデータだけに調整しておく必要があるのでしょうか。

回答

「URLTextDataset」、「TextDataset」は「抽出条件の設定」には対応しておりません。
「抽出条件の設定」を行う場合、「Dataset」を使用してください。
「URLTextDataset」、「TextDataset」を利用する場合は、予め該当データのみを抽出しておいてください。

例えば、
  ・CSVデータがデータベースから出力されたものであれば直接データベースを参照する。
  ・CSVデータをデータベースに一旦格納する。

というような対応方法が考えられます。

同一明細が続く場合に、カラムを結合したような表現をしたい

質問

下図のような表現をしたいのですが、可能ですか？

回答

DatasetTableでは、重複した項目の罫線を消したり、カラムを結合することはできませんので、このような表現を行う場合には、SubReportを使用します。

SubReportとは、DatasetTableの中にDatasetTableを配置する方法です。
外側にあるDatasetTableを「親DatasetTable」、内側にあるDatasetTableを「子DatasetTable」と呼びます。

SubReportは、OPRO X DesignerのSubReportウィザードを使用して作成することができます。

「グルーピング」機能について

質問

OPRO X Designerのコンポーネントメニューに「グルーピング」という機能がありますが、どのような機能ですか？

回答

「グルーピング」は、同じタイプの2個以上のコンポーネントをグループ化するために使用します。Label、URLLabel、DatasetTable、HorizontalDatasetTableに対して有効です。
「グルーピング」の目的は、ひと続きのデータを異なるコンポーネント間で共有することです。

例として、2つのLabelをグルーピングした場合の効果について説明します。

図1は、グルーピングしていない状態です。
グルーピングしておりませんので、データがLabel2に引き継がれることはなく、Label1の高さで表示できるところまででデータが途切れます。

図2は、グルーピングした状態です。
Label1の高さで表示しきれなかったデータが、Label2に引き継がれています。

尚、グルーピングした場合、最初のコンポーネントの「全般」プロパティは、それ以降には適用されません。その他のプロパティ（「フォント」、「カスタム」、「ハイパーリンク」等）は、最初のコンポーネントの設定がそれ以降のコンポーネントにも適用されます。

集計を行う方法を教えてください

質問

帳票で集計を行う方法を教えてください

回答

OXD でテンプレートを作成する際、 Aggregate Function コンポーネントを使用することで集計を行うことができます。
Aggregate Function コンポーネントはDataset Table及びHorizontal Dataset Table上のReport Header、Report Footer、Group Header、Group Footerに配置して、様々な集計を行い、表示するコンポーネントです。
例えば、Group Footer に配置した場合はそのグループでの集計結果を、Report Footer に配置した場合はレポート全体での集計結果を出力します。
Aggregate FunctionはDataプロパティの[フィールド]で選択したフィールドに対して、以下の処理を実行することができます。

  Aggregate Functionで実行できる処理
  ・COUNT データのレコード数を出力します。
  ・MAX データの最大値を出力します。
  ・MIN データの最小値を出力します。
  ・AVG データの平均値を出力します。
  ・SUM データの総合計を出力します。

これらの処理内容は内容プロパティで選択します。

SQLを自由に編集することはできますか？

質問

クエリビルダで作成したクエリを、直接編集することはできますか？

回答

OPRO X Serverは、クエリビルダで設定された情報を元に内部処理を行い、クエリ（SQL）を発行しますので、これを直接編集することはできません。
クエリビルダで作成できない形式のSQLが必要な場合は、データーベース側でビューを作成する等の方法をご検討ください。

尚、OPRO X Serverがデータベースに発行したクエリの内容は、Query.logで確認することができます。
（Query.logの出力場所は、ODCAW.xmlの ODCAW/COMMON/LOG/QUERY/FILE/ で設定されています。通常は、[OXS_HOME]/logs/ です。）

※ クエリビルダの「SQL」ボタンで確認できる内容は、実際にOPRO X Serverが発行するクエリとは異なりますので、ご注意ください。

＜参考＞
DBExecuteコンポーネントを使用することによって、任意に設定したスクリプトをデータベースに対して実行することが可能です。
但し、DBExecuteは実行するのみで、結果を受け取ることはできません。

OXSからデータベースに書き込むことはできますか？

質問

OXSからデータベースに書き込むことはできますか？

回答

はい。
DBExecuteコンポーネントを使用することで指定されたデータベースに対し、複数行のSQL文を記述したデータベーススクリプトを実行できます。さらに、実行タイミングの設定を、ドキュメント生成前か、生成後に指定することができます。
DBExecuteコンポーネントはOXDの「データアクセス」タブから配置します。

※注意
DBExecuteコンポーネントに記述したスクリプトはいかなるチェックも受けずに実行されるため、実行前に他のツールを使ってのテストを推奨します。スクリプトはプレビュー時にも実行されるので注意してください。

DBExecuteについて

質問

DBExecuteについて

回答

DBExecuteコンポーネントは、指定されたデータベースに対し、複数行のSQL文を記述したデータベーススクリプトを実行できます。
例えばストアドプロシージャ等、データベース側で何らかの処理を実行した後に、ドキュメントを生成したいといった場合に使用します。

DBExecuteの実行タイミングは、ドキュメント生成前、生成後を指定することができます。

※ DBExecuteは実行するのみですので、OPRO X Serverが結果を直接受け取ることはできません。

使用例：
複数のテーブルから、帳票出力用の一時テーブルにデータをinsertするという機能を持ったストアドプロシージャ（ここでは仮に「insert_tmp」とします）をデータベース側で用意し、OPRO X Serverからストアドプロシージャを呼び出して、ドキュメントを作成するといったことが考えられます。

CSVファイルの出力は可能ですか？

質問

CSVファイルの出力は可能ですか？

回答

ダイナミックに生成したCSVファイルを出力可能です。
CSV ファイルの出力には[Query Buider から保存する方法]と[OXSへリクエストしてダウンロードする方法]の2つがあります。

[Query Buider から保存する方法]

1) OXD で、Dataset コンポーネントからクエリビルダを使用してクエリを作成します。
2)クエリビルダの「結果の表示」ボタンをクリックします。（作成したクエリの結果を表示することができます。）
3)「結果の表示」画面の「CSV形式で保存」ボタンをクリックして CSV ファイルとして保存することができます。

[OXSへHTTPリクエストしてダウンロードする方法]
OQMファイル(.oqm)という、データベース構成要素を保存したファイルを使用します。
通常、PDF などをダウンロードする際は、OXS へのリクエストでテンプレート(.oxt)を指定しますが、
これと同様に、OQMファイル(.oqm)を OXS へのリクエストで指定することにより、CSV を
ダウンロードすることができます。

1.ODCAW.xml での ODTS 要素の設定
  1)ODCAW.xml で ODTS 要素が適切に設定されているかどうかをご確認ください。
設定例)
------------------------------------------------------
    <ODTS>
        <PATH>
        <IN_FILE>
        <LOCAL>C:/Program File/OPRO/Templates/</LOCAL>
        </IN_FILE>
        <OUT_FILE delete="YES" ttl="15" unit="mins">
        <LOCAL>C:/inetpub/wwwroot/odcaw2/odts_out/</LOCAL>
        <URL>http://127.0.0.1/odcaw2/odts_out/</URL>
        </OUT_FILE>
        </PATH>
    </ODTS>
------------------------------------------------------
ODCAW.xml は [OXS_HOME]/conf 以下にあります。（※1）

2.OQMファイルの作成
  1)クエリビルダ の設定を行った Dataset コンポーネントのフィールドプロパティ-「保存」をクリックします。
  2)ODTS の IN_FILE 要素で設定されているディレクトリに 名前をつけて保存します。
    このとき、「ファイルの種類」は「OQM File（*.oqm）」としてください。
  例）query1.oqm というファイルが作成されます。

3.リクエストパラメータの作成
  例えば、次のようなパラメータで HTTP リクエストを行うことができます。
  http://host/odcaw2_cgi.exe?DO=ex&OP=dl&FM=c&SE=,&TP=query1.oqm&CS=Shift_JIS&ES=odts
  各パラメータは次のような意味になります。
    DO=ex
      ・・・ex (実行)と指定してください。。
    OP=dl
      ・・・操作を dl (ダウンロード)と指定して下さい。
    FM=c
      ・・・フォーマットを c (CSV)と指定して下さい。
    SE=,
      ・・・区切り文字を指定します。今回は , (カンマ)を指定しました。
    TP=query1.oqm
      ・・・OQM ファイル名を拡張子付きで指定してください。
    ES=odts
      ・・・実行サービス名 odts を指定してください。
  パラメータについては製品同梱の manual の次の部分を参照ください。
    CGI / サーブレット パラメータリスト-データのダウンロード

注意
CSVのダウンロードは、HTTP連携でのみ可能です。
APIでは実行できません。

※1)[OXS_HOME]は、OXSのインストールディレクトリのことです。

CSVを使用する場合、テンプレートにはどのように渡せばよいでしょうか？

質問

CSVを使用して帳票を作成しようと思っています。
このとき、テンプレートにCSVのデータを渡すにはどのようにすればよいですか？

回答

CSVを使用して帳票を生成する方法として、下記4つの方法を紹介します。

1.CSVの内容（データ）を、テンプレートに固定で埋め込む方法
 TextDataset の「内容」プロパティの「タイプ」を「Static」にします。

手順
 1) TextDatasetの「内容」プロパティの「タイプ」を「Static」にします。
2)「内容」にCSVデータを入力します。

動的にCSVデータを渡すことはできません。テンプレート作成作業中など、サンプルデータとして使用するときに便利な方法です。

------------------------------
2.CSVの内容（データ）を、リクエストパラメータの値として渡す方法
 TextDatasetの「内容」プロパティの「タイプ」を「Request」にします。

手順
 1)TextDatasetの「内容」プロパティの「タイプ」を「Request」にします。
2)「リクエストパラメータ名」を、例えば「TextDataset1」とします。

この例の場合、　{TextDataset1}　というパラメータ名となりますので、値にCSVデータの内容を渡します。

------------------------------
3.CSVファイル名、またはURLを、テンプレートに固定で埋め込む方法
 CSVファイルが常に同じファイル名、または同じURLで参照できる時に使用します。

手順
 1)URLTextDatasetの「URLデータ」プロパティの「タイプ」を「Static」にします。
2)URLTextDatasetの「内容」プロパティの「内容」に、CSVファイルのファイル名、またはURLを設定します。
  （例）http://172.XXX.XXX.XX/xx/CSV/aaaaaa.csv

この設定で、指定したURLのCSVデータが帳票生成時に使用されます。
「aaaaaa.csv」のように、ファイル名のみを指定した場合は、ODCAW.xml の
ODCAW/ODDS/PATH/DATASOURCE/
で設定されているパス上のファイルを検索し、該当するファイルからデータを取得します。

------------------------------
4.CSVファイル名、またはURLを、リクエストパラメータの値として渡す方法
 CSVファイルまたはファイル名を、動的に渡したい時に使用します。

手順
 1)URTextDatasetの「URLデータ」プロパティの「タイプ」を「Request」にします。
2)「リクエストパラメータ名」を例えば「URLTextDataset1」とします。

この例の場合、　{URLTextDataset1}　というパラメータ名となりますので、値にCSVファイルのURLまたはファイル名を渡します。
「aaaaaa.csv」のように、ファイル名のみを指定した場合は、ODCAW.xml の
ODCAW/ODDS/PATH/DATASOURCE/
で設定されているパス上のファイルを検索し、該当するファイルからデータを取得します。

[URL接頭語 / URL接尾語について]
URL接頭語 / URL接尾語は、URL の最初と最後の部分を固定で指定したい場合に使用します。

例えば、テキストデータが「http://localhost/data/」以下に「～.csv」の形式で配置されることがあらかじめ分かっているような場合に、URL接頭語に「http://localhost/data/」を指定し、URL接尾語に「.csv」を指定すれば、アプリケーションから渡す値はファイル名のみで済ますことができます。

WHERE句の動的指定について

質問

クエリビルダでのWHERE句の指定ですが、動的に指定することは可能でしょうか？
以下に例を示します。

例：画面に抽出条件となる「A」「B」という入力項目があるとします。
・「A」「B」共に入力してある場合
WHERE xxx='A' AND yyy='B'
・「A」は入力してあり「B」は入力してない場合
WHERE xxx='A'
・「A」「B」共に入力してない場合
WHERE句の指定なし

回答

クエリビルダのWHERE句に{USERINPUT}とだけ指定しておくことで実現が可能です。
（実行時にWHERE句をまるごと指定する）

・「A」「B」共に入力してある場合
実行時WHERE句に以下を指定する。
xxx='A' AND yyy='B'

・「A」は入力してあり「B」は入力してない場合
実行時WHERE句に以下を指定する。
xxx='A'

・「A」「B」共に入力してない場合
実行時WHERE句に以下を指定する。
必ず真となる式を指定する。
（WHERE句に何もないとSQLのシンタックスエラーになるため）
例）'A'='A'

条件によって線や画像の表示/非表示を切り替えたい

質問

データベースやCSVの内容によって、罫線や画像の表示/非表示を切り替えたい。

回答

表示/非表示したいコンポーネントの前面にLabelを配置し、Labelの「条件付フォーマット」によって背面のコンポーネントを隠したり表示したりする方法があります。ここでは、その一例をご紹介します。

以下の手順により実現します。

1. 表示/非表示したい罫線（ここではLine1）の前面に、内容が空のLabel（Label2）を配置します。
※ 画面右のエクスプローラでLine1をクリックするか、レイアウト上のLabel2を移動させることで、重なっている様子を確認できます。

2. 前面のLabel（Label2）のプロパティ「条件付フォーマット」で、以下のような設定をします。

[条件]
値1・・・TextDataset1のfield1を選択
演算子・・・=[等しい]を選択
値2・・・2を入力

[表示方法]
「可視」のチェックを外す

以上により、TextDataset1のfield1が2と等しい場合は、Labelは不可視（非表示）になり、それ以外の場合は、前面のLabelが表示されるため、背面に配置したLineは隠れます。

条件付フォーマットの演算子について

質問

Lableコンポーネント 条件付フォーマットの演算子について

回答

Lableコンポーネント 条件付フォーマットの演算子につきまして、日本語の注釈がないものは下記の意味になります。

IS NULL････････････値1が NULL（※1）
IS NOT NULL････････値1が NULLではない（※1）
CONTAINS･･･････････値1が値2を含む
NOT CONTAINS･･･････値1が値2を含まない
STARTS WITH････････値1が値2で始まる
NOT STARTS WITH････値1が値2で始まらない
HAS RECORDS････････値1が抽出されたレコードが1件以上（※2）
HAS NO RECORDS･････値1が抽出されたレコードが0件（※2）

※1）
テキストデータ（TextDataset、URLTextDataset）を使用している場合は、データが入っていない状態が対象となります。

※2） 値1が[CONTENT]以外の場合で使用できます。

連番の付与はできますか？

質問

明細部分に連番を付与したいのですが、できますか？

回答

残念ながら、DatasetTableで連番を付与する機能はございません。

ビューの作成やユーザ定義関数の使用等、データベース側での対応をご検討ください。
例えば Orale での ROWNUM のように、データベース側で擬似列として行番号を表示するといった関数が用意されているようでしたら、クエリビルダの「式の作成」で式を作成することにより、実現可能です。

ページ番号と総ページ番号を表示させたい

質問

帳票にページ番号と総ページ番号を表示させたいと思っております。
ページ番号は「PageNumber」コンポーネント使用すると対応できますが、総ページ番号は上記コンポーネントで対応できるのでしょうか？それとも他のコンポーネントを使用するのでしょうか？

回答

ページ番号：[PageNumber]コンポーネント
総ページ番号：[TotalPageNumber]コンポーネント（※1）を使用することで可能です。

※1）OXS+OXBとの組み合わせが必須のため、PDFでは表示されません。（2.5.5の新機能）

TotalPageNumber を使用できる形式・機能

質問

TotalPageNumberコンポーネントを使用して、PDFで総ページ数を表示したいのですが表示できません。

回答

TotalPageNumberコンポーネントは、ドキュメントの形式や OXS の機能によって、使用できる場合と、できない場合があります。

TotalPageNumber を使用できる形式・機能

・OPR形式
・ODP形式
・OXR形式
・DocuWorks形式
・サーバ印刷機能 （リモート）※
・FAX送信機能

TotalPageNumber を使用できない形式・機能

・PDF形式
・HTML形式
・サーバ印刷機能 （ローカル）

グラフの色を変更したい

質問

Graphコンポーネントで表示するグラフの色を変更したい。

回答

グラフの背景色は、Graphコンポーネントの「設定」プロパティ - 「背景色」で設定することができます。

その他の色は、ODCAW2.propertiesで設定します。
ODCAW2.propertiesは、[OXS_HOME]/bin/ にあります。
テキストエディタ等で編集し、保存してください。

※ ODCAW2.properties変更後は、OPRO X Serverの再起動が必要です。
※ 行頭に # を付けると、コメントアウト（無効）になります。
※ 色の設定は「赤(0～255)-緑(0～255)-青(0～255)」で指定してください。
例
黒：0-0-0
白：255-255-255
赤：255-0-0
緑：0-255-0
青：0-0-255

以下の項目を変更することができます。

HeaderColor・・・ヘッダの色
FooterColor・・・フッタの色
AreaAppearanceFrontColor・・・ポインタ、枠線の色
LabelFrontColor・・・ラベルの色
PlotAreaAppearanceFrontColor・・・枠線の色

対応していないバーコードを使用したい

質問

QRコードを使用するため、外部アプリケーションで作成したQRコードの画像をバイナリでデータベースに格納し、OXSで帳票へ出力しようと考えています。
もし他にも方法がありましたら教えてください。

回答

現在OPRO製品で対応していないバーコードを使用する場合、ご検討されている方法以外にも、次のような方法がございます。

・SATOLabel でデバイスフォントを使用する方法
  ただし、印刷用途のみとなります。また、SATO社ラベルプリンタが必要です。

・URLImage コンポーネントを使用して、作成されたバーコードの画像を取得する方法
  URLImageコンポーネントは、URLから画像を取得する機能です。例えば外部のツールによって生成されたバーコードをURLから取得できる場合は、この方法が使用可能です。
  URLの指定方法は「Static (固定の値)」、「Request (リクエスト時に指定する値)」、「Database (データベースからの値)」のいずれかのタイプを指定することができます。

日付・時間・数値のフォーマット

質問

日付・時間・数値のフォーマット

回答

日付・時間・数値のフォーマット

OPRO X Server では、以下のようなフォーマットが使用可能です。これらは、OPRO X Designer の Label、および DateTime コンポーネントのプロパティで指定します。

日付・時間

記号 | 意味
d | 日 (1-31)
dd | 日 (01-31)
ddd | 曜日 (Sun-Sat)
dddd | 曜日 (Sunday-Saturday)
D | 年における日 (例: 189)
DDD | 曜日 (日-土)
DDDD | 曜日 (日曜日-土曜日)
M | 月 (1-12)
MM | 月 (01-12)
MMM | 月 (Jan-Dec)
MMMM | 月 (January-December)
yy | 年 (00-99)
yyyy | 年 (0000-9999)
h | 時 (1-12)
hh | 時 (01-12)
H | 時 (0-23)
HH | 時 (00-23)
m | 分 (0-59)
mm | 分 (00-59)
s | 秒 (0-59)
ss | 秒 (00-59)
a | 午前/午後
E | 曜日 (日-土)
F | 月における曜日 (7月の第2水曜日など)
w | 年における週 (例: 27)
W | 月における週 (例: 2)
k | 一日における時 (1-24)
K | 午前/午後の時 (0-11)
z | タイムゾーン (例: JST)
' | テキスト用エスケープ
'' | 単一引用符(先頭には表示不可)
gge | 元号 (例: 平成14)

数値

記号 | 意味
0 | 数字
# | 数字 (0だと表示されない)
. | 小数点
, | 数値のセパレータ。
- | マイナス記号
; | 正と負のサブフォーマットのセパレータ。 (例: #,##0;△#,##0)
% | 100 倍してパーセンテージを表す
' | フォーマットするために使用している文字を、そのまま出力したい場合に使用する。 (例: '#'# を使用すると 123 は ""#123"" にフォーマットされる。) また、単一引用符自体を出力するには、 2 つの引用符を使用する 。(例: # o''clock)

OXDとOXSで、禁則処理の方法が異なる

質問

Labelのプロパティ「折り返し」にチェックを入れた場合に、OXD 上での禁則処理と、そのテンプレートから作成したドキュメント上での禁則処理が異なります。

回答

OXS、OXD、OXB での禁則処理は、以下のようになっております。

------------------
[OXS]
・「折り返し」の際の行頭禁則文字は「,.、。，．」の六文字。
・「折り返し」の際の行末禁則処理は行わない。
・禁則処理をしないようにすることや禁則文字を替えることはできない。
・生成ドキュメント形式には依らない。

[OXD]
・「折り返し」の際は、MicrosoftのRichEditの仕様に従って折り返す。
・禁則処理をしないようにすることや禁則文字を替えることはできない。

[OXB]
・禁則処理は行わない。（「折り返し」の際は、OXS が決めた改行位置に改行コードが入ることによって折り返される）
------------------

従いまして、OXD上とドキュメント上では折り返す文字が異なる場合があります。


よくある質問 - 設定

OPRO X Designer - FAQ - 設定

外字について

質問

帳票に外字を使用したいのですが、使えますか？
もし使える場合、注意点なども教えてください。

回答

OXB 2.x は、OPR/OXR 形式の表示・印刷の際、起動しているマシンのフォントを使用します。このため、Label コンポーネント等の「フォント」プロパティに指定した日本語フォントにユーザ定義外字が正しく関連付けられていれば、その文字コードに対応するユーザ定義外字を表示・印刷することができます。

しかし、この方法では、OXB をインストールする各マシンにユーザ定義外字をインストールする必要があり、また、異なるドキュメントで異なるユーザ定義外字を使用することができない等の問題が生じます。

そこで、OPR/OXR 形式にユーザ定義外字フォントを埋め込むことによって、これらの問題を解消することができます。ユーザ定義外字フォントを埋め込むには以下のようにします。

  ①OXD を使用してテンプレートを作成する際に、ドキュメントで使用したいユーザ定義外字を、そのマシンにインストールします。
  ②ユーザ定義外字を関連付けた日本語フォントを、外字を出力したいコンポーネントの「フォント」プロパティで選択します。
  ③コンポーネントの値に、外字の文字コードを指定して正しく表示されるか確認します。
  ④コンポーネントの「フォント」プロパティの「ユーザ外字」にチェックを入れます。
  ⑤テンプレートを保存します。（テンプレートにユーザ定義外字フォントが埋め込まれます。）
  ⑥そのテンプレートから OPR/OXR 形式のドキュメントを生成すると、ユーザ定義外字フォントが埋め込まれたドキュメントが生成されます。

OXB は、ユーザ定義外字フォントが埋め込まれたドキュメントを表示・印刷する際、そのフォントを一時的にそのマシンに設定することで出力を可能にしています。

OXS でサーバ印刷・Fax送信を行う際には、内部的に OXB を使用しますので、ユーザ定義外字フォントが埋め込まれたテンプレートを使用すれば、サーバ印刷やFax送信においてもユーザ定義外字を出力することができます。但し、フォントを一時的にそのマシンに設定するために、OXS のサービスは、ローカルシステムアカウント以外のユーザで起動する必要があります。

OXS が生成する、他のドキュメント形式については、以下のようになります。
■PDF 形式
・テンプレートにユーザ定義外字フォントが埋め込まれている場合
  ドキュメント内にユーザ定義外字フォントが埋め込まれ、外字を出力できます。
・テンプレートにユーザ定義外字フォントが埋め込まれていない場合
  ユーザ定義外字は出力できません。（空白または文字化けすることになります。）
■DocuWorks 形式
  サーバで内部的に印刷を行いますので、サーバ印刷と同じ動作になります。
■HTML 形式
  表示するクライアントに設定されているユーザ定義外字が使用されます。

※注意：ドキュメント内に、ひとつでも「ユーザ外字」のチェックが入っているコンポーネントがある場合、そのコンポーネントと同じフォントを使用するすべてのコンポーネントで、ドキュメントに埋め込まれたユーザ定義外字フォントが使用されます。

USERINPUTの指定方法

質問

テンプレート上で設定した{USERINPUT}は、実際にリクエストする際はどのようなパラメータ名にすればよいですか。

回答

DatasetやDBExecuteで指定した{USERINPUT}は、実行する際には「コンポーネント名_1からの通し番号」という形式のパラメータ名にする必要があります。
（コンポーネント名は、プロパティ「全般」の「名前」で確認できます。）

例えば「Dataset1」という名前のDatasetに、2つの{USERINPUT}が設定されている場合、パラメータ名はそれぞれ「Dataset1_1」「Dataset1_2」となりますので、リクエストする際は以下のように渡します。

{Dataset1_1}=***&{Dataset1_2}=***

※複数のテンプレートを使用する場合(マルチテンプレート)は、先頭にテンプレート名を指定する必要があります。（例）{Template1_Dataset1_1}=***

※テンプレート側で指定できるキーワードは{USERINPUT}という文字列のみになります。例えば、{Dataset1_1}や{USERINPUT_1}といった文字列を、{USERINPUT}の意味で使用することはできません。

OSMSUSER について

質問

テンプレート作成を行うときに、一部のユーザには開発用データベースだけを参照可能にすることはできますか？

回答

はい。OSMSUSER の設定でテンプレート作成、編集時にクエリビルダで参照できるデータベースを制限することができます。
クエリビルダを起動するときに「OSMS ログイン」ダイアログが表示さまれます。初期設定では admin/admin と入力を行いますが、ODCAW.xml を編集して、例えば次の2つのユーザを追加作成することができます。（※1）
・開発用のデータベースだけを参照できるユーザ
・本番用のデータベースだけを参照できるユーザ

OSMSUSER は ODCAW.xml の以下の要素で設定されます。

  ODCAW/OSMS/OSMSUSERS

ODCAW.xmlの設定例 ここから---------------------

<USER>
<USERNAME>admin</USERNAME>
<PASSWORD>admin</PASSWORD>
<DATABASES>
<DATABASE>
<TYPE>all</TYPE>
<NAME>all</NAME>
</DATABASE>
</DATABASES>
</USER>
<USER>
<USERNAME>kaihatu</USERNAME>
<PASSWORD>kaihatu</PASSWORD>
<DATABASES>
<DATABASE>
<TYPE>Oracle</TYPE>
<NAME>KAIHATU</NAME>
</DATABASE>
</DATABASES>
</USER>
<USER>
<USERNAME>honban</USERNAME>
<PASSWORD>honban</PASSWORD>
<DATABASES>
<DATABASE>
<TYPE>Oracle</TYPE>
<NAME>HONBAN</NAME>
</DATABASE>
</DATABASES>
</USER>

ODCAW.xmlの設定例 ここまで-----------------------

各要素の内容は次の通りです。
・USERNAME･･･ ユーザ名
  Datasetコンポーネントからクエリビルダを起動する際に表示されるOSMSログインダイアログで、「ユーザ名」に入力するものです。
・PASSWORD･･･パスワード
  Datasetコンポーネントからクエリビルダを起動する際に表示されるOSMSログインダイアログで、「パスワード」に入力するものです。
・DATABASES/DATABASE/TYPE･･･OSMSUSER が参照できるデータベースのタイプ
  all と指定すると ODCAW.xml の要素 ODCAW/ODCS/DATABASES で設定されているすべてのデータベースのタイプを参照します。
・DATABASES/DATABASE/NAME･･･OSMSUSER が参照できるデータベースのエイリアス
  all と指定すると ODCAW.xml の要素 ODCAW/ODCS/DATABASES で設定されているすべてのデータベースの名前を参照します。

USER についての設定は次の通りです。
・USERNAME が admin となっているもの
  初期設定のものです。すべてのデータベースを参照することができます。
・USERNAME が kaihatu となっているもの
  ODCAW.xml の要素 ODCAW/ODCS/DATABASES でエイリアスが、「KAIHATU」のデータベースだけを参照できます。
・USERNAME が honban となっているもの
  ODCAW.xml の要素 ODCAW/ODCS/DATABASES でエイリアスが、「HONBAN」のデータベースだけを参照できます。

※1）
前提条件としまして、本番用のデータベースと、開発用のデータベースの接続設定が ODCAW.xml の要素 ODCAW/ODCS/DATABASES で次のようになっていることとします。
  ・開発環境のエイリアス（Name）… KAIHATU
  ・本番環境のエイリアス（Name）… HONBAN
ODCAW.xmlの設定例 ここから---------------------
<DATABASE>
<Name>KAIHATU</Name>
<Type>Oracle</Type>
<URL>jdbc:oracle:thin:@XXX.XXX.XX.XX:1521:AAA</URL>
<Driver>oracle.jdbc.driver.OracleDriver</Driver>
<UserID>scott</UserID>
<Password>tiger</Password>
<Connections>50</Connections>
</DATABASE>
<DATABASE>
<Name>HONBAN</Name>
<Type>Oracle</Type>
<URL>jdbc:oracle:thin:@XXX.XXX.XX.XX:1521:BBB</URL>
<Driver>oracle.jdbc.driver.OracleDriver</Driver>
<UserID>scott</UserID>
<Password>tiger</Password>
<Connections>50</Connections>
</DATABASE>
ODCAW.xmlの設定例 ここまで-----------------------

Dataset Table を使用したときのデータの表示順について

質問

Dataset Table を使用したときのデータの表示順について

回答

1.明細行を表示する部分について
明細行を表示する Dataset Band の表示順は、クエリビルダの「並べ替えの設定」で設定します。
▼クエリビルダの「並べ替えの設定」

▼「社員番号」の昇順でソート

2.グループヘッダ/グループフッタを設定している場合
 グループヘッダ/グループフッタを設定している場合、明細行にはグループごとにクエリビルダの「並べ替えの設定」が適用されます。
グループヘッダ/グループフッタに指定したフィールドでソートを行う場合もクエリビルダの「並べ替えの設定」で設定します。

▼「部署番号」でグループヘッタを作成し、明細部分は「社員番号」の昇順でソート

3.グループヘッダ/グループフッタを複数のフィールドで設定している場合
複数のフィールドでグループヘッダ/グループフッタを作成している場合、Dataset Table コンポーネントのカスタムプロパティの「バンド」タブでより上に表示されているフィールドを優先してグルーピングを行います。
この表示順を変更するには、移動したいフィールドを選択し、[上に移動]または[下に移動]をクリックします。

▼「部署番号」、「役職」でグループヘッタを作成し、明細部分は「社員番号」の昇順でソート

▼[上に移動]、[下に移動]ボタン

グループごとに改ページしたいのですが･･･

質問

グループが変わったら、ページ変えをしたいのですが。
例えば、部署が変わったときなどです。

回答

DatsetTableでグループヘッダを作成し、作成されたグループフィールドで「グループが変わったら改ページする」にチェックをつけます。
例）
□データ
テーブル名：A
COL1 COL2 COL3
---- ---- ----
1 1 a
1 2 b
1 3 c
2 1 d
2 2 e
2 3 f
3 1 g
3 2 h
3 3 i

□A.COL1でグループ化し、グループごとに改ページを行う場合
1.DatsetTabelのプロパティエディタ-カスタム-Dataset-バンド タブ-フィールド　にて　A.COL1　の「ヘッダ」にチェックを入れます。
2.DatsetTableにGroupHeaderが作成されます。
3.GroupHeader のプロパティエディタ-カスタム-グループフィールド 「グループが変わったら改ページする」にチェックを入れます。
（「毎ページ出力する」にチェックをいれると、同じグループ内で改ページされたときも、毎ページGroupHeaderを表示します。）
※DatasetTableでGroupHeader/GroupFooterを作成した場合、
  DatsetTabelのプロパティエディタ-カスタム-Dataset-バンド タブ-フィールド
  に表示されている昇順にソートされます。この並び順を変更する場合、上下に移動したいフィールドを選択し、「上へ移動」または「下へ移動」ボタンで移動します。

SubReport機能で、リンクされるレコードがない場合はどのようになりますか？

質問

SubReport機能を使うときに、リンクされるレコードがない場合、どのようになりますか？

回答

2つのパターンに分けて回答いたします。

■子テーブルに、リンクされるレコードがない場合でも、親テーブルのレコードは表示されます。
例）
子テーブルに「部署番号」が30のレコードがありませんが、表示結果には親レコードは表示されます。

■親テーブルに、リンクされるレコードがない場合、子テーブルにのレコードは表示されません。
例）
親テーブルに「部署番号」が30のレコードがありませんので、子テーブルの「部署番号」が30のレコードは表示されません。

同一ページ内で、複数列連続したデータを出力する方法

質問

同じページ内で、2列にデータを表示する方法がありますか？（下図のようなイメージです。）

回答

グルーピング機能をご利用ください。
DatasetTableをグルーピングする手順例を紹介します。お試しください。
1. DatasetTableをテンプレートに2つ配置します。
2. 2つのDatsetTableを同時に選択します。
3.「コンポーネント」メニューで「グルーピング」を選択します。
4. 表示された「グルーピング」ウィンドウの「自動」ボタンをクリックして番号を自動的に生成します。
5. 「OK」をクリックして「グルーピング」ウィンドウを閉じます。
6. それぞれのDatasetTableの右下にグループIDとグループ順序が表示されます。
7. どちらかのDatasetTableにプロパティエディタ-「カスタム」-「Dataset」にDatsetを設定します。
8. 7.で設定を行ったDatasetTableのDatasetBandに、Datsetのフィールドを設定します。
9. プレビューを行い、2つのDatsetTabelにまたがって連続したデータを出力することを確認します。

同一明細が続く場合に、カラムを結合したような表現をしたい

質問

下図のような表現をしたいのですが、可能ですか？

回答

DatasetTableでは、重複した項目の罫線を消したり、カラムを結合することはできませんので、このような表現を行う場合には、SubReportを使用します。

SubReportとは、DatasetTableの中にDatasetTableを配置する方法です。
外側にあるDatasetTableを「親DatasetTable」、内側にあるDatasetTableを「子DatasetTable」と呼びます。

SubReportは、OPRO X DesignerのSubReportウィザードを使用して作成することができます。

また、重複したデータを削除するという機能もあります。「重複の削除」をご覧ください。

集計を行う方法を教えてください

質問

帳票で集計を行う方法を教えてください

回答

OXD でテンプレートを作成する際、 Aggregate Function コンポーネントを使用することで集計を行うことができます。
Aggregate Function コンポーネントはDataset Table及びHorizontal Dataset Table上のReport Header、Report Footer、Group Header、Group Footerに配置して、様々な集計を行い、表示するコンポーネントです。
例えば、Group Footer に配置した場合はそのグループでの集計結果を、Report Footer に配置した場合はレポート全体での集計結果を出力します。
Aggregate FunctionはDataプロパティの[フィールド]で選択したフィールドに対して、以下の処理を実行することができます。

  Aggregate Functionで実行できる処理
  ・COUNT データのレコード数を出力します。
  ・MAX データの最大値を出力します。
  ・MIN データの最小値を出力します。
  ・AVG データの平均値を出力します。
  ・SUM データの総合計を出力します。

これらの処理内容は内容プロパティで選択します。

多段階集計の方法

質問

多段階で集計する方法を教えてください。
例えば、部署ごとに集計して、部署内では役職ごとに集計する、といった場合です。

回答

多段階集計は、グループヘッダ/フッタを集計したいフィールドごとに作成し、それぞれにAggregateFunction コンポーネントを配置することで実現できます。

データベースの抽出条件として渡した値を、ドキュメント上にも表示したい

質問

Datasetの抽出条件に{USERINPUT}を設定し、リクエスト時に抽出条件を指定するようなテンプレートを作成しています。
リクエスト時に渡した値を、生成されたドキュメント上にも表示することはできますか。

回答

表示させたい場所に、タイプがRequestのLabelを配置し、{USERINPUT}のパラメータ名と同じパラメータ名を設定することにより、実現できます。

例えば、{USERINPUT}のパラメータ名が「Dataset1_1」である場合（※1）、値を表示したい場所にLabelを配置し、次のような設定を行います。

1. プロパティ「内容」-「タイプ」で、「Request」を選択する。
2. 「リクエストパラメータ名」を「Dataset1_1」とする。（※2）

これにより、{Dataset1_1}というパラメータで渡された値を、Datasetの{USERINPUT}、Labelのリクエストパラメータという2つの意味で使用することができます。

（※1）Datasetの{USERINPUT}は、実行する際には「Dataset名_通し番号」という形式のパラメータ名にする必要があります。詳しくは FAQ#395「USERINPUTの指定方法」をご覧ください。

（※ 2）OXDで指定するリクエストパラメータ名に中括弧 { } を付ける必要はありません。リクエストパラメータ名は、実行時に中括弧 { } で括ります。（例えば、「Dataset1_1」というリクエストパラメータ名の場合は、実行時に{Dataset1_1}とします。）

「次の条件でレイアウトを隠す」機能について

質問

OPRO X Designerのレイアウトのプロパティ「レイアウト設定」にある「次の条件でレイアウトを隠す」の使用方法を教えてください。

回答

「次の条件でレイアウトを隠す」は、出力しないレイアウトを、リクエスト時に指定するための機能です。

複数のレイアウトを持つテンプレートで、それぞれのレイアウトのプロパティで「次の条件でレイアウトを隠す」にチェックを入れ、{USERINPUT}= に任意の値を設定することにより、出力しないレイアウトを指定することが可能になります。
OPRO X Serverへのリクエストパラメータは、　{TP.LayoutIndex}=[設定した値]　となり、それぞれの意味は

・TPは、テンプレート名
・LayoutIndexは、OXDで「何番目のレイアウトか」を表す数字
・[設定した値]は、OXDの「次の条件でレイアウトを隠す」の「{USERINPUT}=」で設定した値

となります。
例えば、テンプレート名が「Template1.oxt」で、OXD上の1番目のレイアウトの{USERINPUT}=の値が「hide」と設定されている場合、

{Template1.1}=hide

となります。
この指定をすることにより、1番目のレイアウトが無い状態のドキュメントを生成することができます。

クエリビルダで表示形式を変更したが、反映されない

質問

クエリビルダのデザイングリッドで、表示形式を変更しました。
（#,##0 から \#,##0 に変更）
しかし、該当フィールドを表示するLabelコンポーネントの内容プロパティの表示形式に反映されませんでした。

回答

クエリビルダ/テキストクエリビルダのデザイングリッドで設定する表示形式（format1.png）と内容プロパティで設定する表示形式（format2.png）について、クエリビルダ/テキストクエリビルダのデザイングリッドで設定した表示形式は設定後に配置したLabelコンポーネントの内容プロパティの表示形式に設定されます。ただし、Labelコンポーネントを配置したあとに、クエリビルダ/テキストクエリビルダのデザイングリッドで表示形式を変更しても、すでに配置されているLabelコンポーネントの内容プロパティの表示形式には反映されません。

Graph ウィザードの「3D表示」の設定

質問

Graph ウィザードの「3D表示」には、どのような値を設定すればよいですか？
目安があれば教えてください。

回答

「3D表示」で設定できる3つの項目はそれぞれ以下のような意味になります。

奥行き・・・3Dグラフの奥行き
立体化・・・仰角（上下の視点）
回転の角度・・・回転角（左右の視点）

Graph を出力する際の注意

質問

Graph を出力する際の注意

回答

UNIX 系 OS 上で動作している OXS にて Graph を使用する際には、OXS 起動ユーザで GUI 環境にログインしておく必要がありますので、ご確認ください。

Tabボタンでのフォーカス移動について

質問

PDFフォームでの入力画面上で、キーボードのTabボタンを使用し、Text間のフォーカス移動を行ないたいのですが、移動順をどこで指定すればいいのでしょうか？
Textを作成した順に移動するのかと思い試してみましたが、順番通りには移動しませんでした。
また、テンプレートエクスプローラで、移動したい順にTextを並べて試しましたが、やはりうまく移動しませんでした。
OPRO X Designer2.5.0を使用しています。

回答

2.5.5(OPRO X Server2.5.5+OPRO X Designer2.5.5)より「タブ順」プロパティが設定可能になっております。

「タブ順」プロパティは、キーボードでTabキーを押す毎に移動する、電子フォームのアクセスフィールドの順番を定義するのに使用します。

「タブ順」を定義する手順
1. InterfaceGroupコンポーネント内にフォームコンポーネント(例：Text, Password, Memo, DropDowm等)を選択し、F11キーを押します。
2. プロパティエディタの「アクティブ」タブが表示されます。
3. 必要に応じて「カスタム／タブ順」の番号を変更します。

最初にアクセスするコンポーネントの「タブ順」番号はゼロ(0)に設定する必要があります。

プレビューボタンを押すことができない

質問

プレビューボタンを押すことができない

回答

CGI またはサーブレットの URL が設定されていない可能性があります。OPRO X Designer のオプションメニュー → 環境設定 で、「CGI/サーブレットURL」の項目をご確認ください。

OXB、OXDでスクロールバーが表示される

質問

OXB、OXDでスクロールバーが表示される

回答

テーブルコンポーネント（Table、DatasetTable、HorizontalDatasetTable）上に配置したコンポーネントが範囲内に収まりきらない場合、OXB、OXD上でスクロールバーが表示されます。

はみ出ているコンポーネントのサイズを小さくするか、テーブルコンポーネントのカラム、バンドのサイズを大きくすることにより回避できます。

また、範囲内ぎりぎりのサイズでコンポーネントを配置している場合、OXBでは、表示倍率によってスクロールバーが表示されることがあります。このような場合は、表示倍率100%で表示してください。

テンプレートのサイズ(ピクセル)

質問

横A4サイズのテンプレートだと、縦横のサイズ（ピクセル）はどの程度になりますか？

回答

横A4サイズのテンプレートですと、以下のようになります。
ピクセル ( cm)
高さ 793 (21.0)
幅 1122 (29.7)

以下の方法で確認することができます。
テンプレートをテキストエディターなどで開いた上で、<paper>タグを参照する。
<paper>
<height>793</height>
<width>1122</width>
<size>a4</size>
<orientation>landscape</orientation>
</paper>

テンプレートを保存できない

質問

テンプレートを保存できない

回答

Trial Version では、テンプレートは保存できません。テンプレートをすべて閉じた状態で、「ヘルプ」メニューから「バージョン情報」を開いて、「Serial Number」ボタンを押し、シリアル番号を製品版のものにしてください。

パフォーマンスについて

質問

ドキュメントの生成速度を上げるためには？

回答

ドキュメントの生成速度を上げるための調整項目を以下に紹介いたします。

1.テンプレートの作成方法
1)コンポーネント数を減らします。コンポーネントが多いと、それだけ時間を要します。
2)Table 類のカラム数を減らしてテーブル構造を単純化します。
  罫線は Line コンポーネントで代用できます。
3)コンポーネントを非透過にします。
  透過にすると背面にあるコンポーネントとの交わりを考慮する分だけ遅くなります。
4)画像のサイズを減らします。大きい画像の処理には、それだけ時間を要します。
5)発行するクエリを減らします。DatasetTable、HorizontalDatasetTable でグループヘッダ・グループフッタを設定している場合、データ内のグループの数だけクエリを発行しますので、グループの階層を減らすことでクエリ処理に要する時間を減らせます。

1),2),4) はドキュメントサイズを小さくするための項目でもあります。
ドキュメントサイズを小さくすることにより、ドキュメント生成速度をあげることができます。

2.リクエストの間隔
OXS は、受け付けたリクエストを並行して処理します。
複数の処理が重なるようにリクエストすると、それだけ個々の速度は低下します。
アプリケーションから連続でリクエストを行うような場合には、その間隔を考慮する必要があります。
1 CPU の場合、最も時間がかかるドキュメントの生成時間だけリクエスト間隔を空ければ、リクエストが重なることはなくなるでしょう。
例えば、最大のドキュメントが 100 ページであれば、OXS に他の負荷がない状態で 100 ページ生成のリクエストを行い、その時間に基づいて間隔を決定します。
最も時間がかかるドキュメントが特殊だということであれば、平均的なドキュメントの生成時間だけ空けることでも同時処理の割合を減らすことができます。

3.データベースのチューニング
ドキュメント生成時間の中にはデータベースとの通信時間も含まれていますので、データベースの応答速度を速くすることができれば、それだけ生成速度が上がります。

4.マシンのスペック
ドキュメント生成速度に最も影響を及ぼすのは CPU の演算速度です。

5.Java の起動パラメータ
 OXS は Javaアプリケーションですので、Javaの起動パラメータを変更することで、チューニングが可能です。

6.ログ
 Query.log は、OXS が JDBC ドライバに発行するすべてのクエリを記録しますので、クエリの量が多いと、それだけパフォーマンスは落ちます。
（ログの設定は出力するかしないかのみで、WARNING 以上だけ出力するといった設定はできません。）


よくある質問 - 操作

OPRO X Designer - FAQ - 操作

バージョンを表示させたい

質問

バージョンを確認する方法

回答

以下のそれぞれの方法で確認することができます。

OPRO X Server

* Windows版 : [OXS_HOME]/bin 以下の「version.bat」を実行。
* Linux/Solaris版 : [OXS_HOME]/bin 以下の「version.sh」を実行。
* 共通 : OXS が起動している状態で、Webブラウザから OXS の CGI/Servlet に対し、「DO=sv&ES=odcaw」というパラメータでリクエストを行う。

（例）http://127.0.0.1/scripts/odcaw2_cgi.exe?DO=sv&ES=odcaw

OPRO X Designer

* 「ヘルプ」メニューの「バージョン情報」

OPRO X Browser

* 「ヘルプ」メニューの「バージョン情報」

出力したドキュメントの左上に「OXS Trial Version」もしくは「OXS SDK Version」と表示される

質問

出力したドキュメントの左上に「OXS Trial Version」もしくは「OXS SDK Version」と表示される

回答

「OXS Trial Version」と表示される場合
Trial Version (試用版) のライセンスであることを示します。
ODCAW.xml の ODCAW/COMMON/SERIAL/ の値を製品用のシリアル番号に変更し、OPRO X Server を再起動することにより解決します。
製品用シリアル番号は、製品 CD の serial.txt に記載されております。

「OXS SDK Version」と表示される場合
SDK のライセンスであることを示します。
SDK は開発用ライセンスですので、主な機能をすべて使用することができますが、ドキュメントに「OXS SDK Version」の文字が表示されるようになっております。
ODCAW.xml の ODCAW/COMMON/SERIAL/ の値を製品用のシリアル番号に変更し、OPRO X Server を再起動することにより解決します。
製品用シリアル番号は、製品 CD の serial.txt に記載されております。

DatasetTable の選択方法（ボックスコンポーネントについて）

質問

DatasetTable の選択方法（ボックスコンポーネントについて）

回答

Table、 InterfaceGroup、DatasetTable、DatasetTableContainer などのコンポーネントは「ボックスコンポーネント」と呼ばれ、Labelなど通常のコンポーネントとは選択方法が異なります。ボックスコンポーネント上には他のコンポーネントを配置して使用するのが一般的であるため、このような仕様になっています。

ボックスコンポーネントを選択する上での基本的な操作は、以下の方法が挙げられます。

1. 「エクスプローラ」上で選択する
2. [Alt] + クリックで選択する
3. コンポーネントの境界線の辺りをマウスで囲むように選択する

DatasetTable の Column の高さが変更できない（DatasetTable の構造について）

質問

DatasetTable の Column の高さが変更できない（DatasetTable の構造について）

回答

DatasetTable は階層構造になっており、コンポーネント本体の上にバンドがあり、その上にカラムがあるような構造になっています。

カラムの高さを変更するには、バンドの高さを変更する必要があります。
テンプレートエクスプローラーでバンドを選択し、プロパティエディタの全般プロパティから「位置とサイズ」で高さを変更するというのが、基本的な操作となります。
別の方法として、バンドの境界線の辺りをマウスで囲むようにすると、バンドを選択することができますので、マウスの操作で高さを変更することができます。
また、キーボードの Alt キーを押しながらクリックすることでカラムを選択することができ、キーボードの Esc キーを押すごとに、カラム→ バンド→ コンポーネント本体 と選択しているコンポーネントを切り替えることができます（テンプレートエクスプローラー にて動きをご確認ください）。
また、バンドを選択した状態で、キーボードの Shift + 矢印キー を押しても、サイズを変更することができます。
（Table コンポーネントも同様の仕様です）

データベースを開発から本番に変更すると、テンプレートも変更しないといけませんか？

質問

開発用データベースと本番用データベースを分けています。
OXDでテンプレートを作成するときは開発用データベースを参照しています。本番用データベースを使用するときは、テンプレートを修正しないといけませんか？
なるべくならテンプレートを変更したくないのですが、よい方法がありましたら教えてください。

回答

まず、OXSがデータベースをどのように識別しているかを説明します。
OXSは次の2点でデータベースを識別します。
・データベースのタイプ（OracleやAccess、SQLServerなど）
  これはODCAW.xmlの次の要素をさします。 ODCAW/ODCS/DATABASES/DATABASE/Type
・データベースエイリアス（OXDのクエリビルダのデータベースツリーに表示されるデータベース名）
  これはODCAW.xmlの次の要素をさします。
ODCAW/ODCS/DATABASES/Name
（この2つが同一になるような設定を行いますと、OXS起動時に次のようなエラーが発生します。
OXS-01215 重複したエイリアスは許可されていません）

次に、参照先データベースを変更する方法につきまして、3通りの方法を紹介いたします。

1.OXS、データベースが、それぞれ開発環境と本番環境に分かれている場合に推奨される方法
  データベースのタイプ（Type）とエイリアス（Name）が開発環境、本番環境で同一になるようにODCAW.xmlの設定します。
  この場合、テンプレートを変更する必要はありません。

2.OXSは1体で、データベースは開発環境と本番環境に分かれている場合に推奨される方法
  例を挙げて説明します。
  テンプレート名はTemplate1.oxt とします。
  次のようにODCAW.xmlで設定したとします。
  ・開発環境のエイリアス（Name）… KAIHATU
  ・本番環境のエイリアス（Name）… HONBAN
    ODCAW.xmlの設定例 ここから---------------------
<DATABASE>
<Name>KAIHATU</Name>
<Type>Oracle</Type>
<URL>jdbc:oracle:thin:@XXX.XXX.XX.XX:1521:AAA</URL>
<Driver>oracle.jdbc.driver.OracleDriver</Driver>
<UserID>scott</UserID>
<Password>tiger</Password>
<Connections>50</Connections>
</DATABASE>
<DATABASE>
<Name>HONBAN</Name>
<Type>Oracle</Type>
<URL>jdbc:oracle:thin:@XXX.XXX.XX.XX:1521:BBB</URL>
<Driver>oracle.jdbc.driver.OracleDriver</Driver>
<UserID>scott</UserID>
<Password>tiger</Password>
<Connections>50</Connections>
</DATABASE>
    ODCAW.xmlの設定例 ここまで-----------------------

開発環境のデータベースを参照するように作成したテンプレートを、本番環境のデータベースを参照するように変更します。
  手順-----------------------------------------
  1)テンプレートをコピーしてバックアップをとります。
  2)ODCAW.xmlで開発環境のエイリアス（Name） KAIHATU を記述している部分を DATABASE 要素ごとコメントアウトします。

<!--
<DATABASE>
<Name>KAIHATU</Name>
<Type>Oracle</Type>
<URL>jdbc:oracle:thin:@XXX.XXX.XX.XX:1521:AAA</URL>
<Driver>oracle.jdbc.driver.OracleDriver</Driver>
<UserID>scott</UserID>
<Password>tiger</Password>
<Connections>50</Connections>
</DATABASE>
-->
<DATABASE>
<Name>HONBAN</Name>
<Type>Oracle</Type>
<URL>jdbc:oracle:thin:@XXX.XXX.XX.XX:1521:BBB</URL>
<Driver>oracle.jdbc.driver.OracleDriver</Driver>
<UserID>scott</UserID>
<Password>tiger</Password>
<Connections>50</Connections>
</DATABASE>

  3)OXSを再起動します。
  4)OXSを再起動する前からOXDを起動していた場合、OXD編集メニュー-データーセットの更新をクリックします。
  5)OXDでTemplate1.oxtを開き、Datasetコンポーネントをダブルクリックしてクエリビルダを起動します。
  6)OSMSログインを行います。
  7)次のようなメッセージダイアログが表示されることを確認します。
    「指定されたDatabaseが見つかりません。DB名を変更しますか？」
  8)「はい」をクリックします。
  9)「データベースエイリアス」というタイトルのダイアログが表示されることを確認します。
  10) 9)で表示されたダイアログの「DBエイリアス:」に次のように入力します。
    HONBAN
  11)OKボタンをクリックします。
  12)クエリビルダが起動したことを確認します。
  13)クエリビルダでエイリアスが変更になったことを確認します。
  14)OKボタンをクリックしてクエリビルダを終了します。
  15)Template1.oxt を上書き保存します。
  ---------------------------------------------------

  手順 2) で行ったコメントアウトをはずしても Template1.oxt で変更したエイリアスは HONBAN のままになります。

3.Datasetを本番環境でのものと、開発環境とのものと2つ作成する場合
  Datasetを本番環境でのものと、開発環境とのものと2つ作成し、Labelコンポーネントの内容プロパティ-Dataset の設定を変更するウィザードを実行します。
  開発環境で設定したDatasetをDatset1、本番環境で設定したDatasetをDataset2とします。
  テンプレートをコピーしてバックアップをとってからDataset変換ウィザードを実行してください。

※ODCAW.xmlを変更した場合、OXSの再起動が必要です。


よくある質問 - その他

OPRO X Designer - FAQ - その他

テンプレートの保存場所

質問

テンプレートの保存場所

回答

OPRO X Designer で作成したテンプレート (.oxt) を、OPRO X Server で使用できる状態にするには、OPRO X Server の設定ファイル「ODCAW.xml」（※1）の COMMON/ODDS/PATH/IN_FILE 要素で指定されているディレクトリに保存する必要があります。

（ODCAW.xmlの設定例）
C:/Program Files/OPRO/Templates/

（※1）ODCAW.xmlは、通常、[OXS_HOME]/conf/ にあります。（[OXS_HOME]はOPRO X Serverインストールディレクトリを示しています。）

既存の帳票デザインに合わせてテンプレートを作成したい

質問

既存の帳票デザインに合わせてテンプレートを作成したい

回答

既存の帳票デザインに合わせて作成する場合、画像を下敷きにするという方法がございます。

[手順]
1.PDFを画面に表示させてキャプチャーする[Pint Screen]
2.キャプチャーした画像をpngファイルなどとして保存する
3.テンプレート上にImageを配置する
4.Imageに2で保存したファイルを読み込む（この時、Imageの「カスタム」プロパティで「縦横比を固定して伸縮」にチェックを入れると、テンプレートの大きさに画像を合わせることが可能です）
5.画像に合わせて各種コンポーネントを配置していく（テンプレートを作成する）

横に伸びる連続帳票は作れますか？

質問

横に伸びる連続帳票は作れますか？

回答

作れます。下に伸びる連続帳票同様、横に伸びる連続帳票も作れます。

クエリビルダの「結果の表示」で、時間がかかる

質問

クエリビルダの「結果の表示」で、時間がかかる

回答

データ量が多い場合、表示に時間がかかります。
目安として、データの件数が 2000 件を超える場合は、抽出条件を設定するなどして、件数を減らすようにしてください。

クライアント側に必要なソフトウェアを教えてください。

質問

PDFをご使用の場合は、Adobe(Acrobat) Readerが必要です。
OPR/OXR（弊社独自XMLフォーマット）を使用の場合は、OPRO X Browser (OXB)が必要です。OXBは、無償でダウンロードできます。また、テンプレート開発用クライアントにはOPRO X Designerが必要になります。

回答

ANS

英語の開発環境はありますか？

質問

英語の開発環境はありますか？

回答

OPRO X Designerは日本語以外のWindowsにインストールすると、インターフェイスが英語になります。別途英語版のライセンスは必要ありません。オフショア開発でも使用できます。また、帳票内の文字コードはUnicodeに対応しておりますので、日本語、英語以外の多言語の文字を帳票に表示させることもできます。

バージョンの考え方

質問

バージョンの考え方

回答

[バージョン表記について]

OPRO X Server のバージョンは例えば「OXS 2.5.0.0」のように表記され、「2.5.0.0」の部分はそれぞれ「メジャーバージョン.マイナーバージョン.リビジョン.ビルド」を表します。

* メジャーバージョン・・・製品を根本から変更する場合に変更されます。
* マイナーバージョン・・・大幅な仕様変更・機能追加をする場合に変更されます。
* リビジョン・・・仕様変更・機能追加をする場合に変更されます。
* ビルド・・・修正パッチごとに変更されます。

メジャーバージョン・マイナーバージョン・リビジョンが変更される場合、より下位の変更・修正内容を含んでおります。

[アプリケーションの互換性について]

マイナーバージョンアップもしくはリビジョンアップ ( = 仕様変更・機能追加) をする際は、以下のような考え方になります。

OPRO X Designer、OPRO X Browser では、同一メジャーバージョン内での上位互換を保ちます。例えば、メジャーバージョンが2である限り、最新の OPRO X Designer、OPRO X Browser では常に過去のテンプレート, OPR ファイルを読み込むことが出来ます。
一方、古いバージョンの OPRO X Designer、OPRO X Browser で、最新のテンプレート, OPR ファイルを読み込めるかどうかは保証しておりません。

ビルドアップの場合は、上記の考え方は適用されません。ビルドアップは「修正」であり、「仕様変更・機能追加」ではありませんので、同一リビジョン内での下位・上位はありません。例えば 2.5.0.0 と 2.5.0.10 は同位となり、互換性は保たれます。

[具体例]
例1) OXS2.5.0.40 → OXS2.5.5.30 （リビジョン以上のバージョンアップ）
・OXS は新規インストールとなります。
・テンプレートは、古いバージョンのOXDで作成したものをそのまま使用できます。
・OXB は、2.5.5.0 以上（OXS と同じか、上位であるリビジョン）にバージョンアップする必要があります。
※アップデートサイトの「注意事項」を必ずご参照ください。

例2) OXS2.5.0.0 → OXS2.5.0.40 （ビルドアップ）
・OXSに、アップデートパッチを適用します。適用方法は、パッチのZIP ファイル内の readme.txt を参照してください。
・既存のテンプレートにつきましては、バージョンアップの必要はありません。
・OXBにつきましては 2.5.0.0 以上 （OXS と同じか、上位であるリビジョン）であれば問題ありません。


IDH_OXD0001=html\about_oxd.html
IDH_OXD0002=html\Template.html
IDH_OXD0003=html\about_oxs.html
IDH_OXD0004=html\Label.html
IDH_OXD0005=html\Image.html
IDH_OXD0006=html\Invisible.html
IDH_OXD0007=html\Text.html
IDH_OXD0008=html\Password.html
IDH_OXD0009=html\Memo.html
IDH_OXD0010=html\DropDown.html
IDH_OXD0011=html\List.html
IDH_OXD0012=html\Check.html
IDH_OXD0013=html\Radio.html
IDH_OXD0014=html\Chart.html
IDH_OXD0015=html\Submit.html
IDH_OXD0016=html\Reset.html
IDH_OXD0017=html\URLLabel.html
IDH_OXD0018=html\URLImage.html
IDH_OXD0019=html\URLInvisible.html
IDH_OXD0020=html\URLText.html
IDH_OXD0021=html\URLMemo.html
IDH_OXD0022=html\URLDropDown.html
IDH_OXD0023=html\URLList.html
IDH_OXD0024=html\URLExecute.html
IDH_OXD0025=html\Table.html
IDH_OXD0026=html\DatasetTable.html
IDH_OXD0027=html\InterfaceGroup.html
IDH_OXD0028=html\Dataset.html
IDH_OXD0029=html\DateTime.html
IDH_OXD0030=html\BarCode.html
IDH_OXD0031=html\DatasetTableContainer.html
IDH_OXD0032=html\Shape.html
IDH_OXD0033=html\Line.html
IDH_OXD0034=html\PageNumber.html
IDH_OXD0035=html\property_rule.html
IDH_OXD0038=html\menu_Options.html#GeneratesampleHTML
IDH_OXD0039=html\menu_Edit.html#RefreshDatabase
IDH_OXD0087=html\property_general.html#Name
IDH_OXD0088=html\property_general.html#LocationAndSize
IDH_OXD0089=html\property_general.html#Frame-Size
IDH_OXD0090=html\property_general.html#Frame-Color
IDH_OXD0091=html\DigitalSignature.html
IDH_OXD0092=html\property_general.html#Appearance-Transparent
IDH_OXD0093=html\property_general.html#Appearance-DragLock
IDH_OXD0094=html\property_font.html#Name
IDH_OXD0095=html\property_font.html#Appearance-Size
IDH_OXD0096=html\property_font.html#Appearance-Color
IDH_OXD0097=html\property_font.html#Appearance-Bold
IDH_OXD0098=html\property_font.html#Appearance-Strikeout
IDH_OXD0099=html\property_font.html#Appearance-Italic
IDH_OXD0100=html\property_font.html#Appearance-Underline
IDH_OXD0101=html\property_custom.html#Layout
IDH_OXD0102=html\property_custom.html#Color
IDH_OXD0103=html\property_custom.html#Style-AutoSize
IDH_OXD0104=html\property_custom.html#Style-WordWrap
IDH_OXD0105=html\property_custom.html#Style-Equalize
IDH_OXD0106=html\property_custom.html#Style-Fit
IDH_OXD0107=html\property_custom.html#TextAppearance-LineInterval
IDH_OXD0108=html\property_custom.html#TextAppearance-CharacterInterval
IDH_OXD0109=html\property_custom.html#TextAppearance-TabSize
IDH_OXD0110=html\property_data.html#Type
IDH_OXD0111=html\property_data.html#Value
IDH_OXD0112=html\property_data.html#File
IDH_OXD0113=html\property_data.html#URL
IDH_OXD0114=html\property_data.html#Type
IDH_OXD0115=html\property_grid.html#Grid-Visible
IDH_OXD0116=html\property_custom_Line.html#Border-Style
IDH_OXD0117=html\property_LayoutSetting.html#HideLayoutIf
IDH_OXD0118=html\DBExecute.html
IDH_OXD0119=html\menu_Components.html#GroupObjects
IDH_OXD0122=html\property_custom_Image.html#Appearance-AutoSize
IDH_OXD0123=html\property_custom_Image.html#Appearance-Stretch
IDH_OXD0124=html\property_hyperlink.html#EnabledHyperlink
IDH_OXD0126=html\property_custom_Image.html#Layout
IDH_OXD0127=html\property_data.html#File
IDH_OXD0128=html\property_data.html#URL
IDH_OXD0129=html\menu_Help.html#ContentsAndIndex
IDH_OXD0130=html\property_custom_Table.html#RepeatEmptyReportHeader
IDH_OXD0131=html\property_custom.html#AlignReportFooterToBottom
IDH_OXD0132=html\QueryBuilder.html#TableArea
IDH_OXD0133=html\QueryBuilder.html
IDH_OXD0134=html\property_general.html#LocationAndSize
IDH_OXD0141=html\QueryBuilder.html#TableArea
IDH_OXD0142=html\QueryBuilder.html#TableArea
IDH_OXD0143=html\property_custom.html#Color
IDH_OXD0144=html\property_custom_Form.html#MaxLength
IDH_OXD0147=html\DatasetChangeWizard.html
IDH_OXD0148=html\property_data.html#URL
IDH_OXD0149=html\property_setting_Graph.html#Graph-BackgroundColor
IDH_OXD0152=html\-.html
IDH_OXD0153=html\component_Wizard.html
IDH_OXD0154=html\DatasetChangeWizard.html
IDH_OXD0156=html\SubReportWizard.html
IDH_OXD0157=html\property_data.html#GraphType
IDH_OXD0158=html\property_data.html#GraphType
IDH_OXD0159=html\property_data.html#GraphType
IDH_OXD0160=html\property_data.html#GraphType
IDH_OXD0161=html\property_data.html#GraphType
IDH_OXD0162=html\property_data.html#GraphType
IDH_OXD0163=html\property_data.html#GraphType
IDH_OXD0164=html\property_data.html#GraphType
IDH_OXD0165=html\property_data.html#GraphType
IDH_OXD0166=html\property_data.html#GraphType
IDH_OXD0170=html\property_data.html#Value
IDH_OXD0173=html\property_data.html#GraphType
IDH_OXD0174=html\property_data.html#GraphType
IDH_OXD0175=html\property_data.html#GraphType
IDH_OXD0176=html\property_data.html#GraphType
IDH_OXD0177=html\property_data.html#GraphType
IDH_OXD0178=html\property_data.html#GraphType
IDH_OXD0179=html\property_custom_Table.html#Group
IDH_OXD0181=html\property_custom_Table.html#BandBinding
IDH_OXD0182=html\property_setting_BarCode.html#InsertCheckDigit
IDH_OXD0187=html\property_general.html#Frame-Size
IDH_OXD0189=html\property_data.html#DropDown-Value
IDH_OXD0211=html\property_custom_Form.html#CheckName
IDH_OXD0212=html\QueryBuilder.html#Howto_SelectTable
IDH_OXD0216=html\property_general.html#LocationAndSize
IDH_OXD0217=html\property_custom_Form.html#CheckName
IDH_OXD0220=html\property_data.html#File
IDH_OXD0221=html\property_custom_Image.html#Appearance-ShowAllPages
IDH_OXD0223=html\property_general.html#LocationAndSize
IDH_OXD0228=html\property_custom_Form.html#RadioName
IDH_OXD0239=html\menu_Edit.html#PastePointer
IDH_OXD0240=html\HorizontalDatasetTable.html
IDH_OXD0241=html\property_custom_Table.html#DistributeBandsEvenly
IDH_OXD0242=html\property_custom_Table.html#DistributeColumnsEvenly
IDH_OXD0243=html\property_custom_Form.html#Checked
IDH_OXD0250=html\property_data.html#File
IDH_OXD0252=html\property_data.html#Value
IDH_OXD0253=html\TimeStamp.html
IDH_OXD0254=html\DocuWorksSignature.html
IDH_OXD0261=html\property_data.html#File
IDH_OXD0263=html\property_data.html#Value
IDH_OXD0264=html\TextQueryBuilder.html
IDH_OXD0274=html\menu_Components.html#GroupObjects
IDH_OXD0275=html\NumberFormat.html
IDH_OXD0276=html\DateTimeFormat.html
IDH_OXD0277=html\GraphWizard.html
IDH_OXD0278=html\property_custom_Table.html#Links
IDH_OXD0284=html\QueryBuilder.html#Howto_AddAllFields
IDH_OXD0285=html\QueryBuilder.html#Howto_AddField
IDH_OXD0286=html\QueryBuilder.html#Howto_DisplayFieldData
IDH_OXD0287=html\QueryBuilder.html#Howto_DisplayTableData
IDH_OXD0288=html\property_URLData.html#Type
IDH_OXD0289=html\property_URLData.html#Value
IDH_OXD0290=html\property_custom_Table.html#RemoveDuplicates
IDH_OXD0298=html\QueryBuilder.html#Howto_DeleteTable
IDH_OXD0310=html\property_URLData.html#Type
IDH_OXD0311=html\property_URLData.html#Value
IDH_OXD0326=html\property_custom_Form.html#MaxLength
IDH_OXD0327=html\property_URLData.html#Type
IDH_OXD0328=html\property_URLData.html#Value
IDH_OXD0334=html\property_hyperlink.html#EnabledHyperlink
IDH_OXD0335=html\menu_Help.html#QuickHelp
IDH_OXD0336=html\property_hyperlink.html#URL
IDH_OXD0337=html\property_setting_Graph.html#Legend-Show
IDH_OXD0338=html\property_setting_Graph.html#Legend-Alignment
IDH_OXD0339=html\property_setting_Graph.html#Legend-Layout
IDH_OXD0343=html\property_custom_Form.html#Appearance-BackgroundColor
IDH_OXD0345=html\property_URLData.html#Type
IDH_OXD0346=html\property_URLData.html#Value
IDH_OXD0347=html\component_Wizard.html
IDH_OXD0348=html\menu_Components.html
IDH_OXD0349=html\menu_Help.html#About
IDH_OXD0350=html\-.html
IDH_OXD0351=html\interface.html
IDH_OXD0352=html\property_setting_Graph.html#Legend-Layout
IDH_OXD0353=html\TotalPageNumber.html
IDH_OXD0355=html\property_setting_Page.html#NumberingFor
IDH_OXD0356=html\property_setting_Page.html#Offset
IDH_OXD0357=html\property_font.html#Appearance-Color
IDH_OXD0358=html\MGSignedPDF.html
IDH_OXD0359=html\property_setting_Page.html#TotalPageNumber-NumberingFor
IDH_OXD0360=html\property_custom_Sec.html#Printable
IDH_OXD0361=html\property_custom_Sec.html#Author
IDH_OXD0362=html\property_custom_Sec.html#Location
IDH_OXD0363=html\property_general.html#Frame-Size
IDH_OXD0364=html\property_grid.html#Grid-Interval
IDH_OXD0365=html\property_grid.html
IDH_OXD0366=html\property_grid.html
IDH_OXD0367=html\property_custom_Sec.html#Reason
IDH_OXD0368=html\property_custom_Sec.html#Comment
IDH_OXD0374=html\property_fields.html#Edit
IDH_OXD0389=html\property_setting_Page.html#VisibleInTheFirstPage
IDH_OXD0390=html\property_setting_Page.html#TotalPageNumber-Offset
IDH_OXD0391=html\property_setting_Page.html#TotalPageNumber-Value
IDH_OXD0392=html\property_setting_Page.html#TotalPageNumber-VisibleInTheFirstPage
IDH_OXD0393=html\property_setting_Page.html#TotalPageNumber-VisibleInTheLastPage
IDH_OXD0395=html\property_custom_Form.html#TabOrder
IDH_OXD0398=html\property_format.html#Kind
IDH_OXD0399=html\property_format.html#Date
IDH_OXD0400=html\property_format.html#Time
IDH_OXD0401=html\property_font.html#Appearance-EUDC
IDH_OXD0402=html\property_custom_Form.html#AllowUserInput
IDH_OXD0403=html\property_data.html#Type
IDH_OXD0404=html\property_data.html#Type
IDH_OXD0405=html\property_custom_Form.html#Checked
IDH_OXD0406=html\DatasetTable.html
IDH_OXD0407=html\property_general.html#LocationAndSize
IDH_OXD0409=html\property_custom_Image.html#Appearance-Stretch
IDH_OXD0413=html\property_setting_BarCode.html#BarcodeType
IDH_OXD0415=html\DocumentSecurity.html
IDH_OXD0416=html\property_setting_BarCode.html#ShowText
IDH_OXD0417=html\menu_File.html#SaveAllTemplates
IDH_OXD0418=html\property_custom_Table.html#AutoAdjust
IDH_OXD0419=html\property_custom_Table.html#RowCount
IDH_OXD0421=html\property_custom_Table.html#Align
IDH_OXD0422=html\property_custom_Table.html#Dataset
IDH_OXD0423=html\property_custom_Table.html#PageHeader
IDH_OXD0424=html\property_custom_Table.html#PageFooter
IDH_OXD0425=html\property_custom_Table.html#Group
IDH_OXD0426=html\property_custom_Table.html#ReportHeader
IDH_OXD0427=html\property_custom_Table.html#ReportFooter
IDH_OXD0428=html\property_custom_Table.html#RowHeader
IDH_OXD0429=html\property_custom_Table.html#Links
IDH_OXD0430=html\property_custom_Table.html#RemoveDuplicates
IDH_OXD0431=html\property_custom_Table.html#RepeatEmptyReportHeader
IDH_OXD0432=html\property_custom_Table.html#AlignReportFooterToBottom
IDH_OXD0433=html\property_custom_Line.html#Shape
IDH_OXD0434=html\property_custom_Line.html#Border-Color
IDH_OXD0435=html\property_custom_Line.html#Border-Size
IDH_OXD0436=html\property_custom_Line.html#Background-Color
IDH_OXD0437=html\property_custom_Table.html#RestrictTheNumberOfDetails
IDH_OXD0438=html\property_custom_Table.html#NumberOfDetails
IDH_OXD0440=html\property_general.html#Frame-Color
IDH_OXD0441=html\property_general.html#Appearance-Visible
IDH_OXD0442=html\about_oxb.html
IDH_OXD0443=html\about_oxd.html
IDH_OXD0444=html\property_custom_Form.html#Action-Content
IDH_OXD0445=html\property_custom_Line.html#Line-Style
IDH_OXD0446=html\property_custom_Line.html#Line-Size
IDH_OXD0447=html\property_custom_Line.html#Line-Color
IDH_OXD0448=html\PropertyEditor.html
IDH_OXD0449=html\HorizontalDatasetTable.html
IDH_OXD0450=html\property_general.html#Appearance-Visible
IDH_OXD0454=html\property_custom_Sec.html#SetAsBackground
IDH_OXD0460=html\property_setting_Graph.html#Graph-Rotation
IDH_OXD0461=html\property_setting_BarCode.html#Rotation
IDH_OXD0464=html\property_setting_Page.html#VisibleInTheFirstPage
IDH_OXD0465=html\property_setting_Page.html#VisibleInTheLastPage
IDH_OXD0466=html\property_setting_Page.html#Offset
IDH_OXD0467=html\tutorial.html
IDH_OXD0469=html\property_general.html#Appearance-BackgroundColor
IDH_OXD0470=html\property_operation.html#Interval
IDH_OXD0472=html\property_LayoutSetting.html#Repeating
IDH_OXD0473=html\property_operation.html#Visible
IDH_OXD0474=html\property_operation.html#Color
IDH_OXD0475=html\property_LayoutSetting.html#Margins
IDH_OXD0476=html\property_LayoutSetting.html#Margins
IDH_OXD0477=html\property_LayoutSetting.html#Margins
IDH_OXD0478=html\property_LayoutSetting.html#Margins
IDH_OXD0479=html\property_LayoutSetting.html#Unit
IDH_OXD0480=html\property_LayoutSetting.html#Unit
IDH_OXD0481=html\property_LayoutSetting.html#Height_Width
IDH_OXD0482=html\property_LayoutSetting.html#Height_Width
IDH_OXD0483=html\property_LayoutSetting.html#Orientation
IDH_OXD0484=html\property_LayoutSetting.html#Orientation
IDH_OXD0485=html\menu_File.html
IDH_OXD0486=html\menu_File.html#NewTemplate
IDH_OXD0487=html\menu_File.html#Open
IDH_OXD0488=html\menu_File.html#Reopen
IDH_OXD0489=html\menu_File.html#Close
IDH_OXD0490=html\menu_File.html#CloseAll
IDH_OXD0491=html\menu_File.html#SaveTemplate
IDH_OXD0492=html\menu_File.html#SaveTemplateAs
IDH_OXD0493=html\menu_File.html#SaveAllTemplates
IDH_OXD0494=html\menu_File.html#Preview
IDH_OXD0495=html\menu_File.html#Exit
IDH_OXD0496=html\menu_Edit.html
IDH_OXD0497=html\menu_Edit.html#Undo
IDH_OXD0498=html\menu_Edit.html#Redo
IDH_OXD0499=html\menu_Edit.html#Cut
IDH_OXD0500=html\menu_Edit.html#Copy
IDH_OXD0501=html\menu_Edit.html#Paste
IDH_OXD0502=html\menu_Edit.html#Delete
IDH_OXD0503=html\menu_Edit.html#QuickDelete
IDH_OXD0504=html\menu_Edit.html#SelectAll
IDH_OXD0505=html\menu_Edit.html#Align
IDH_OXD0506=html\menu_Edit.html#Size
IDH_OXD0507=html\menu_Edit.html#BringToFront
IDH_OXD0508=html\menu_Edit.html#SendtoBack
IDH_OXD0509=html\menu_View.html
IDH_OXD0510=html\menu_View.html#TemplateExplorer
IDH_OXD0511=html\menu_View.html#PropertyEditor
IDH_OXD0512=html\menu_View.html#Toolbar
IDH_OXD0513=html\menu_Components.html
IDH_OXD0514=html\menu_Options.html
IDH_OXD0515=html\menu_Window.html
IDH_OXD0516=html\menu_Help.html
IDH_OXD0517=html\property_general.html#Appearance-Visible
IDH_OXD0518=html\property_operation.html#MagnetMode
IDH_OXD0520=html\property_custom_Form.html#Action-Method
IDH_OXD0521=html\property_custom_Form.html#Action-URL
IDH_OXD0522=html\property_data.html#Value
IDH_OXD0523=html\property_general.html#Name
IDH_OXD0524=html\property_general.html#Appearance-BackgroundColor
IDH_OXD0525=html\property_operation.html#Interval
IDH_OXD0526=html\property_operation.html#Snap
IDH_OXD0527=html\property_operation.html#Style
IDH_OXD0528=html\property_operation.html#Visible
IDH_OXD0529=html\property_operation.html#Color
IDH_OXD0530=html\property_LayoutSetting.html#Unit
IDH_OXD0531=html\property_LayoutSetting.html#Margins
IDH_OXD0532=html\property_LayoutSetting.html#Margins
IDH_OXD0533=html\property_LayoutSetting.html#Margins
IDH_OXD0534=html\property_LayoutSetting.html#Margins
IDH_OXD0535=html\property_LayoutSetting.html#Size
IDH_OXD0536=html\property_LayoutSetting.html#Height_Width
IDH_OXD0537=html\property_LayoutSetting.html#Height_Width
IDH_OXD0538=html\property_LayoutSetting.html#Orientation
IDH_OXD0539=html\property_LayoutSetting.html#Orientation
IDH_OXD0545=html\property_custom_Table.html#Group
IDH_OXD0546=html\-.html
IDH_OXD0547=html\property_custom_Table.html#BandCount
IDH_OXD0548=html\property_custom_Table.html#ColumnCount
IDH_OXD0549=html\property_custom_Table.html#Table-Appearance-BackgroundColor
IDH_OXD0550=html\property_custom_Table.html#DistributeBandsEvenly
IDH_OXD0551=html\property_custom_Table.html#DistributeColumnsEvenly
IDH_OXD0552=html\property_custom_Table.html#AutoAdjust
IDH_OXD0557=html\menu_View.html#Magnifier
IDH_OXD0558=html\property_custom_Table.html#ColumnCount
IDH_OXD0559=html\property_custom_Table.html#Table-Appearance-BackgroundColor
IDH_OXD0560=html\property_custom_Table.html#Dataset
IDH_OXD0561=html\menu_View.html#Tracker
IDH_OXD0563=html\property_custom_Table.html#RestrictTheNumberOfDetails
IDH_OXD0564=html\property_custom_Table.html#NumberOfDetails
IDH_OXD0565=html\Graph.html
IDH_OXD0566=html\property_setting_BarCode.html#BaseWidth
IDH_OXD0570=html\SATOLabel.html
IDH_OXD0575=html\property_hyperlink.html#EnabledHyperlink
IDH_OXD0578=html\property_data.html#BarCode-Value
IDH_OXD0579=html\property_data.html#Single
IDH_OXD0580=html\property_data.html#Multi
IDH_OXD0581=html\property_data.html#Point-Rotation
IDH_OXD0582=html\property_data.html#Point-FontSize
IDH_OXD0583=html\property_data.html#LegendTitle
IDH_OXD0584=html\property_data.html#GraphType
IDH_OXD0585=html\property_data.html#Series
IDH_OXD0586=html\property_data.html#Value
IDH_OXD0588=html\property_setting_Graph.html#Header
IDH_OXD0589=html\property_setting_Graph.html#Footer
IDH_OXD0593=html\property_data.html#DisplayGraph
IDH_OXD0594=html\DigitalSignature.html
IDH_OXD0598=html\property_DeviceFont.html#GetDeviceFontList
IDH_OXD0599=html\menu_Edit.html#PastePointer
IDH_OXD0600=html\menu_Edit.html#PastePointer
IDH_OXD0601=html\menu_Edit.html#PastePointer
IDH_OXD0602=html\property_custom_Table.html#BackgroundColor
IDH_OXD0603=html\property_custom_Table.html#BackgroundColor
IDH_OXD0607=html\OCCS.html
IDH_OXD0609=html\property_data.html#Type
IDH_OXD0610=html\AggregateFunction.html
IDH_OXD0611=html\OCCS.html
IDH_OXD0612=html\QueryBuilder.html
IDH_OXD0613=html\File.html
IDH_OXD0614=html\VeriSignDigitalSignature.html
IDH_OXD0615=html\property_grid.html#Grid-Color
IDH_OXD0616=html\property_hyperlink.html#Type
IDH_OXD0617=html\property_conditional.html#Add
IDH_OXD0618=html\property_conditional.html#Remove
IDH_OXD0619=html\property_conditional.html#Operand1_Operator_Operand2
IDH_OXD0620=html\property_conditional.html#Operand1_Operator_Operand2
IDH_OXD0621=html\property_conditional.html#Operand1_Operator_Operand2
IDH_OXD0622=html\property_conditional.html#Name
IDH_OXD0623=html\property_custom.html#Background-Color
IDH_OXD0624=html\property_conditional.html#Appearance-Size
IDH_OXD0628=html\property_data.html#URL
IDH_OXD0630=html\property_URLData.html#Type
IDH_OXD0631=html\property_URLData.html#URLImage-Value
IDH_OXD0632=html\property_conditional.html#Appearance-Color
IDH_OXD0633=html\property_conditional.html#Appearance-Strikeout
IDH_OXD0637=html\property_conditional.html#Appearance-Bold
IDH_OXD0638=html\property_conditional.html#Appearance-Underline
IDH_OXD0639=html\property_conditional.html#Appearance-Italic
IDH_OXD0642=html\property_conditional.html#BackgroundColor
IDH_OXD0643=html\property_conditional.html#Visible
IDH_OXD0644=html\property_conditional.html#Transparent
IDH_OXD0645=html\property_conditional.html#Layout
IDH_OXD0646=html\property_conditional.html#ChangeValue
IDH_OXD0647=html\property_conditional.html#ChangeValue
IDH_OXD0648=html\property_conditional.html#Reset
IDH_OXD0650=html\property_conditional.html#AddCondition
IDH_OXD0651=html\property_URLData.html#Type
IDH_OXD0652=html\property_URLData.html#Value
IDH_OXD0653=html\property_URLData.html#DisplayValueContents
IDH_OXD0654=html\property_conditional.html#DeleteCondition
IDH_OXD0655=html\property_conditional.html#ClearAll
IDH_OXD0656=html\property_custom_Line.html#CornerAdjustment
IDH_OXD0657=html\property_custom_Line.html#Line-Direction
IDH_OXD0658=html\property_custom_Form.html#Appearance-BackgroundColor
IDH_OXD0659=html\property_custom_Form.html#Popup
IDH_OXD0660=html\property_custom_Form.html#ParameterName
IDH_OXD0661=html\property_custom_Form.html#DataType
IDH_OXD0662=html\property_custom_Form.html#Required
IDH_OXD0663=html\property_custom_Form.html#Disabled
IDH_OXD0664=html\property_custom_Form.html#Read-only
IDH_OXD0665=html\property_custom_Form.html#Masked
IDH_OXD0666=html\property_custom_Form.html#Read-only
IDH_OXD0667=html\property_custom_Form.html#Disabled
IDH_OXD0689=html\OFDIO.html
IDH_OXD0690=html\property_custom_Form.html#Save
IDH_OXD0691=html\property_custom_Form.html#Load
IDH_OXD0694=html\property_custom_Form.html#SpecifyOXROPRLocation
IDH_OXD0701=html\menu_Components.html#SetPropertiesAsDefault
IDH_OXD0703=html\property_custom_Form.html#Action-Content
IDH_OXD0712=html\property_URLData.html#Type
IDH_OXD0713=html\property_custom_Table.html#AlternateColor
IDH_OXD0714=html\property_URLData.html#DisplayValueContents
IDH_OXD0716=html\property_URLData.html#DisplayValueContents
IDH_OXD0717=html\property_URLData.html#DisplayValueContents
IDH_OXD0718=html\property_URLData.html#DisplayValueContents
IDH_OXD0719=html\property_custom_Table.html#Align
IDH_OXD0720=html\property_custom_Table.html#ReportHeader
IDH_OXD0721=html\property_custom_Table.html#ReportFooter
IDH_OXD0722=html\property_custom_Table.html#PageHeader
IDH_OXD0723=html\property_custom_Table.html#PageFooter
IDH_OXD0724=html\property_custom_Table.html#ColumnHeader
IDH_OXD0725=html\QueryBuilder.html
IDH_OXD0726=html\property_URLData.html#URLPrefix_URLSuffix
IDH_OXD0728=html\property_data.html#BarCode-Value
IDH_OXD0729=html\property_data.html#ShowBarCode
IDH_OXD0730=html\property_URLData.html#Type
IDH_OXD0731=html\property_data.html#Type
IDH_OXD0733=html\menu_File.html#NewTemplate
IDH_OXD0738=html\property_setting_Page.html#Value
IDH_OXD0754=html\property_custom.html#Layout
IDH_OXD0755=html\property_custom.html#Color
IDH_OXD0756=html\property_custom.html#Style-AutoSize
IDH_OXD0757=html\property_custom.html#Style-WordWrap
IDH_OXD0758=html\property_custom.html#Style-Equalize
IDH_OXD0759=html\property_custom.html#Style-Fit
IDH_OXD0760=html\property_custom.html#TextAppearance-LineInterval
IDH_OXD0761=html\property_custom.html#TextAppearance-CharacterInterval
IDH_OXD0762=html\property_custom.html#TextAppearance-TabSize
IDH_OXD0763=html\property_data.html#Function
IDH_OXD0764=html\property_data.html#Format
IDH_OXD0765=html\property_data.html#Type
IDH_OXD0766=html\property_data.html#Dataset
IDH_OXD0767=html\property_data.html#Field
IDH_OXD0775=html\property_data.html#Value
IDH_OXD0778=html\QueryBuilder.html
IDH_OXD0779=html\QueryBuilder.html
IDH_OXD0780=html\QueryBuilder.html
IDH_OXD0781=html\QueryBuilder.html
IDH_OXD0782=html\QueryBuilder.html
IDH_OXD0783=html\QueryBuilder.html
IDH_OXD0787=html\property_URLData.html#Value
IDH_OXD0788=html\property_URLData.html#DisplayValueContents
IDH_OXD0792=html\DigitalSignature.html
IDH_OXD0793=html\DigitalSignature.html
IDH_OXD0801=html\component_Security.html
IDH_OXD0802=html\menu_Edit.html#FormatPainter
IDH_OXD0803=html\TextDataset.html
IDH_OXD0804=html\URLTextDataset.html
IDH_OXD0809=html\property_general.html#LocationAndSize
IDH_OXD0811=html\property_custom_Image.html#Appearance-Stretch
IDH_OXD0816=html\property_data.html#GetContent
IDH_OXD0817=html\property_data.html#ShowContent
IDH_OXD0818=html\menu_Options.html#EnvironmentOptions
IDH_OXD0836=html\menu_Help.html#About
IDH_OXD0837=html\property_fields.html#Load
IDH_OXD0838=html\menu_Options.html#OFMSAdministrator
IDH_OXD0849=html\property_custom_Form.html#OFDXMLTransform
IDH_OXD0850=html\about_oxd.html
IDH_OXD0851=html\menu_File.html#AddLayout
IDH_OXD0852=html\menu_File.html#RenameLayout
IDH_OXD0853=html\menu_File.html#RemoveLayout
IDH_OXD0854=html\menu_Components.html#Pointer
IDH_OXD0855=html\component_Standard.html
IDH_OXD0856=html\component_Additional.html
IDH_OXD0857=html\component_Form.html
IDH_OXD0858=html\component_DataAccess.html
IDH_OXD0859=html\SubReport.html
IDH_OXD0860=html\property_data.html#Type
IDH_OXD0890=html\property_font.html#Appearance-CJK
IDH_OXD0892=html\property_setting_Page.html#NumberingFor
IDH_OXD0893=html\property_fields.html#Edit
IDH_OXD0895=html\property_fields.html#Save
IDH_OXD0896=html\property_data.html#Type
IDH_OXD0897=html\property_data.html#Value
IDH_OXD0898=html\property_data.html#File
IDH_OXD0899=html\property_data.html#URL
IDH_OXD0900=html\property_URLData.html#Type
IDH_OXD0901=html\property_URLData.html#Value
IDH_OXD0902=html\property_URLData.html#Value
IDH_OXD0903=html\TextQueryBuilder.html
IDH_OXD0904=html\property_custom_Form.html#OFDXML
IDH_OXD0905=html\property_custom_Form.html#XMLOFD
IDH_OXD0906=html\property_custom_Form.html#Button
IDH_OXD0907=html\property_custom_Form.html#Popup
IDH_OXD0910=html\property_URLData.html#Value
IDH_OXD0916=html\Table.html
IDH_OXD0917=html\Table.html
IDH_OXD0918=html\DatasetTable.html
IDH_OXD0919=html\HorizontalDatasetTable.html
IDH_OXD0922=html\DatasetDropDown.html
IDH_OXD0923=html\DatasetList.html
IDH_OXD0924=html\property_data.html#Dataset
IDH_OXD0925=html\property_data.html#Format
IDH_OXD0926=html\property_data.html#Field
IDH_OXD0927=html\property_custom_Label.html#Vertical
IDH_OXD0928=html\property_custom_Label.html#Vertical
IDH_OXD0930=html\menu_File.html#NewTemplate
IDH_OXD0931=html\menu_View.html#Magnifier
IDH_OXD0932=html\menu_View.html#Magnifier
IDH_OXD0933=html\menu_View.html#Magnifier
IDH_OXD0934=html\menu_View.html#Magnifier
IDH_OXD0999=html\property_permissions.html


.topic 36
選択をキャンセルします。

.topic 37
コンポーネントの背景色を指定します。

.topic 40
コンポーネントを画面に表示するかどうかを指定します。

.topic 41
フォーム上でこのコンポーネントの背面にあるコンポーネントを表示するかどうかを指定します。

.topic 42
コンポーネントを移動できないようにロックします。

.topic 43
選択を確認します。

.topic 44
GETメソッドを使用してテンプレートを送信する場合に選択します。

.topic 45
POSTメソッドを使用してテンプレートを送信する場合に選択します。

.topic 46
対話的に操作できるHTMLページを作成します。このオプションはエンドユーザに適しています。

.topic 47
このオプションは、開発者がサンプルHTMLページを取得する場合に便利です。すべてのパラメータが名前付きで一つのHTMLページに表示されます。

.topic 48
このオプションを指定すると、OPR、 OXR、PDF、HTML形式のいずれかの形式でドキュメントをダウンロードすることができます。

.topic 49
OPR、OXR、PDF、HTMLのいずれかの形式でドキュメントをメール送信することができます。

.topic 50
テキストを表示する位置を指定します。

.topic 51
背景色を指定します。

.topic 52
サーバサイドの印刷機能を使用します。

.topic 53
ドキュメントをFAX送信することができます。

.topic 54
このオプションを指定すると、ドキュメントをプリンタに直接印刷することができます。

.topic 55
出力を表示します。

.topic 56
コンポーネントのテキストの行間隔を指定します。

.topic 57
コンポーネントのテキストの文字間隔を指定します。

.topic 58
タブ幅を指定します。

.topic 59
入力タイプを指定します。

.topic 60
内容を指定します。

.topic 61
出力を生成します。

.topic 62
テンプレートの出力形式としてOPRを有効にする場合に選択します。

.topic 63
「サンプルHTMLの作成」を閉じます。

.topic 64
テンプレートの出力形式としてPDFを有効にする場合に選択します。

.topic 65
入力できる最大文字数を指定します。

.topic 66
名前を指定します。

.topic 67
テンプレートの出力形式としてHTMLを有効にする場合に選択します。

.topic 68
CGI (Common Gateway Interface)またはサーブレットファイルの場所の絶対URLを入力します。 これは、データをサーバに転送するために使用します。

.topic 69
クリックすると、標準のWebブラウザでサンプルHTMLページを表示します。

.topic 70
HTMLファイルを作成して保存します。

.topic 71
バーコードを指定します。

.topic 72
バーコードの内容を入力します。

.topic 73
HTMLを作成後にデフォルトのブラウザで表示します。

.topic 74
「True」のときにテキストを表示します。

.topic 75
バーコードの色を指定します。

.topic 76
データセットを選択します。

.topic 77
「抽出条件」で指定されているすべての入力キーを表示します。

.topic 78
入力キーで指定されているすべての条件を表示します。

.topic 79
選択した入力キーの表題を入力します。

.topic 80
選択した入力キーの初期値を入力します。

.topic 81
URLコンポーネントを除き、タイプをリクエストとして選択しているすべてのコンポーネントを表示します。

.topic 82
選択したコンポーネントのリクエストパラメータ名を表示します。

.topic 83
選択した入力キーの初期値を入力します。

.topic 84
選択した入力キーの表題を入力します。

.topic 85
タイプをリクエストとして選択しているすべてのURLコンポーネントを表示します。

.topic 86
選択したURLコンポーネントのリクエストパラメータ名を表示します。

.topic 120
選択した入力URLコンポーネントの表題を入力します。

.topic 121
選択したURL入力キーの初期値を入力します。

.topic 137
グループIDは、相関している一連のコンポーネントに与えられる一意な整数値です。OXDでは、非常に柔軟な方法で、テンプレートのレイアウトでコンポーネントをグルーピングできます。

.topic 138
「コンポーネント名」 グルーピング可能な類似するコンポーネントをすべて表示します。 「グループ順序」 グループ内での順序を指定します。手動で、または「自動」をクリックして順序を設定できます。

.topic 139
グループ内での順序を指定します。手動で、または「自動」をクリックして順序を設定できます。

.topic 140
コンポーネントの順序を自動的に設定します。

.topic 150
変更元Datasetを選択

.topic 151
Select to print the Template faster.

.topic 155
変更先Datasetを選択

.topic 167
変更先Datasetのフィールドを選択します。

.topic 168
変更先Datasetのフィールドを表示

.topic 169
クリックすると戻ります

.topic 171
クリックすると進みます

.topic 172
クリックすると完了します

.topic 183
重複したフィールドの値を検索するテーブルを選択します。

.topic 184
重複した情報が含まれているフィールドをクリックします。

.topic 185
重複値の抽出フィールドを表示します。

.topic 186
変更先Datasetのフィールドを選択

.topic 188
クリックすると、自動的にすべての変更元Datsetフィールドを変更先Datasetに選択します。

.topic 190
DBExecuteを選択します

.topic 191
全てのDBExecute入力キーを一覧表示します

.topic 192
クエリ用に表示するフィールドを選択します。

.topic 193
クエリ用に表示するフィールドを表示します。

.topic 194
前の画面に戻ります。

.topic 195
次の画面に進みます。

.topic 196
クエリを完了します。

.topic 197
クエリをキャンセルします。

.topic 198
クエリ結果のレコードが含まれているテーブルを選択します。

.topic 199
関連するレコードが含まれているテーブルを選択します。

.topic 200
重複した情報が含まれている可能性のあるフィールドを選択します。

.topic 201
対応するフィールドを最初のテーブル一覧から選択します。

.topic 202
クエリ結果に表示するフィールドを選択します。

.topic 203
クエリ結果に表示する、選択されたフィールドを表示します。

.topic 206
確認のためにパスワードを再入力します。

.topic 209
「フィールドの情報」    「フィールド名」  フィールドの名前を指定します。    「データタイプ」  データタイプを指定します。    「形式」  データタイプで「Date」を選んだ場合に、日時の表示形式を指定します。    「開始位置」  「固定長」オプションをオンにした場合に表れます。フィールドを開始するカラム位置を指定します。    「長さ」  「固定長」オプションをオンにした場合に表れます。フィールドの長さを指定します。

.topic 210
サンプルのテキストファイルを読み込んで、フィールドを設定します。

.topic 222
クエリのテーブルを選択します。

.topic 224
クエリのフィールドを選択します。

.topic 225
クエリ用に選択されたフィールドを表示します。

.topic 226
結果のカラムおよびヘッダを指定します。

.topic 227
DatasetTable/HorizontalDatasetTableのDatasetを選択します。

.topic 233
Dataset内のテーブルのフィールドをすべて表示します。DatasetTable/HorizontalDatasetTableのフィールドを選択します。

.topic 234
DatasetTable/HorizontalDatasetTable用に選択されたフィールドを表示します。

.topic 235
DatasetTable/HorizontalDatasetTableの名前を表示します。必要に応じて変更できます。

.topic 236
DatasetTable/HorizontalDatasetTableの上の位置を指定します。

.topic 237
DatasetTable/HorizontalDatasetTableの左の位置を指定します。

.topic 238
DatasetTable/HorizontalDatasetTableの高さを指定します。

.topic 244
DatasetTable/HorizontalDatasetTableの幅を指定します。

.topic 245
DatasetTable/HorizontalDatasetTableを一つ選択して指定します。

.topic 246
DatasetTable/HorizontalDatasetTableを二つ選択して指定します。

.topic 247
DatasetTable/HorizontalDatasetTableを三つ選択して指定します。

.topic 248
DatasetTable/HorizontalDatasetTableを四つ選択して指定します。

.topic 249
グループの番号を選択します。同じテンプレート内の別のDatasetTable/HorizontalDatasetTableコンポーネントでは使用できない番号を選択してください。

.topic 255
レポートヘッダを追加します。

.topic 256
レポートフッタを追加します。

.topic 257
カラム/ローヘッダを追加します。

.topic 258
各フィールドのカラム/ローを設定します。

.topic 259
すべてのフィールドのカラム/ローを設定します。

.topic 260
ウィザードを完了します。

.topic 262
The Settings button of the Internet Connections section is used to bring up the Internet Explorer settings dialog box in order to set the proxy address and the port used by the proxy server.

.topic 265
指定されたURL位置にあるCSV(テキスト)ファイルのデータの文字コードを指定します。

.topic 266
ウィザードをキャンセルします。

.topic 267
親DatasetTable/HorizontalDatasetTableのDatasetを選択します。

.topic 268
DatasetTable/HorizontalDatasetTableでフィールドを横並びに指定します。

.topic 269
DatasetTable/HorizontalDatasetTableでフィールドを縦並びに指定します。

.topic 270
Dataset内のテーブルのフィールドをすべて表示します。

.topic 271
DatasetTable/HorizontalDatasetTable用に選択されたフィールドを表示します。

.topic 272
子DatasetTable/HorizontalDatasetTableのDatasetを選択します。

.topic 273
親と子からリンクするフィールドを選択します。矢印キーを押下すると、リンクを追加できます。

.topic 279
データがUnicode形式の場合、読み込まれるデータを正しく参照できるようにするには、「文字コード」ドロップダウンメニューを使用し、適切なエンコード形式を指定する必要があります。

.topic 280
プロキシサーバのアドレスおよびポートを設定するために「インターネットのプロパティ」ダイアログを開きます。

.topic 281
出力形式としてXDWを選択します。

.topic 282
プレビューする形式としてXDWを指定します。

.topic 283
出力テンプレート形式としてXDWを指定するのに選択します。

.topic 291
簡単なグラフを作成します。

.topic 292
さまざまな尺度で高度なグラフを作成します。

.topic 293
グラフの静的な値を選択できます。

.topic 294
グラフの値をデータベースから選択できます。

.topic 295
テンプレートに表示するグラフのタイプを選択します。

.topic 296
グラフの系列数を選択します。

.topic 297
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトの「背景色」として、基本色以外の色を選択します。

.topic 299
クリックすると、ドキュメントをメール本文に埋め込みます。

.topic 300
クリックすると、ドキュメントをメール本文に埋め込みません。

.topic 301
クリックすると、読まれたかどうかを送信者に通知するリクエスト(受信確認)をメールに追加します。

.topic 302
クリックすると、読まれたかどうかを送信者に通知するリクエスト(受信確認)をメールに追加しません。

.topic 303
「列の追加」オプションは、リンクフィールドのグリッドの最後に列を追加します。

.topic 304
グラフの値を入力します。

.topic 305
CSVファイルから値を読込ます。

.topic 306
ファイルからPointの値を読込ます。

.topic 307
グラフの上の位置を指定します。

.topic 308
グラフの左の位置を指定します。

.topic 309
グラフの幅を指定します。

.topic 312
グラフの高さを指定します。

.topic 313
表題を表示します。

.topic 314
グラフを縦並びまたは横並びに表示します。

.topic 315
グラフの背景色を選択します。

.topic 316
グラフのヘッダを入力します。

.topic 317
グラフのフッタを入力します。

.topic 318
前のウィンドウを選択します。

.topic 319
次のウィンドウを選択します。

.topic 320
ウィザードを完了します。

.topic 321
ウィザードをキャンセルします。

.topic 322
表題を入力します。

.topic 323
グラフのフォントサイズを指定します。

.topic 324
Pointを回転する角度を選択します。

.topic 325
AUTOオプションは、リンクフィールドのグリッドにある、同じフィールド名、同じフィールドタイプの2つのDatasetのフィールドを自動的にリンクします。

.topic 329
グラフの奥行きを指定します。

.topic 330
グラフの立体化を指定します。

.topic 331
グラフの横方向の回転角度を指定します。

.topic 332
グラフ用にフィールドを選択するDatasetを選択します。

.topic 333
Datasetからフィールドを選択します。

.topic 340
「列の削除」オプションは、リンクフィールドのグリッドの最後の列を削除します。

.topic 341
「すべての列をクリア」オプションは、リンクフィールドのグリッドにある全ての列をクリアします。

.topic 342
グラフに表題を表示します。必要に応じてグラフをドラッグして移動します。

.topic 344
セキュリティレベルを有効または無効にします。

.topic 394
選択されたURLにリクエストを送り、ダイアログにOPRO X Serverのバージョンを表示します。

.topic 408
Select the default paper Size for the new Template or for the new Layout, which will be added to an existing Template.

.topic 410
「用紙サイズ」で「Custom」を選択したときにデフォルトの「高さ」を指定します。

.topic 411
「用紙サイズ」で「Custom」を選択したときにデフォルトの「幅」を指定します。

.topic 412
「用紙サイズ」の「高さ」と「幅」の単位を選択します。選択できる単位には「cm(センチメートル)」と「inch(インチ)」があります。

.topic 414
デフォルトの「用紙の向き」を「縦」から「横」に変更します。

.topic 420
デフォルトの「用紙の向き」を「横」から「縦」に変更します。

.topic 451
抽出条件で指定されている条件が表示されます。

.topic 452
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトの「左」マージンを指定します。

.topic 453
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトの「右」マージンを指定します。

.topic 455
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトの「上」マージンを指定します。

.topic 456
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトの「下」マージンを指定します。

.topic 457
「2.3と同じ方法」プロパティは、バージョン2.5以降のテンプレートによって生成されたOPRドキュメントをOPRO X Browserで印刷する際に、2.5未満のバージョンで作成されたテンプレートと互換性があるように文字の位置を調整するために使用します。

.topic 458
「表示と印刷を合わせる」プロパティは、テンプレートにより生成されたOPRドキュメントをOPRO X Browserで印刷する際に、文字の位置を画面の表示と合わせるために使用します。

.topic 468
ウィザードで使用するDatasetTableを選択します。

.topic 471
ウィザードで使用するHorizontalDatasetTableを選択します。

.topic 519
ウィザードで使用するDatasetTableを選択します。

.topic 540
DatasetTable/HorizontalDatasetTableのプレビューを表示します。

.topic 541
DatasetTableを選択します。

.topic 542
HorizontalDatasetTableを選択します。

.topic 543
プレビューを表示します。

.topic 544
「ファイル」メニューから「新規テンプレート」オプションを選択したとき、「新規テンプレート」ダイアログを開くようにする場合はチェックを入れます。

.topic 553
グルーピング用の新しいグループIDを選択します。

.topic 554
選択したグループIDのコンポーネントを表示します。

.topic 555
選択したコンポーネントをグループから外すにはこれをチェックしてください。

.topic 567
サーバ(OXS)で、URLエンコードのリクエスト文字列をデコードする文字セットとして使用します。

.topic 568
富士ゼロックス株式会社のサービス「PrintXchange」を使用して印刷します。

.topic 569
このオプションだけを指定した場合、ドキュメントの生成のみを行います。あらかじめドキュメント生成しておくことでテンプレートをオフラインでも利用できるようになります。

.topic 668
式をクリアします。

.topic 669
選択されているすべての式を表示します。

.topic 670
表示するテキストに合わせてサイズを変更します。

.topic 671
テキストコンポーネントを、表示されるテキストに合わせて自動的に折り返すかどうかを指定します。

.topic 672
コンポーネント内の文字間隔を拡大または縮小して、等間隔に並べます。

.topic 673
コンポーネントのサイズに合わせてコンテンツのサイズを変更します。

.topic 674
クエリのすべての関数と演算子を表示します。

.topic 675
すべてのテーブルとフィールドを表示します。

.topic 676
すべてのデータベースを表示します。

.topic 677
コンポーネントの内容として使用するファイルを選択します。

.topic 678
内容を指すURLアドレスを指定します。

.topic 679
コンポーネントのコンテンツのサイズを変更します。

.topic 680
クリックすると、URLボックスで指定されているWebアドレスを呼び出すことができます。

.topic 681
入力できる最大文字数を指定します。

.topic 682
実行するスクリプトファイルを選択します。

.topic 683
バンド数を選択します。

.topic 684
カラム数の増減を指定します。

.topic 685
プロパティを表示および変更するフィールドを選択します。

.topic 686
Datasetを選択します。

.topic 687
表示する詳細数を制限します。

.topic 688
表示する詳細数を指定します。

.topic 692
リクエストメソッドを指定します。

.topic 693
URLアドレスを指定します。

.topic 695
日付の表示形式を選択します。

.topic 696
時刻の表示形式を選択します。

.topic 697
「条件式ビルダ」で設計された条件を表示します。

.topic 698
テーブルをドラッグアンドドロップするか、またはダブルクリックして、テーブルを選択します。

.topic 699
フィールドを追加します。

.topic 700
選択可能なすべてのフィールドを表示します。フィールドを選択するには、フィールドをダブルクリックするか、または「追加」ボタンをクリックします。

.topic 702
選択されているフィールドを削除します。

.topic 704
境界色を変更します。

.topic 705
コンポーネントの境界線の太さを変更します。

.topic 706
背景色を設定します。

.topic 707
線のスタイルを選択します。

.topic 708
選択されているフィールドを下に移動します。

.topic 709
すべてのフィールドを削除します。

.topic 710
すべてのフィールドを表示します。

.topic 711
選択されているフィールドを上に移動します。

.topic 732
テンプレートの出力形式としてOXRを有効にする場合に選択します。

.topic 737
ラベルに指定されている条件を保持します。

.topic 739
フォームテンプレートを作成します。

.topic 740
作成テンプレートを作成します。

.topic 741
テンプレートを生成します。

.topic 742
テンプレートウィザードを閉じます。

.topic 743
選択したコンポーネントを表示します。コンポーネントを選択して、対象となるプロパティの詳細を設定します。

.topic 744
対象となるコンポーネントを選択します。

.topic 745
対象となるコンポーネントの表題を入力します。

.topic 746
対象となるコンポーネントの値を入力します。

.topic 747
フォーム送信のリクエストメソッドを選択します。

.topic 748
送信ボタンの表題を指定します。

.topic 749
フォームの操作タイプを選択します。

.topic 750
出力形式としてOPRを選択します。

.topic 751
出力形式としてOXRを選択します。

.topic 752
出力形式としてPDFを選択します。

.topic 753
出力形式としてHTMLを選択します。

.topic 768
サービス用のパラメータを表示します。パラメータを選択し、対象プロパティページで値を指定します。

.topic 769
今指定する 設計時にパラメータの内容を入力   ドキュメントで指定する 実行時にパラメータの内容を入力

.topic 770
「今指定する」を選択した場合に、パラメータの内容を入力します。

.topic 771
パラメータ入力の実行時に、表示するコンポーネントを選択します。

.topic 772
パラメータの表題を指定します。

.topic 773
パラメータの値を指定します。

.topic 784
部数を指定します。

.topic 785
電子メールのメッセージ本文を入力します。

.topic 786
ラジオボタンの表題および値を入力します。

.topic 790
表題を選択可能または選択不能にします。

.topic 794
作成するユーザ名を入力します。

.topic 795
会社名を入力します。

.topic 796
部門名を入力します。

.topic 797
国を選択します。

.topic 798
プロファイルのファイル名を選択します。

.topic 799
ユーザプロファイルのパスワードを入力します。

.topic 800
確認のためにパスワードを再入力します。

.topic 819
OXSのCGIパスのIPアドレスを指定します。

.topic 820
プロキシサーバを選択します。

.topic 821
プロキシサーバのIPアドレスを指定します。

.topic 822
プロキシ サーバーのポートを指定します。

.topic 823
「ファイル」メニューの「開き直す」オプションと、ツールバーの「テンプレートを開く」ボタンから選択可能なテンプレート一覧表示数を指定します。

.topic 824
サンプルHTMLファイルのパスを指定します。

.topic 825
プレビュー形式として「OPR」を指定します。

.topic 826
プレビュー形式として「PDF」を指定します。

.topic 827
プレビュー形式として「HTML」を指定します。

.topic 828
「環境設定／オプション」の変更を確定します。

.topic 829
「環境設定」をキャンセルします。

.topic 830
テンプレートの背景色を指定します。

.topic 831
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトのグリッド間隔を指定します。

.topic 832
新規テンプレートクリックすると、新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルト設定において、グリッドを表示または非表示に指定します。

.topic 833
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトのグリッドの「色」を選択します。

.topic 834
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルト設定において、グリッドポイント上であらゆるコンポーネントの移動を許可します。

.topic 835
新規テンプレートまたは既存のテンプレートに追加するレイアウトに適用されるデフォルトの「スタイル」を選択します。

.topic 839
選択内容を確定します。

.topic 840
選択内容を破棄します。

.topic 841
クリックして、テンプレートのユーザパスワードを指定します。

.topic 842
ユーザパスワードを入力してテンプレートを開きます。

.topic 843
マスタパスワードを指定して、権限とパスワードを変更します。

.topic 844
マスタパスワードが使用された場合、テンプレートで指定された権限は適用されません。

.topic 845
クリックすると、テンプレートの印刷が制限されます。

.topic 846
クリックすると、テンプレートの変更が制限されます。

.topic 847
クリックすると、内容のコピーまたは抽出が制限されます。

.topic 848
クリックすると、コメントとフォームフィールドの追加または変更が制限されます。

.topic 861
デジタル署名で使用するプロファイルを選択します。

.topic 862
デジタル署名のプロファイルのパスワードを入力します。

.topic 863
クリックしてログインします。

.topic 864
クリックして新規ユーザプロファイルを作成します。

.topic 865
ユーザプロファイルの名前を入力します。

.topic 866
会社名を入力します。

.topic 867
部門名を入力します。

.topic 868
国名を選択または入力します。

.topic 869
パスワードを入力します。

.topic 870
パスワードを確認します。

.topic 871
証明書の名前を表示します。

.topic 872
確認のためにパスワードを入力します。

.topic 873
このテンプレートに署名する理由を選択または入力します。

.topic 874
署名地を入力します。

.topic 875
連絡先情報を入力します。

.topic 876
署名の外観を選択します。

.topic 877
既定の外観の設定をプレビューします。

.topic 878
選択されている外観の設定を編集します。

.topic 879
新しい署名の外観を作成します。

.topic 880
クリックしてテンプレートに署名します。

.topic 881
外観の名前が「既定値」以外であれば、編集できます。

.topic 882
外観の名前が「既定値」以外であれば、署名の名前を有効または無効にできます。

.topic 883
外観の名前が「既定値」以外であれば、署名の署名地を有効または無効にできます。

.topic 884
外観の名前が「既定値」以外であれば、署名の識別名を有効または無効にできます。

.topic 885
外観の名前が「既定値」以外であれば、署名の接頭語ラベルを有効または無効にできます。

.topic 886
外観の名前が「既定値」以外であれば、署名の署名日を有効または無効にできます。

.topic 887
外観の名前が「既定値」以外であれば、署名の理由を有効または無効にできます。

.topic 888
外観の名前が「既定値」以外であれば、署名の背景画像を表示または非表示にできます。

.topic 889
外観の名前が「既定値」以外であれば、デジタル署名の画像を選択できます。

.topic 908
The Current property is used to select only the current eForm when Saving.

.topic 909
保存時にすべての電子フォームを選択します。

.topic 911
ファイル内のテキストを分割する「区切り記号付き」は、「フィールド区切り記号」または「文字列の引用符」を使用して指定できます。

.topic 912
フィールドを区切るフィールド区切り記号を選択します。

.topic 913
引用符で囲まれたデータは、フィールドデータとして処理されます。 例： 「フィールド区切り記号」が,で、「文字列の引用符」が"の場合、 A,"B,C",D   と入力すると、出力は以下のようになります。 A B,C D

.topic 914
ファイルの区切り記号を固定の長さで指定します。これは「区切り位置設定」を使用して指定できます。

.topic 915
データの先頭行を無視します。

.topic 920
テキストクエリビルダにテーブルフィールドを追加します。

.topic 921
テキストクエリビルダにすべてのフィールドを追加します。

.topic 929
テキストの最初の行のデータをフィールド名として使用します。

.topic 935
クリックすると、フィールドの長さを指定します。

.topic 936
クリックすると、フィールドを上に移動します。

.topic 937
クリックすると、フィールドを下に移動します。

.topic 938
クリックすると、選択されたフィールドを削除します。

.topic 970
レイアウトの用紙サイズを選択します。

.topic 971
用紙サイズの高さを表示します。レイアウトの用紙サイズで「Custom」を選択した場合、この高さを入力することができます。

.topic 972
用紙サイズの幅を表示します。レイアウトの用紙サイズで「Custom」を選択した場合、この幅を入力することができます。

.topic 973
「用紙サイズ」の「高さ」と「幅」を測る単位を「cm(センチメートル)」または「inch(インチ)」から選択します。

.topic 974
レイアウトの「用紙の向き」を「縦」から「横」に変更します。

.topic 975
レイアウトの「用紙の向き」を「横」から「縦」に変更します。

.topic 976
新たに追加するレイアウトに「用紙サイズ」と「用紙の向き」の設定を行なう「Layout」タブを追加します。

.topic 977
現在選択中の「Layout」タブを削除します。

.topic 978
再度「新規テンプレート」オプションを選択したときに「新規テンプレート」ダイアログが開くのを回避します。これは「オプション」ダイアログにある「「ファイル」メニューの「新規テンプレート」を選択したときにダイアログを開く」オプションでも設定可能です。

.topic 979
選択を決定します。

.topic 980
選択をキャンセルします。

.topic 981
「用紙サイズ」と「用紙の向き」の設定を行なう「Layout」タブを選択します。

.topic 982
サンプルHTMLページで、OXV形式のドキュメントをリクエストするためのオプションを生成します。

.topic 983
ドキュメントをFAX送信する際にApeosPortを使用することができます。

.topic 984
ドキュメントをFAX送信する際にimagioを使用することができます。

.topic 268435456
内容


OPRO X Browser (OXB) とは

OPRO X Browser (略称 OXB) は、OPRO X Server (略称 OXS) で生成された OXR ドキュメント(OPRO XML Report, 拡張子 .oxr)、OPR ドキュメント(OPRO Print Report, 拡張子 .opr)、OFD ファイル(OPRO Form Data, 拡張子 .ofd)等のドキュメントフォーマットを閲覧・印刷するためのブラウザアプリケーションです。

ユーザがインターネット経由で OXS にリクエストをかけると、生成されたドキュメント(電子帳票)がクライアントにダウンロードされ、OXB によって自動的に開かれます。


OPRO X Server

OPRO X Server (略称 OXS) は、ウェブ対応のオンライン レポートおよび印刷ソリューションであり、開発サーバ、実行サーバ、開発ツールで構成されています。パーソナル コンピュータやモバイル デバイスからリアルタイムの情報をリクエストし、指定した場所にFAXやメールで送信したり、指定した場所で印刷することができます。


日時の表示形式

日付と時刻の「表示形式」プロパティは、日付または時刻の適用されたDate Timeコンポーネント、および、「Database」タイプの適用されたLabelコンポーネントの日時の表示形式をカスタマイズするために使われます。

指定子 | 表示形式
d | 日を、先頭にゼロを付けない数字で表示します(1-31)。
dd | 日を、先頭にゼロを付けた数字で表示します(01-31)。
ddd | 曜日を省略形で表示します(Sun-Sat)。
dddd | 曜日を完全な名前で表示します(Sunday-Saturday)。
D | 日を年間の通算日数で表示します(123)。
DDD | サーバが日本語環境にインストールされている場合に、曜日を日本語の省略形で表示します。例：(日-土)
DDDD | サーバが日本語環境にインストールされている場合に、曜日を日本語の完全な名前で表示します。例：(日曜日-土曜日)
M | 月を、先頭にゼロを付けない数字で表示します(1-12)。
MM | 月を、先頭にゼロを付けた数字で表示します(01-12)。
MMM | 月を省略形で表示します(Jan-Dec)。
MMMM | 月を完全な名前で表示します(January-December)。
yy | 年を二桁の数字で表示します(00-99)。
yyyy | 年を四桁の数字で表示します(0000-9999)。
h | 時間を、先頭にゼロを付けない数字で表示します(0-12)。
hh | 時間を、先頭にゼロを付けた数字で表示します(00-12)。
H | 時間を、先頭にゼロを付けない数字で表示します(0-23)。
HH | 時間を、先頭にゼロを付けた数字で表示します(00-23)。
m | 分を、先頭にゼロを付けない数字で表示します(0-59)。
mm | 分を、先頭にゼロを付けた数字で表示します(00-59)。
s | 秒を、先頭にゼロを付けない数字で表示します(0-59)。
ss | 秒を、先頭にゼロを付けた数字で表示します(00-59)。
S | ミリ秒 (718)。
a | 午前/午後のマーカ(AM)。
E | 曜日を表示します。例：Tuesday
F | 月の曜日を表示します。
G | 紀元(西暦、または、AD)。
w | 週を年間の通算週数で表示します(27)。
W | 週を月間の通算週数で表示します(2)。
k | 時間を24時間制で表示します(1-24)。
K | 時間を12時間制で表示します(0-11)。
z | 一般的なタイムゾーン(GMT+09:00、または、JST)。
Z | RFC 822 タイムゾーン (+0900)。
' | これで囲んだテキストはそのまま表示されます。
" | 一重引用符を表示します。
gge | 日本語の年号を表示します。例：gge'年'MM'月'dd'日' -> 平成12年2月8日。

例

参照：数値の表示形式


DBExecuteエディタ

DBExecuteエディタは、DBExecuteコンポーネントにスクリプトを追加／削除／修正するのに使います。スクリプトはコンポーネントに何行でも記述することができます。

「データベース ツリー」
クエリビルダ同様、すべてのデータベースを表示します。
「＋追加」
コンポーネントにスクリプトを追加します。
「×削除」
コンポーネントからスクリプトを削除します。
「スクリプト一覧」
コンポーネントに設定したすべてのスクリプトを一覧表示します。
「適用」
スクリプト一覧にスクリプトを追加します。
「キャンセル」
スクリプトをキャンセルします。
{USERINPUT}
テンプレート実行中に、ユーザ入力値を指定できます。実行するとダイアログが現れ、ユーザ入力値を求められます。
「OK」ボタン
設定を適用して、DBExecuteエディタを閉じます。
「キャンセル」ボタン
設定を適用せずに、DBExecuteエディタを閉じます。

スクリプトを追加するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「スクリプト／編集」をクリック、またはテンプレート上に配置したコンポーネントをダブルクリックします。
  3. 「OSMSログイン」ダイアログでユーザ名とパスワードを入力し、「ログイン」ボタンをクリックします。
  4. スクリプトを追加するデータベースを選択します。
  5. 「追加」をクリックし、データベースに対するスクリプトを入力します。
  6. 「適用」をクリックします。

※エディタにスクリプトを追加する前に、Databaseを選択してください。


数値の表示形式

数値の表示形式は、コンポーネントに適用する数値の表示形式をカスタマイズするのに使用します。

指定子 | 表示形式
0 | 数字のプレースホルダ。表示形式を指定する値の、表示形式文字列で「0」が表示されている位置に数字がある場合は、その数字が出力文字列にコピーされます。それ以外の場合は、出力文字列の該当する位置に「0」が入ります。
# | 数字のプレースホルダ。表示形式を指定する値の、表示形式文字列で「#」が表示されている位置に数字がある場合は、その数字が出力文字列にコピーされます。それ以外の場合は、出力文字列の該当する位置には何も入りません。
. | 小数点。表示形式文字列の最初の「.」は、表示形式を指定する値の小数区切り記号の位置を特定します。
, | 桁区切り記号。表示形式文字列に一つまたは複数の「,」が含まれている場合、出力文字列では、小数点の左側に区切り記号が表示されます。
- | マイナス記号。
; | プラスのパターンとマイナスのパターンを区切ります。
% | 100を掛けてパーセンテージで表示します。
' | 接頭語または接尾語で特殊文字の引用に使用します。たとえば、表示形式を「'#'#」と指定すると、123は「#123」と表示されます。一重引用符自体を作成する場合は、「# o''clock」のように、二つ連続して使用します。

例

参照：日時の表示形式


用紙サイズと用紙の向き

  • pxは小数点以下切り捨て、cm/inchは小数第2位以下切り捨てです。
  • 「用紙サイズ」が「Custom」の場合、「用紙の向き」は「縦」のみです。
用紙サイズ | 用紙の向き | 高さ px | 幅 px | 高さ cm | 幅 cm | 高さ inch | 幅 inch
A3 | 縦 | 1587 | 1122 | 42.0 | 29.7 | 16.5 | 11.7
A3 | 横 | 1122 | 1587 | 29.7 | 42.0 | 11.7 | 16.5
A4 | 縦 | 1122 | 793 | 29.7 | 21.0 | 11.7 | 8.3
A4 | 横 | 793 | 1122 | 21.0 | 29.7 | 8.3 | 11.7
A4Small | 縦 | 1122 | 793 | 29.7 | 21.0 | 11.7 | 8.3
A4Small | 横 | 793 | 1122 | 21.0 | 29.7 | 8.3 | 11.7
A5 | 縦 | 793 | 559 | 21.0 | 14.8 | 8.3 | 5.8
A5 | 横 | 559 | 793 | 14.8 | 21.0 | 5.8 | 8.3
B4 (ISO) | 縦 | 1334 | 944 | 35.3 | 25.0 | 13.9 | 9.8
B4 (ISO) | 横 | 944 | 1334 | 25.0 | 35.3 | 9.8 | 13.9
B4 (JIS) | 縦 | 1375 | 972 | 36.3 | 25.7 | 14.3 | 10.1
B4 (JIS) | 横 | 972 | 1375 | 25.7 | 36.3 | 10.1 | 14.3
B5 (ISO) | 縦 | 944 | 665 | 25.0 | 17.6 | 9.8 | 6.9
B5 (ISO) | 横 | 665 | 944 | 17.6 | 25.0 | 6.9 | 9.8
B5 (JIS) | 縦 | 973 | 687 | 25.7 | 18.2 | 10.1 | 7.2
B5 (JIS) | 横 | 687 | 973 | 18.2 | 25.7 | 7.2 | 10.1
Default | 縦 | 1056 | 816 | 27.9 | 21.6 | 11.0 | 8.5
Default | 横 | 816 | 1056 | 21.6 | 27.9 | 8.5 | 11.0
Env10 | 縦 | 912 | 396 | 24.1 | 10.5 | 9.5 | 4.1
Env10 | 横 | 396 | 912 | 10.5 | 24.1 | 4.1 | 9.5
Env11 | 縦 | 996 | 432 | 26.4 | 11.4 | 10.4 | 4.5
Env11 | 横 | 432 | 996 | 11.4 | 26.4 | 4.5 | 10.4
Env12 | 縦 | 1056 | 456 | 27.9 | 12.1 | 11.0 | 4.8
Env12 | 横 | 456 | 1056 | 12.1 | 27.9 | 4.8 | 11.0
Env14 | 縦 | 1104 | 480 | 29.2 | 12.7 | 11.5 | 5.0
Env14 | 横 | 480 | 1104 | 12.7 | 29.2 | 5.0 | 11.5
Env9 | 縦 | 852 | 372 | 22.5 | 9.8 | 8.9 | 3.9
Env9 | 横 | 372 | 852 | 9.8 | 22.5 | 3.9 | 8.9
Executive | 縦 | 1008 | 696 | 26.7 | 18.4 | 10.5 | 7.3
Executive | 横 | 696 | 1008 | 18.4 | 26.7 | 7.3 | 10.5
Folio | 縦 | 1248 | 816 | 33.0 | 21.6 | 13.0 | 8.5
Folio | 横 | 816 | 1248 | 21.6 | 33.0 | 8.5 | 13.0
Ledger | 縦 | 1056 | 1632 | 27.9 | 43.2 | 11.0 | 17.0
Ledger | 横 | 1632 | 1056 | 43.2 | 27.9 | 17.0 | 11.0
Legal | 縦 | 1344 | 816 | 35.6 | 21.6 | 14.0 | 8.5
Legal | 横 | 816 | 1344 | 21.6 | 35.6 | 8.5 | 14.0
Letter | 縦 | 1056 | 816 | 27.9 | 21.6 | 11.0 | 8.5
Letter | 横 | 816 | 1056 | 21.6 | 27.9 | 8.5 | 11.0
LetterSmall | 縦 | 1056 | 816 | 27.9 | 21.6 | 11.0 | 8.5
LetterSmall | 横 | 816 | 1056 | 21.6 | 27.9 | 8.5 | 11.0
Statement | 縦 | 816 | 528 | 21.6 | 14.0 | 8.5 | 5.5
Statement | 横 | 528 | 816 | 14.0 | 21.6 | 5.5 | 8.5
Tabloid | 縦 | 1632 | 1056 | 43.2 | 27.9 | 17.0 | 11.0
Tabloid | 横 | 1056 | 1632 | 27.9 | 43.2 | 11.0 | 17.0
Custom | (最大) | 2116 | 2116 | 56.0 | 56.0 | 22.0 | 22.0
Custom | (最小) | 3 | 3 | 0.1 | 0.1 | 0.1 | 0.1


「外観」プロパティ

「タイプ」

「タイプ」プロパティで TimeStamp の形状を「丸型」か「角型」に変更することができます。

「丸型」

「角型」

TimeStamp の「タイプ」を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「外観／タイプ」で、必要な形状を選択します。

※この機能は PDF 形式のみで使用可能です。

「背景」

「背景」プロパティでは、TimeStamp の背景スタイルを指定することができます。

指定可能な背景スタイル
「透明」 | TimeStamp 画像の背景部分を透明にします。
「半透明」 | 背景部分を透明に、TimeStamp 画像を半透明にします。
「不透明」 | TimeStamp 画像を不透明にします。

TimeStamp の「背景」を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「外観／背景」で、必要なスタイルを選択します。

※この機能は PDF 形式のみで使用可能です。

「リンク」

TimeStamp にアマノタイムビジネス社( http://www.e-timing.ne.jp/tsa/index_product_info.html )へのリンクを表示します。

TimeStamp にリンクを作成するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「外観／リンク」チェックボックスにチェックを入れます。

※この機能は PDF 形式のみで使用可能です。

「出力形式」

「日付」「時刻」

TimeStamp の日付と時刻の出力形式を「日付」と「時刻」のプロパティで指定します。

日付と時刻の出力形式を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「外観／日付」または「外観／時刻」で、必要な出力形式を指定します。

例：

日付の出力形式

出力形式 | 出力結果
yyyy/MM/dd | 2006/12/01
yyyy/MMM/dd | 2006/Dec/01
MMM/dd/yyyy | Dec/01/2006
dd/MMM/yyyy | 01/Dec/2006
yyyy.MM.dd | 2006.12.01
yyyy.MMM.dd | 2006.Dec.01
MMM.dd.yyyy | Dec.01.2006
dd.MMM.yyyy | 01.Dec.2006
yyyy-MM-dd | 2006-Dec-01
yyyy-MMM-dd | 2006-Dec-01
MMM-dd-yyyy | Dec-01-2006
dd-MMM-yyyy | 01-Dec-2006
yyyy MMM dd | 2006 Dec 01
MMM dd,yyyy | Dec 01,2006
dd MMM yyyy | 1 Dec 2006

時刻の出力形式

出力形式 | 出力結果
HH:mm | 15:10
KK:mm | 03:10 PM
HH:mm:ss | 15:10:18
KK:mm:ss | 03:10:18 PM

※この機能は PDF 形式のみで使用可能です。


「外観」プロパティ

「テキストの色」

「テキストの色」プロパティは、チャートの文字色を指定するのに使用します。

「背景色」

「背景色」プロパティは、チャート全体の背景色を指定するのに使用します。

「プロットの背景色」

「プロットの背景色」プロパティは、チャートのプロット部分の背景色を指定するのに使用します。

「プロットを転置する」

「プロットを転置する」プロパティは、チャートのプロット部分を縦向きにするか横向きにするかを選択します。横向きにする場合にチェックをオンにします。

「回転」

「回転」

「回転」プロパティは、チャートの画像を 0, 90, 180, 270 度、時計回りに回転させるのに使用します。

「サイズ」

「解像度」

「解像度」プロパティは、コンポーネントの大きさに対するチャートの画像の大きさの比を指定します。コンポーネントの大きさと同じドット数の画像の場合は「96 DPI」です。大きい値を指定すると印刷時に鮮明な画像を得られますが、パフォーマンスが悪くなります。

「タイトル」

「タイトル」

「タイトル」プロパティは、チャートのタイトルを指定するのに使用します。

「配置」

「配置」プロパティは、チャートのタイトルを配置する場所を指定するのに使用します。

「グリッド」

「定義域のグリッド線を表示する」

「定義域のグリッド線を表示する」プロパティは、定義域のグリッド線を表示する場合にチェックをオンにします。

「値域のグリッド線を表示する」

「値域のグリッド線を表示する」プロパティは、値域のグリッド線を表示する場合にチェックをオンにします。


「条件付フォーマット」プロパティ

「追加」

「追加」プロパティは、コンポーネントに条件を指定する CONTENT を追加するのに使用します。

CONTENT を追加するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックします。

条件を指定するには

静的タイプの Label で、条件に静的データを使用する場合

  1. 「Label」コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックします。
  3. 「条件付フォーマット／演算子」から、必要な演算子( 例：等しい )を選択します。
  4. 「条件付フォーマット／値2」に、必要なデータ( 例：OPRO )を入力します。
  5. 「条件付フォーマット」のプロパティ( 例：可視、透過、フォント、サイズ、色、取り消し線、太字、下線、イタリック、配置、背景色、値を変更する )を変更して、条件を満たした場合の効果が示されるようにしてください。
  6. 「内容／内容」に、必要なデータ( 例：OPRO )を入力します。
  7. 「プレビュー」ボタン [image] をクリックします。
  8. 条件が満たされていれば、Label が、変更したプロパティ通りに変化する様子を見ることができるはずです。
  9. 次に、「内容／内容」に別のデータ( 例：OPRO以外 )を入力して「プレビュー」ボタン [image] をクリックします。
  10. すると、Lable には、変更したプロパティが適用されません。

静的タイプの Label で、条件にデータベースを使用する場合

  1. テンプレートに「Dataset」コンポーネントを配置し、データベース( 例：Employeeデータベース )をリンクします。
  2. 「Label」コンポーネントをテンプレートに配置し、F11キーを押してプロパティを表示します。
  3. 「条件付フォーマット／追加」をクリックします。
  4. 「条件付フォーマット／値1」からデータベース フィールド( 例：EmployeeデータベースのSalaryフィールド等 )を選択します。
  5. 「条件付フォーマット／演算子」から演算子( 例：より大きい )を選択します。
  6. 「条件付フォーマット／値2」に、必要なデータ( 例：5000 )を入力します。
  7. CONTENT にさらに別の条件を追加する場合は、「条件付フォーマット／追加」をクリックし、手順5から7までを繰り返します。
  8. 「条件付フォーマット」が条件を満たした場合、効果が示されるようにプロパティを変更します。
  9. 「プレビュー」ボタン [image] をクリックします。
  10. 最初のレコードが条件を満たす場合、手順9で Label に行なったプロパティの変更が適用されます。

データベースタイプの Label で、条件にデータベースを使用する場合

  1. テンプレートに「Dataset」コンポーネントを配置し、データベース( 例：Employeeデータベース )をリンクします。
  2. Dataset の「フィールド」プロパティからフィールド( 例：Salaryフィールド )をテンプレートにドラッグ＆ドロップし、Label として配置します。
  3. 配置した「Label」コンポーネントを選択し、F11キーを押してプロパティを表示します。
  4. 「条件付フォーマット／追加」をクリックします。
  5. 「条件付フォーマット／演算子」から演算子( 例：より大きい )を選択します。
  6. 「条件付フォーマット／値2」に、必要なデータ( 例：5000 )を入力します。
  7. CONTENT にさらに別の条件を追加する場合は、「条件付フォーマット／追加」をクリックし、手順5から7までを繰り返します。
  8. 「条件付フォーマット」が条件を満たした場合、効果が示されるようにプロパティを変更します。
  9. 「プレビュー」ボタン [image] をクリックします。
  10. 条件を満たすレコードがある場合、手順9で Label に行なったプロパティの変更が適用されます。

「削除」

「削除」プロパティは、コンポーネントから CONTENT を削除するのに使用します。

CONTENT を削除するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 削除する内容を選択し、「条件付フォーマット／削除」をクリックします。

「条件の追加」

「条件の追加」プロパティは、「条件付フォーマット」の CONTENT の条件を追加するのに使用します。CONTENT の条件はいくつでも追加することができます。

CONTENT に条件を追加するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックします。
  3. 「条件付フォーマット／条件の追加」をクリックします。
  4. 同じ CONTENT に条件を追加して、複数条件にします。

「条件の削除」

「条件の削除」プロパティは、「条件付フォーマット」プロパティの CONTENT に追加した複数の条件を削除するのに使用します。

CONTENT から条件を削除するには

  1. 条件内容の設定されたテンプレートを開きます。
  2. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  3. 削除する条件内容にチェックマークを入れて選択し、「条件付フォーマット／条件の削除」をクリックします。

※該当する条件をチェックしないと、条件の削除はできません。

「すべてクリア」

「すべてクリア」プロパティは、条件の内容のすべての変更をクリアし、デフォルト値に戻すために使用します。

すべてクリアするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 削除する条件内容にチェックマークを入れて選択し、「条件付フォーマット／条件の削除」をクリックします。
  3. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  4. 「条件付フォーマット／すべてクリア」をクリックします。これでデフォルトの設定にリセットされます。

※「すべてクリア」を選択するには、「すべて削除にチェック」をクリックします。

「値1」「演算子」「値2」

「条件付フォーマット」では、「値1」と「値2」に指定された値を「演算子」を使って比較することができます。また、Dataset のフィールドを「値1」「値2」に指定する値として使うこともできます。

「値1」「演算子」「値2」を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックします。
  3. 「条件付フォーマット／演算子」から、必要なオプションを選択します( 「等しい」等 )。
  4. 「条件付フォーマット／値1」に必要なコンポーネントを選択します( 「Label1」等 )。
  5. 「条件付フォーマット／値2」に必要なコンポーネントを選択します( 「OPRO」等 )。

※使用可能な内容がある場合にのみ選択できます。

「可視」

「可視」プロパティは、選択されたコンポーネントを可視、または、不可視にするのに使用します。これは、「条件付フォーマット」の条件が満たされていた場合に適用されます。

「条件付フォーマット」でコンポーネントの可視／不可視を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. コンポーネントを可視または不可視に指定するのに「条件付フォーマット／可視」をクリックします。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「透過」

「透過」プロパティは、コンポーネントの背景を透明にするのに使用します。これは、「条件付フォーマット」の条件が満たされていた場合に適用されます。

「条件付フォーマット」でコンポーネントを「透過」に指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. コンポーネントを透明にするのに「条件付フォーマット／透過」をクリックします。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「フォント」

「フォント」プロパティは、「条件付フォーマット」適用時に、フォントのタイプを選択するのに使用します。

フォントの書体を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／フォント」から使用するフォントを選択します。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「文字飾り」

「サイズ」

フォントのサイズを指定します。

フォントのサイズを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／文字飾り／サイズ」から使用するサイズを選択します。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「色」

フォントの色を指定します。

フォントの色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／文字飾り／色」から使用する色を選択します。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「取り消し線」

取り消し線の表示／非表示を指定します。

取り消し線を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／文字飾り／取り消し線」をクリックします。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「太字」

太字にするかどうかを指定します。

太字を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／文字飾り／太字」をクリックします。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「下線」

下線の表示／非表示を指定します。

下線を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／文字飾り／下線」をクリックします。

「イタリック」

イタリックにするかどうかを指定します。

イタリックを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／文字飾り／イタリック」をクリックします。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「ユーザ外字」

ユーザ外字を使用するかどうかを指定します。

ユーザ外字を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／文字飾り／ユーザ外字」をクリックします。

※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

「配置」

「配置」プロパティは、「条件付フォーマット」適用時に、コンポーネントの範囲内に表示するテキスト配置を指定するのに使用されます。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／配置」領域で、画像を配置したい位値をクリックします。

「背景色」

「背景色」プロパティは、「条件付フォーマット」適用時に、コンポーネントの背景色を選択するのに使用します。

背景色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「条件付フォーマット／追加」をクリックし、条件を指定します。
  3. 「条件付フォーマット／背景色」から使用する色を選択します。

「値を変更する」

「値を変更する」プロパティは、「条件付フォーマット」の条件が満たされたときに表示されるデータを入力するのに使用します。「値を変更する」ドロップダウンに値を入力するには、「値を変更する」チェックボックスをチェックする必要があります。「値を変更する」プロパティは、ドロップダウンメニューから、テンプレートに配置されたDataset、または、TextDatasetからデータベースフィールドを選択することもできます。フィールドを選択するには、Datasetをダブルクリックしてツリー展開し、「値を変更する」ドロップダウンから必要なフィールドをダブルクリックします。これで、「条件付フォーマット」の条件が満たされたとき、選択されたフィールドの値がコンポーネントに表示されます。

「値を変更する」にデータベースフィールドの値を表示するには

  1. Dataset をテンプレートに配置し、クエリビルダを通じてデータベースを追加します。

  2. クエリビルダでテーブルおよびフィールド( 例：Employeeテーブルとそのすべてのフィールド )を選択します。
  3. 「Dataset」コンポーネントの「フィールド」プロパティからフィールド( 例：Employee ID, Employee Name, Salary等のフィールド )をテンプレートにドラッグ＆ドロップされたフィールドは Label として配置されます。

  4. 「Label」コンポーネント( 例：テンプレートにある Salary の Label )を一つ選択し、F11キーを押し、プロパティを設定します。
  5. 「条件付フォーマット／追加」をクリックします。

  6. 「条件付フォーマット／演算子」から演算子( 例：より大きい )を選択します。

  7. 「条件付フォーマット／値2」に、必要なデータ( 例：5000 )を入力します。

  8. 「条件付フォーマット」が条件を満たした場合、効果が示されるようにプロパティを変更します。
  9. 「条件付フォーマット／背景色」プロパティで、背景色を黄色に変更します。
  10. 「条件付フォーマット／文字飾り／太字」で、太字にします。

  11. 「条件付フォーマット／値を変更する」チェックボックスをチェックして、値の入力ができる状態にします。
  12. 「値を変更する」ドロップダウンメニューから、表示する別の Dataset のフィールド( 例：Employee Name )を選択します。

  13. 「プレビュー」ボタン [image] をクリックします。
  14. 変更された Label ( 例：SalaryのLabel )の内容が、設定した条件に対応して、「値を変更する」ドロップダウンで指定されたフィールド( 例：Jobフィールド )の値に替わるのを確認できるはずです。

    15. 「値を変更する」に静的な値を指定するには

    1. テンプレートに「Label」コンポーネントを配置します。

    2. 「Label」コンポーネントを選択し、F11キーを押してプロパティを表示します。
    3. 「条件付フォーマット／追加」をクリックします。

    4. 「条件付フォーマット／演算子」から演算子を選択します。

    5. 「条件付フォーマット／値2」に、必要なデータ( 例：OPRO )を入力します。

    6. 「内容／内容」プロパティに「条件付フォーマット／値2」のデータと同じ値( 例：OPRO )を入力します。

    7. 「条件付フォーマット」が条件を満たした場合、効果が示されるようにプロパティを変更します。
    8. 「条件付フォーマット／背景色」プロパティで、背景色を黄色に変更します。
    9. 「条件付フォーマット／文字飾り／太字」で、太字にします。

    10. 「値を変更する」ドロップダウンにデータ( 例：Japan )を入力します。「条件付フォーマット」の条件が満たされると、このデータが表示されます。

    11. 「プレビュー」ボタン [image] をクリックします。
    12. Label に表示される値が太字になり、背景色が黄色になり、内容が「値を変更する」ドロップダウンに指定した値( 例：Japan )になるのを確認できるはずです。

      ※「Label」コンポーネントが条件を満たしていて、このコンポーネントが条件に使用されている場合にのみ機能します。

      「リセット」

      「条件付フォーマット」のプロパティを初期値に戻します。

      リセットするには

      1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
      2. 「条件付フォーマット／追加」をクリックします。
      3. 「条件付フォーマット」のプロパティを変更します。
      4. 「条件付フォーマット／リセット」をクリックします。


「カスタム」プロパティ

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「背景色」

コンポーネントの背景色を指定します。

背景色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／色」から使用する色を選択します。

「縦書き」

内容を縦書きで表示します。

テキストを縦書きで表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／縦書き」をクリックします。

「スタイル」

「自動サイズ」

コンポーネントのサイズを、そこに表示される内容に合わせて自動的に変更するかどうかを指定します。

自動サイズを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／自動サイズ」をクリックします。

「折り返し」

「折り返し」プロパティは、コンポーネントの中に表示されるテキストをコンポーネントのサイズに合わせて改行するのに使用します。「折り返し」プロパティがチェックされていると、コンポーネントの右端で表示しきれない単語は、単語の手前部分で改行され、分断されずに表示されるようになります。

折り返しを使用するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／折り返し」をクリックします。

「均等」

コンポーネント内の文字間隔を拡大または縮小して、等間隔に並べます。

均等を使用するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／均等」をクリックします。

「縮小して全体を表示」

「縮小して全体を表示」プロパティは、コンポーネントの内容をコンポーネントサイズに応じて縮小し、全体を表示できるようにするのに使用します。

コンテンツのサイズ変更を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／縮小して全体を表示」をクリックします。

「文字幅と間隔」

「行間隔」

テキストの行間隔を指定します。

行間隔を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 単位タイプを選択し、「カスタム／行間隔」テキストボックスに値を直接入力するか、スピナーコントロールをクリックして値を増減し、行間隔を指定します。

単位タイプは、ピクセル(Px)、インチ(In)、センチメートル(Cm)、ポイント(Pt)を指定することができます。

「文字間隔」

テキストの文字間隔を指定します。

文字間隔を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／文字間隔」テキストボックスに値を入力するか、またはスピナーコントロールをクリックして値を指定し、単位タイプを選択します。

「タブ幅」

文字間のタブ幅を指定します。

タブ幅を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／タブ幅」テキストボックスに値を直接入力するか、スピナーコントロールをクリックして値を指定し、単位タイプを選択します。

単位タイプは、ピクセル(Px)、インチ(In)、センチメートル(Cm)、ポイント(Pt)を指定することができます。

「外観」

「自動サイズ」

「自動サイズ」コンポーネントは、表示される内容に合わせてコンポーネントサイズを自動的に変更するかどうかを指定するのに使用します。

自動サイズを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／自動サイズ」をクリックします。

「枠に合わせて表示」

「枠に合わせて表示」プロパティは、コンポーネントの水平サイズおよび垂直サイズに対応して、内容をリサイズするのに使用します。

画像を枠に合わせて表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／枠に合わせて表示」をクリックします。

※枠に合わせて表示すると、画像の品質は劣化します。

「縦横比を固定して伸縮」

「縦横比を固定して伸縮」プロパティは、画像の元の高さと幅の比率を維持したまま、画像をリサイズするのに使用します。

縦横比を固定して画像を伸縮するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／縦横比を固定して伸縮」チェックオプションを有効にします。
  3. 画像のふちをドラッグして、リサイズします。

「すべてのページを出力」

「すべてのページを出力」プロパティは、マルチページ TIFF 画像のすべてのページを表示するのに使用します。このオプションを有効にすると、マルチページ TIFF の各ページをドキュメント1ページごとに生成・出力します。

「すべてのページを出力」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／すべてのページを出力」チェックオプションを有効にします。

※「Image」コンポーネントがDataset、または、HorizontalDatasetTableに置かれたとき、または別の画像形式(例: GIF、JPEG等)を選択したとき、「すべてのページを出力」プロパティは使用不可になります。

「タイプ」

「タイプ」プロパティは、図形タイプを「RoundRect」「Rectangle」「Ellipse」から選択し、変更できます。

図形タイプを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／タイプ」から使用するタイプを選択します。

※「角の丸み調整」は、タイプとして「RoundRect」を選択している場合に限り使用できます。

「境界」

「サイズ」

Shape の境界線の太さを指定します。

境界線の太さを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／サイズ」テキストボックスに値を入力するか、またはスピナーコントロールをクリックして値を指定します。

「スタイル」

「スタイル」プロパティは、コンポーネントの境界のスタイルを指定します。使用できるスタイルは、Solid, Dash, Dot, DashDot, DashDotDot です。

スタイルを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／スタイル」で、使用するスタイルをクリックします。

※「Shape」コンポーネントの境界のサイズが1より大きいときは、スタイルを変更することができません。

「色」

「色」プロパティは、Shape の境界色を指定します。

境界色を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／境界／色」から使用する色を選択します。

「背景」

「色」

「色」プロパティは、Shape の背景色を変更します。

背景色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／背景／色」から使用する色を選択します。

「角の丸み調整」

「角の丸み調整」プロパティは、Shape の角の丸みを調整するのに使用します。

角の丸みを調整するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／角の丸み調整」テキストボックスに値を入力するか、スピナーコントロールをクリックして値を指定します。

「対称にする」

「対称にする」プロパティは、Shape の4つの角の丸みを同時に調整するのに使用します。

4つの角の丸みを同時調整するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／角の丸み調整／対称にする」をクリックします。
  3. 「カスタム／角の丸み調整」テキストボックスに値を入力するか、スピナーコントロールをクリックして値を指定します。

「サイズ」

「サイズ」プロパティは、線の太さを変更するのに使用します。

サイズを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／サイズ」テキストボックスに値を入力するか、スピナーコントロールをクリックして値を指定します。

「色」

「色」プロパティは、線の色を選択するのに使用します。

線の色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／色」から使用する色を選択します。

「スタイル」

「スタイル」プロパティは、様々な線の種類を選択するのに使用します。使用できる線の種類は、Solid, Dash, Dot, DashDot, DashDotDot です。

スタイルを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／スタイル」で、使用するスタイルをクリックします。

※PDF の制限により、DashDot と DashDotDot の線は、PDF 出力では正しく表示されません。

「向き」

「向き」プロパティは６方向の線( 上辺、下辺、左辺、右辺、右上から左下への対角線、左上から右下への対角線 )を描くのに使用します。

ラインの向き
 | コンポーネントの左辺に線をひきます。
 | コンポーネントの右辺に線をひきます。
 | コンポーネントの上辺に線をひきます。
 | コンポーネントの下辺に線をひきます。
 | 右上から左下への対角線をひきます。
 | 左上から右下への対角線をひきます。

線は複数同時に指定して描くことができます。

例1:

例2:

※最低でも一つ以上の方向を選択する必要があります。

線の「向き」を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／向き」から、適切な方向ボタンをクリックします。

「バンド数」

「バンド数」プロパティは、テーブルのバンド数を指定します。

バンド数を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／バンド数」テキストボックスに値を入力して「OK」ボタンをクリックするか、スピナーコントロールをクリックして値を指定します。

「カラム数」

「カラム数」プロパティは、テーブルのカラム数を指定します。

カラム数を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／カラム数」テキストボックスに値を入力して「OK」ボタンをクリックするか、スピナーコントロールをクリックして値を指定します。

「バンドを等幅に分割」

「バンドを等幅に分割」プロパティを使うと、テーブルでバンドを等幅に分割できます。

バンドを等幅に分割するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／バンドを等幅に分割」をクリックします。

「カラムを等幅に分割」

「カラムを等幅に分割」プロパティを使うと、テーブルでカラムを等幅に分割できます。

カラムを等幅に分割するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／カラムを等幅に分割」をクリックします。

「外観」

「背景色」

「背景色」プロパティは、コンポーネントの背景色を指定します。

背景色を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／背景色」から使用する色を選択します。

「アクション」

「URL」

「URL」プロパティは、リクエスト方法で使われるサーブレット/CGIアドレスを指定するのに使用します。

URLを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／URL」にサーブレット/CGIアドレスを入力します。

「メソッド」

「メソッド」プロパティは、リクエスト方法を指定するのに使用します。リクエスト方法には、「OFMS」「POST」「GET」が選択できます。

メソッドを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／メソッド」ドロップダウンから、使用するメソッドを選択します。

「内容」

送信する情報の形式を指定します。指定した形式によって、OXBドキュメント、または、フォームデータのソースファイルとなります。

「URL」
名前と値のペアになっているフォームデータは、送信中にURLエンコードされます。
「Multipart」
ファイルコンポーネントを使用して外部で読み込まれたファイルデータを、フォーム情報( URLエンコードされた名前と値のペア )と共に送信する必要がある場合に使用します。
「OFD」
フォームデータをOFD形式で送信できます。OFD とは、OXB Form Data ( ファイル拡張子「.ofd」 )の略であり、XML形式です。
「OXR」
現在開いているドキュメントを OXR 形式で送信できます。
「OPR」
現在開いているドキュメントを OPR 形式で送信できます。
「XML」
カスタマイズされた XML を送信できます。InterfaceGroup から生成される OFD ファイルは、指定されている「OFD>XML」に従って変換されます( 例えば、SOAP リクエストを生成し、「XML>OFD」に従って応答を変換することもできます )。
「FDF」
FDF ( Forms Data Format )は、Acrobat 固有のフォームデータのエンコードです。出力形式が PDF の場合にのみサポートされます。フォームデータのみを特定のサーバに送信する場合に便利です。PDF ドキュメントは、FDF 応答の値によって更新されます。
「XFDF」
XFDF は FDF と同じですが、形式が XMLベースの FDF である点が異なります。XFDF 形式を使用して送信されるフォームは、OXB でもサポートされています。
「PDF」
フォームを含む PDF ドキュメント全体が送信されます。出力形式が PDF である場合にのみサポートされます。

送信情報の形式を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／内容」ドロップダウンから、使用する形式を選択します。

「OFD/XML変換」

「OFD>XML...」

「OFD>XML」プロパティは、サーバ独自のXML変換命令を持つ XSL ファイルを選択します。
指定されたXSLファイルは、OFDファイルをサーバ、または、SOAPサーブレットに解釈されるXML形式に変換するのに必要な変換命令を持ち、OXBから外部への電子フォームリクエストを可能にします。

「OFD>XML」ボタンをクリックすると、「XSLファイルの内容」ダイアログが表示されます。

「読込」
「読込」ボタンは、「ファイルを開く」ダイアログから XSL ファイルを読み込み、「XSLファイルの内容」ダイアログのテキストエリアにその内容を表示します。
「クリア」
「クリア」ボタンは、「XSLファイルの内容」ダイアログのテキストエリアに読み込まれた内容( XSL命令 )をクリアします。
「OK」
「OK」ボタンは、「XSLファイルの内容」ダイアログのテキストエリアの内容( XSL命令 )を確定します。
「キャンセル」
「キャンセル」ボタンは、「XSLファイルの内容」ダイアログのテキストエリアの内容( XSL命 令)に加えられた変更を破棄します。

ユーザは、「XSLファイルの内容」ダイアログのテキストエリアで表示された内容( XSL命令 )を編集することができます。

※このプロパティは、「メソッド」プロパティで「POST」を、「内容」プロパティで「XML」を選択した場合に指定可能になります。

「XML>OFD...」

サーバから OXB へのレスポンスは、OXD のボタンをクリックすることで、XSL ファイルが選択され、元の OFD フォーマットへと変換します。

「属性」

「パラメータ名」

「パラメータ名」プロパティは、電子フォームを使用して値を渡すときのコンポーネントに対する名前を指定します。

パラメータ名を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／パラメータ名」を選択し、パラメータの名前を入力します。

「データ型」

「データ型」プロパティは、「内容」のデータ型を「ANY」「ALPHABET」「INTEGER」「NUMERIC」「ASCII」から選択・指定します。

データ型を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／データ型」から必要なタイプを選択します。

「最大長」

「最大長」プロパティは、入力できる最大文字数を指定します。

最大文字数を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 値を入力するか、または「カスタム／最大長」でテキストボックスのボタンをクリックして値を変更します。

※「最大長」に0を指定した場合、入力できる文字数は無制限になります。

「必須」

このオプションは、電子フォーム使用時に、値の入力が必須であるかどうかを指定します。

「必須」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／必須」をチェックします。

「選択不能」

「選択不能」プロパティは、プレビュー時にコンポーネントの入力機能を無効にするのに使用されます。

「選択不能」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／選択不能」をチェックします。

「読取専用」

「読取専用」プロパティは、プレビュー時にコンポーネントの内容を編集不可にするのに使用します。

「読取専用」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／読取専用」をチェックします。

「マスクする」

「マスクする」プロパティは、プレビュー時にコンポーネントの内容を隠す( 非表示 )ために使用します。

「マスクする」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／マスクする」をチェックします。

「タブ順」

「タブ順」プロパティは、キーボードで Tab キーを押す毎に移動する、電子フォームのアクセスフィールドの順番を定義するのに使用します。

「タブ順」を定義するには

  1. 「InterfaceGroup」コンポーネント内にフォームコンポーネント( 例：Text, Password, Memo, DropDowm等 )を配置・選択します。
  2. F11キーを押すと、プロパティエディタの「アクティブ」タブが表示されます。
  3. 必要に応じて「カスタム／タブ順」の番号を変更します。

※最初にアクセスするコンポーネントの「タブ順」番号はゼロ( 0 )に設定する必要があります。

「入力可能」

「入力可能」プロパティは、ドキュメントの閲覧者が DropDown や URLDropDown, DatasetDropDown の選択肢にない値を入力できるようにするのに使用されます。

「入力可能」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／入力可能」をチェックします。

※この機能は、HTML には対応していません。

「パラメータ名」

「パラメータ名」プロパティは、「Check」コンポーネントをグルーピングします。この機能を使用するには、複数の「Check」コンポーネントに対して、グルーピングするための同じパラメータ名を指定する必要があります。

「Check」コンポーネントをグルーピングするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／パラメータ名」テキストボックスをクリックし、パラメータ名を入力します。

※PDF では、「Check」コンポーネントで複数のチェックを使用することができません(「パラメータ名」プロパティの値がすべての「Check」コンポーネントで同一の場合、PDF で同時にクリックできるチェックボックスは一つだけとなります)。

「チェック済」

「チェック済」プロパティは、コンポーネントにおいて、デフォルトで選択状態にするのに使用されます。

チェック済みの状態にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／チェック済」を選択します。

※「Check」コンポーネントでは、グループ内の複数のコンポーネントに選択状態を適用できます。

※「Radio」コンポーネントを複数選択している場合でも、チェックできるコンポーネントは一つだけです。ただし、「Radio」コンポーネントのグループがある場合は、グループごとに一つずつコンポーネントをチェックできます。

「パラメータ名」

「パラメータ名」プロパティは、「Radio」コンポーネントをグルーピングするのに使用されます。複数の「Radio」コンポーネントで同じ名前を付けることで、１つのグループとして指定することができます。

グルーピングするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「パラメータ名」テキストボックスに名前を入力します。

「形態」

「ボタン」

「形態」プロパティの「ボタン」オプションを使うと、生成される OPR/OXR ドキュメントに「OFD I/O」ボタンを出現させることができます。このボタンをクリックすることで、フォームデータの保存または読み込みを行うことができます。

「ボタン」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」の「ボタン」オプションを選択します。

※フォームデータを保存、または、読み込むコントロールの「形態」には、「ボタン」オプションか「ポップアップ」オプションの一方、または両方を選択することができます。

「ポップアップ」

「形態」プロパティの「ポップアップ」オプションを使うと、生成されるOPR/OXRドキュメントの電子フォームを右クリックしたときに現れるポップアップに「データの読込」または「データの保存」というオプションを出現させることができます。このオプションを選択することで、フォームデータの保存、または、読み込みを行うことができます。

「ポップアップ」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」の「ポップアップ」オプションを選択します。

※フォームデータを保存、または、読み込むコントロールの「形態」には、「ボタン」オプションか「ポップアップ」オプションの一方、または両方を選択することができます。

「動作」

「保存」

「保存」オプションは、生成された OPR/OXR ドキュメントの電子フォームから、フォームデータを OFD ( OPRO Form Data ) ファイルに保存するのに使用します。

生成されたドキュメントの電子フォームに現れる「OFD I/O」ボタン、または、「OFD I/O」ポップアップのどちらかをクリックすると、「保存」オプションは実行されます。
「形態」プロパティで「ボタン」オプションが選択されていると、生成された OPR/OXR ドキュメントには「OFD I/O」ボタンが現れます。そして、そのボタンをクリックするとフォームデータを保存することができます。
また、「形態」プロパティで「ポップアップ」オプションが選択されていると、生成された OPR/OXR ドキュメントの電子フォームで右クリックしたときに現れるポップアップの中に「データの保存」オプションが現れます。このオプションを選択するとフォームデータを保存することができます。
「ボタン」と「ポップアップ」両方を選択した場合には、フォームデータを読み込む どちらの方法も利用することができます。

「保存」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」から、「ボタン」または「ポップアップ」の一方、あるいは両方を選択します。
  3. 「カスタム／動作」から、「保存」オプションを選択します。

※「保存」オプションは、「対象となる InterfaceGroup」で「すべて」が選択されている場合、同じドキュメントにある複数の電子フォームのフォームデータを保存します。

「読込」

「読込」オプションは、電子フォームを含む、生成された OPR/OXR ドキュメントに、OFD（OPRO Form Data）ファイルからフォームデータを読み込むために使用します。

生成されたドキュメントの電子フォームに現れる「OFD I/O」ボタンまたは「OFD I/O」ポップアップのどちらかをクリックすると、「読込」オプションは実行されます。
「形態」プロパティで「ボタン」オプションが選択されていると、生成された OPR/OXR ドキュメントには「OFD I/O」ボタンが現れます。そして、そのボタンをクリックするとフォームデータを読み込むことができます。
また、「形態」プロパティで「ポップアップ」オプションが選択されていると、生成された OPR/OXR ドキュメントの電子フォームで右クリックしたときに現れるポップアップの中に「データの読込」オプションが現れます。このオプションを選択するとフォームデータを読み込むことができます。
「ボタン」と「ポップアップ」両方を選択した場合には、フォームデータを読み込む どちらの方法も利用することができます。

「読込」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」から、「ボタン」または「ポップアップ」の一方、あるいは両方を選択します。
  3. 「カスタム／動作」から、「読込」オプションを選択します。

※「読込」オプションは、「対象となる InterfaceGroup」で「すべて」が選択されている場合、同じドキュメントにある複数の電子フォームにフォームデータを読み込みます。

「OXR/OPRの場所を指定」

「OXR/OPRの場所を指定」プロパティは、OXR、または、OPRへのパスを指定するのに使用します。「.ofd」ファイルがクリックされた場合、対応した「.oxr」または「.opr」ファイル(拡張子以外のファイル名が同じもの)が指定されたパスから開かれます。

OXR/OPR の場所を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／保存」をクリックします。
  3. 「カスタム／OXR／OPRの場所を指定」をチェックします。
  4. URLパスを「カスタム／URL」に入力します。

「対象となる InterfaceGroup」

「直属のみ」「すべて」

「対象となる InterfaceGroup」の「すべて」にチェックすると、外側にある場合はドキュメント全体を対象に、「InterfaceGroup」内にある場合はその範囲内を対象に適用します。

対象となる InterfaceGroupを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／対象となる InterfaceGroup」で「直属のみ」または「すべて」をクリックします。

「配置」

「配置」プロパティは、「DatasetTable」コンポーネントを「DatasetTable Container」コンポーネントの「Top」「Bottom」または「Client」に配置します。

「Top」
コンポーネントを DatasetTable Container の上部に配置します。
「Bottom」
コンポーネントを DatasetTable Container の下部に配置します。
「Client」
コンポーネントを DatasetTable Container 内の空いている領域に配置します。

コンポーネントを配置するには

  1. テンプレートに「DatasetTable Container」コンポーネントを配置します。
  2. 次に DatasetTable を DatasetTable Container 内に配置します。
  3. DatasetTable を選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  4. 「カスタム／配置」ドロップダウンから、配置タイプを選択します。

※「DatasetTable」コンポーネントが DatasetTable Container 内に配置された場合に限り、「配置」プロパティは使用できます。

「Dataset」

DatasetTable で使用する Dataset を選択します。このオプションを使用するには、テンプレート上に「Dataset」コンポーネントを配置しておく必要があります。

Dataset を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」から、必要な Dataset を選択します。

「バンド」

「ページヘッダ」

「ページヘッダ」プロパティは、DatasetTable において、ページヘッダを使用するかどうかを指定します。ページヘッダは、個々のレイアウトの冒頭に情報を印刷するのに使用します。

ページヘッダを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「ページヘッダ」を選択します。

「ページフッタ」

「ページフッタ」プロパティは、DatasetTable において、ページフッタを使用するかどうかを指定します。ページフッタは、個々のレイアウトの末尾に情報を印刷するのに使用します。

ページフッタを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「ページフッタ」を選択します。

「レポートヘッダ」

「レポートヘッダ」プロパティは、DatasetTable において、レポートヘッダを使用するかどうかを指定します。レポートヘッダは、テンプレートの最初に１回だけ情報を印刷するのに使用します。

レポートヘッダを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「レポートヘッダ」を選択します。

「レポートフッタ」

「レポートフッタ」プロパティは、DatasetTable において、レポートフッタを使用するかどうかを指定します。レポートフッタは、テンプレートの最後に１回だけ情報を印刷するのに使用します。

レポートフッタを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「レポートフッタ」を選択します。

「カラムヘッダ」

これは、選択された DatasetTable にカラムヘッダを割り当てるプロパティです。DatasetTable に表示された個々のカラムの見出しを表示するのに使用されます。

カラムヘッダを追加するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」ドロップダウンから、必要な Dataset を選択します。
  3. 「カスタム／カラムヘッダ」をクリックします。

「空のレポートヘッダを繰り返す」

「空のレポートヘッダを繰り返す」プロパティは、複数ページを持つドキュメントのために2ページ目以降から空のレポートヘッダを適用します。複数ページは、DatasetTable から表示されるレコードの一覧によって出力されるものです。「空のレポートヘッダを繰り返す」プロパティは、DatasetTable の「レポートヘッダ」を選択した場合のみに選択可能です。

「空のレポートヘッダを繰り返す」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」で「Dataset」を選択し、「レポートヘッダ」チェックオプションををクリックします。
  3. 「カスタム／空のレポートヘッダを繰り返す」をクリックします。

「レポートフッタを下部に配置」

DatasetTable で表示される最後のデータバンドの直下よりも、さらに下部の位置にレポートフッタを配置できます。

レポートフッタを下部に配置するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」で Dataset を選択し、「カスタム／レポートフッタ」チェックボックスをクリックします。
  3. 「レポートフッタを下部に配置」チェックボックスをクリックします。

「リンク」

「リンク」タブは、SubReportを作成するときに使用します。二つの「DatasetTable」コンポーネントのテーブルから、関連する二つのフィールドをリンクします。フィールドはいくつでも選択することが可能です。

フィールドをリンクするには

  1. テンプレートに二つの「Dataset」コンポーネントを配置し、それぞれにテーブルを指定します。
  2. テンプレートに「DatasetTable」コンポーネントを配置します。
  3. もう一つの「DatasetTable」コンポーネントを、最初に置いた DatasetTableのDatasetBand 内に配置します。これを子DatasetTable とします。
  4. 一方の Dataset を親DatasetTable に割り当て、もう一方の Dataset を子DatasetTable に割り当てます。
  5. 子DatasetTable のプロパティを選択(またはF11キーを押)し、「リンク」タブを選択します。
  6. 「カスタム／親」ドロップダウンから、子に関連付けるフィールドを選択します。
  7. 「カスタム／子」ドロップダウンから、親に関連付けるフィールドを選択します。

「重複の削除」

テンプレートの「DatasetTable」コンポーネントおよび「HorizontalDatasetTable」コンポーネントで、重複したフィールドを削除できます。データベースタイプの Label, URLLabel, SATOLabel, URLImage, BarCode の各コンポーネントに適用されます。重複を削除するには、必要なフィールドのチェックボックスをチェックする必要があります。

重複を削除するには

  1. テンプレートに Dataset と DatasetTable を配置します。
  2. Dataset のテーブルを選択します。
  3. 「DatasetTable」コンポーネントで Dataset を選択します。
  4. 「重複の削除」タブを選択し、必要なフィールドをチェックして重複を削除します。

※「重複の削除」タブに表示されるフィールドは、ドラッグするか、「上に移動」ボタン または「下に移動」ボタンをクリックすると、移動できます。

「詳細数の制限」

「詳細数の制限」プロパティは、DatasetTable で表示する項目の数を制限します。

詳細数を制限するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／詳細数の制限」チェックオプションをクリックし、有効にします。

「詳細数」

「詳細数」プロパティは、DatasetTable で表示する項目の数を指定します。

詳細数を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／詳細数」テキストボックスのスピナーコントロールをクリックするか、値を直接を入力し、指定します。

「ローヘッダ」

「ローヘッダ」プロパティは、HorizontalDatasetTable に、列のヘッダを割り当てるために使用します。このプロパティは、HorizontalDatasetTable で表示される繰り返しデータ項目の隣に、列のヘッダを表示するのに使用します。

ローヘッダを追加するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」ドロップダウンから「Dataset」を選択します。
  3. 「ローヘッダ」をクリックするか、プロパティから選択します。

「画像」

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「テキスト」

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「背景にセット」

「背景にセット」プロパティは、画像を「DigitalSignature」コンポーネントのテキストの背景としてセットするのに使用されます。

画像を背景にセットするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／背景にセット」をクリックします。

「署名のプロパティ」

「印刷可能」

「印刷可能」プロパティは、ドキュメントの印刷時に MGSigned PDF を印刷するかどうかを指定するのに使用します。

印刷可能にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／印刷可能」をクリックします。

「署名者」

「署名者」プロパティは、ドキュメントの署名者を指定するのに使用します。

署名者を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム」で「署名者」の名前を入力します。

「署名地」

「署名地」プロパティは、MGSigned PDF の署名フィールドに、署名地の詳細(都市名など)を入力するのに使用します。

署名地を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／署名地」に署名地の情報を入力します。

「理由」

「理由」プロパティは、ドキュメントに署名する理由を入力するのに使用します。

理由を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／理由」に理由を入力します。

「コメント」

「コメント」プロパティは、MGSigned PDF にコメントを追加するのに使用します。PDF ドキュメントの MGSigned PDF 署名フィールド上にマウスポインタを移動すると、コメントが表示されます。

コメントを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／コメント」にコメントを入力します。


「カスタム」プロパティ

「外観」

「背景色」

「背景色」プロパティは、コンポーネントの背景色を指定します。

背景色を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／背景色」から使用する色を選択します。

- InterfaceGroup コンポーネント -

「アクション」

「URL」

「URL」プロパティは、リクエスト方法で使われるサーブレット/CGIアドレスを指定するのに使用します。

URLを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／URL」にサーブレット/CGIアドレスを入力します。

「メソッド」

「メソッド」プロパティは、リクエスト方法を指定するのに使用します。リクエスト方法には、「OFMS」「POST」「GET」が選択できます。

メソッドを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／メソッド」ドロップダウンから、使用するメソッドを選択します。

「内容」

送信する情報の形式を指定します。指定した形式によって、OXBドキュメント、または、フォームデータのソースファイルとなります。

「URL」
名前と値のペアになっているフォームデータは、送信中にURLエンコードされます。
「Multipart」
ファイルコンポーネントを使用して外部で読み込まれたファイルデータを、フォーム情報( URLエンコードされた名前と値のペア )と共に送信する必要がある場合に使用します。
「OFD」
フォームデータをOFD形式で送信できます。OFD とは、OXB Form Data ( ファイル拡張子「.ofd」 )の略であり、XML形式です。
「OXR」
現在開いているドキュメントを OXR 形式で送信できます。
「OPR」
現在開いているドキュメントを OPR 形式で送信できます。
「XML」
カスタマイズされた XML を送信できます。InterfaceGroup から生成される OFD ファイルは、指定されている「OFD>XML」に従って変換されます( 例えば、SOAP リクエストを生成し、「XML>OFD」に従って応答を変換することもできます )。
「FDF」
FDF ( Forms Data Format )は、Acrobat 固有のフォームデータのエンコードです。出力形式が PDF の場合にのみサポートされます。フォームデータのみを特定のサーバに送信する場合に便利です。PDF ドキュメントは、FDF 応答の値によって更新されます。
「XFDF」
XFDF は FDF と同じですが、形式が XMLベースの FDF である点が異なります。XFDF 形式を使用して送信されるフォームは、OXB でもサポートされています。
「PDF」
フォームを含む PDF ドキュメント全体が送信されます。出力形式が PDF である場合にのみサポートされます。

送信情報の形式を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／内容」ドロップダウンから、使用する形式を選択します。

「OFD/XML変換」

「OFD>XML...」

「OFD>XML」プロパティは、サーバ独自のXML変換命令を持つ XSL ファイルを選択します。
指定されたXSLファイルは、OFDファイルをサーバ、または、SOAPサーブレットに解釈されるXML形式に変換するのに必要な変換命令を持ち、OXBから外部への電子フォームリクエストを可能にします。

「OFD>XML」ボタンをクリックすると、「XSLファイルの内容」ダイアログが表示されます。

「読込」
「読込」ボタンは、「ファイルを開く」ダイアログから XSL ファイルを読み込み、「XSLファイルの内容」ダイアログのテキストエリアにその内容を表示します。
「クリア」
「クリア」ボタンは、「XSLファイルの内容」ダイアログのテキストエリアに読み込まれた内容( XSL命令 )をクリアします。
「OK」
「OK」ボタンは、「XSLファイルの内容」ダイアログのテキストエリアの内容( XSL命令 )を確定します。
「キャンセル」
「キャンセル」ボタンは、「XSLファイルの内容」ダイアログのテキストエリアの内容( XSL命 令)に加えられた変更を破棄します。

ユーザは、「XSLファイルの内容」ダイアログのテキストエリアで表示された内容( XSL命令 )を編集することができます。

※このプロパティは、「メソッド」プロパティで「POST」を、「内容」プロパティで「XML」を選択した場合に指定可能になります。

「XML>OFD...」

サーバから OXB へのレスポンスは、OXD のボタンをクリックすることで、XSL ファイルが選択され、元の OFD フォーマットへと変換します。

- Text コンポーネント -

「属性」

「パラメータ名」

「パラメータ名」プロパティは、電子フォームを使用して値を渡すときのコンポーネントに対する名前を指定します。

パラメータ名を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／パラメータ名」を選択し、パラメータの名前を入力します。

「データ型」

「データ型」プロパティは、「内容」のデータ型を「ANY」「ALPHABET」「INTEGER」「NUMERIC」「ASCII」から選択・指定します。

データ型を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／データ型」から必要なタイプを選択します。

「最大長」

「最大長」プロパティは、入力できる最大文字数を指定します。

最大文字数を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 値を入力するか、または「カスタム／最大長」でテキストボックスのボタンをクリックして値を変更します。

※「最大長」に0を指定した場合、入力できる文字数は無制限になります。

「必須」

このオプションは、電子フォーム使用時に、値の入力が必須であるかどうかを指定します。

「必須」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／必須」をチェックします。

「選択不能」

「選択不能」プロパティは、プレビュー時にコンポーネントの入力機能を無効にするのに使用されます。

「選択不能」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／選択不能」をチェックします。

「読取専用」

「読取専用」プロパティは、プレビュー時にコンポーネントの内容を編集不可にするのに使用します。

「読取専用」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／読取専用」をチェックします。

「マスクする」

「マスクする」プロパティは、プレビュー時にコンポーネントの内容を隠す( 非表示 )ために使用します。

「マスクする」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／マスクする」をチェックします。

「タブ順」

「タブ順」プロパティは、キーボードで Tab キーを押す毎に移動する、電子フォームのアクセスフィールドの順番を定義するのに使用します。

「タブ順」を定義するには

  1. 「InterfaceGroup」コンポーネント内にフォームコンポーネント( 例：Text, Password, Memo, DropDowm等 )を配置・選択します。
  2. F11キーを押すと、プロパティエディタの「アクティブ」タブが表示されます。
  3. 必要に応じて「カスタム／タブ順」の番号を変更します。

※最初にアクセスするコンポーネントの「タブ順」番号はゼロ( 0 )に設定する必要があります。

- DropDown コンポーネント -

「入力可能」

「入力可能」プロパティは、ドキュメントの閲覧者が DropDown や URLDropDown, DatasetDropDown の選択肢にない値を入力できるようにするのに使用されます。

「入力可能」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／入力可能」をチェックします。

※この機能は、HTML には対応していません。

- Check コンポーネント -

「パラメータ名」

「パラメータ名」プロパティは、「Check」コンポーネントをグルーピングします。この機能を使用するには、複数の「Check」コンポーネントに対して、グルーピングするための同じパラメータ名を指定する必要があります。

「Check」コンポーネントをグルーピングするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／パラメータ名」テキストボックスをクリックし、パラメータ名を入力します。

※PDF では、「Check」コンポーネントで複数のチェックを使用することができません(「パラメータ名」プロパティの値がすべての「Check」コンポーネントで同一の場合、PDF で同時にクリックできるチェックボックスは一つだけとなります)。

「チェック済」

「チェック済」プロパティは、コンポーネントにおいて、デフォルトで選択状態にするのに使用されます。

チェック済みの状態にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／チェック済」を選択します。

※「Check」コンポーネントでは、グループ内の複数のコンポーネントに選択状態を適用できます。

※「Radio」コンポーネントを複数選択している場合でも、チェックできるコンポーネントは一つだけです。ただし、「Radio」コンポーネントのグループがある場合は、グループごとに一つずつコンポーネントをチェックできます。

- Radio コンポーネント -

「パラメータ名」

「パラメータ名」プロパティは、「Radio」コンポーネントをグルーピングするのに使用されます。複数の「Radio」コンポーネントで同じ名前を付けることで、１つのグループとして指定することができます。

グルーピングするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「パラメータ名」テキストボックスに名前を入力します。

- OFD I/Oコンポーネント -

「形態」

「ボタン」

「形態」プロパティの「ボタン」オプションを使うと、生成される OPR/OXR ドキュメントに「OFD I/O」ボタンを出現させることができます。このボタンをクリックすることで、フォームデータの保存または読み込みを行うことができます。

「ボタン」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」の「ボタン」オプションを選択します。

※フォームデータを保存、または、読み込むコントロールの「形態」には、「ボタン」オプションか「ポップアップ」オプションの一方、または両方を選択することができます。

「ポップアップ」

「形態」プロパティの「ポップアップ」オプションを使うと、生成されるOPR/OXRドキュメントの電子フォームを右クリックしたときに現れるポップアップに「データの読込」または「データの保存」というオプションを出現させることができます。このオプションを選択することで、フォームデータの保存、または、読み込みを行うことができます。

「ポップアップ」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」の「ポップアップ」オプションを選択します。

※フォームデータを保存、または、読み込むコントロールの「形態」には、「ボタン」オプションか「ポップアップ」オプションの一方、または両方を選択することができます。

「動作」

「保存」

「保存」オプションは、生成された OPR/OXR ドキュメントの電子フォームから、フォームデータを OFD ( OPRO Form Data ) ファイルに保存するのに使用します。

生成されたドキュメントの電子フォームに現れる「OFD I/O」ボタン、または、「OFD I/O」ポップアップのどちらかをクリックすると、「保存」オプションは実行されます。
「形態」プロパティで「ボタン」オプションが選択されていると、生成された OPR/OXR ドキュメントには「OFD I/O」ボタンが現れます。そして、そのボタンをクリックするとフォームデータを保存することができます。
また、「形態」プロパティで「ポップアップ」オプションが選択されていると、生成された OPR/OXR ドキュメントの電子フォームで右クリックしたときに現れるポップアップの中に「データの保存」オプションが現れます。このオプションを選択するとフォームデータを保存することができます。
「ボタン」と「ポップアップ」両方を選択した場合には、フォームデータを読み込む どちらの方法も利用することができます。

「保存」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」から、「ボタン」または「ポップアップ」の一方、あるいは両方を選択します。
  3. 「カスタム／動作」から、「保存」オプションを選択します。

※「保存」オプションは、「対象となる InterfaceGroup」で「すべて」が選択されている場合、同じドキュメントにある複数の電子フォームのフォームデータを保存します。

「読込」

「読込」オプションは、電子フォームを含む、生成された OPR/OXR ドキュメントに、OFD（OPRO Form Data）ファイルからフォームデータを読み込むために使用します。

生成されたドキュメントの電子フォームに現れる「OFD I/O」ボタンまたは「OFD I/O」ポップアップのどちらかをクリックすると、「読込」オプションは実行されます。
「形態」プロパティで「ボタン」オプションが選択されていると、生成された OPR/OXR ドキュメントには「OFD I/O」ボタンが現れます。そして、そのボタンをクリックするとフォームデータを読み込むことができます。
また、「形態」プロパティで「ポップアップ」オプションが選択されていると、生成された OPR/OXR ドキュメントの電子フォームで右クリックしたときに現れるポップアップの中に「データの読込」オプションが現れます。このオプションを選択するとフォームデータを読み込むことができます。
「ボタン」と「ポップアップ」両方を選択した場合には、フォームデータを読み込む どちらの方法も利用することができます。

「読込」オプションを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／形態」から、「ボタン」または「ポップアップ」の一方、あるいは両方を選択します。
  3. 「カスタム／動作」から、「読込」オプションを選択します。

※「読込」オプションは、「対象となる InterfaceGroup」で「すべて」が選択されている場合、同じドキュメントにある複数の電子フォームにフォームデータを読み込みます。

「OXR/OPRの場所を指定」

「OXR/OPRの場所を指定」プロパティは、OXR、または、OPRへのパスを指定するのに使用します。「.ofd」ファイルがクリックされた場合、対応した「.oxr」または「.opr」ファイル(拡張子以外のファイル名が同じもの)が指定されたパスから開かれます。

OXR/OPR の場所を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／保存」をクリックします。
  3. 「カスタム／OXR／OPRの場所を指定」をチェックします。
  4. URLパスを「カスタム／URL」に入力します。

「対象となる InterfaceGroup」

「直属のみ」「すべて」

「対象となる InterfaceGroup」の「すべて」にチェックすると、外側にある場合はドキュメント全体を対象に、「InterfaceGroup」内にある場合はその範囲内を対象に適用します。

対象となる InterfaceGroupを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／対象となる InterfaceGroup」で「直属のみ」または「すべて」をクリックします。


「カスタム」プロパティ

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「外観」

「自動サイズ」

「自動サイズ」コンポーネントは、表示される内容に合わせてコンポーネントサイズを自動的に変更するかどうかを指定するのに使用します。

自動サイズを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／自動サイズ」をクリックします。

「枠に合わせて表示」

「枠に合わせて表示」プロパティは、コンポーネントの水平サイズおよび垂直サイズに対応して、内容をリサイズするのに使用します。

画像を枠に合わせて表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／枠に合わせて表示」をクリックします。

※枠に合わせて表示すると、画像の品質は劣化します。

「縦横比を固定して伸縮」

「縦横比を固定して伸縮」プロパティは、画像の元の高さと幅の比率を維持したまま、画像をリサイズするのに使用します。

縦横比を固定して画像を伸縮するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／縦横比を固定して伸縮」チェックオプションを有効にします。
  3. 画像のふちをドラッグして、リサイズします。

「すべてのページを出力」

「すべてのページを出力」プロパティは、マルチページ TIFF 画像のすべてのページを表示するのに使用します。このオプションを有効にすると、マルチページ TIFF の各ページをドキュメント1ページごとに生成・出力します。

「すべてのページを出力」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／すべてのページを出力」チェックオプションを有効にします。

※「Image」コンポーネントがDataset、または、HorizontalDatasetTableに置かれたとき、または別の画像形式(例: GIF、JPEG等)を選択したとき、「すべてのページを出力」プロパティは使用不可になります。


「カスタム」プロパティ

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「背景色」

コンポーネントの背景色を指定します。

背景色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／色」から使用する色を選択します。

「縦書き」

内容を縦書きで表示します。

テキストを縦書きで表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／縦書き」をクリックします。

「スタイル」

「自動サイズ」

コンポーネントのサイズを、そこに表示される内容に合わせて自動的に変更するかどうかを指定します。

自動サイズを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／自動サイズ」をクリックします。

「折り返し」

「折り返し」プロパティは、コンポーネントの中に表示されるテキストをコンポーネントのサイズに合わせて改行するのに使用します。「折り返し」プロパティがチェックされていると、コンポーネントの右端で表示しきれない単語は、単語の手前部分で改行され、分断されずに表示されるようになります。

折り返しを使用するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／折り返し」をクリックします。

「均等」

コンポーネント内の文字間隔を拡大または縮小して、等間隔に並べます。

均等を使用するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／均等」をクリックします。

「縮小して全体を表示」

「縮小して全体を表示」プロパティは、コンポーネントの内容をコンポーネントサイズに応じて縮小し、全体を表示できるようにするのに使用します。

コンテンツのサイズ変更を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／縮小して全体を表示」をクリックします。

「文字幅と間隔」

「行間隔」

テキストの行間隔を指定します。

行間隔を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 単位タイプを選択し、「カスタム／行間隔」テキストボックスに値を直接入力するか、スピナーコントロールをクリックして値を増減し、行間隔を指定します。

単位タイプは、ピクセル(Px)、インチ(In)、センチメートル(Cm)、ポイント(Pt)を指定することができます。

「文字間隔」

テキストの文字間隔を指定します。

文字間隔を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／文字間隔」テキストボックスに値を入力するか、またはスピナーコントロールをクリックして値を指定し、単位タイプを選択します。

「タブ幅」

文字間のタブ幅を指定します。

タブ幅を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／タブ幅」テキストボックスに値を直接入力するか、スピナーコントロールをクリックして値を指定し、単位タイプを選択します。

単位タイプは、ピクセル(Px)、インチ(In)、センチメートル(Cm)、ポイント(Pt)を指定することができます。


「カスタム」プロパティ

- Shape コンポーネント -

「タイプ」

「タイプ」プロパティは、図形タイプを「RoundRect」「Rectangle」「Ellipse」から選択し、変更できます。

図形タイプを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／タイプ」から使用するタイプを選択します。

※「角の丸み調整」は、タイプとして「RoundRect」を選択している場合に限り使用できます。

「境界」

「サイズ」

Shape の境界線の太さを指定します。

境界線の太さを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／サイズ」テキストボックスに値を入力するか、またはスピナーコントロールをクリックして値を指定します。

「スタイル」

「スタイル」プロパティは、コンポーネントの境界のスタイルを指定します。使用できるスタイルは、Solid, Dash, Dot, DashDot, DashDotDot です。

スタイルを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／スタイル」で、使用するスタイルをクリックします。

※「Shape」コンポーネントの境界のサイズが1より大きいときは、スタイルを変更することができません。

「色」

「色」プロパティは、Shape の境界色を指定します。

境界色を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／境界／色」から使用する色を選択します。

「背景」

「色」

「色」プロパティは、Shape の背景色を変更します。

背景色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／背景／色」から使用する色を選択します。

「角の丸み調整」

「角の丸み調整」プロパティは、Shape の角の丸みを調整するのに使用します。

角の丸みを調整するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／角の丸み調整」テキストボックスに値を入力するか、スピナーコントロールをクリックして値を指定します。

「対称にする」

「対称にする」プロパティは、Shape の4つの角の丸みを同時に調整するのに使用します。

4つの角の丸みを同時調整するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／角の丸み調整／対称にする」をクリックします。
  3. 「カスタム／角の丸み調整」テキストボックスに値を入力するか、スピナーコントロールをクリックして値を指定します。

- Line コンポーネント -

「サイズ」

「サイズ」プロパティは、線の太さを変更するのに使用します。

サイズを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／サイズ」テキストボックスに値を入力するか、スピナーコントロールをクリックして値を指定します。

「色」

「色」プロパティは、線の色を選択するのに使用します。

線の色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／色」から使用する色を選択します。

「スタイル」

「スタイル」プロパティは、様々な線の種類を選択するのに使用します。使用できる線の種類は、Solid, Dash, Dot, DashDot, DashDotDot です。

スタイルを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／スタイル」で、使用するスタイルをクリックします。

※PDF の制限により、DashDot と DashDotDot の線は、PDF 出力では正しく表示されません。

「向き」

「向き」プロパティは６方向の線( 上辺、下辺、左辺、右辺、右上から左下への対角線、左上から右下への対角線 )を描くのに使用します。

ラインの向き
 | コンポーネントの左辺に線をひきます。
 | コンポーネントの右辺に線をひきます。
 | コンポーネントの上辺に線をひきます。
 | コンポーネントの下辺に線をひきます。
 | 右上から左下への対角線をひきます。
 | 左上から右下への対角線をひきます。

線は複数同時に指定して描くことができます。

例1:

例2:

※最低でも一つ以上の方向を選択する必要があります。

線の「向き」を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／向き」から、適切な方向ボタンをクリックします。


「カスタム」プロパティ

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「枠に合わせて表示」

「枠に合わせて表示」プロパティは、コンポーネントの水平サイズおよび垂直サイズに対応して、内容をリサイズするのに使用します。

画像を枠に合わせて表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／枠に合わせて表示」をクリックします。

※枠に合わせて表示すると、画像の品質は劣化します。

「色」

「色」プロパティは、コンポーネントの背景色を変更します。

色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／色」から使用する色を選択します。

- Digital Signature コンポーネント -

「画像」

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「テキスト」

「配置」

コンポーネントに表示する内容の位置を指定します。

内容の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／配置」領域で、内容を配置したい位値をクリックします。

「背景にセット」

「背景にセット」プロパティは、画像を「DigitalSignature」コンポーネントのテキストの背景としてセットするのに使用されます。

画像を背景にセットするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／背景にセット」をクリックします。

- MGSigned PDF コンポーネント -

「署名のプロパティ」

「印刷可能」

「印刷可能」プロパティは、ドキュメントの印刷時に MGSigned PDF を印刷するかどうかを指定するのに使用します。

印刷可能にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／印刷可能」をクリックします。

「署名者」

「署名者」プロパティは、ドキュメントの署名者を指定するのに使用します。

署名者を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム」で「署名者」の名前を入力します。

「署名地」

「署名地」プロパティは、MGSigned PDF の署名フィールドに、署名地の詳細(都市名など)を入力するのに使用します。

署名地を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／署名地」に署名地の情報を入力します。

「理由」

「理由」プロパティは、ドキュメントに署名する理由を入力するのに使用します。

理由を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／理由」に理由を入力します。

「コメント」

「コメント」プロパティは、MGSigned PDF にコメントを追加するのに使用します。PDF ドキュメントの MGSigned PDF 署名フィールド上にマウスポインタを移動すると、コメントが表示されます。

コメントを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／コメント」にコメントを入力します。


「カスタム」プロパティ

- Table コンポーネント -

「バンド数」

「バンド数」プロパティは、テーブルのバンド数を指定します。

バンド数を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／バンド数」テキストボックスに値を入力して「OK」ボタンをクリックするか、スピナーコントロールをクリックして値を指定します。

「カラム数」

「カラム数」プロパティは、テーブルのカラム数を指定します。

カラム数を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／カラム数」テキストボックスに値を入力して「OK」ボタンをクリックするか、スピナーコントロールをクリックして値を指定します。

「バンドを等幅に分割」

「バンドを等幅に分割」ボタンを使うと、テーブルでバンドを等幅に分割できます。

バンドを等幅に分割するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム」/「バンドを等幅に分割」ボタンをクリックします。

「カラムを等幅に分割」

「カラムを等幅に分割」ボタンを使うと、テーブルでカラムを等幅に分割できます。

カラムを等幅に分割するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム」/「カラムを等幅に分割」ボタンをクリックします。

「外観」

「背景色」

「背景色」プロパティは、コンポーネントの背景色を指定します。

背景色を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／背景色」から使用する色を選択します。

- DatasetTable コンポーネント -

「配置」

「配置」プロパティは、「DatasetTable」コンポーネントを「DatasetTable Container」コンポーネントの「Top」「Bottom」または「Client」に配置します。

「Top」
コンポーネントを DatasetTable Container の上部に配置します。
「Bottom」
コンポーネントを DatasetTable Container の下部に配置します。
「Client」
コンポーネントを DatasetTable Container 内の空いている領域に配置します。

コンポーネントを配置するには

  1. テンプレートに「DatasetTable Container」コンポーネントを配置します。
  2. 次に DatasetTable を DatasetTable Container 内に配置します。
  3. DatasetTable を選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  4. 「カスタム／配置」ドロップダウンから、配置タイプを選択します。

※「DatasetTable」コンポーネントが DatasetTable Container 内に配置された場合に限り、「配置」プロパティは使用できます。

「Dataset」

DatasetTable で使用する Dataset を選択します。このオプションを使用するには、テンプレート上に「Dataset」コンポーネントを配置しておく必要があります。

Dataset を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」から、必要な Dataset を選択します。

「バンド」

「ページヘッダ」

「ページヘッダ」プロパティは、DatasetTable において、ページヘッダを使用するかどうかを指定します。ページヘッダは、個々のレイアウトの冒頭に情報を印刷するのに使用します。

ページヘッダを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「ページヘッダ」を選択します。

「ページフッタ」

「ページフッタ」プロパティは、DatasetTable において、ページフッタを使用するかどうかを指定します。ページフッタは、個々のレイアウトの末尾に情報を印刷するのに使用します。

ページフッタを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「ページフッタ」を選択します。

「レポートヘッダ」

「レポートヘッダ」プロパティは、DatasetTable において、レポートヘッダを使用するかどうかを指定します。レポートヘッダは、テンプレートの最初に１回だけ情報を印刷するのに使用します。

レポートヘッダを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「レポートヘッダ」を選択します。

「レポートフッタ」

「レポートフッタ」プロパティは、DatasetTable において、レポートフッタを使用するかどうかを指定します。レポートフッタは、テンプレートの最後に１回だけ情報を印刷するのに使用します。

レポートフッタを追加するには

  1. コンポーネントを選択し、F11を押してください。プロパティエディタのアクティブタブが現れます。
  2. 「カスタム」プロパティの「レポートフッタ」を選択します。

「カラムヘッダ」

選択された DatasetTable にカラムヘッダを割り当てるプロパティです。DatasetTable に表示された個々のカラムの見出しを表示するのに使用されます。

カラムヘッダを追加するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」ドロップダウンから、必要な Dataset を選択します。
  3. 「カスタム／カラムヘッダ」をクリックします。

「グループ」

割り当てられたDatasetで選択されたデータをグループ化して出力したい場合に設定します。グループ化するには「グループヘッダ」または「グループフッタ」を出力する必要があります。グリッドに割り当てられたDatasetのフィールドの一覧が表示されますので、グループ化したいフィールドの「ヘッダ」または「フッタ」にチェックを入れてください。

「上に移動」ボタン、「下に移動」ボタンによりグループ化の階層の順番を変更できます。上にあるフィールドが上の階層（外側に出力される）に相当します。

「空のレポートヘッダを繰り返す」

「空のレポートヘッダを繰り返す」プロパティは、複数ページを持つドキュメントのために2ページ目以降から空のレポートヘッダを適用します。複数ページは、DatasetTable から表示されるレコードの一覧によって出力されるものです。「空のレポートヘッダを繰り返す」プロパティは、DatasetTable の「レポートヘッダ」を選択した場合のみに選択可能です。

「空のレポートヘッダを繰り返す」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」で「Dataset」を選択し、「レポートヘッダ」チェックオプションををクリックします。
  3. 「カスタム／空のレポートヘッダを繰り返す」をクリックします。

「レポートフッタを下部に配置」

DatasetTable で表示される最後のデータバンドの直下よりも、さらに下部の位置にレポートフッタを配置できます。

レポートフッタを下部に配置するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」で Dataset を選択し、「カスタム／レポートフッタ」チェックボックスをクリックします。
  3. 「レポートフッタを下部に配置」チェックボックスをクリックします。

「リンク」

「リンク」タブは、SubReportを作成するときに使用します。二つの「DatasetTable」コンポーネントのテーブルから、関連する二つのフィールドをリンクします。フィールドはいくつでも選択することが可能です。

フィールドをリンクするには

  1. テンプレートに二つの「Dataset」コンポーネントを配置し、それぞれにテーブルを指定します。
  2. テンプレートに「DatasetTable」コンポーネントを配置します。
  3. もう一つの「DatasetTable」コンポーネントを、最初に置いた DatasetTableのDatasetBand 内に配置します。これを子DatasetTable とします。
  4. 一方の Dataset を親DatasetTable に割り当て、もう一方の Dataset を子DatasetTable に割り当てます。
  5. 子DatasetTable のプロパティを選択(またはF11キーを押)し、「リンク」タブを選択します。
  6. 「カスタム／親」ドロップダウンから、子に関連付けるフィールドを選択します。
  7. 「カスタム／子」ドロップダウンから、親に関連付けるフィールドを選択します。

「重複の削除」

テンプレートの「DatasetTable」コンポーネントおよび「HorizontalDatasetTable」コンポーネントで、重複したフィールドを削除できます。データベースタイプの Label, URLLabel, SATOLabel, URLImage, BarCode の各コンポーネントに適用されます。重複を削除するには、必要なフィールドのチェックボックスをチェックする必要があります。

重複を削除するには

  1. テンプレートに Dataset と DatasetTable を配置します。
  2. Dataset のテーブルを選択します。
  3. 「DatasetTable」コンポーネントで Dataset を選択します。
  4. 「重複の削除」タブを選択し、必要なフィールドをチェックして重複を削除します。

※「重複の削除」タブに表示されるフィールドは、ドラッグするか、「上に移動」ボタン または「下に移動」ボタンをクリックすると、移動できます。

「詳細数の制限」

「詳細数の制限」プロパティは、DatasetTable で表示する項目の数を制限します。

詳細数を制限するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／詳細数の制限」チェックオプションをクリックし、有効にします。

「詳細数」

「詳細数」プロパティは、DatasetTable で表示する項目の数を指定します。

詳細数を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／詳細数」テキストボックスのスピナーコントロールをクリックするか、値を直接を入力し、指定します。

- HorizontalDatasetTable コンポーネント -

「列数」

「列数」プロパティは、テーブルの列数を指定します。

列数を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム」／「列数」テキストボックスに値を入力して「OK」ボタンをクリックするか、スピナーコントロールをクリックして値を指定します。

「列を等幅に分割」

「列を等幅に分割」ボタンを使うと、テーブルで列を等幅に分割できます。

列を等幅に分割するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム」/「列を等幅に分割」ボタンをクリックします。

「バンド」

「ローヘッダ」

「ローヘッダ」プロパティは、HorizontalDatasetTable に、列のヘッダを割り当てるために使用します。このプロパティは、HorizontalDatasetTable で表示される繰り返しデータ項目の隣に、列のヘッダを表示するのに使用します。

ローヘッダを追加するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「カスタム／Dataset」ドロップダウンから「Dataset」を選択します。
  3. 「ローヘッダ」をクリックするか、プロパティから選択します。

- DatasetBand コンポーネント -

「外観」

「背景色」

バンドの背景色を設定します。

「第２背景色」

バンドの第２背景色を設定します。これが設定されていると、詳細行（ヘッダ・フッタ以外の行）で背景色が交互になります。

「バンドの高さ」

「自動調節する」

カラム上またはロー上にあるコンポーネントが「自動サイズ」なっていると、その内容によりコンポーネントが拡大します。その拡大に合わせてバンドの高さを自動的に調整します。

「バンドの接着」

「内側のバンドから離れないようにする」

テーブルの高さと詳細行の数によっては、ヘッダの直後、またはフッタの直前で改ページが起こり、それによってどの詳細行に対するヘッダ・フッタか分かりづらくなることがあります。このような状況を防ぐために、ヘッダの直後・フッタの直前では改ページを行わず、その内側のバンドを引き連れて改ページするように設定できます。

「グループヘッダ」

「グループが変わったら改ページする」

既定では、グループが変わっても前のグループと同じページに引き続いて出力されますが、グループが変わったときに必ず改ページを行うように設定できます。

「毎ページ出力する」

グループ内の詳細行の途中で改ページが起こる場合に、再度、グループヘッダを出力するようにします。


「内容」プロパティ

「タイプ」

「内容」の「タイプ」プロパティは、内容の値タイプを選択するのに使用します。「Static ( 内容の値そのものを指定 )」「Request ( ユーザのリクエスト値 )」、「Database ( データベースからの値 )」のいずれかのタイプを指定することができます。

タイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」から使用するタイプを選択します。
「Static」
「Static」タイプを選択した場合、設計時にコンポーネントに入力されたハイパーリンクは、OPR、PDF、または、HTMLで表示される同じコンポーネントに挿入されます。
「Request」
「Request」タイプを選択した場合、ハイパーリンクのパスを、サンプル HTML でプレビューまたは入力する前に、ポップアップウィンドウで入力する必要があります。
「Database」
「Database」タイプを選択した場合、表示するハイパーリンクパスは選択されているデータベースフィールドから抽出されます。

「内容」

「内容」プロパティは、コンポーネントの表題を入力するために使用されます。「タイプ」として「Static」を選択した場合に限り、このプロパティが表示されます。

内容を入力するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Static」を選択します。
  3. 「内容／内容」テキストボックスに、使用するデータを入力します。

「ファイル」

「ファイル」プロパティは、コンポーネントの内容を、ストレージにあるテキストファイルから読み込むために使用します。ユーザは、テキストファイルのパスを指定する必要があります。

ファイルを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Static」を選択します。
  3. 「内容／ファイル」をクリックし、読み込むファイルを選択します。

「URL」

「URL」プロパティは、指定した URL アドレスから取得される値を指定値とするために使用します。

URL を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Static」を選択します。
  3. 「内容／URL」をクリックし、ダイアログから URL アドレスを入力し、「OK」ボタンをクリックします。

「リクエストパラメータ名」

「リクエストパラメータ名」プロパティは、リクエストパラメータ名を指定するのに使用します。「タイプ」として「Request」を選択した場合に限り、このプロパティが表示されます。

リクエストパラメータ名を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Request」を選択します。
  3. 「内容／リクエストパラメータ名」にリクエストパラメータ名を入力します。

「Dataset」

「Dataset」プロパティは、Datasetを指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

Dataset を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Database」を選択します。
  3. 「内容／Dataset」で Dataset を選択します。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。

「フィールド」

「フィールド」プロパティは、フィールドを指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

フィールドを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Database」を選択します。
  3. 「内容／Dataset」で Dataset を選択します。
  4. 「内容／フィールド」でフィールドを選択します。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。

「表示形式」

このドロップダウンボックスを使用すると、選択されたフィールドの表示形式を指定できます。

表示形式を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Database」を選択します。
  3. 「内容／Dataset」で Dataset を選択します。
  4. 「内容／フィールド」でフィールドを選択します。
  5. 「内容／表示形式」テキストボックスで表示形式を選択するか、直接入力指定します。

参照：「数値の表示形式」および「日時の表示形式」を参照してください。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。

「値がヌルの場合～を使用する」

データベース内で値がヌルだった場合のフィールド値を指定します。

値がヌルの場合に使用するデータを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Database」を選択します。
  3. 「内容／値がヌルの場合」テキストボックスに、使用するデータを入力します。

「スキャナから取得」

「スキャナから取得」プロパティは、画像をスキャンして、「Image」コンポーネントにセットするために使用します。

スキャナから画像を読み込むには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／スキャナから取得」をクリックします。
  3. 「内容／値がヌルの場合」テキストボックスに、使用するデータを入力します。

※このオプションを有効にするには、スキャナドライバとスキャナを接続する必要があります。

- BarCode コンポーネント -

「内容」

バーコード表示される内容を入力します。

内容を入力するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／内容」に、バーコード表示させる内容を入力します。

「バーコードの表示」

「バーコードの表示」プロパティは、バーコードを表示します。

バーコードを表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／内容」に、使用するバーコードの値を入力します。
  3. 「内容／バーコードの表示」をクリックします。

- OCCS コンポーネント -

「コンテンツ一覧の取得」

「コンテンツ一覧の取得」プロパティは、OCCS からファイルを取得するのに使用します。

コンテンツ一覧を取得するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／コンテンツ一覧の取得」をクリックします。

※「コンテンツの表示」を使用すると、選択したファイルを表示できます。

「コンテンツの表示」

｢コンテンツの表示｣プロパティは、OCCS サービスから取得したファイルを表示するのに使用します。

コンテンツを表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／コンテンツ一覧の取得」をクリックし、一覧から表示するファイルを選択します。
  3. 「内容／コンテンツの表示」をクリックします。

「コンテンツ一覧の取得」を使用すると、画像を表示できます。

- DropDown コンポーネント -

「内容」

ドロップダウンに適用される内容を入力します。

ドロップダウンの内容を入力するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／内容」テキストボックスに、必要な内容を入力します。

- List コンポーネント -

「内容」

リストボックスに適用される内容を入力します。

リストボックスの内容を入力するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／内容」テキストボックスに、必要な内容を入力します。

- TextDataset コンポーネント -

「サンプルデータ作成」

「サンプルデータ作成」プロパティは、TextDataset のサンプルデータ作成に使用します。データを作成するには、あらかじめテキストクエリビルダを使ってフィールドの定義を設定しておく必要があります。

サンプルデータを作成するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フィールド／編集」をクリックするか、テンプレート上のコンポーネントをダブルクリックします。
  3. テキストクエリビルダでレコードを追加します。
  4. 「内容」のをクリックします。
  5. 直接、テキストボックスに数値を入力するか、スピナーコントロールをクリックして作成するレコード行数を指定し、「OK」ボタンをクリックしてください。

サンプルデータの形式

- Aggregate Function コンポーネント -

「関数」

「関数」プロパティは、集計関数を指定します。

利用可能な関数
SUM | 選択されたフィールド全体の合計値を表示します。
AVG | 選択されたフィールド全体の平均値を表示します。
MAX | 選択されたフィールドの最大値を表示します。
MIN | 選択されたフィールドの最小値を表示します。
COUNT | 選択されたフィールドのレコード数を表示します。

関数を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／関数」から、使用する関数を選択します。

※「Dataset」コンポーネントのフィールドを選択する必要があります。


「内容」プロパティ (Chart)

「設定一覧の取得」

コンポーネントのプロパティで設定できる以上の詳細な設定を OPRO X Server (OXS) の設定ファイル (/works/chart/内のXMLファイル) として保存しておくことができます。この「設定一覧の取得」ボタンは、その設定ファイル名の一覧を取得して、下の「設定」プロパティの選択肢に表示させるために使用します。既定の設定を使用する場合は、このボタンを押す必要はありません。

「シングル」・「ダブル」

「ダブル」を選択すると、ひとつのチャートにふたつのプロットを重ね合わせて表示させることができます。だたし、重ね合わせることができるプロットの組み合わせは限られています。

「プロットタイプ」

OPRO X Server は以下のプロットタイプをサポートしています。

Bar, Bar3D
棒グラフとその立体版です。
StackedBar, StackedBar3D
積み上げ棒グラフとその立体版です。
Line, Line3D
折れ線グラフとその立体版です。
Area
面積グラフです。
StackedArea
積み上げ面積グラフです。
XYBar
X値が可変の、棒グラフです。
XYLine
X値が可変の、折れ線グラフです。
XYArea
X値が可変の、面積グラフです。
StackedXYArea
X値が可変の、積み上げ面積グラフです。
Scatter
散布図です。
HighLow
High, Low, Open, Close の4種類の値を使った株価チャートです。系列数は 4 で、High, Low, Open, Closeの順である必要があります。
Candlestick
High, Low, Open, Close の4種類の値を使ったローソク足型の株価チャートです。系列数は 4 で、High, Low, Open, Closeの順である必要があります。
Pie, Pie3D
円グラフとその立体版です。
SpiderWeb
クモの巣グラフ（レーダーチャート）です。

「設定」

「設定一覧の取得」ボタンで取得した設定の一覧からこのコンポーネントで使用する設定を選択します。既定の設定を使用する場合は、空欄にしておいてください。

「凡例」

「凡例を表示する」

チャートの凡例を表示する場合にチェックをオンにします。

「配置」

チャートの凡例を表示する場所を指定します。

「背景色」

チャートの凡例の背景色を指定します。

「定義域」

「タイトル」

定義域のタイトルを指定します。

「範囲」

X値が可変のプロットで、定義域の下限・上限を指定できます。必ずしも指定する必要はありません。指定しない場合は、最大値・最小値で調節した値が自動的に使用されます。

「値域」

「タイトル」

値域のタイトルを指定します。

「範囲」

値域の下限・上限を指定できます。必ずしも指定する必要はありません。指定しない場合は、最大値・最小値で調節した値が自動的に使用されます。

「項目」

「ラベルを表示する」

チャートの各項目値（頂点ごとの値）を表示するかどうかを指定します。表示する場合にチェックをオンにします。

「タイプ」

「内容」の「タイプ」プロパティは、内容の値タイプを選択するのに使用します。「Static ( 内容の値そのものを指定 )」、「Database ( データベースからの値 )」のいずれかのタイプを指定することができます。

タイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」から使用するタイプを選択します。

「Dataset」

「Dataset」プロパティは、Datasetを指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

Dataset を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Database」を選択します。
  3. 「内容／Dataset」で Dataset を選択します。

※あらかじめテンプレートに Dataset、TextDataset、URLTextDataset のいずれかを配置・設定しておく必要があります。

「データを転置する」

データの系列名とレコード行を入れ替えて使用する場合にチェックをオンにします。系列名に相当する値がデータのフィールド名ではなくレコードで与えられる場合に使用します。

「系列数」

「系列数」プロパティは、チャートに表示する系列数（カテゴリー数）を増減させます。

「チャートの表示」

「チャートの表示」ボタンは、チャートの画像のみをプレビュー表示するために使用します。「タイプ」が「Static」の場合のみ使用可能です。

チャートを表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／チャートの表示」をクリックします。


「内容」プロパティ (Graph)

「タイプ」

「内容」の「タイプ」プロパティは、内容の値タイプを選択するのに使用します。「Static ( 内容の値そのものを指定 )」、「Database ( データベースからの値 )」のいずれかのタイプを指定することができます。

タイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」から使用するタイプを選択します。

「Dataset」

「Dataset」プロパティは、Datasetを指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

Dataset を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／タイプ」で「Database」を選択します。
  3. 「内容／Dataset」で Dataset を選択します。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。

「シングル」

「シングル」プロパティは、グラフを一つだけ選択します。二つのグラフを描画するには「マルチ」オプションを選択します。

「シングル」プロパティを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／シングル」をクリックします。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、「シングル」プロパティを使用した一つのグラフ ( Bar ) です。

「マルチ」

「マルチ」プロパティは、別のグラフを選択するために使用します。

マルチを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／マルチ」をクリックします。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、「マルチ」プロパティを使用して二つのグラフ ( Bar と Plot ) を組み合わせたものです。

「Graph」

「ポイント」

「回転角度」

「回転角度」プロパティは、グラフの回転角度を指定するために使用します。

グラフを回転するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／回転角度」から、回転角度を選択します。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、時計回りに90度回転させた Bar グラフです。

「フォントサイズ」

「フォントサイズ」プロパティは、ポイントのフォントサイズを変更します。

フォントサイズを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／フォントサイズ」から、必要なフォントサイズを選択します。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、「フォントサイズ」を14ポイントまで増加させた Bar グラフです。

「表題」

「表題」プロパティは、グラフの表題を指定するために使用します。

表題を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／表題」に表題を入力します。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、「1,2,3月の製品売上」という表題を付けた Bar グラフです。

「グラフ種類」

OXDでは BAR, PLOT, CANDLE, SCATTER PLOT, AREA, STACKING AREA, STACKING BAR, PIE, HILO, HILO OPEN CLOSE のグラフ種類をサポートしています。

BAR

BAR グラフ ( 棒グラフ ) は、個々の項目毎の量を長短のバーで示します。

PLOT

PLOT グラフ ( 折れ線グラフ ) は、特定のカテゴリにおける一定期間の傾向を比較するのに使用されます。

CANDLE

CANDLE グラフ ( ロウソク足グラフ ) は、High, Low, Open, Close の4種類の値を使って株価情報等を表示します。芯線のサイズは High/Low 値で決定し、バーのサイズは Open/Close 値で決定します。株価が上がった場合と下がった場合の色を変えて示します。

SCATTER PLOT

SCATTER PLOT グラフ ( 散布図 ) は、特定のカテゴリの値に従って散布した打点を比較するのに使用されます。

AREA

AREA グラフ ( 領域グラフ ) は、期間または特定のカテゴリにおける傾向を比較するのに使用されます。

STACKING AREA

STACKING AREA グラフ ( 積み重ね領域グラフ ) は二つ以上の系列値が相互に積み重ねられた Area グラフです。それぞれの系列値の合計を示したい場合に、このグラフを使用することができます。

STACKING BAR

STACKING BAR グラフ ( 積み重ね棒グラフ ) は2つ以上の系列値が相互に積み重ねられた Bar グラフです。それぞれの系列値の合計を示したい場合に、このグラフを使用することができます。

PIE

PIE グラフ ( 円グラフ ) は、個々の項目の割合が、それぞれ全体のどの程度になるのかを示します。

HILO

HILO グラフは、High/Low 値を使って株価情報等を表示します。Hilo 線の長さは High/Low 値で決まります。

HILO OPEN CLOSE

HILO OPEN CLOSE グラフは、High, Low, Open, Close の4種類の値を使って株価情報等を表示します。芯線の左側の短線は初値を示し、右側の短線は終値を示します。

グラフ種類を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／グラフ種類」から使用する種類を選択します。

※HILO OPEN CLOSE や CANDLE を表示するには、最低四つの系列値が必要となります。また、HILO グラフを表示するには、最低二つの系列値が必要です。その他のグラフ ( BAR, PLOT, SCATTER PLOT, AREA, STACKING AREA, STACKING BAR, PIE ) は一つの系列値のみで表示することができます。

「系列数」

「系列数」プロパティは、グラフに表示する系列数を増減させます。

系列数を増減するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／系列」テキストボックスのスピナーコントロールをクリックするか、または直接値を入力して指定します。

「グラフの表示」

「グラフの表示」ボタンは、グラフの画像のみをプレビュー表示するために使用します。「タイプ」が「Static」の場合のみ使用可能です。

グラフを表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／グラフの表示」をクリックします。


「デバイスフォント」プロパティ

「デバイスフォント一覧の取得」

SATOLabel のデバイスフォント一覧を取得できます。フォント一覧を取得するには、リクエスト先の OXS に接続されているターゲットサーバ ( OIPS ) を、「デバイスフォント一覧の取得」ウィンドウから選択する必要があります。

デバイスフォント一覧を取得するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「デバイスフォント／デバイスフォント一覧の取得」をクリックします。
  3. 「デバイスフォント一覧の取得」ウィンドウで、「サーバ」ドロップダウンからサーバを選択します。
  4. 「プリンタ」ドロップダウンから、使用するプリンタを選択し、「OK」ボタンをクリックすると、デバイスフォントがすべて表示されます。


「フィールド」プロパティ

「編集」

クエリビルダを呼び出して、条件式または式を変更し、Dataset のデータをフィルタリングすることができます。

Datasetを編集するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フィールドの情報／編集」をクリック、またはテンプレート上の「Dataset」コンポーネントをダブルクリックします。

「読込」

Dataset に「.oqm( OPRO Query Maker )」ファイルを追加します。「.oqm」ファイルは、クエリビルダを使用して生成します。

「.oqm」ファイルを読み込むには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フィールドの情報／読込」をクリックします。
  3. 「.oqm」ファイルを選択し、「OK」ボタンをクリックします。

「保存」

「.oqm ( OPRO Query Maker )」ファイルを保存します。

「.oqm」ファイルを保存するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フィールド／保存」をクリックします。
  3. 保存するファイル名を入力、または選択し、「OK」ボタンをクリックします。

※OQMファイルは、クエリビルダで作成されたクエリ定義ファイルです。

- TextDataset コンポーネント -

「編集」

「編集」プロパティは、テキストクエリビルダを呼び出し、フィールドの定義やテーブルのファイル形式を指定するために使用します。

ファイル形式を編集するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フィールド／編集」をクリックするか、テンプレート上の「TextDataset」コンポーネントをダブルクリックします。


「フォント」プロパティ

「フォント」

フォント名を指定します。

フォントの書体を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／フォント」から使用するフォントを選択します。

PDF でサポートされているフォントは、 [image] アイコン付きでリストされます。適切な PDF 出力を得るためには、PDF で使用されているフォントを、ユーザ ( クライアント ) だけでなく、サーバにもインストールしておく必要があります。

「文字飾り」

「サイズ」

フォントのサイズを指定します。

フォントのサイズを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／サイズ」から使用するサイズを選択します。

「色」

フォントの色を指定します。

フォントの色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／色」から使用する色を選択します。

「取り消し線」

取り消し線の表示／非表示を指定します。

取り消し線を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／取り消し線」をクリックします。

「太字」

太字にするかどうかを指定します。

太字を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／太字」をクリックします。

「下線」

下線の表示／非表示を指定します。

下線を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／下線」をクリックします。

「イタリック」

イタリックにするかどうかを指定します。

イタリックを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／イタリック」をクリックします。

「ユーザ外字」

ユーザ外字を使用するかどうかを指定します。

ユーザ外字を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／ユーザ外字」をクリックします。

「CJK」

CJKを使用するかどうかを指定します。

CJKを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「フォント／文字飾り／CJK」をクリックします。


「表示形式」プロパティ

「種類」

「種類」プロパティは、「日付」、「時刻」、または「日付と時刻」を選択します。

種類を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「表示形式／種類」から、必要な種類を選択します。

「日付」

「日付」プロパティは、日付の表示形式を選択します。

日付の表示形式を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「表示形式／日付」から、必要な日付の表示形式を選択します。

参照：日時の表示形式

「時刻」

「時刻」プロパティは、時刻の表示形式を選択します。

時刻の表示形式を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「表示形式／時刻」から、必要な時刻の表示形式を選択します。

参照：日時の表示形式


「全般」プロパティ

「名前」

コンポーネントの識別名を指定します。

使用可能な文字は以下の通り。

数値：0123456789
文字：ABCDEFGHIJKLMNOPQRSTUVWXYZabcdefghijklmnopqrstuvwxyz
特殊文字：_-@

名前は文字で始まる必要があります。

名前を入力するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「全般／名前」に名前を入力します。

「位置とサイズ」

コンポーネントの位置とサイズを指定します。

「位置とサイズ」を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「全般／位置とサイズ」テキストボックスに値を直接入力するか、スピナーコントロールをクリックして値を指定します。

「枠線」

枠線ボックスの四方をクリックして、枠線のオン／オフを行なえます。

「サイズ」

枠線のサイズ ( 太さ ) を指定します。

枠線の太さを変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「全般／枠線／サイズ」テキストボックスに値を直接入力するか、スピナーコントロールをクリックして値を指定します。

「色」

枠線の色を指定します。

枠線の色を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「全般／枠線／色」から使用する色を選択します。

「外観」

「可視」

コンポーネントの表示／非表示を指定します。

可視／不可視を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「全般／外観／可視」をクリックします。

「透過」

コンポーネントの透過／不透過を指定します。

透過を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「全般／外観／透過」をクリックします。

「ドラッグ禁止」

「ドラッグ禁止」プロパティは、そのコンポーネントの移動や、幅、高さの変更に関するマウスイベントを禁止するために使用します。ただし、キー操作からはそれらの変更を実行できます。例えば、サイズの変更は「Shift + 矢印キー」、移動は「Shift + Ctrl + 矢印キー」で実行することができます。

ドラッグ禁止を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「全般／外観／ドラッグ禁止」をクリックします。

- テンプレート -

「背景色」

「背景色」プロパティは、テンプレートの背景色を指定します。

テンプレートの背景色を変更するには

  1. テンプレートを配置し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「背景色」ドロップダウンボックスをクリックし、使用する色を選択します。


「グリッド」プロパティ

「間隔」

「間隔」プロパティは、グリッドの間隔を変更するために使用します。

グリッドの間隔を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 値を入力するか、「グリッド」で「間隔」テキストボックスのボタンをクリックして値を選択します。

「可視」

「可視」プロパティは、「InterfaceGroup」コンポーネントのグリッドの表示／非表示を指定するために使用します。

グリッドの表示と非表示を切り替えるには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「グリッド／可視」チェックオプションをクリックし、有効にします。

「色」

「色」プロパティは、「InterfaceGroup」コンポーネントのグリッド色を選択するのに使用します。グリッド色を指定するには、「可視」プロパティがチェックされている必要があります。

グリッドの色を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「可視」をクリックして、「グリッド」の色を選択できるようにします。
  3. 「色」ドロップダウンから使用する色を選択します。


「ハイパーリンク」プロパティ

「ハイパーリンクを有効にする」

「ハイパーリンクを有効にする」プロパティは、「ハイパーリンク／URL」で指定されるハイパーリンクを Label コンポーネントに設定するために使用します。

ハイパーリンクを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「ハイパーリンク／ハイパーリンクを有効にする」をクリックします。

「タイプ」

「ハイパーリンク」の「タイプ」プロパティは、ハイパーリンク値の取得タイプを選択するのに使用します。「Static (ハイパーリンク値そのものを指定)」、「Request (ユーザのリクエスト値)」、「Database (データベースからの値)」のいずれかのタイプを指定することができます。

タイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「ハイパーリンク／タイプ」から使用するタイプを選択します。
「Static」
「Static」タイプを選択した場合、設計時にコンポーネントに入力されたハイパーリンクは、OPR、PDF、または、HTMLで表示される同じコンポーネントに挿入されます。
「Request」
「Request」タイプを選択した場合、ハイパーリンクのパスを、サンプルHTMLでプレビュー、または、入力する前に、ポップアップウィンドウで入力する必要があります。
「Database」
「Database」タイプを選択した場合、表示するハイパーリンクパスは、選択されているデータベースフィールドから抽出されます。

「URL」

「URL」プロパティは、URL パスを指定するのに使用します。「タイプ」として「Static」を選択した場合に限り、このプロパティが表示されます。

URL を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「ハイパーリンク／ハイパーリンクを有効にする」チェックオプションをクリックし、有効にします。
  3. 「ハイパーリンク／タイプ」で「Static」を選択します。
  4. 「ハイパーリンク／URL」に URL を入力します。

「リクエストパラメータ名」

「リクエストパラメータ名」プロパティは、リクエストパラメータ名を指定するのに使用します。「タイプ」として「Request」を選択した場合に限り、このプロパティが表示されます。

リクエストパラメータ名を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「ハイパーリンク／ハイパーリンクを有効にする」チェックオプションをクリックし、有効にします。
  3. 「ハイパーリンク／タイプ」で「Request」を選択します。
  4. 「ハイパーリンク／リクエストパラメータ名」にリクエストパラメータ名を入力します。

「Dataset」

「Dataset」プロパティは、Datasetを指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

Dataset を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「ハイパーリンク／ハイパーリンクを有効にする」チェックオプションをクリックし、有効にします。
  3. 「ハイパーリンク／タイプ」で「Database」を選択します。
  4. 「ハイパーリンク／Dataset」で Dataset を選択します。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。

「フィールド」

「フィールド」プロパティは、フィールドを指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

フィールドを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「ハイパーリンク／ハイパーリンクを有効にする」チェックオプションをクリックし、有効にします。
  3. 「ハイパーリンク／タイプ」で「Database」を選択します。
  4. 「ハイパーリンク／Dataset」で Dataset を選択します。
  5. 「ハイパーリンク／フィールド」でフィールドを選択します。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。


「レイアウト設定」プロパティ

「単位」

「単位」プロパティは、OXD のレイアウトで使用する測定単位を選択します。

単位を設定するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「レイアウトの設定／単位」ドロップダウンから、使用する単位を選択します。

「マージン」

「左」「右」「上」「下」

「マージン」プロパティは、ページの四辺との距離を設定します。

マージンの位置を設定するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「レイアウトの設定／マージン」で「左」「右」「上」「下」のテキストボックスに値を入力するか、またはスピナーコントロールをクリックします。

※レイアウトで割り当てられるマージンは、生成・出力されるドキュメントには影響しません。

「用紙サイズ」

「用紙サイズ」プロパティは、テンプレートに適用する出力用紙サイズを設定します。選択した用紙サイズがプリンタでサポートされていない場合は、デフォルトの用紙サイズが使用されます。

用紙サイズを指定するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「レイアウトの設定／用紙サイズ」ドロップダウンボックスから、使用するサイズを選択します。

参考：用紙サイズと用紙の向き

「高さ」「幅」

「高さ」と「幅」プロパティは、選択されたレイアウトの縦方向の用紙サイズ指定します。

用紙の高さと幅を指定するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「レイアウトの設定」で、「高さ」または「幅」のテキストボックスに値を入力するか、上向き、または、下向きの矢印ボタンをクリックします。

参考：用紙サイズと用紙の向き

「用紙の向き」

「縦」「横」

テンプレートを縦方向(垂直)または横方向(水平)に印刷することを指定します。

縦方向／横方向の印刷を指定するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「縦」または「横」ボタンをクリックします。

「用紙サイズ」が「Custom」の場合は、つねに「縦」の扱いになります。

「表示/非表示」

「次の条件でレイアウトを隠す」

「次の条件でレイアウトを隠す」プロパティは、サーバ側からのプレビューのレイアウトを隠すために使用します。

レイアウトを隠すには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「表示／非表示」の下の「次の条件でレイアウトを隠す」チェックボックスをクリックします。
  3. 「{USERINPUT}」テキストボックスに一意なレイアウトIDを入力します。

「繰り返し設定」

「繰り返さない」

「繰り返さない」プロパティはレコードの表示を2ページ目以降に出さないようにする場合に使用します。これを選択しないと、レコードが2ページ目以降にも出力されます。レイアウトが複数ある場合は、それぞれ個々に「繰り返さない」プロパティを指定する必要があります。

「繰り返さない」を指定するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「繰り返し設定／繰り返さない」を選択します。


「操作」プロパティ

「磁石モード」

二つのコンポーネントを接触させることができます。あるコンポーネントを別のコンポーネントの近くに移動すると、二つのコンポーネントが接触していることを示す赤の境界線がコンポーネントの周囲に表示されます。
「磁石モード」オプションは、二つのコンポーネントを自動的に接合することができます。一つのコンポーネントを別のコンポーネントの近くに移動すると、二つのコンポーネントが接触していることを示す赤の境界線がコンポーネントの周囲に表示されます。

磁石モードにするには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「磁石モード」オプションをクリックします。

「グリッド」

「間隔」

「間隔」プロパティは、テンプレートのグリッドの間隔をピクセル単位で変更します。

グリッドの間隔を変更するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「グリッド／間隔」オプションの上向き、または、下向きの矢印ボタンをクリックします。

「スナップ」

「スナップ」プロパティは、マウスドラッグでコンポーネントを移動させるときに、コンポーネントの位置をグリッドに合わせるかどうかを指定します。

スナップを指定するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「グリッド／スナップ」オプションをクリックします。

または

  1. テンプレートウィンドウの「グリッドにあわせる」ボタンをクリックします。

※テンプレートにコンポーネントを配置して移動すると、このオプションの効果の違いがわかります。

「スタイル」

「スタイル」プロパティはコンポーネントの移動スタイルを指定します。「スナップ」プロパティが有効な場合のみ、「スタイル」プロパティは使用することができます。「スタイル」プロパティには「Absolute」、「Relative」のいずれかが指定できます。

「Absolute」
テンプレート上に配置したコンポーネントをマウスで移動すると、レイアウトにマークされているグリッドポイントに沿ってポイント間を移動します。

「Relative」
テンプレート上に配置したコンポーネントをマウスで移動すると、グリッド間の距離を単位として元の位置から移動します。

スタイルを指定するには

  1. テンプレートにコンポーネントを配置します。
  2. 「グリッド／可視」チェックオプションと「スナップ」チェックオプションを有効にして、グリッドを表示すると同時にテンプレートのプロパティでスナップを有効にします。
  3. 「Absolute」または「Relative」を選択します。
  4. コンポーネントを移動すると、グリッドポイント間をコンポーネントが移動します。

「可視」

「可視」プロパティは、テンプレートのグリッドを表示、または、非表示にします。

グリッドの表示と非表示を切り替えるには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「グリッド／可視」をクリックします。

「色」

「色」プロパティは、グリッドの色を指定します。

色を選択するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「グリッド／色」ドロップダウンボックスをクリックし、使用する色を選択します。


「パスワード」プロパティ

「マスタ」

「パスワード」

ドキュメントの権限を変更可能にするには、マスタ・パスワードを設定する必要があります。ドキュメントを開くときにこのパスワードが入力された場合、フルアクセス権限が与えられます。

マスタ・パスワードを設定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「パスワード／マスタ／パスワード」にパスワード文字列を入力します。

※「マスタ」に入力するパスワードの最大長は15文字です。

「ユーザ」

「パスワード」

ドキュメントを保護し、誰でも開くことができないようにするには、ユーザ・パスワードを設定する必要があります。このパスワードは、ドキュメントを開こうとしたとき、OXB 等のビューアから要求されます。

ユーザ・パスワードを設定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「パスワード／ユーザ／パスワード」にパスワード文字列を入力します。

※「ユーザ」に入力するパスワードの最大長は15文字です。


「セキュリティ」プロパティ

「操作の許可」

作成されるドキュメントで許可する操作を指定します。

「文書の印刷」

ドキュメントの印刷を許可します。

「低解像度のみ」

低解像度でのみ、ドキュメントの印刷を許可します。PDFでのみサポートされています。

「内容のコピーと抽出」

ドキュメントのテキストや画像等のコピーを許可します。PDF、DocuWorksでのみサポートされています。PDFでは、リーダーデバイス等による内容へのアクセスも許可します。

「アクセシビリティ用のみ」

リーダーデバイス等による内容へのアクセスのみを許可します。PDFでのみサポートされています。

「文書の変更」

ドキュメントの変更の許可の種類を指定します。ドキュメントタイプによって有効な選択値が異なります。また、3個のドロップダウンは、連動して選択値が変更されます。

ドキュメントタイプ | 有効な選択値 | 効果
OXB | 許可 | ドキュメントの変更を許可します。
 | 許可しない | ドキュメントの変更を許可しません。
PDF | 許可 | ドキュメントの変更を許可します。
 | 編集、フォームの入力と署名、ページの挿入・削除・回転のみ | 注釈の編集は行えません。
 | 注釈の編集、フォームの入力と署名のみ | 文書の編集、ページの挿入・削除・回転は行えません。
 | フォームの入力と署名のみ | 文書の編集、注釈の編集、ページの挿入・削除・回転は行えません。
 | ページの挿入・削除・回転のみ | 文書の編集、注釈の編集、フォームの入力と署名は行えません。
 | 許可しない | ドキュメントの変更を許可しません。
DocuWorks | 許可 | ドキュメントの変更を許可します。
 | 編集のみ | アノテーションの編集は行えません。
 | アノテーションの編集のみ | 文書の編集は行えません。
 | 許可しない | ドキュメントの変更を許可しません。

「動作の強制」

ドキュメントを表示するアプリケーションに、強制的に行わせる動作を指定します。

「閉じた時に文書を削除」

ドキュメントを閉じたとき、または、印刷後にドキュメントを削除します。OXBでのみサポートされています。

セキュリティを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「セキュリティ」プロパティの各チェックボックス、および、ドロップダウンで、操作の許可と動作の強制を設定します。


「罫線」プロパティ

「罫線」プロパティは、コンポーネントに境界線を付記します。境界線の描画には、「罫線」に含まれているラインのみが使用できます。

描画する辺
 | コンポーネントのすべての境界に線を描画します。
 | コンポーネントの外枠と横線を描画します。
 | コンポーネントの横線のみを描画します。
 | コンポーネントで選択されている境界線をすべて削除します。

境界線を描画するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 必要な「罫線」をクリックします。


「スクリプト」プロパティ

「編集」

DBExecute エディタを開きます。このエディタはスクリプトを記述するために使用されます。

編集を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「スクリプト／編集」をクリックするか、テンプレート上に配置した「DBexecute」コンポーネントをダブルクリックします。

「実行しない」

「実行しない」プロパティは、スクリプトを使用不可にするオプションです。

「実行しない」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「スクリプト／実行しない」をクリックします。

「スクリプト」

編集・追加したスクリプト一覧が表示されます。「下に移動」「上に移動」ボタンでスクリプトを実行する順番を変更することができます

スクリプト実行順序を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「スクリプト／スクリプト」で、移動したいスクリプトを選択します。
  3. 「下に移動」または「上に移動」ボタンをクリックします。

「実行タイミング」

「ドキュメント生成前」

ドキュメント生成前にスクリプトを実行します。

「ドキュメント生成前」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「スクリプト／ドキュメント生成前」チェックオプションをクリックして有効にします。

「ドキュメント生成後」

ドキュメント生成後にスクリプトを実行します。

「ドキュメント生成後」を選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「スクリプト／ドキュメント生成後」チェックオプションをクリックして有効にします。


「設定」プロパティ

「バーコードタイプ」

OXD では、Code39, JAN-13, JAN-8, EAN-13, EAN-8, NW-7, ITF, UPC-A, UPC-E, CUSTOMER, GS1-128, QR Code, Micro QR Code 等のバーコードタイプをサポートします。「BarCode」コンポーネントで「チェックデジット」オプションを選択すると、システムによりチェックデジットが作成されて、バーコードに付加されます。

Code39

Code39 コードは英数字といくつかの記号をコード化します。

Code39 コードで使用可能な文字
英字 | A - Z
数字 | 0 - 9
記号 | $ % + - . / スペース

JAN-13

JAN-13 コードは 12 桁の数字をコード化します。

JAN-13 コードで使用可能な文字
数字 0 - 9

JAN-8

JAN-8 コードは 7 桁の数字をコード化します。

JAN-8 コードで使用可能な文字
数字 0 - 9

EAN-13

EAN-13コードは 12 桁の数字をコード化します。

EAN-13 コードで使用可能な文字
数字 0 - 9

EAN-8

EAN-8 コードは 7 桁の数字をコード化します。

EAN-8 コードで使用可能な文字
数字 0 - 9

NW-7

NW-7 コードは桁数無制限で、英数字といくつかの記号をコード化します。

NW-7 コードで使用可能な文字
英字 | A - D、a - d
数字 | 0 - 9
記号 | $ + - . /

※先頭と最後の文字は A, B, C, D, a, b, c, d のいずれかでなければなりません。

ITF

ITF コードは数字をコード化します。数値の桁数が奇数でチェックデジットを使用しない場合、先頭に 0 が付加されます。例えば 123 と入力すると、桁数が 3 なので、対応するバーコードは 0123 となります。チェックデジットを使用する場合は、数値の最後にチェックデジットが付加されるので先頭に 0 が付加されることはありません。たとえば 123 と入力すると、チェックデジットが計算され、対応するバーコードは 1236 となります。入力できる桁数は無制限となっています。

ITF コードで使用可能な文字
数字 0 - 9

UPC-A

UPC-A コードは 11 桁の数字をコード化します。

UPC-A コードで使用可能な文字
数字 0 - 9

UPC-E

UPC-E コードは数字をコード化します。出力される値の桁数は入力した数値によって異なります。ただし、入力する数値は 11 桁でなければなりません。

計算方式
2 桁目から 6 桁目までの 5 文字はメーカーコードと呼ばれ、7 桁目から 11 桁目までの 5 文字は製品コードと呼ばれます。

  • メーカーコードの下 3 桁が 000, 100, 200 の場合
    メーカーコードの上 2 桁 + 製品コードの下 3 桁 + メーカーコードの 3 桁目
    例：0 42100 00526 --> 425261 ( 製品コードは 00000 - 00999 の範囲内であること )
  • メーカーコードの下 2 桁が 00 であり、上記の #1 に該当しない場合
    メーカーコードの上 3 桁 + 製品コードの下 2 桁 +3 ( 製品コードは 00000 - 00099 の範囲内であること )
  • メーカーコードの下 1 桁が 0 であり、上記の #1 および #2 のいずれにも該当しない場合
    メーカーコードの上 4 桁 + 製品コードの下 1 桁 +4 ( 製品コードは 00000 - 00009 の範囲内であること )
  • 数値の下 1 桁が 0 以外の場合
    メーカーコードの全 5 桁 + 製品コードの下 1 桁( 5 - 9 の範囲内 ) ( 製品コードは 00005 - 00999 の範囲内であること )
UPC-E コードで使用可能な文字
数字 0 - 9

CUSTOMER

CUSTOMER コードは桁数無制限で、英数字とハイフン ( - ) をコード化します。

CUSTOMER コードで使用可能な文字
英字 | A - Z, a - z
数字 | 0 - 9
記号 | -

※大文字小文字は区別されません。テキストは出力されません。

GS1-128

GS1-128 コードは英数字をコード化します。与えるデータの形式は、以下のようになっていなければいけません。

"(" + AI1 + ")" + DATA1 + "(" + AI2 + ")" + DATA2 + ...  + "(" + AIm + ")" + DATAm

ここで、mは1以上の整数、AInはn番目のアプリケーション識別子、DATAnはそれに対するデータです。DATAnに含まれるコントロールコードとスペースとハイフン ( - )は無視されます。DATAnの最大長は、アプリケーション識別子によって決まります。それより短いデータが与えられた場合は、CODE128コードのFNC1キャラクタが区切り文字として挿入されます。mが1、AI1が"91"、DATA1の長さが41桁か42桁の場合は、料金代理収納用のバーコードであると見なされます。41桁の場合、42桁目は自動的に計算されます。

GS1-128 コードで使用可能な文字
英字 | A - Z, a - z
数字 | 0 - 9
記号 | -, (, ), スペース

※大文字小文字は区別されます。

QR Code

QR Code は英数字、および、シフトJISの日本語文字列をコード化する二次元コードです。バーコードの大きさを表す 1 から 40 までの型番と L, M, Q, H の誤り訂正レベルがあります。型番と誤り訂正レベルによってデータの最大長が決まります。最大長を超えるデータが与えられた場合、誤り訂正レベルは自動的に L に下げられます。それでも最大長を超える場合は、自動的に型番が上げられます。

QRコードは(株)デンソーウェーブの登録商標です。

Micro QR Code

Micro QR Code も QR Code と同様に、ASCII、および、シフトJISの日本語文字列をコード化する二次元コードです。バーコードの大きさを表す M1 から M4 までの型番と L, M, Q の誤り訂正レベルがあります。

バーコードタイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／バーコードタイプ」から使用するタイプを選択します。

「テキスト表示」

バーコード画像の直下に、バーコードの内容をテキストで表示します。

バーコードの内容をテキスト表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／テキスト表示」をクリックします。
  3. 「内容／内容」に、テキスト内容を入力します。
  4. 「内容／バーコードの表示」をクリックします。

「チェックデジット」

バーコードへのチェックデジットの追加を有効または無効にします。これは、システムで自動的に生成される数値です。チェックデジットはユーザが選択または選択解除できます。

チェックデジットを有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定」をクリックし、「チェックデジット」をクリックします。

「基準幅」

バーコードの縦線の基準幅をピクセル単位で指定します。

利用可能な基準幅
Thin | 線の基準幅を 1 ピクセルに指定します。
Normal | 線の基準幅を 2 ピクセルに指定します。
Thick | 線の基準幅を 3 ピクセルに指定します。

基準幅を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／内容」に、バーコード表示させる内容を入力します。
  3. 「設定／基準幅」で、使用する基準幅のタイプを選択します。

「型番」

QR Code, Micro QR Code の型番を指定します。

「誤り訂正」

QR Code, Micro QR Code の誤り訂正レベルを指定します。

「回転」

「回転」プロパティは、バーコードの画像を 0, 90, 180, 270 度、時計回りに回転させるのに使用します。

バーコードの画像を回転させるには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／回転」プロパティにある角度( 0, 90, 180, 270 度 )ボタンをクリックします。
  3. 「内容／バーコードの表示」をクリックします。
  4. バーコードの画像が指定した角度に回転します。


「設定」プロパティ

「ヘッダ」

「ヘッダ」プロパティは、グラフのヘッダを指定するのに使用します。

ヘッダを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／ヘッダ」に名前を入力します。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、ヘッダに「会社の月間売上高」と題した Bar グラフです。

「フッタ」

「フッタ」プロパティは、グラフのフッタを指定するのに使用します。

フッタを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／フッタ」に名前を入力します。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、フッタに「2005年1月-3月の売上」と題した Bar グラフです。

「表題」

「配置」

「配置」プロパティは、グラフに表示する表題の位置を指定するのに使用します。 配置できる位置は、左上、中央上、右上、左中央、右中央、左下、中央下、右下のいずれかです。

表題の位置を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容／表題」に表題を入力し、「設定／表示する」をクリックします。
  3. 「設定／配置」で、表題を配置する位置をクリックします。
  4. 「内容／グラフの表示」ボタンをクリックします。

下図は、「1,2,3月の製品売上」という「表題」の配置を真ん中の上( 「北」の位置 )に変更した Bar グラフです。

「表示する」

「表示する」プロパティは、表題を表示または非表示するために使用します。

表題の表示を有効にするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／表示する」をクリックします。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、「1,2,3月の製品売上」という表題を付けた Bar グラフです。

「整列方法」

「整列方法」プロパティは、グラフに表示する表題の整列方法を垂直( Virtical )、または 水平( Horizontal )に指定します。

表題の整列方法を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／整列方法」から、必要な整列方法を選択します。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、「1,2,3月の製品売上」という「表題」を垂直に表示した Bar グラフです。

「外観」

「背景色」

「背景色」プロパティは、グラフの背景色を選択できます。

背景色をセットするには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／背景色」から使用する色を選択します。
  3. 「内容／グラフの表示」ボタンをクリックします。

下図は、「背景色」に水色を指定した Bar グラフです。

「回転」

「回転」プロパティは、グラフの画像を 0, 90, 180, 270 度、時計回りに回転させるのに使用します。

グラフの画像を回転させるには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／回転」プロパティにある角度( 0, 90, 180, 270 度 )ボタンをクリックします。
  3. 「内容／グラフの表示」をクリックします。
  4. グラフの画像が指定した角度に回転します。

下図は、時計回りに 90 度回転させたグラフです。


「設定」プロパティ

- Page Number コンポーネント -

「番号の割付」

「番号の割付」プロパティは、レイアウト／テンプレート／ドキュメント単位のいずれの割付方法でページ番号を表示するかを指定します。このプロパティのオプションは、「レイアウト単位」「テンプレート単位」「ドキュメント単位」で、デフォルトは「レイアウト単位」になっています。

例：

以下のドキュメント構造を参照してください。

ここに、二つのテンプレート( Template-1 と Template-2 )を含む一つのドキュメントがあります。
Template-1 には、一つのレイアウト( Layout-1 )があります。Layout-1 は3ページです。
Template-2 には、二つのレイアウト( Layout-1 と Layout-2 )があります。Layout-1 は2ページ、Layout-2 は1ページです。

レイアウト単位

「番号の割付／レイアウト単位」オプションは、テンプレートにある個々のレイアウト単位にページ番号を割り付けます。
上記の例に従って「レイアウト単位」オプションを選択すると、ページの割付は以下のようになります。

Template-1 の Layout-1 に「Page Number」コンポーネントを配置すると、3ページで構成された Layout-1 のページ番号には 1 から 3 が割り付けられます。
Template-2 の Layout-1 に「Page Number」コンポーネントを配置すると、2ページで構成された Layout-1 のページ番号には 1 から 2 が割り付けられます。
Template-2 の Layout-2 に「Page Number」コンポーネントを配置すると、1ページで構成された Layout-1 のページ番号には 1 が割り付けられます。

テンプレート単位

「番号の割付／テンプレート単位」オプションは、ドキュメントのテンプレート単位にページ番号を割り付けます。
上記の例に従って「テンプレート単位」オプションを選択すると、ページの割付は以下のようになります。

Template-1 に「Page Number」コンポーネントを配置すると、3ページで構成された Template-1 のページ番号には 1 から 3 が割り付けられます。
2ページで構成された Layout-1 と 1 ページで構成された Layout-2 をもつ計 3 ページ構成の Template-2 に「Page Number」コンポーネントを配置すると、Template-2 のページ番号には 1 から 3 が割り付けられます。

ドキュメント単位

「番号の割付／ドキュメント単位」オプションは、ドキュメント全体にページ番号を割り付けます。
上記の例に従って「ドキュメント単位」オプションを選択すると、ページの割付は以下のようになります。

Template-1 に Layout-1, Template-2 に Layout-1 と Layout-2 のページをもつ全 6 ページで構成されたドキュメントに「Page Number」コンポーネントを配置すると、ドキュメントのページ番号には 1 から 6 が割り付けられます。

高度なページ番号の割付方法

ここに、二つのテンプレート( Template-1 と Template-2 )を含むドキュメントがあるとします。
Template-1 には、一つのレイアウト( Layout-1 )があります。
Template-2 には、四つのレイアウト( Layout-1, Layout-2, Layout-3, Layout-4 )があります。

例：

「Page Number」コンポーネント A は、ドキュメント全体の 18 ページ目から始まる Layout-3 に置かれ、「番号の割付」は「ドキュメント単位」とします。そして、このドキュメントの構成は、Template-1 に Layout-1, Template-2 に複数レイアウトがあるものとします。
「Page Number」コンポーネント B は、Template-2 の 8 ページ目から始まる Layout-3 に置かれ、「番号の割付」は「テンプレート単位」とします。そして、このドキュメントの Template-2 には Layout-1～4 があるものとします。
「Page Number」コンポーネントCは、Layout-3 に置かれ、「番号の割付」は「レイアウト単位」とします。

「番号の割付」プロパティの単位タイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 単位タイプ( レイアウト単位、テンプレート単位、ドキュメント単位 )を「設定／番号の割付」ドロップダウンから選択します。

※以下のようなプロパティ値に設定された「Page Number」コンポーネントを持つ、OXD バージョン 2.5.0 以前のテンプレートを開いた場合；

「最初のページを表示する」がチェックされている。
「最後のページを表示する」がチェックされていない。
「内容」が「#」記号を含んでいない。

「番号の割付」は「ドキュメント単位」に変更されます。

「最初のページを表示する」

「最初のページを表示する」プロパティは、レイアウト単位、テンプレート単位、ドキュメント単位の最初のPage Numberを表示、または、非表示にするのに使用します。このプロパティは既定でチェックされています。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。
二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Page Number」コンポーネントを配置します。
Layout-1 は 3 ページ、そして Layout-2 は 2 ページで構成されているので、Layout-1 の「Page Number」コンポーネントは 1～3 の番号を、Layout-2 の「Page Number」コンポーネントは 1～2 の番号をページに割付するでしょう。

Layout-1 に配置した「Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最初のページを表示する」プロパティのチェックを外します。すると、Layout-1 の最初のページはページ番号を表示しないでしょう。

同様に、Layout-2 に配置した「Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最初のページを表示する」プロパティでチェックを外します。これで、Layout-1 と Layout-2 の最初のページがページ番号を表示しないでしょう。

このプロパティが「番号の割付」プロパティに指定された単位によって、どのように反応が変化するかを参照しましょう。

上記の例から、「最初のページを表示する」プロパティは以下の通り適用します。

「ドキュメント単位」では、このプロパティが適用されるページはドキュメント全体の最初のページです。
「テンプレート単位」では、このプロパティが適用されるページは、Template-1 の最初のページと Template-2 の最初のページです。
「レイアウト単位」では、Template-1 / Layout-1 の最初のページ、Template-2 / Layout-1 の最初のページ、Template-2 / Layout-2 の最初のページ、Template-2 / Layout-3 の最初のページ、および Template-2 / Layout-4 の最初のページに適用されます。

最初の Page Number を表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／最初のページを表示する」チェックボックスのチェックを入れるか、または外します。

「最後のページを表示する」

「最後のページを表示する」プロパティは、レイアウト単位、テンプレート単位、ドキュメント単位の最後のPage Numberを表示、または、非表示にするのに使用します。このプロパティは既定でチェックされています。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。
二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Page Number」コンポーネントを配置します。
Layout-1 は 3 ページ、そして Layout-2 は 2 ページで構成されているので、Layout-1 の「Page Number」コンポーネントは 1～3 の番号を、Layout-2 の「Page Number」コンポーネントは 1～2 の番号をページに割付するでしょう。

Layout-1 に配置した「Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最後のページを表示する」プロパティのチェックを外します。すると、Layout-1 の最後のページはページ番号を表示しないでしょう。

同様に、Layout-2 に配置した「Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最後のページを表示する」プロパティでチェックを外します。これで、Layout-1 と Layout-2 の最後のページがページ番号を表示しないでしょう。

このプロパティが「番号の割付」プロパティに指定された単位によって、どのように反応が変化するかを参照しましょう。

上記の例から、「最後のページを表示する」プロパティは以下の通り適用します。

「ドキュメント単位」では、このプロパティが適用されるページはドキュメント全体の最終ページである 24 ページ目になります。
「テンプレート単位」では、このプロパティが適用されるページは、Template-1 の 10 ページ目と Template-2 の 14 のページ目です。
「レイアウト単位」では、Template-1 / Layout-1 の 10 ページ目、Template-2/Layout-1の3ページ目、Template-2 / Layout-2 の 4 ページ目、Template-2 / Layout-3 の 5 ページ目、および Template-2 / Layout-4 の 2 ページ目に適用されます。

最後の Page Number を表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／最後のページを表示する」チェックボックスのチェックを入れるか、または外します。

「オフセット」

「オフセット」プロパティの値は、表示される元のページ番号に与える増減値です。「オフセット」プロパティのデフォルト値は 0 ( ゼロ )になっています。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。
二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Page Number」コンポーネントを配置します。
Layout-1 は 1～3 ページ、Layout-2 は 1～2 ページのページ番号を含んでいます。

Layout-1 に置いた「Page Number」コンポーネントの「オフセット」プロパティの値を 3 に増やします。すると、Layout-1 にある 3 ページのページ番号は 4,5,6 に変化するでしょう。

高度なページ番号の割付方法と「オフセット」プロパティの使用法

ここに、二つのテンプレート( Template-1 と Template-2 )を含むドキュメントがあるとします。
Template-1 には、一つのレイアウト( Layout-1 )があります。
Template-2 には、四つのレイアウト( Layout-1, Layout-2, Layout-3, Layout-4 )があります。

例では、「オフセット」の値は0となっています。

「Page Number」コンポーネント A において、
「オフセット」の値がもし 0 ならページ番号は 18,19,20,21 となり、
もし 3 ならページ番号は 21,22,23,24 となり、
もし -1 ならページ番号は 17,18,19,20 となります。

「Page Number」コンポーネント B において、
「オフセット」の値がもし 0 ならページ番号は 8,9,10,11 となり、
もし 3 ならページ番号は 11,12,13,14 となり、
もし -1 ならページ番号は 7,8,9,10 となります。

「Page Number」コンポーネント C において、
「オフセット」の値がもし 0 ならページ番号は 1,2,3,4 となり、
もし 3 ならページ番号は 4,5,6,7 となり、
もし -1 ならページ番号は 0,1,2,3 となります。

Page Numberの「オフセット」値を増減するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／オフセット」のスピナーコントロールを使って値を増減させます。

「内容」

「内容」プロパティは、「Page Number」コンポーネントでページ番号を表示するときに表示する書式を定義するのに使用されます。デフォルトの内容は「Page #」となっており、「#」の部分がページ番号になります。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Page Number」コンポーネントを配置します。
Layout-1 は 1～3 ページ、Layout-2 は 1～2 ページのページ番号を含んでいます。そして、これらの「Page Number」コンポーネントの「内容」プロパティ値は「Page #」となっているとします。

Layout-1 に配置した「Page Number」コンポーネントの「内容」プロパティ値を「Page Number #」と変更すると、出力される内容は、以下のように表示されるでしょう。

Page Number の「内容」を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容」プロパティに新しく文字列を入力します。ページ番号の数値は「#」という記号を代わりに含めます。

※「内容」プロパティ値には「#」を含む必要があります。

- Total Page Number コンポーネント -

「番号の割付」

「番号の割付」プロパティは、どの単位で総ページ数を表示するかを指定します。このプロパティのオプションは、「レイアウト単位」「テンプレート単位」「ドキュメント単位」となっています。

例：

以下のドキュメント構造を参照してください。

ここに、二つのテンプレート( Template-1 と Template-2 )を含む一つのドキュメントがあります。
Template-1 には、一つのレイアウト( Layout-1 )があります。Layout-1は3ページです。
Template-2 には、二つのレイアウト( Layout-1 と Layout-2 )があります。Layout-1 は 2 ページ、Layout-2 は 1 ページです。

レイアウト単位

「番号の割付／レイアウト単位」オプションは、それぞれのレイアウトが複数ページを含む場合に、レイアウト単位に総ページ数を割り付けます。「Total Page Number」コンポーネントの値は、レイアウトのすべてのページに表示されます。

上記の例に従って「レイアウト単位」オプションを選択すると、総ページ数の割付は以下のようになります。

Template-1 の Layout-1 に配置された「Total Page Number」コンポーネントは、Layout-1 の全ページに番号「3」を表示するでしょう。これは Layout-1 のページ数の合計が 3 ページだからです。
Template-2 の Layout-1 に配置された「Total Page Number」コンポーネントは、Layout-1 の全ページに番号「2」を表示するでしょう。これは Layout-1 のページ数の合計が 2 ページだからです。
Template-2 の Layout-2 に配置された「Total Page Number」コンポーネントは、Layout-2 の全ページに番号「1」を表示するでしょう。これは Layout-1 のページ数の合計が 1 ページだからです。

テンプレート単位

「番号の割付／テンプレート単位」オプションは、それぞれのテンプレートが複数ページを含む場合に、テンプレート単位に総ページ数を割り付けます。「Total Page Number」コンポーネントの値は、レイアウトのすべてのページに表示されます。

上記の例に従って「テンプレート単位」オプションを選択すると、総ページ数の割付は以下のようになります。

Template-1 の Layout-1 に配置された「Total Page Number」コンポーネントは、Layout-1 の全ページに「3」と表示するでしょう。これは Template-1 の総ページ数が 3 ページだからです。
Template-2 の Layout-1 と Layout-2 に配置された「Total Page Number」コンポーネントは、Layout-1 と Layout-2 の全ページに「3」と表示するでしょう。これは Template-2 の総ページ数が 3 ページだからです。

ドキュメント単位

「番号の割付／ドキュメント単位」オプションは、ドキュメント全体の総ページ数を割り付けます。
上記の例に従って「ドキュメント単位」オプションを選択すると、総ページ数の割付は以下のようになります。

Template-1 の Layout-1, Template-2 の Layout-1 と Layout-2 に配置された「Total Page Number」コンポーネントは、番号「6」を表示します。なぜならドキュメントのページ数合計が「6」だからです。

高度なページ番号の割付方法

ここに、二つのテンプレート( Template-1 と Template-2 )を含むドキュメントがあるとします。
Template-1 には、一つのレイアウト( Layout-1 )があります。
Template-2 には、四つのレイアウト( Layout-1, Layout-2, Layout-3, Layout-4 )があります。

例：

「Total Page Number」コンポーネント A の「番号の割付」は「ドキュメント単位」と指定されたので、ドキュメントが含む Template-1 および Template-2, その中にあるレイアウトの、すべてのページを含めた合計ページ数「24」を表示します。
「Total Page Number」コンポーネント B の「番号の割付」は「テンプレート単位」と指定されたので、Template-2 の中にあるレイアウトの、すべてのページを含めた合計ページ数「14」を表示します。
「Total Page Number」コンポーネント C の「番号の割付」は「レイアウト単位」と指定されたので、Template-2 の Layout-3 の全ページ数「5」を表示します。

「番号の割付」プロパティの単位タイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 単位タイプ( レイアウト単位、テンプレート単位、ドキュメント単位 )を「設定／番号の割付」ドロップダウンから選択します。

「最初のページを表示する」

「最初のページを表示する」プロパティは、レイアウト単位、テンプレート単位、ドキュメント単位の最初の Total Page Number を表示または非表示にするのに使用します。このプロパティはデフォルト設定ではチェックされています。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。
二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Total Page Number」コンポーネントを配置します。
Layout-1 は 3 ページで、Layout-2 は 2 ページで構成されています。

従って、Layout-1 に配置された「Total Page Number」コンポーネントは Layout-1 の全ページに「3」と表示し、Layout-2 に配置された「Total Page Number」コンポーネントは Layout-2 の全ページに「2」と表示するでしょう。

Layout-1 に配置した「Total Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最初のページを表示する」プロパティのチェックを外します。すると、Layout-1 の最初のページは総ページ数を表示しないでしょう。

同様に、Layout-2 に配置した「Total Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最初のページを表示する」プロパティでチェックを外します。これで、Layout-1 と Layout-2 の最初のページが総ページ数を表示しないでしょう。

このプロパティが「番号の割付」プロパティに指定された単位によって、どのように反応が変化するかを参照しましょう。

上記の例から、「最初のページを表示する」プロパティは以下の通り適用します。

「ドキュメント単位」では、このプロパティが適用されるページはドキュメント全体の最初のページです。
「テンプレート単位」では、このプロパティが適用されるページは、Template-1 の最初のページと Template-2 の最初のページです。
「レイアウト単位」では、Template-1 / Layout-1 の最初のページ、Template-2 / Layout-1 の最初のページ、Template-2 / Layout-2 の最初のページ、Template-2 / Layout-3 の最初のページ、および Template-2 / Layout-4 の最初のページに適用されます。

最初の Total Page Number を表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／最初のページを表示する」チェックボックスのチェックを入れるか、または外します。

「最後のページを表示する」

「最後のページを表示する」プロパティは、レイアウト単位、テンプレート単位、ドキュメント単位の最後の Total Page Number を表示または非表示にするのに使用します。このプロパティはデフォルト設定ではチェックされています。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。
二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Total Page Number」コンポーネントを配置します。
Layout-1 は 3 ページで、Layout-2 は 2 ページで構成されています。従って、Layout-1 に配置された「Total Page Number」コンポーネントは Layout-1 の全ページに「3」と表示し、Layout-2 に配置された「Total Page Number」コンポーネントは Layout-2 の全ページに「2」と表示します。

Layout-1 に配置した「Total Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最後のページを表示する」プロパティのチェックを外します。すると、Layout-1 の最後のページは総ページ数を表示しないでしょう。

同様に、Layout-2 に配置した「Total Page Number」コンポーネントの「番号の割付」を「レイアウト単位」とし、「最後のページを表示する」プロパティでチェックを外します。これで、Layout-1 と Layout-2 の最後のページがページ番号を表示しないでしょう。

このプロパティが「番号の割付」プロパティに指定された単位によって、どのように反応が変化するかを参照しましょう。

上記の例から、「最後のページを表示する」プロパティは以下の通り適用します。

「ドキュメント単位」では、このプロパティが適用されるページはドキュメント全体の最後のページである 24 ページ目となります。
「テンプレート単位」では、このプロパティが適用されるページは、Template-1 の最後のページである 10 ページ目と Template-2 の最後のページである 14 ページ目となります。
「レイアウト単位」では、個々のレイアウトの最後のページとなる Template-1 / Layout-1 の 10 ページ目、Template-2 / Layout-1 の 3 ページ目、Template-2 / Layout-2 の 4 ページ目、Template-2 / Layout-3 の 5 ページ目、および Template-2 / Layout-4 の 2 ページ目に適用されます。

最後の Total Page Number を表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／最後のページを表示する」チェックボックスのチェックを入れるか、または外します。

「オフセット」

「オフセット」プロパティの値は、表示される元の総ページ数に与える増減値です。「オフセット」プロパティのデフォルト値は 0 ( ゼロ )になっています。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。
二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Total Page Number」コンポーネントを配置します。
Layout-1 は 3 ページで、Layout-2 は 2 ページで構成されています。

従って、Layout-1 に配置された「Total Page Number」コンポーネントは Layout-1 の全ページに「3」と表示し、Layout-2 に配置された「Total Page Number」コンポーネントは Layout-2 の全ページに「2」と表示するでしょう。

Layout-1 に置いた「Total Page Number」コンポーネントの「オフセット」プロパティの値を 3 に増やします。すると、Layout-1 に表示される総ページの値は「6」に変化するでしょう。

高度なページ番号の割付方法と「オフセット」プロパティの使用法

ここに、二つのテンプレート( Template-1 と Template-2 )を含むドキュメントがあるとします。
Template-1 には、一つのレイアウト( Layout-1 )があります。
Template-2 には、四つのレイアウト( Layout-1, Layout-2, Layout-3, Layout-4 )があります。

例では、「オフセット」の値は 0 となっています。

「Total Page Number」コンポーネント A において、
「オフセット」の値がもし 0 ならページ番号は 24,24,24,24 となり、
もし 3 ならページ番号は 27,27,27,27 となり、
もし -1 ならページ番号は 23,23,23,23 となります。

「Total Page Number」コンポーネント B において、
「オフセット」の値がもし 0 ならページ番号は 14,14,14,14 となり、
もし 3 ならページ番号は 17,17,17,17 となり、
もし -1 ならページ番号は 13,13,13,13 となります。

「Total Page Number」コンポーネント C において、
「オフセット」の値がもし0ならページ番号は 5,5,5,5 となり、
もし 3 ならページ番号は 8,8,8,8 となり、
もし -1 ならページ番号は 4,4,4,4 となります。

Total Page Number の「オフセット」値を増減するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「設定／オフセット」のスピナーコントロールを使って値を増減させます。

「内容」

「内容」プロパティは、「Total Page Number」コンポーネントで総ページ数を表示するときに表示する書式を定義するのに使用されます。デフォルトの内容は「Total #」となっており、「#」の部分に総ページ数の値が入ります。

例：

次のテンプレート( Template-1 )は二つのレイアウト( Layout-1 と Layout-2 )を含んでいます。二つのレイアウト( Layout-1 と Layout-2 )それぞれに「Total Page Number」コンポーネントを配置します。
Layout-1 は 3 ページで、Layout-2 は 2 ページで構成されています。従って、Layout-1 に配置された「Total Page Number」コンポーネントは Layout-1 の全ページに「3」と表示し、Layout-2 に配置された「Total Page Number」コンポーネントは Layout-2 の全ページに「2」と表示します。そして、これらの「Total Page Number」コンポーネントの「内容」プロパティ値は「Total #」となっているとします。

Layout-1 に配置した「Total Page Number」コンポーネントの「内容」プロパティ値を「Total Page #」と変更すると、出力される内容は、以下のように表示されるでしょう。

Total Page Number の「内容」を変更するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「内容」プロパティに新しく文字列を入力します。総ページ数の値は「#」という記号を代わりに含めます。

※「内容」プロパティ値には「#」を含む必要があります。


「OPR の印刷方法」プロパティ

「表示と印刷を合わせる」

「表示と印刷を合わせる」プロパティは、このテンプレートから生成された OPR ドキュメントを OXB で印刷するときに、文字の位置を画面の表示と合わせるために使用します。

「表示と印刷を合わせる」を選択するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「テンプレート設定／表示と印刷を合わせる」を選択します。

「2.3 と同じ方法」

「2.3 と同じ方法」プロパティは、このテンプレートから生成された OPR ドキュメントを OXB で印刷するときに、文字の位置が 2.5 未満のバージョンで作成されたテンプレートと互換性があるようにするために使用します。

「2.3 と同じ方法」を選択するには

  1. テンプレートを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「テンプレート設定／2.3 と同じ方法」を選択します。


「タイムスタンプサーバ」プロパティ

「名前」

タイムスタンプサーバ名を参照します。

タイムスタンプサーバ名を表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「タイムスタンプサーバ／名前」の下でタイムスタンプサーバ名を参照できます。


「URLデータ」プロパティ

- URLLabel コンポーネント -

「タイプ」

コンポーネントに入力する内容のタイプを選択します。静的 ( Static ) な値、データベース ( Database ) からの読込、リクエスト ( Request ) のいずれかを指定します。

タイプを選択するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／タイプ」から使用するタイプを選択します。
「Static」
「Static」タイプを選択した場合、設計時にコンポーネントに入力されたハイパーリンクは、OPR、PDF、または、HTMLで表示される同じコンポーネントに挿入されます。
「Request」
「Request」タイプを選択した場合、ハイパーリンクのパスを、サンプルHTMLでプレビュー、または、入力する前に、ポップアップで入力する必要があります。
「Database」
「Database」タイプを選択した場合、表示するハイパーリンクパスは選択されているデータベースフィールドから抽出されます。

「内容」

このプロパティの内容には、URL、または、OXSが稼動しているサーバ上に置かれたテキストファイルのローカルパスを入力します。

タイプがStaticの場合、URL、または、OXSをインストールしたサーバ上のファイルのローカルパスを入力します。このファイルは、コンポーネントが表示可能なデータを含んでいなければなりません。「http://」あるいは「https://」で始まる値を入力した場合、表示する内容は指定したURLから取得されます。「http://」あるいは「https://」ではないテキストファイルのパスを入力した場合、テキストファイルはOXS設定で指定したフォルダから取得されます。

※OXS が稼動しているサーバ上のテキストファイルをローカルパスで指定する場合、相対パスで記述します。

例えば、OXS 設定で指定したテキストファイル保存フォルダに「test」というサブフォルダがあり、その中に「a.txt」ファイルがあるとします。
OXS のデフォルト設定では、絶対パスは「C:/Program Files/OPRO/OPRO X Server/works/texts/test/a.txt」となります。OXD では、このプロパティの内容に「test/a.txt」と入力します。

※このプロパティに URL を指定した場合、テンプレート設計時に URL から取得したテキストデータを表示することができます。

OXS 上のローカルに置かれたテキストファイルのパスを指定した場合、テンプレート設計時にファイルの内容を表示することはできません。

URLデータの内容を設定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／内容」に、使用するURLパスあるいはファイルパスを入力します。

「内容の表示」

URL パスで指定された内容を表示します。

内容を表示するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／内容」に、使用するURLパスあるいはファイルパスを入力します。
  3. 「URLデータ／内容の表示」をクリックします。

「リクエストパラメータ名」

「リクエストパラメータ名」プロパティは、リクエストパラメータ名を指定するのに使用します。「タイプ」として「Request」を選択した場合に限り、このプロパティが表示されます。

リクエストパラメータ名を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／タイプ」で「Request」を選択します。
  3. 「URLデータ／リクエストパラメータ名」にリクエストパラメータ名を入力します。

「Dataset」

「Dataset」プロパティは、Dataset を指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

Dataset を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／タイプ」で「Database」を選択します。
  3. 「URLデータ／Dataset」で Dataset を選択します。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。

「フィールド」

「フィールド」プロパティは、フィールドを指定するのに使用します。「タイプ」として「Database」を選択した場合に限り、このプロパティが表示されます。

フィールドを指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／タイプ」で「Database」を選択します。
  3. 「URLデータ／Dataset」で Dataset を選択します。
  4. 「URLデータ／フィールド」でフィールドを選択します。

※あらかじめテンプレートに Dataset を配置・設定しておく必要があります。

「URL接頭語」「URL接尾語」

この二つのプロパティは、コンポーネントのテキストを表示するのに使用します。例えば、複数のテキストを含む Web サイトがあり、それらのテキストを頻繁に呼び出す場合は、「URL接頭語」に URL パスを、「URL接尾語」にファイルタイプを指定します。こうすると、テンプレートを表示する際には、テキストの名前を入力するだけの操作ですみます。

例：
Web サイトに以下のテキストファイルが含まれているとします。

http://www.opro.lk/text1.txt
http://www.opro.lk/text2.txt
http://www.opro.lk/text3.txt
http://www.opro.lk/text4.txt
http://www.opro.lk/text5.txt
http://www.opro.lk/text6.txt
http://www.opro.lk/text7.txt

「URL接頭語」に「http://www.opro.lk/text」「URL接尾語」に「.txt」を入力します。テンプレートの表示中は、1, 2, 3 などの数値を入力するだけでテキストを呼び出すことができます。したがって、テキストを呼び出すたびにパスをすべて入力する必要がなくなります。

「URL接頭語」と「URL接尾語」を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／タイプ」で「Request」または「Database」を選択します。
  3. 「URLデータ／URL接頭語」と「URLデータ／URL接尾語」にURL文字列の前後部分を入力します。

- URLImage コンポーネント -

「内容」

このプロパティの内容には、URL、または、OXSが稼動しているサーバ上に置かれた画像ファイルのローカルパスを入力します。

タイプがStaticの場合、URL、または、OXSをインストールしたサーバ上のファイルのローカルパスを入力します。このファイルは、コンポーネントが表示可能なデータを含んでいなければなりません。「http://」あるいは「https://」で始まる値を入力した場合、画像データは指定したURLから取得されます。「http://」あるいは「https://」ではない画像ファイルのパスを入力した場合、画像ファイルはOXSがインストールされているサーバ上から取得されます。

※OXS が稼動しているサーバ上の画像ファイルをローカルパスで指定する場合、相対パスで記述します。

例えば、OXS 設定で指定した画像ファイル保存フォルダに「test」というサブフォルダがあり、その中に「a.tiff」ファイルがあるとします。
OXS のデフォルト設定では、絶対パスは「C:/Program Files/OPRO/OPRO X Server/works/texts/test/a.tiff」となります。OXD では、このプロパティの内容に「test/a.tiff」と入力します。

※このプロパティに URL を指定した場合、テンプレート設計時に URL から取得した画像を表示することができます。
OXS 上のローカルに置かれた画像ファイルのパスを指定した場合、テンプレート設計時にファイルの内容を表示することはできません。

URLデータに内容を設定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／内容」に、使用する URL パスあるいはファイルパスを入力します。

「URL接頭語」「URL接尾語」

どちらのプロパティも、コンポーネントに画像を表示するために使用します。複数の画像が含まれる Web サイトがあり、それらの画像を頻繁に使用する場合に有効な機能です。「URL接頭語」に URL パスを、「URL接尾語」に画像タイプを指定し、テンプレートを表示する際に、画像の名前を入力するだけで画像を表示できるようにすることが可能です。

例：
Webサイトに以下の画像ファイルが含まれているとします。

http://www.opro.lk/image1.jpg
http://www.opro.lk/image2.jpg
http://www.opro.lk/image3.jpg
http://www.opro.lk/image4.jpg
http://www.opro.lk/image5.jpg
http://www.opro.lk/image6.jpg
http://www.opro.lk/image7.jpg

ここで、「URL接頭語」に「http://www.opro.lk/image」「URL接尾語」に「.jpg」を入力します。テンプレートの表示中は、1, 2, 3 などの数値を入力するだけで、画像を呼び出すことができます。したがって、画像を呼び出すたびにパスを全部入力する必要がなくなります。

「URL接頭語」と「URL接尾語」を指定するには

  1. コンポーネントを選択し、F11キーを押します。プロパティエディタの「アクティブ」タブが表示されます。
  2. 「URLデータ／タイプ」で「Request」または「Database」を選択します。
  3. 「URLデータ／URL接頭語」と「URLデータ／URL接尾語」に URL 文字列の前後部分を入力します。


クエリビルダ

クエリビルダを使用すると、OXSに接続されているリモートデータベースを使用して、簡単な操作で短時間でクエリを作成できます。この最新のデータベースクエリツールを使用すると、プログラミングの知識がないユーザでも、Access、Cache、DB2、DB2native、Informix、Lotus、MySQL、Oracle、PostgreSQL、SQL、Sybase、または、OPROXML等のデータベースに対する複雑なクエリを作成できます。クエリビルダを使用すると、単純なクエリから複雑なクエリまで、簡単に作成することができます。

クエリを作成するには

  1. テンプレートに「Dataset」コンポーネントを配置します。
  2. 「Dataset」コンポーネントをダブルクリックします。
  3. OSMS ( OPRO Schema Manager Service ) の「ユーザ名」と「パスワード」を入力し、「ログイン」をクリックします。
  4. データベース領域で、使用したいデータベースの種類をダブルクリックし、ツリー展開されたデータベース エイリアスをさらにダブルクリックして選択します。
  5. データベース領域でテーブル(複数可)を選択し、ダブルクリック、または、ドラッグ＆ドロップによってテーブル領域に配置します。
  6. デザイングリッドで、クエリで使用するレコードを選択します。個々のレコードを選択する場合は [image] を、すべてのレコードを選択する場合は [image] を、それぞれクリックします。
  7. 「OK」ボタンをクリックします。
  • テーブルを選択するには
  • テーブルをリンクするには
  • リンクを削除するには
  • フィールドを追加するには
  • すべてのフィールドを追加するには
  • テーブルを削除するには
  • フィールドデータを表示するには
  • テーブルデータを表示するには

テーブルの選択

ここでは、クエリビルダでテーブルを選択する手順を示します。

テーブルを選択するには

  1. 使用するデータベースのタイプを選択し、ダブルクリックします。
  2. 「全般／位置とサイズ」テキストボックスに値を直接入力するか、スピンコントロールをクリックして値を指定します。
  3. 使用するデータベースエイリアスを選択し、ダブルクリックします。
  4. 使用するテーブルを選択し、ダブルクリックします。

※必要に応じて、異なるタイプのデータベースから、任意の数のフィールドを選択できます。

テーブルのリンク

ここでは、テーブルをリンクする手順を示します。

テーブルをリンクするには

  1. 最初のテーブルでリンクするフィールドを選択します。
  2. そのフィールドをクリックし、マウスボタンを押したまま、二番目のテーブルの対応するフィールドにドラッグ＆ドロップします。

※テーブル領域に、類似するフィールドを含む複数のテーブルが必要です。

リンクの削除

ここでは、クエリビルダでリンクを削除する手順を示します。

リンクを削除するには

  1. 削除するリンクをクリックして選択します。
  2. マウスボタンを右クリックして、ポップアップメニューの「結合の削除」オプションを選択します。

フィールドの追加

ここでは、クエリビルダでフィールドを追加する手順を示します。

フィールドを追加するには

  1. データベース領域でテーブルを選択します。
  2. フィールドをダブルクリックするか、フィールドを選択してからテーブルの [image] をクリックするか、またはテーブル上でマウスボタンを右クリックして「フィールドの追加」を選択することによって、デザイングリッドにフィールドを移動し、表示します。

すべてのフィールドの追加

ここでは、クエリビルダですべてのフィールドを追加する手順を示します。

すべてのフィールドを追加するには

  1. データベース領域でテーブルを選択します。
  2. フィールドをダブルクリックするか、フィールドを選択してからテーブルの [image] をクリックするか、またはテーブル上でマウスを右クリックして「すべてのフィールドの追加」を選択することによって、デザイングリッドにフィールドを移動し、表示します。

テーブルの削除

ここでは、クエリビルダでテーブルを削除する手順を示します。

テーブルを削除するには

  1. 削除するテーブルを選択し、右クリックします。
  2. 「テーブルの削除」を選択します。
  3. 「はい」をクリックして、削除することを確認します。

フィールドデータの表示

ここでは、クエリビルダでフィールドデータを表示する手順を示します。

フィールドデータを表示するには

  1. 表示するテーブルのフィールドをクリックします。
  2. 右クリックして「フィールドのデータ表示」を選択するか、 [image] ボタンをクリックします。

テーブルデータの表示

ここでは、クエリビルダでテーブルデータを表示する手順を示します。

テーブルデータを表示するには

  1. 表示するテーブルをクリックします。
  2. マウスボタンを右クリックします。
  3. 「テーブルのデータ表示」を選択するか、 [image] アイコンをクリックします。
データベース領域
クエリの作成に使用できるすべてのデータベース、テーブル および ビューが表示されます。現在選択されているテーブルは強調表示されます。テーブルをテーブル領域に移動するには、選択したテーブルをダブルクリックするか、テーブルをテーブル領域にドラッグ＆ドロップするか、移動するテーブルでマウスボタンを右クリックして「テーブルの追加」を選択します。
テーブル領域
アイコンをクリックすることによってテーブルからデザイングリッドにフィールドを選択するか、テーブル上の [image] アイコンをクリックすることによってすべてのフィールドを選択できる、操作用に選択したテーブルが表示されます。 アイコンをクリックすると、テーブルのフィールドデータを表示できます。 アイコンをクリックすると、テーブルのすべてのデータを表示できます。また、テーブルでマウスボタンを右クリックすると、ここで説明したすべてのオプションを選択できます。複数のファイルの関連するフィールドを選択することによって、それらのテーブルをリンクできます。最初のテーブルのフィールドをクリックし、二番目のファイルの関連するフィールドにドラッグ＆ドロップすると、リンクを作成できます。リンク線をダブルクリックするか、またはそれを右クリックして「結合のプロパティ」を選択することによって「結合プロパティ」ダイアログを呼び出し、テーブルの結合を作成できます。
デザイングリッド
テーブル領域からテーブルのフィールドをデザイングリッドにドラッグ＆ドロップすることができます。デザイングリッドでは、フィールドの「見出し」「Length」「表示形式」などを編集できます。選択解除したフィールドは、結果に表示されません。また、「並べ替え」および「グループ」に番号を入力することで、それぞれ並べ替え および グループの対象とするフィールドを選択できます。
「抽出条件」
条件式ビルダで作成した条件式が表示されます。
「SQLの表示」
作成したクエリを SQL 文で表示します。
「結果の表示」
クエリの実行結果を表示します。
「式の作成」
データベース、または、計算値のフィールドを指定して式を作成できます。
「抽出条件の設定」
レコードの抽出条件を指定できます。
「グループの設定」
選択したフィールドを指定の順序でグルーピングします。
「並べ替えの設定」
選択したフィールドを昇順または降順に並べ替えます。
「ウィザード」
クエリを簡単な手順で作成します。
「Distinct」
同じ内容をもつ複数のレコードを一つにして表示します。

「結合プロパティ」
結合プロパティを使用すると、二つのテーブルで共通する値を持つカラムに基づいてそれらのテーブルを結合できます。
「Inner Join」
共通するカラム値に基づいて二つのテーブルを結合します。ただし、両方のテーブルの一致しないレコードは除きます。
「Left Outer Join」
外部 Join 演算子の左側にあるテーブルから結果セットに含める すべての列を結合し、右側のテーブルからは一致するレコードのみを結合します。
「Right Outer Join」
外部 Join 演算子の右側にあるテーブルから結果セットに含める すべての列を結合し、左側のテーブルからは一致するレコードのみを結合します。


SubReport

「DatasetTable」コンポーネントを使用して、メインレポート内にレポートを作成できます。これは「グループの設定」に似ていますが、DatasetTable を使用します。SubReportを作成するには、少なくとも二つの DatasetTable を使用して、二番目の DatasetTable を一番目の DatasetTable の Databand 内部に配置する必要があります。最初の DatasetTable を 親DatasetTable、二番目の DatasetTable を 子DatasetTable といいます。いずれの DatasetTable にも、テーブルに関連付けられた Dataset が必要であり、それらのフィールドを関連付けてリンクを作成しておく必要があります。リンクは、子DatasetTable のリンクタブで作成する必要があります。そのため、リンクタブを選択するには、子DatasetTable を選択してから「カスタム」で「リンク」タブを選択します。DatasetTableが一つしか配置されていない場合、「リンク」タブは表示されません。

SubReportを作成するには

  1. テンプレートにDatasetTableコンポーネントを配置します。
  2. 二つのDatasetコンポーネントを配置し、それぞれにテーブルを選択します。テーブルを追加するには、「Datasetの編集」を参照してください。
  3. 最初のDatasetTableのDataBandにDatasetTableコンポーネントをもう一つ配置します。これを子DatasetTableといいます。
  4. 一方のDatasetを親DatasetTableにリンクし、もう一方のDatasetを子DatasetTableにリンクします。
  5. 子DatasetTableの「リンク」タブを選択し、親DatasetTableと子DatasetTableの両方で同じフィールドを関連付けます。


テキストクエリビルダ

テキストクエリビルダを使用すると、テキストデータからクエリを作成できます。このテキストデータは、静的に( ファイルや URL から )読み込むか、または テンプレート作成時にファイルや URL から動的に読み込むことができます。クエリのテキストフィールドの定義は、「テキストの定義」ウィンドウから設定できます。このウィンドウは、「フィールドの定義」ボタンをクリックすると開くことができます。「フィールドの定義」ボタンをクリックすると、「テキストの定義」ウィンドウが開き、フィールドやそのタイプを追加することができます。

「式」

「式」ボタンから、フィールドを使った式 ( Expression ) を作成することができます。定数の数値、および、シングルクォート「'」で括った定数文字列と、フィールド名を使って、関数や演算子でつなぎ合わせることによって、さまざまな式を作成することができます。

「条件」

「条件」ボタンから、フィールドを使った式を作成して、テキストデータからの抽出条件を設定することができます。定数の数値、および、シングルクォート「'」で括った定数文字列と、フィールド名を使って、関数や演算子でつなぎ合わせることによって、さまざまな等式や不等式を作成することができます。また、「{USERINPUT}」キーワードを使用すると、リクエストパラメータで条件値を設定することも可能です。

※注意：フィールド名に記号が含まれる場合は、ダブルクォテーションマーク「"」でフィールド名を括ってください。

「テキストの定義」

「テキストの定義」では、TextDataset ( クエリ ) を作成するために、テキストフィールドおよびそのプロパティを定義できます。フィールドは、区切り記号付きまたは固定長として指定できます。「区切り位置設定」オプションを使用すると、固定長を簡単に指定できます。

「ファイル形式」
「文字コード」
「文字コード」オプションは、CSV ( またはテキスト ) ファイルのエンコード形式を表示します。「固定長」オプションを選択すると、エンコード形式は「932 (Shift_JIS)」に、「区切り記号付き」オプションを選択すると、エンコード形式は「UTF-16 little endian」に設定されます。
「区切り記号付き」
「フィールド区切り記号」
ドロップダウンボックスから区切り記号を選択するか、任意の文字を区切り記号として指定することができます。
「文字列の引用符」
引用符で囲まれたデータは、フィールドデータとして処理されます。「文字列の引用符」には任意の文字を指定できます。
「固定長」
「固定長」オプションを使用すると、固定の長さを基準にデータを分割できます。
「区切り位置設定」
「区切り位置設定」オプションを使用すると、長さをより簡単に指定できます。フィールドの長さは、マウスを使用して指定できます。
「先頭行を無視する」
データの先頭行を無視します。
「形式の読込み」
テキストファイル( .csv )からクエリへ、フィールドを読み込むことができます。

フィールドを定義するには

  1. 「フィールドの定義」ボタンをクリックします。
  2. 「フィールド区切り記号」コンボボックスからフィールドの区切り記号を選択するか、区切り記号を直接入力します。
  3. 文字列の引用符を選択します。
  4. フィールドグリッドの「フィールド名」下の列で、フィールド名を入力します。
  5. 「データタイプ」及び「形式」下の列で、指定したフィールドに対応したタイプを定義します。
  6. 「OK」ボタンをクリックします。