intra-mart Accel Platform セットアップガイド 第33版 2020-09-01

4.2.2. JDBCドライバ

4.2.2.1. JDBCドライバの入手

以下の条件に該当するJDBCドライバを入手します。

  • 利用するデータベースがサポートしている最新JDBCドライバ
  • JDBC 4.2 または JDBC 4.3 のJDBCドライバ

コラム

本ページの外部URLは、2019-12-01時点のものです。
なお、掲載されているURLは変更になる場合があります。
その場合は条件に合ったJDBCドライバを検索して入手してください。

注意

Resinは、JDBC 4.2 または JDBC 4.3 を利用する場合4.0.56以上が必要です。

4.2.2.1.1. PostgreSQL

  1. PostgreSQL のJDBCドライバは以下のURLよりダウンロードできます。

  2. 利用するデータベースがサポートしている JDBC 4.2 の最新ファイルを入手してください。

4.2.2.1.2. Oracle Database

  1. Oracle のJDBCドライバは以下のURLよりダウンロードできます。

  2. 利用するデータベースがサポートしている JDBC 4.2 または JDBC 4.3 の各バージョンの最新ファイルを入手してください。

    Oracle Database 12c Release 2 の場合は、Oracle Database 12c Release 2 Build の最新
    Oracle Database 18c の場合は、Oracle Database 18c Build の最新
    Oracle Database 19c の場合は、Oracle Database 19c Build の最新

    JDKのバージョンがJDK 8 の場合は、JDBC 4.2 のJDBCドライバを使用してください。
    JDKのバージョンがJDK 11 の場合は、JDBC 4.3 のJDBCドライバを使用してください。

注意

Oracle Database 12c Release 2 および Oracle Database 18c は JDBC 4.2 のみ対象です。

4.2.2.1.3. Microsoft SQL Server

  1. Microsoft SQL Server の JDBCドライバは以下のURLよりダウンロードできます。

  2. 利用するデータベースがサポートしている JDBC 4.2 または JDBC 4.3 の各バージョンの最新ファイルを入手してください。

    JDKのバージョンがJDK 8 の場合は、JDBC 4.2 のJDBCドライバを使用してください。
    JDKのバージョンがJDK 11 の場合は、JDBC 4.3 のJDBCドライバを使用してください。

4.2.2.1.4. SAP HANA

  1. SAP HANA のJDBCドライバをインストールしてください。
    詳しくは、SAP HANA のドキュメントを参照してください。
  2. <ngdbc.jar> ファイルを入手します。

コラム

弊社ではデータベース接続に利用するJDBCドライバは、Type4(非XA)にて検証を実施しています。