Intramart.Bpw.WebService.Client Namespace

[image]

intra-mart Wrokflow Client for .Net
Intramart.Bpw.WebService.Client名前空間には、intra-martワークフローWebServiceに関する基本的なサポートを提供する型が含まれています。

クラス

クラス | 詳細
ApplicationKey | アプリケーションキー情報の操作を支援します。
Approver | 承認関連の処理に使用されるクラスです。
CompanyManager | 会社や組織に関連する情報を管理します。
DocumentLibInfo | ライブラリとドキュメント情報の操作を支援します。
Drafter | 起票関連の処理に使用されるクラスです。
DraftList | 起票済み案件情報に取得に使用されるクラスです。
Process | 案件関連の情報取得などに使用されるクラスです。
TaskInfo | タスク情報関連処理で使用されるクラスです。
TaskList | タスクリスト関連の処理に使用されるクラスです。
UserInfo | ユーザ情報
WebServicesClient | intra-mart Webサービスクライアントクラス
WFInformation | ワークフロー情報関連の処理に使用されるクラスです。
WFShortCutUrl | ショートカットURL関連の処理に使用されるクラスです。
WorkflowInfo | ワークフロー連携情報モデル
WorkflowResult | 拡張結果クラス

デリゲート

デリゲート | 詳細
WebServicesClient..::.CreateWebServiceInstanceDelegate | プロキシを取得するデリゲート。


ApplicationKey クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
アプリケーションキー情報の操作を支援します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class ApplicationKey
Visual Basic (Declaration)
Public Class ApplicationKey
Visual C++
public ref class ApplicationKey

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.ApplicationKey

参照

ApplicationKey メンバ
Intramart.Bpw.WebService.Client Namespace


ApplicationKey メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
ApplicationKey クラス コンストラクタ メソッド プロパティ See Also

ApplicationKey については メンバ を参照

コンストラクタ

名称 | 詳細
ApplicationKey | コンストラクタ

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetApplicationKey | 指定したドキュメントIdに対応するアプリケーションキーを取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
SetApplicationKey | 指定したドキュメントIdを用いてアプリケーションキーを保存します。
ToString | Returns a String that represents the current Object. (Objectより継承)

プロパティ

名称 | 詳細
ConnectionString | SQL Server データベースを開くために使用する文字列を取得または設定します。

参照

ApplicationKey クラス


ApplicationKey コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
ApplicationKey クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public ApplicationKey(
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String _
)
Visual C++
public:
ApplicationKey(
    String^ value
)

パラメータ

value
Type: System..::.String
SQL Server データベースを開くために使用する接続。

参照

ApplicationKey クラス


ApplicationKey メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
ApplicationKey クラス See Also

ApplicationKey については メソッド を参照

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetApplicationKey | 指定したドキュメントIdに対応するアプリケーションキーを取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
SetApplicationKey | 指定したドキュメントIdを用いてアプリケーションキーを保存します。
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

ApplicationKey クラス


GetApplicationKey メソッド

[image]

intra-mart Wrokflow Client for .Net
ApplicationKey クラス サンプル See Also
指定したドキュメントIdに対応するアプリケーションキーを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string[] GetApplicationKey(
    string documentId
)
Visual Basic (Declaration)
Public Function GetApplicationKey ( _
    documentId As String _
) As String()
Visual C++
public:
array<String^>^ GetApplicationKey(
    String^ documentId
)

パラメータ

documentId
Type: System..::.String
ドキュメントId

戻り値

アプリケーションキー情報配列

解説

サンプル

メソッドの使用コード例です。
CopyC#
string uid = GetIMUniqueID("ono", "default");

System.Diagnostics.Trace.WriteLine(uid);

string[] applicationKey = new string[] { "", "1000", "8", "9", "aaaaa" };

SqlConnectionStringBuilder scb
        = new SqlConnectionStringBuilder(Properties.Settings.Default.imarWfInfoConnectionString);
ApplicationKey appkey = new ApplicationKey(scb.ConnectionString);
appkey.SetApplicationKey(uid, applicationKey);

string[] getkey = appkey.GetApplicationKey(uid);

参照

ApplicationKey クラス


SetApplicationKey メソッド

[image]

intra-mart Wrokflow Client for .Net
ApplicationKey クラス サンプル See Also
指定したドキュメントIdを用いてアプリケーションキーを保存します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void SetApplicationKey(
    string documentId,
    string[] applicationKey
)
Visual Basic (Declaration)
Public Sub SetApplicationKey ( _
    documentId As String, _
    applicationKey As String() _
)
Visual C++
public:
void SetApplicationKey(
    String^ documentId,
    array<String^>^ applicationKey
)

パラメータ

documentId
Type: System..::.String
ドキュメントId
applicationKey
Type: array< System..::.String >[]()[]
アプリケーションキー情報配列

解説

ドキュメントIdと配列のIndexをキーとしてテーブルに情報を保存します。 同一キーが存在する場合は上書きします。

解説

サンプル

メソッドの使用コード例です。
CopyC#
string uid = GetIMUniqueID("ono", "default");

System.Diagnostics.Trace.WriteLine(uid);

string[] applicationKey = new string[] { "", "1000", "8", "9", "aaaaa" };

SqlConnectionStringBuilder scb
        = new SqlConnectionStringBuilder(Properties.Settings.Default.imarWfInfoConnectionString);
ApplicationKey appkey = new ApplicationKey(scb.ConnectionString);
appkey.SetApplicationKey(uid, applicationKey);

string[] getkey = appkey.GetApplicationKey(uid);

参照

ApplicationKey クラス


ApplicationKey プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
ApplicationKey クラス See Also

ApplicationKey については プロパティ を参照

プロパティ

名称 | 詳細
ConnectionString | SQL Server データベースを開くために使用する文字列を取得または設定します。

参照

ApplicationKey クラス


ConnectionString プロパティ

[image]

intra-mart Wrokflow Client for .Net
ApplicationKey クラス See Also
SQL Server データベースを開くために使用する文字列を取得または設定します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

参照

ApplicationKey クラス


Approver クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
承認関連の処理に使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class Approver : WebServicesClient
Visual Basic (Declaration)
Public Class Approver _
    Inherits WebServicesClient
Visual C++
public ref class Approver : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.Approver

参照

Approver メンバ


Approver メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
Approver クラス コンストラクタ メソッド フィールド プロパティ See Also

Approver については メンバ を参照

コンストラクタ

名称 | 詳細
Approver | オーバーロードされます

メソッド

名称 | 詳細
ApprovePullbackWF | 引戻し処理を実行します。
ApproveWF | 承認処理を実行します。
Close | リソースを解放します。
DenialWF | 否認処理を実行します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetApproveService | SOAP通信クライアントプロキシを取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
SendbackWF | 差し戻し処理を実行します。
SuspendWF | 保留処理を実行します。
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

Approver クラス


Approver コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also

オーバーロード リスト

名称 | 詳細
Approver()()() | コンストラクタ
Approver(String) | コンストラクタ
Approver(String, Int32) | コンストラクタ

参照

Approver クラス
Approver メンバ


Approver コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Approver()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Approver()

参照

Approver クラス
Approver オーバーロード


Approver コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Approver(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
Approver(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

Approver クラス
Approver オーバーロード


Approver コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Approver(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
Approver(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

Approver クラス
Approver オーバーロード


Approver フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also

Approver については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

Approver クラス


Approver メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also

Approver については メソッド を参照

メソッド

名称 | 詳細
ApprovePullbackWF | 引戻し処理を実行します。
ApproveWF | 承認処理を実行します。
Close | リソースを解放します。
DenialWF | 否認処理を実行します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetApproveService | SOAP通信クライアントプロキシを取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
SendbackWF | 差し戻し処理を実行します。
SuspendWF | 保留処理を実行します。
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

Approver クラス


ApprovePullbackWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Approver クラス サンプル See Also
引戻し処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel ApprovePullbackWF(
    UserInfo userInfo,
    ApproveTaskModel model
)
Visual Basic (Declaration)
Public Function ApprovePullbackWF ( _
    userInfo As UserInfo, _
    model As ApproveTaskModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ ApprovePullbackWF(
    UserInfo^ userInfo,
    ApproveTaskModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ApproveTaskModel
認証情報

戻り値

拡張結果クラス

解説

引戻し処理を実行します。

intra-martのワークフローモジュールのApproverクラスのapprovePullbackメソッドをラッピング実装したサービスです。

このサービスを使うことで承認した後、特定の１つの案件に対して本人の引戻し処理や、代理者による代行引戻し処理を行うことができます。

承認した後、更に先に進んだ（承認された）案件は、引戻しできません。

例えば、申請⇒１次承認者⇒２次承認者⇒３次承認者⇒最終承認者 のようなフローの場合、「１次承認者」が承認した後、「２次承認者」に処理が進んだ状態では、「１次承認者」は引戻しすることはできますが、「３次承認者」まで処理が進んだ後、「１次承認者」は引戻しすることはできません。（エラーとなります。）

サンプル

ApprovePullbackWFメソッドの使用コード例です。
CopyC#
private WorkflowResult workflowResult;

private void ExecApprovePullback()
{
    ExecApprove();  //起票,承認
    WorkflowInfo workflowInfo = workflowResult.models[0];
    ApproveTaskModel req = new ApproveTaskModel();
    //承認者情報
    {
        req.userID = "munakata";
        req.loginGroupID = @"default";
        //代理承認の場合
        if (!string.IsNullOrEmpty(workflowInfo.agentUserId))
        {
            req.agentUserId = workflowInfo.agentUserId;
        }
    }
    //プロセス情報
    {
        req.processDefCd = workflowInfo.processDefCd;
        req.versionCd = workflowInfo.versionCd;
        req.processCd = workflowInfo.processCd;
        //承認したアクティビティコード
        req.activityCd = "5";
    }
    //承認情報
    {
        req.comment = string.Format("webサービスからの承認者引戻し{0}", DateTime.Now);
    }

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
    {
        userID = req.userID,
        loginGroupID = @"default",
        authType = @"MOSSNTLM"
    };
    Intramart.Bpw.WebService.ApproveServiceReference.WFResultModel res;
    using (Approver c = new Approver("192.168.1.120"))
    {
        //認証情報を設定
        c.Credentials = new NetworkCredential(req.userID, "Password!", "example");
        res = c.ApprovePullbackWF(ui, req);
    }
    WorkflowResult wr = WorkflowResult.Parse(res);
    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    if (wr.HasError())
    {
        System.Diagnostics.Trace.WriteLine("Error");
        return;
    }
    workflowResult = wr;

}

参照

Approver クラス


ApproveWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Approver クラス サンプル See Also
承認処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel ApproveWF(
    UserInfo userInfo,
    ApproveTaskModel model
)
Visual Basic (Declaration)
Public Function ApproveWF ( _
    userInfo As UserInfo, _
    model As ApproveTaskModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ ApproveWF(
    UserInfo^ userInfo,
    ApproveTaskModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ApproveTaskModel
認証情報

戻り値

拡張結果クラス

解説

承認処理を実行します。

intra-martのワークフローモジュールのApproverクラスのapproveメソッドをラッピング実装したサービスです。

このサービスを使うことで特定の１つの案件に対して本人の承認処理や、代理者による代行承認処理を行うことができます。

ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。

次タスクが動的承認者の場合は、利用できません。

根回しメール機能は、クライアント側の実装となります。

サンプル

ApproveWFメソッドの使用コード例です。
CopyC#
private WorkflowResult workflowResult;

private void ExecApprove()
{
    ExecDraft();    //起票
    WorkflowInfo workflowInfo = workflowResult.models[0];
    ApproveTaskModel req = new ApproveTaskModel();
    //承認者情報
    {
        req.userID = workflowInfo.userID;
        req.loginGroupID = @"default";
        req.compCd = workflowInfo.companyCd;
        req.orgnCd = workflowInfo.departmentCd;
        //代理承認の場合
        if (!string.IsNullOrEmpty(workflowInfo.agentUserId))
        {
            req.agentUserId = workflowInfo.agentUserId;
        }
    }
    //プロセス情報
    {
        req.processDefCd = workflowInfo.processDefCd;
        req.versionCd = workflowInfo.versionCd;
        req.processCd = workflowInfo.processCd;
        req.activityCd = workflowInfo.activityCd;
    }
    //承認情報
    {
        req.comment = string.Format("webサービスからの承認{0}", DateTime.Now); ;
    }

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
    {
        userID = req.userID,
        loginGroupID = @"default",
        authType = @"MOSSNTLM"
    };
    Intramart.Bpw.WebService.ApproveServiceReference.WFResultModel res;
    using (Approver c = new Approver("192.168.1.120"))
    {
        //認証情報を設定
        c.Credentials = new NetworkCredential(req.userID, "Password!", "example");
        res = c.ApproveWF(ui, req);
    }
    WorkflowResult wr = WorkflowResult.Parse(res);
    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    if (wr.HasError())
    {
        System.Diagnostics.Trace.WriteLine("Error");
        return;
    }
    workflowResult = wr;
}

参照

Approver クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

Approver クラス


DenialWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Approver クラス サンプル See Also
否認処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel DenialWF(
    UserInfo userInfo,
    ApproveTaskModel model
)
Visual Basic (Declaration)
Public Function DenialWF ( _
    userInfo As UserInfo, _
    model As ApproveTaskModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ DenialWF(
    UserInfo^ userInfo,
    ApproveTaskModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ApproveTaskModel
認証情報

戻り値

拡張結果クラス

解説

否認処理を実行します。

intra-martのワークフローモジュールのApproverクラスのdenialメソッドをラッピング実装したサービスです。

このサービスを使うことで特定の１つの案件に対して本人の否認処理や、代理者による代行否認処理を行うことができます。

ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。

根回しメール機能は、クライアント側の実装となります。

サンプル

DenialWFメソッドの使用コード例です。
CopyC#
private WorkflowResult workflowResult;

private void ExecDenial()
{
    ExecDraft();    //起票
    WorkflowInfo workflowInfo = workflowResult.models[0];
    ApproveTaskModel req = new ApproveTaskModel();
    //承認者情報
    {
        req.userID = workflowInfo.userID;
        req.loginGroupID = @"default";
        req.compCd = workflowInfo.companyCd;
        req.orgnCd = workflowInfo.departmentCd;
        //代理承認の場合
        if (!string.IsNullOrEmpty(workflowInfo.agentUserId))
        {
            req.agentUserId = workflowInfo.agentUserId;
        }
    }
    //プロセス情報
    {
        req.processDefCd = workflowInfo.processDefCd;
        req.versionCd = workflowInfo.versionCd;
        req.processCd = workflowInfo.processCd;
    }
    //否認情報
    {
        req.comment = string.Format("webサービスからの否認{0}", DateTime.Now); ;
    }
    //WebServiceログイン情報
    UserInfo ui = new UserInfo
    {
        userID = req.userID,
        loginGroupID = @"default",
        authType = @"MOSSNTLM"
    };
    Intramart.Bpw.WebService.ApproveServiceReference.WFResultModel res;
    using (Approver c = new Approver("192.168.1.120"))
    {
        //認証情報を設定
        c.Credentials = new NetworkCredential(req.userID, "Password!", "example");
        res = c.DenialWF(ui, req);
    }
    WorkflowResult wr = WorkflowResult.Parse(res);
    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    if (wr.HasError())
    {
        System.Diagnostics.Trace.WriteLine("Error");
        return;
    }
    workflowResult = wr;

}

参照

Approver クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

Approver クラス
Approver メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

Approver クラス
Dispose オーバーロード


GetApproveService メソッド

[image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected ApproveService GetApproveService()
Visual Basic (Declaration)
Protected Function GetApproveService As ApproveService
Visual C++
protected:
ApproveService^ GetApproveService()

戻り値

SOAP通信クライアントプロキシ

参照

Approver クラス


SendbackWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Approver クラス サンプル See Also
差し戻し処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel SendbackWF(
    UserInfo userInfo,
    ApproveTaskModel model
)
Visual Basic (Declaration)
Public Function SendbackWF ( _
    userInfo As UserInfo, _
    model As ApproveTaskModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ SendbackWF(
    UserInfo^ userInfo,
    ApproveTaskModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ApproveTaskModel
認証情報

戻り値

拡張結果クラス

解説

差し戻し処理を実行します。

intra-martのワークフローモジュールのApproverクラスのsendBackメソッドをラッピング実装したサービスです。

このサービスを使うことで特定の１つの案件に対して本人の差戻し処理や、代理者による代行差戻し処理を行うことができます。

申請者へ差戻し、直前の処理者への差戻し処理は行うことはできますが、任意のタスクへの差戻しは行うことはできません。

根回しメール機能は、クライアント側の実装となります。

差戻し先としてsendBackTypeに「start」:申請者または「before」:前処理者を指定します。

サンプル

SendbackWFメソッドの使用コード例です。
CopyC#

                    private WorkflowResult workflowResult;

                    private void ExecSendback()
                    {
                        ExecApprove();  //起票,承認
                        WorkflowInfo workflowInfo = workflowResult.models[0];
                        ApproveTaskModel req = new ApproveTaskModel();
                        //承認者情報
                        {
                            req.userID = workflowInfo.userID;
                            req.loginGroupID = @"default";
                            req.compCd = workflowInfo.companyCd;
                            req.orgnCd = workflowInfo.departmentCd;
                            //代理承認の場合
                            if (!string.IsNullOrEmpty(workflowInfo.agentUserId))
                            {
                                req.agentUserId = workflowInfo.agentUserId;
                            }
                        }
                        //プロセス情報
                        {
                            req.processDefCd = workflowInfo.processDefCd;
                            req.versionCd = workflowInfo.versionCd;
                            req.processCd = workflowInfo.processCd;
                            //承認したアクティビティコード
                            req.activityCd = workflowInfo.activityCd;
                        }
                        //承認情報
                        {
                            req.comment = string.Format("webサービスからの差し戻し{0}", DateTime.Now);
                        }

                        //前の承認者に差し戻し
                        req.sendBackType = "before";
                        //起票者に差し戻す場合は"start"を設定します。
                        //req.sendBackType = "start";

                        //WebServiceログイン情報
                        UserInfo ui = new UserInfo
                        {
                            userID = req.userID,
                            loginGroupID = @"default",
                            authType = @"MOSSNTLM"
                        };
                        Intramart.Bpw.WebService.ApproveServiceReference.WFResultModel res;
                        using (Approver c = new Approver("192.168.1.120"))
                        {
                            //認証情報を設定
                            c.Credentials = new NetworkCredential(req.userID, "Password!", "example");
                            res = c.SendbackWF(ui, req);
                        }
                        WorkflowResult wr = WorkflowResult.Parse(res);
                        //戻り値を表示します。
                        System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
                        System.IO.StringWriter sw = new StringWriter();
                        x.Serialize(sw, res);
                        System.Diagnostics.Trace.WriteLine(sw.ToString());

                        if (wr.HasError())
                        {
                            System.Diagnostics.Trace.WriteLine("Error");
                            return;
                        }
                        workflowResult = wr;

                    }

  参照
Approver クラス


SuspendWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Approver クラス サンプル See Also
保留処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel SuspendWF(
    UserInfo userInfo,
    ApproveTaskModel model
)
Visual Basic (Declaration)
Public Function SuspendWF ( _
    userInfo As UserInfo, _
    model As ApproveTaskModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ SuspendWF(
    UserInfo^ userInfo,
    ApproveTaskModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ApproveTaskModel
認証情報

戻り値

拡張結果クラス

解説

保留処理を実行します。

intra-martのワークフローモジュールのApproverクラスのsuspendメソッドをラッピング実装したサービスです。

このサービスを使うことで特定の１つの案件に対して本人の保留処理や、代理者による代行保留処理を行うことができます。

ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。

根回しメール機能は、クライアント側の実装となります。

サンプル

SuspendWFメソッドの使用コード例です。
CopyC#

                    private WorkflowResult workflowResult;

                    private void ExecSuspend()
                    {
                        ExecApprove();  //起票,承認
                        WorkflowInfo workflowInfo = workflowResult.models[0];
                        ApproveTaskModel req = new ApproveTaskModel();
                        //承認者情報
                        {
                            req.userID = workflowInfo.userID;
                            req.loginGroupID = @"default";
                            req.compCd = workflowInfo.companyCd;
                            req.orgnCd = workflowInfo.departmentCd;
                            //代理承認の場合
                            if (!string.IsNullOrEmpty(workflowInfo.agentUserId))
                            {
                                req.agentUserId = workflowInfo.agentUserId;
                            }
                        }
                        //プロセス情報
                        {
                            req.processDefCd = workflowInfo.processDefCd;
                            req.versionCd = workflowInfo.versionCd;
                            req.processCd = workflowInfo.processCd;
                            //承認したアクティビティコード
                            req.activityCd = workflowInfo.activityCd;
                        }
                        //承認情報
                        {
                            req.comment = string.Format("webサービスからの保留{0}", DateTime.Now);
                        }

                        //前の承認者に差し戻し
                        req.sendBackType = "before";
                        //起票者に差し戻す場合は"start"を設定します。
                        //req.sendBackType = "start";

                        //WebServiceログイン情報
                        UserInfo ui = new UserInfo
                                          {
                                              userID = req.userID,
                                              loginGroupID = @"default",
                                              authType = @"MOSSNTLM"
                                          };
                        Intramart.Bpw.WebService.ApproveServiceReference.WFResultModel res;
                        using (Approver c = new Approver("192.168.1.120"))
                        {
                            //認証情報を設定
                            c.Credentials = new NetworkCredential(req.userID, "Password!", "example");
                            res = c.SuspendWF(ui, req);
                        }
                        WorkflowResult wr = WorkflowResult.Parse(res);
                        //戻り値を表示します。
                        System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
                        System.IO.StringWriter sw = new StringWriter();
                        x.Serialize(sw, res);
                        System.Diagnostics.Trace.WriteLine(sw.ToString());

                        if (wr.HasError())
                        {
                            System.Diagnostics.Trace.WriteLine("Error");
                            return;
                        }
                    }

  参照
Approver クラス


Approver プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
Approver クラス See Also

Approver については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

Approver クラス


CompanyManager クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
会社や組織に関連する情報を管理します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class CompanyManager : WebServicesClient
Visual Basic (Declaration)
Public Class CompanyManager _
    Inherits WebServicesClient
Visual C++
public ref class CompanyManager : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.CompanyManager

参照

CompanyManager メンバ


CompanyManager メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス コンストラクタ メソッド フィールド プロパティ See Also

CompanyManager については メンバ を参照

コンストラクタ

名称 | 詳細
CompanyManager | オーバーロードされます

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetCompanyManagerService | SOAP通信クライアントプロキシを取得します。
GetDepartmentMainWF | ユーザの所属する部署を取得します。
GetDepartmentMemberWF | 部署に所属するユーザーの一覧を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

CompanyManager クラス


CompanyManager コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also

オーバーロード リスト

名称 | 詳細
CompanyManager()()() | コンストラクタ
CompanyManager(String) | コンストラクタ
CompanyManager(String, Int32) | コンストラクタ

参照

CompanyManager クラス
CompanyManager メンバ


CompanyManager コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public CompanyManager()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
CompanyManager()

参照

CompanyManager クラス
CompanyManager オーバーロード


CompanyManager コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public CompanyManager(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
CompanyManager(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

CompanyManager クラス
CompanyManager オーバーロード


CompanyManager コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public CompanyManager(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
CompanyManager(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

CompanyManager クラス
CompanyManager オーバーロード


CompanyManager フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also

CompanyManager については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

CompanyManager クラス


CompanyManager メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also

CompanyManager については メソッド を参照

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetCompanyManagerService | SOAP通信クライアントプロキシを取得します。
GetDepartmentMainWF | ユーザの所属する部署を取得します。
GetDepartmentMemberWF | 部署に所属するユーザーの一覧を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

CompanyManager クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

CompanyManager クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

CompanyManager クラス
CompanyManager メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean

[Missing <param name="disposing"/> documentation for "M:Intramart.Bpw.WebService.Client.CompanyManager.Dispose(System.Boolean)"]

参照

CompanyManager クラス
Dispose オーバーロード


GetCompanyManagerService メソッド

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected CompanyManagerService GetCompanyManagerService()
Visual Basic (Declaration)
Protected Function GetCompanyManagerService As CompanyManagerService
Visual C++
protected:
CompanyManagerService^ GetCompanyManagerService()

戻り値

SOAP通信クライアントプロキシ

参照

CompanyManager クラス


GetDepartmentMainWF メソッド

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
ユーザの所属する部署を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DepartmentMainResultModel GetDepartmentMainWF(
    UserInfo userInfo,
    DepartmentMainSerchModel model
)
Visual Basic (Declaration)
Public Function GetDepartmentMainWF ( _
    userInfo As UserInfo, _
    model As DepartmentMainSerchModel _
) As DepartmentMainResultModel
Visual C++
public:
DepartmentMainResultModel^ GetDepartmentMainWF(
    UserInfo^ userInfo,
    DepartmentMainSerchModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: DepartmentMainSerchModel
所属検索情報

戻り値

所属部署情報

参照

CompanyManager クラス


GetDepartmentMemberWF メソッド

[image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also
部署に所属するユーザーの一覧を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DepartmentUserResultModel GetDepartmentMemberWF(
    UserInfo userInfo,
    DepartmentUserSerchModel model
)
Visual Basic (Declaration)
Public Function GetDepartmentMemberWF ( _
    userInfo As UserInfo, _
    model As DepartmentUserSerchModel _
) As DepartmentUserResultModel
Visual C++
public:
DepartmentUserResultModel^ GetDepartmentMemberWF(
    UserInfo^ userInfo,
    DepartmentUserSerchModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: DepartmentUserSerchModel
所属ユーザ検索情報

戻り値

所属ユーザ情報

参照

CompanyManager クラス


CompanyManager プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
CompanyManager クラス See Also

CompanyManager については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

CompanyManager クラス


DocumentLibInfo クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
ライブラリとドキュメント情報の操作を支援します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class DocumentLibInfo
Visual Basic (Declaration)
Public Class DocumentLibInfo
Visual C++
public ref class DocumentLibInfo

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.DocumentLibInfo

参照

DocumentLibInfo メンバ


DocumentLibInfo メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
DocumentLibInfo クラス コンストラクタ メソッド プロパティ See Also

DocumentLibInfo については メンバ を参照

コンストラクタ

名称 | 詳細
DocumentLibInfo | コンストラクタ

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetListInfomatein | 指定した日付に対応するドキュメントライブラリ情報を取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

プロパティ

名称 | 詳細
ConnectionString | SQL Server データベースを開くために使用する文字列を取得または設定します。

参照

DocumentLibInfo クラス


DocumentLibInfo コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
DocumentLibInfo クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DocumentLibInfo(
    string value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As String _
)
Visual C++
public:
DocumentLibInfo(
    String^ value
)

パラメータ

value
Type: System..::.String
SQL Server データベースを開くために使用する接続。

参照

DocumentLibInfo クラス


DocumentLibInfo メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
DocumentLibInfo クラス See Also

DocumentLibInfo については メソッド を参照

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetListInfomatein | 指定した日付に対応するドキュメントライブラリ情報を取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

DocumentLibInfo クラス


GetListInfomatein メソッド

[image]

intra-mart Wrokflow Client for .Net
DocumentLibInfo クラス See Also
指定した日付に対応するドキュメントライブラリ情報を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public moss_bpw_t_user_document_libDataTable GetListInfomatein(
    string liblaryId,
    DateTime draftDate
)
Visual Basic (Declaration)
Public Function GetListInfomatein ( _
    liblaryId As String, _
    draftDate As DateTime _
) As moss_bpw_t_user_document_libDataTable
Visual C++
public:
moss_bpw_t_user_document_libDataTable^ GetListInfomatein(
    String^ liblaryId,
    DateTime draftDate
)

パラメータ

liblaryId
Type: System..::.String

[Missing <param name="liblaryId"/> documentation for "M:Intramart.Bpw.WebService.Client.DocumentLibInfo.GetListInfomatein(System.String,System.DateTime)"]

draftDate
Type: System..::.DateTime

[Missing <param name="draftDate"/> documentation for "M:Intramart.Bpw.WebService.Client.DocumentLibInfo.GetListInfomatein(System.String,System.DateTime)"]

戻り値

ライブラリ情報

参照

DocumentLibInfo クラス


DocumentLibInfo プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
DocumentLibInfo クラス See Also

DocumentLibInfo については プロパティ を参照

プロパティ

名称 | 詳細
ConnectionString | SQL Server データベースを開くために使用する文字列を取得または設定します。

参照

DocumentLibInfo クラス


ConnectionString プロパティ

[image]

intra-mart Wrokflow Client for .Net
DocumentLibInfo クラス See Also
SQL Server データベースを開くために使用する文字列を取得または設定します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string ConnectionString { get; set; }
Visual Basic (Declaration)
Public Property ConnectionString As String
Visual C++
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

参照

DocumentLibInfo クラス


Drafter クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
起票関連の処理に使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class Drafter : WebServicesClient
Visual Basic (Declaration)
Public Class Drafter _
    Inherits WebServicesClient
Visual C++
public ref class Drafter : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.Drafter

参照

Drafter メンバ


Drafter メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
Drafter クラス コンストラクタ メソッド フィールド プロパティ See Also

Drafter については メンバ を参照

コンストラクタ

名称 | 詳細
Drafter | オーバーロードされます

メソッド

名称 | 詳細
CancelWF | 取り止め処理を実行します。
Close | リソースを解放します。
Dispose | オーバーロードされます
DraftWF | 起票処理を実行します。
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetDraftService | SOAP通信クライアントプロキシを取得します。
GetDraftUserOrgListWF | 処理実行時の組織情報を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
PullbackWF | 引戻し処理を実行します。
RetryWF | 再起票処理を実行します。
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

Drafter クラス


Drafter コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also

オーバーロード リスト

名称 | 詳細
Drafter()()() | コンストラクタ
Drafter(String) | コンストラクタ
Drafter(String, Int32) | コンストラクタ

参照

Drafter クラス
Drafter メンバ


Drafter コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Drafter()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Drafter()

参照

Drafter クラス
Drafter オーバーロード


Drafter コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Drafter(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
Drafter(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

Drafter クラス
Drafter オーバーロード


Drafter コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Drafter(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
Drafter(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

Drafter クラス
Drafter オーバーロード


Drafter フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also

Drafter については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

Drafter クラス


Drafter メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also

Drafter については メソッド を参照

メソッド

名称 | 詳細
CancelWF | 取り止め処理を実行します。
Close | リソースを解放します。
Dispose | オーバーロードされます
DraftWF | 起票処理を実行します。
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetDraftService | SOAP通信クライアントプロキシを取得します。
GetDraftUserOrgListWF | 処理実行時の組織情報を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
PullbackWF | 引戻し処理を実行します。
RetryWF | 再起票処理を実行します。
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

Drafter クラス


CancelWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス サンプル See Also
取り止め処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel CancelWF(
    UserInfo userInfo,
    DraftModel model
)
Visual Basic (Declaration)
Public Function CancelWF ( _
    userInfo As UserInfo, _
    model As DraftModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ CancelWF(
    UserInfo^ userInfo,
    DraftModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: DraftModel
起票情報

戻り値

拡張結果クラス

解説

取り止め処理を実行します。

intra-martのワークフローモジュールのDraftクラスのcancelメソッドをラッピング実装したサービスです。

このサービスを使うことで引き戻した案件の取止め処理を行うことができます。

根回しメール機能は、クライアント側の実装となります。

サンプル

CancelWFメソッドの使用コード例です。
CopyC#
private WorkflowResult workflowResult;

private  void ExecCancel()
{
    ExecDraft();    //起票
    ExecPullback(); //引き戻し
    WorkflowInfo workflowInfo = workflowResult.models[0];

    DraftModel req = new DraftModel();
    {//起票者情報
        req.userID = @"ono";
        req.loginGroupID = @"default";
        req.compCd = @"comp_im_create";
        req.orgnCd = @"sec_eigyou_2";
    }
    //プロセス情報
    {
        req.processDefCd = workflowInfo.processDefCd;
        req.versionCd = workflowInfo.versionCd;
        req.processCd = workflowInfo.processCd;
    }
    //取り消し情報
    {
        req.comment = string.Format("webサービスからの取消{0}", DateTime.Now); ;
    }

    //代理
    {
        req.agentUserID = null;
    }
    //WebServiceログイン情報
    UserInfo ui = new UserInfo
    {
        userID = @"ono",
        loginGroupID = @"default",
        authType = @"MOSSNTLM"
    };
    Intramart.Bpw.WebService.DraftServiceReference.WFResultModel res;
    using (Drafter c = new Drafter("192.168.1.120"))
    {
        //認証情報を設定
        c.Credentials = new NetworkCredential("ono", "Password!", "example");
        res = c.CancelWF(ui, req);
    }
    WorkflowResult wr = WorkflowResult.Parse(res);

    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    if (wr.HasError())
    {
        System.Diagnostics.Trace.WriteLine("Error");
        return;
    }
    workflowResult = wr;

}

参照

Drafter クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

Drafter クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

Drafter クラス
Drafter メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

Drafter クラス
Dispose オーバーロード


DraftWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス サンプル See Also
起票処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel DraftWF(
    UserInfo userInfo,
    DraftModel model
)
Visual Basic (Declaration)
Public Function DraftWF ( _
    userInfo As UserInfo, _
    model As DraftModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ DraftWF(
    UserInfo^ userInfo,
    DraftModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: DraftModel
起票情報

戻り値

拡張結果クラス

解説

起票処理を実行します。

intra-martのワークフローモジュールのDraftクラスのdraftメソッドをラッピング実装したサービスです。

このサービスを使うことで本人の起票処理を行うことができます。

一時プロセスコードを利用する場合は、・\ / : , ; * ? " < > | & # + [ ] ( ) { } (space) (tab)の文字を含めることはできません。

ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。

根回しメール機能は、クライアント側の実装となります。

アプリケーションキーの0（ゼロ）番目の要素は利用できません。0番目の要素は空文字を設定する必要があります。

アプリケーションキーは1番目の要素から9番目の要素を利用することができます。

サンプル

DraftWFメソッドの使用コード例です。
CopyC#
private WorkflowResult workflowResult;

private void ExecDraft()
{
    DraftModel req = new DraftModel();
    {//起票者情報
        req.userID = @"ono";
        req.loginGroupID = @"default";
        req.compCd = @"comp_im_create";
        req.orgnCd = @"sec_eigyou_2";
    }
    //プロセス情報
    {
        req.processDefCd = "10";
        req.versionCd = "00000000000000000001";
    }
    //起票情報
    {
        req.processName = string.Format("Webサービスからの申請{0}", DateTime.Now); //プロセス名
        req.applicationKey = new string[] { "", "1000", "8", "9", "aaaaa" };    //アプリケーションキー
        req.comment = "コメント";
    }
    //任意情報
    {
        req.draftAppointDate = string.Empty;
        req.locale = string.Empty;
        req.processTemporaryCd = string.Empty;
    }
    //代理
    {
        req.agentUserID = null;
    }

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
                      {
                          userID = @"ono",
                          loginGroupID = @"default",
                          authType = @"MOSSNTLM"
                      };
    Intramart.Bpw.WebService.DraftServiceReference.WFResultModel res;
    using (Drafter c = new Drafter("192.168.1.120"))
    {
        //認証情報を設定
        c.Credentials = new NetworkCredential("ono", "Password!", "example");
        //起票処理
        res = c.DraftWF(ui, req);
    }
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());

    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    WorkflowResult wr = WorkflowResult.Parse(res);
    if (wr.HasError())
    {
        System.Diagnostics.Trace.WriteLine("Error");
    }

    workflowResult = wr;
}

参照

Drafter クラス


GetDraftService メソッド

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected DraftService GetDraftService()
Visual Basic (Declaration)
Protected Function GetDraftService As DraftService
Visual C++
protected:
DraftService^ GetDraftService()

戻り値

SOAP通信クライアントプロキシ

参照

Drafter クラス


GetDraftUserOrgListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス サンプル See Also
処理実行時の組織情報を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TargetOrgResultModel GetDraftUserOrgListWF(
    UserInfo userInfo,
    TargetOrgConditionModel model
)
Visual Basic (Declaration)
Public Function GetDraftUserOrgListWF ( _
    userInfo As UserInfo, _
    model As TargetOrgConditionModel _
) As TargetOrgResultModel
Visual C++
public:
TargetOrgResultModel^ GetDraftUserOrgListWF(
    UserInfo^ userInfo,
    TargetOrgConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: TargetOrgConditionModel
所属検索情報

戻り値

組織情報クラス

解説

サンプル

GetDraftUserOrgListWFメソッドの使用コード例です。
CopyC#

                    private StringWriter ExecGetDraftUserOrgListWF()
                    {
                        TargetOrgConditionModel req = new TargetOrgConditionModel();

                        //検索対象者
                        {
                            req.userID = @"ono";
                            req.loginGroupID = @"default";
                        }
                        //プロセス情報
                        {
                            req.processDefCd = "10";
                            req.versionCd = "00000000000000000001";
                        }

                        req.targetDate = DateTime.Today.ToString("yyyy/MM/dd|hh:mm:ss");

                        //WebServiceログイン情報
                        UserInfo ui = new UserInfo
                        {
                            userID = @"ono",
                            loginGroupID = @"default",
                            authType = @"MOSSNTLM"
                        };

                        Intramart.Bpw.WebService.DraftServiceReference.TargetOrgResultModel res;
                        using (Drafter c = new Drafter("192.168.1.120"))
                        {
                            //認証情報を設定
                            c.Credentials = new NetworkCredential("ono", "Password!", "example");

                            res = c.GetDraftUserOrgListWF(ui, req);
                        }

                        //戻り値の表示
                        System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
                        System.IO.StringWriter sw = new StringWriter();
                        x.Serialize(sw, res);
                        System.Diagnostics.Trace.WriteLine(sw.ToString());
                        return sw;
                    }

  参照
Drafter クラス


PullbackWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス サンプル See Also
引戻し処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel PullbackWF(
    UserInfo userInfo,
    DraftModel model
)
Visual Basic (Declaration)
Public Function PullbackWF ( _
    userInfo As UserInfo, _
    model As DraftModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ PullbackWF(
    UserInfo^ userInfo,
    DraftModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: DraftModel
起票情報

戻り値

拡張結果クラス

解説

引戻し処理を実行します。

intra-martのワークフローモジュールのDraftクラスのpullbackメソッドをラッピング実装したサービスです。

このサービスを使うことで起票直後の案件に対して引戻し処理を行うことができます。

起票直後でないタスクの引戻しはできません。

起票直後でないタスクとは、例えば、申請⇒１次承認者⇒２次承認者⇒最終承認者 のようなフローの場合、「２次承認者」タスクもしくは「最終承認者」タスクのような「申請」タスクの直後以外のタスクを示します。

サンプル

PullbackWFメソッドの使用コード例です。
CopyC#
private WorkflowResult workflowResult;

private void ExecPullback()
{
    ExecDraft();
    WorkflowInfo workflowInfo = workflowResult.models[0];

    DraftModel req = new DraftModel();
    {//起票者情報
        req.userID = @"ono";
        req.loginGroupID = @"default";
        req.compCd = @"comp_im_create";
        req.orgnCd = @"sec_eigyou_2";
    }
    //プロセス情報
    {
        req.processDefCd = "10";
        req.versionCd = "00000000000000000001";
        //起票時にプロセスコードが生成されます。
        req.processCd = workflowInfo.processCd;
    }
    //代理
    {
        req.agentUserID = null;
    }

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
                      {
                          userID = @"ono",
                          loginGroupID = @"default",
                          authType = @"MOSSNTLM"
                      };
    Intramart.Bpw.WebService.DraftServiceReference.WFResultModel res;
    using (Drafter c = new Drafter("192.168.1.120"))

    {
        //認証情報を設定
        c.Credentials = new NetworkCredential("ono", "Password!", "example");
        res = c.PullbackWF(ui, req);
    }
    WorkflowResult wr = WorkflowResult.Parse(res);
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());

    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());
    if (wr.HasError())
    {
        System.Diagnostics.Trace.WriteLine("Error");
        return;
    }
    workflowResult = wr;
}

参照

Drafter クラス


RetryWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Drafter クラス サンプル See Also
再起票処理を実行します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFResultModel RetryWF(
    UserInfo userInfo,
    DraftModel model
)
Visual Basic (Declaration)
Public Function RetryWF ( _
    userInfo As UserInfo, _
    model As DraftModel _
) As WFResultModel
Visual C++
public:
WFResultModel^ RetryWF(
    UserInfo^ userInfo,
    DraftModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: DraftModel
起票情報

戻り値

拡張結果クラス

解説

再起票処理を実行します。

intra-martのワークフローモジュールのDraftクラスのretryメソッドをラッピング実装したサービスです。

このサービスを使うことで本人の再起票処理を行うことができます。

ユーザの起票会社コード・起票組織コードには、そのユーザが所属している組織を設定してください。

次タスクが動的承認者の場合は、利用できません。

根回しメール機能は、クライアント側の実装となります。

アプリケーションキーの0（ゼロ）番目の要素は利用できません。0番目の要素は空文字を設定する必要があります。

アプリケーションキーは1番目の要素から9番目の要素を利用することができます。

サンプル

RetryWFメソッドの使用コード例です。
CopyC#
private WorkflowResult workflowResult;

private void ExecRetry()
{
    ExecDraft();    //起票
    ExecPullback(); //引き戻し
    WorkflowInfo workflowInfo = workflowResult.models[0];

    DraftModel req = new DraftModel();

    {//起票者情報
        req.userID = @"ono";
        req.loginGroupID = @"default";
        req.compCd = @"comp_im_create";
        req.orgnCd = @"sec_eigyou_2";
    }
    //プロセス情報
    {
        req.processDefCd = workflowInfo.processDefCd;
        req.versionCd = workflowInfo.versionCd;
        req.processCd = workflowInfo.processCd;
    }
    //再起票情報
    {
        req.processName = string.Format("Webサービスからの再申請{0}", DateTime.Now);
        req.applicationKey = new string[] { "", "10000", "0", "0", "Retry" };    //アプリケーションキー
        req.comment = string.Format("再申請"); ;
    }

    //代理
    {
        req.agentUserID = null;
    }

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
    {
        userID = @"ono",
        loginGroupID = @"default",
        authType = @"MOSSNTLM"
    };
    Intramart.Bpw.WebService.DraftServiceReference.WFResultModel res;
    using (Drafter c = new Drafter("192.168.1.120"))
    {
        //認証情報を設定
        c.Credentials = new NetworkCredential("ono", "Password!", "example");
        res = c.RetryWF(ui, req);
    }
    WorkflowResult wr = WorkflowResult.Parse(res);

    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    if (wr.HasError())
    {
        System.Diagnostics.Trace.WriteLine("Error");
        return;
    }
    workflowResult = wr;
}

参照

Drafter クラス


Drafter プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
Drafter クラス See Also

Drafter については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

Drafter クラス


DraftList クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
起票済み案件情報に取得に使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class DraftList : WebServicesClient
Visual Basic (Declaration)
Public Class DraftList _
    Inherits WebServicesClient
Visual C++
public ref class DraftList : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.DraftList

参照

DraftList メンバ


DraftList メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
DraftList クラス コンストラクタ メソッド フィールド プロパティ See Also

DraftList については メンバ を参照

コンストラクタ

名称 | 詳細
DraftList | オーバーロードされます

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetDraftListService | SOAP通信クライアントプロキシを取得します。
GetEndedList | 起票済み案件を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetListWF | 起票可能プロセス一覧を取得します。
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

DraftList クラス


DraftList コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also

オーバーロード リスト

名称 | 詳細
DraftList()()() | コンストラクタ
DraftList(String) | コンストラクタ
DraftList(String, Int32) | コンストラクタ

参照

DraftList クラス
DraftList メンバ


DraftList コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DraftList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
DraftList()

参照

DraftList クラス
DraftList オーバーロード


DraftList コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DraftList(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
DraftList(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

DraftList クラス
DraftList オーバーロード


DraftList コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DraftList(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
DraftList(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

DraftList クラス
DraftList オーバーロード


DraftList フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also

DraftList については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

DraftList クラス


DraftList メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also

DraftList については メソッド を参照

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetDraftListService | SOAP通信クライアントプロキシを取得します。
GetEndedList | 起票済み案件を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetListWF | 起票可能プロセス一覧を取得します。
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

DraftList クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

DraftList クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

DraftList クラス
DraftList メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

DraftList クラス
Dispose オーバーロード


GetDraftListService メソッド

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected DraftListService GetDraftListService()
Visual Basic (Declaration)
Protected Function GetDraftListService As DraftListService
Visual C++
protected:
DraftListService^ GetDraftListService()

戻り値

SOAP通信クライアントプロキシ

参照

DraftList クラス


GetEndedList メソッド

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
起票済み案件を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DraftEndedResultModel GetEndedList(
    UserInfo userInfo,
    SearchConditionModel model
)
Visual Basic (Declaration)
Public Function GetEndedList ( _
    userInfo As UserInfo, _
    model As SearchConditionModel _
) As DraftEndedResultModel
Visual C++
public:
DraftEndedResultModel^ GetEndedList(
    UserInfo^ userInfo,
    SearchConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: SearchConditionModel
検索条件

戻り値

起票済み案件情報

解説

起票済み案件を取得します。

起票済み案件一覧情報は、起票済み案件情報オブジェクトのリストです。

intra-martのワークフローモジュールのDraftクラスのgetEndProcessListメソッドをラッピング実装したサービスです。

このサービスを使うことで特定のユーザが起票した案件一覧を取得することができます。

取得した一覧は、以下の順序となります。

1. 完了タスク (否認)

2. 差し戻しタスク

3. 引き戻しタスク

4. 未処理タスク

5. 完了タスク (否認以外)

また、ソート項目を指定した場合、タスクごとのソートとなります。

参照

DraftList クラス


GetListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also
起票可能プロセス一覧を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public DraftListResultModel GetListWF(
    UserInfo userInfo,
    SearchConditionModel model
)
Visual Basic (Declaration)
Public Function GetListWF ( _
    userInfo As UserInfo, _
    model As SearchConditionModel _
) As DraftListResultModel
Visual C++
public:
DraftListResultModel^ GetListWF(
    UserInfo^ userInfo,
    SearchConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: SearchConditionModel
検索条件

戻り値

起票可能プロセス情報

解説

起票可能プロセス一覧を取得します。

起票可能プロセス一覧情報は、起票可能プロセスオブジェクトのリストです。

intra-martのワークフローモジュールのDraftクラスのgetActivityProcessDefListメソッドをラッピング実装したサービスです。

このサービスを使うことで特定のユーザが起票できる案件（プロセス）の一覧を取得することができます。

起票する際に必要となる所属会社・組織情報も取得することができます。

一覧を取得するための検索条件を指定することはできません。（すべて取得されます）

参照

DraftList クラス


DraftList プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
DraftList クラス See Also

DraftList については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

DraftList クラス


Process クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
案件関連の情報取得などに使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class Process : WebServicesClient
Visual Basic (Declaration)
Public Class Process _
    Inherits WebServicesClient
Visual C++
public ref class Process : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.Process

参照

Process メンバ


Process メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
Process クラス コンストラクタ メソッド フィールド プロパティ See Also

Process については メンバ を参照

コンストラクタ

名称 | 詳細
Process | オーバーロードされます

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetApprovedFlowInfoListWF | 処理(承認)したタスク情報を取得します。
GetCurrentFlowInfoListWF | プロセス上の現在位置を取得します。
GetCustomProcessStatusWF | プロセスコードに対応するステータスを返却します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetProcessHistoryListWF | 案件の処理履歴を取得します。
GetProcessInfoWF | プロセス情報を取得します。
GetProcessService | SOAP通信クライアントプロキシを取得します。
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

Process クラス


Process コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
Process クラス See Also

オーバーロード リスト

名称 | 詳細
Process()()() | コンストラクタ
Process(String) | コンストラクタ
Process(String, Int32) | コンストラクタ

参照

Process クラス
Process メンバ


Process コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Process()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Process()

参照

Process クラス
Process オーバーロード


Process コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Process(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
Process(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

Process クラス
Process オーバーロード


Process コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Process(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
Process(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

Process クラス
Process オーバーロード


Process フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
Process クラス See Also

Process については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

Process クラス


Process メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
Process クラス See Also

Process については メソッド を参照

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetApprovedFlowInfoListWF | 処理(承認)したタスク情報を取得します。
GetCurrentFlowInfoListWF | プロセス上の現在位置を取得します。
GetCustomProcessStatusWF | プロセスコードに対応するステータスを返却します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetProcessHistoryListWF | 案件の処理履歴を取得します。
GetProcessInfoWF | プロセス情報を取得します。
GetProcessService | SOAP通信クライアントプロキシを取得します。
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

Process クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

Process クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
Process クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

Process クラス
Process メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

Process クラス
Dispose オーバーロード


GetApprovedFlowInfoListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
処理(承認)したタスク情報を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public ApprovedFlowResultModel GetApprovedFlowInfoListWF(
    UserInfo userInfo,
    ProcessSearchModel model
)
Visual Basic (Declaration)
Public Function GetApprovedFlowInfoListWF ( _
    userInfo As UserInfo, _
    model As ProcessSearchModel _
) As ApprovedFlowResultModel
Visual C++
public:
ApprovedFlowResultModel^ GetApprovedFlowInfoListWF(
    UserInfo^ userInfo,
    ProcessSearchModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ProcessSearchModel
プロセス検索情報

戻り値

承認済みタスク一覧

解説

処理（承認）したタスク情報を取得します。

タスク情報の一覧は、処理（承認）したタスク情報のリストです。

intra-martのワークフローモジュールのProcessクラスのgetProcessHistoryメソッドをラッピング実装したサービスです。

このサービスを使うことで処理（承認）したタスクの一覧情報を行うことができます。

intra-martの標準画面のフロー表示（フローの進行状況の画像）で、人が処理したタスクおよび待ちのタスク（赤枠および青枠）のタスク情報を取得します。複数ルートの分岐内、同期内において、差戻しできないものに対して当該サービスで取得した情報をもとに差戻しを行う場合は、エラーステータスを利用してエラーハンドリングを行ってください。

参照

Process クラス


GetCurrentFlowInfoListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
プロセス上の現在位置を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public CurrentFlowResultModel GetCurrentFlowInfoListWF(
    UserInfo userInfo,
    ProcessSearchModel model
)
Visual Basic (Declaration)
Public Function GetCurrentFlowInfoListWF ( _
    userInfo As UserInfo, _
    model As ProcessSearchModel _
) As CurrentFlowResultModel
Visual C++
public:
CurrentFlowResultModel^ GetCurrentFlowInfoListWF(
    UserInfo^ userInfo,
    ProcessSearchModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ProcessSearchModel
プロセス検索情報

戻り値

現在位置情報

解説

プロセス上の現在位置を取得します。

現在位置情報の一覧は、現在位置情報オブジェクトのリストです。

intra-martのワークフローモジュールのProcessクラスのgetFlowメソッドをラッピング実装したサービスです。

このサービスを使うことでプロセス上の現在位置情報を取得することができます。

現在位置が複数存在する場合は、複数の現在位置情報を取得することができます。

参照

Process クラス


GetCustomProcessStatusWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
プロセスコードに対応するステータスを返却します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public ProcessInfoRsltModel GetCustomProcessStatusWF(
    UserInfo userInfo,
    ProcessSearchModel model
)
Visual Basic (Declaration)
Public Function GetCustomProcessStatusWF ( _
    userInfo As UserInfo, _
    model As ProcessSearchModel _
) As ProcessInfoRsltModel
Visual C++
public:
ProcessInfoRsltModel^ GetCustomProcessStatusWF(
    UserInfo^ userInfo,
    ProcessSearchModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ProcessSearchModel
プロセス検索情報

戻り値

プロセスステータス

参照

Process クラス


GetProcessHistoryListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
案件の処理履歴を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public ProcessHistoryResultModel GetProcessHistoryListWF(
    UserInfo userInfo,
    ProcessSearchModel model
)
Visual Basic (Declaration)
Public Function GetProcessHistoryListWF ( _
    userInfo As UserInfo, _
    model As ProcessSearchModel _
) As ProcessHistoryResultModel
Visual C++
public:
ProcessHistoryResultModel^ GetProcessHistoryListWF(
    UserInfo^ userInfo,
    ProcessSearchModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ProcessSearchModel
プロセス検索情報

戻り値

プロセス履歴情報

解説

案件の処理履歴を取得します。

案件の処理履歴の一覧は、案件の処理履歴オブジェクトのリストです。

intra-martのワークフローモジュールのProcessクラスのgetProcessHistoryメソッドをラッピング実装したサービスです。

このサービスを使うことで特定の案件の処理履歴情報の一覧をすべて取得することができます。

参照

Process クラス


GetProcessInfoWF メソッド

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
プロセス情報を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public ProcessInfoRsltModel GetProcessInfoWF(
    UserInfo userInfo,
    ProcessSearchModel model
)
Visual Basic (Declaration)
Public Function GetProcessInfoWF ( _
    userInfo As UserInfo, _
    model As ProcessSearchModel _
) As ProcessInfoRsltModel
Visual C++
public:
ProcessInfoRsltModel^ GetProcessInfoWF(
    UserInfo^ userInfo,
    ProcessSearchModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: ProcessSearchModel
プロセス検索情報

戻り値

プロセス情報

参照

Process クラス


GetProcessService メソッド

[image]

intra-mart Wrokflow Client for .Net
Process クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected ProcessService GetProcessService()
Visual Basic (Declaration)
Protected Function GetProcessService As ProcessService
Visual C++
protected:
ProcessService^ GetProcessService()

戻り値

SOAP通信クライアントプロキシ

参照

Process クラス


Process プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
Process クラス See Also

Process については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

Process クラス


TaskInfo クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
タスク情報関連処理で使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class TaskInfo : WebServicesClient
Visual Basic (Declaration)
Public Class TaskInfo _
    Inherits WebServicesClient
Visual C++
public ref class TaskInfo : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.TaskInfo

参照

TaskInfo メンバ


TaskInfo メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス コンストラクタ メソッド フィールド プロパティ See Also

TaskInfo については メンバ を参照

コンストラクタ

名称 | 詳細
TaskInfo | オーバーロードされます

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetTargetActivityDefInfoWF | アクティビティの処理対象者を取得します。
GetTargetRunGroup | プロセスとアクティビティに対応するユーザを取得します。
GetTargetRunGroupByProcessCd | プロセスに対応するユーザを検索します。
GetTaskInfoService | SOAP通信クライアントプロキシを取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

TaskInfo クラス


TaskInfo コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also

オーバーロード リスト

名称 | 詳細
TaskInfo()()() | コンストラクタ
TaskInfo(String) | コンストラクタ
TaskInfo(String, Int32) | コンストラクタ

参照

TaskInfo クラス
TaskInfo メンバ


TaskInfo コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TaskInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TaskInfo()

参照

TaskInfo クラス
TaskInfo オーバーロード


TaskInfo コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TaskInfo(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
TaskInfo(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

TaskInfo クラス
TaskInfo オーバーロード


TaskInfo コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TaskInfo(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
TaskInfo(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

TaskInfo クラス
TaskInfo オーバーロード


TaskInfo フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also

TaskInfo については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

TaskInfo クラス


TaskInfo メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also

TaskInfo については メソッド を参照

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetTargetActivityDefInfoWF | アクティビティの処理対象者を取得します。
GetTargetRunGroup | プロセスとアクティビティに対応するユーザを取得します。
GetTargetRunGroupByProcessCd | プロセスに対応するユーザを検索します。
GetTaskInfoService | SOAP通信クライアントプロキシを取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

TaskInfo クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

TaskInfo クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

TaskInfo クラス
TaskInfo メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

TaskInfo クラス
Dispose オーバーロード


GetTargetActivityDefInfoWF メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス サンプル See Also
アクティビティの処理対象者を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TargetActivityDefInfoResultModel GetTargetActivityDefInfoWF(
    UserInfo userInfo,
    TargetActivityDefInfoConditionModel model
)
Visual Basic (Declaration)
Public Function GetTargetActivityDefInfoWF ( _
    userInfo As UserInfo, _
    model As TargetActivityDefInfoConditionModel _
) As TargetActivityDefInfoResultModel
Visual C++
public:
TargetActivityDefInfoResultModel^ GetTargetActivityDefInfoWF(
    UserInfo^ userInfo,
    TargetActivityDefInfoConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: TargetActivityDefInfoConditionModel
アクティビティ対象者検索情報

戻り値

処理対象者一覧

解説

サンプル

メソッドの使用コード例です。
CopyC#
private void ExecGetTargetActivityDefInf()
{

    TargetActivityDefInfoConditionModel req = new TargetActivityDefInfoConditionModel();

    //検索者
    {
        req.userID = @"ono";
        req.loginGroupID = @"default";
    }

    //検索アクティビティ
    {
        req.processDefCd = "10";
        req.versionCd = "00000000000000000001";
        req.activityCd ="5";
    }

    //WebServiceにログインするための情報を設定
    //Windows認証を使用する為パスワードを設定する必要はない。
    UserInfo ui = new UserInfo();
    ui.userID = req.userID;
    ui.loginGroupID = req.loginGroupID;

    TargetActivityDefInfoResultModel res;
    using (TaskInfo c = new TaskInfo(WebServiceHostName))
    {
        //HACK :
        c.Credentials = GetCredentials(ui.userID);

        res = c.GetTargetActivityDefInfoWF(ui, req);
    }

    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());
}

参照

TaskInfo クラス


GetTargetRunGroup メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
プロセスとアクティビティに対応するユーザを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TargetRunGroupResultModel GetTargetRunGroup(
    UserInfo userInfo,
    TargetRunGroupConditionModel model
)
Visual Basic (Declaration)
Public Function GetTargetRunGroup ( _
    userInfo As UserInfo, _
    model As TargetRunGroupConditionModel _
) As TargetRunGroupResultModel
Visual C++
public:
TargetRunGroupResultModel^ GetTargetRunGroup(
    UserInfo^ userInfo,
    TargetRunGroupConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: TargetRunGroupConditionModel
タスク検索情報

戻り値

アクティビティの所有者

参照

TaskInfo クラス


GetTargetRunGroupByProcessCd メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
プロセスに対応するユーザを検索します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TargetRunGroupResultModel GetTargetRunGroupByProcessCd(
    UserInfo userInfo,
    TargetRunGroupConditionModel model
)
Visual Basic (Declaration)
Public Function GetTargetRunGroupByProcessCd ( _
    userInfo As UserInfo, _
    model As TargetRunGroupConditionModel _
) As TargetRunGroupResultModel
Visual C++
public:
TargetRunGroupResultModel^ GetTargetRunGroupByProcessCd(
    UserInfo^ userInfo,
    TargetRunGroupConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: TargetRunGroupConditionModel
タスク検索情報

戻り値

ユーザ一覧

参照

TaskInfo クラス


GetTaskInfoService メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected TaskInfoService GetTaskInfoService()
Visual Basic (Declaration)
Protected Function GetTaskInfoService As TaskInfoService
Visual C++
protected:
TaskInfoService^ GetTaskInfoService()

戻り値

SOAP通信クライアントプロキシ

参照

TaskInfo クラス


TaskInfo プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
TaskInfo クラス See Also

TaskInfo については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

TaskInfo クラス


TaskList クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
タスクリスト関連の処理に使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class TaskList : WebServicesClient
Visual Basic (Declaration)
Public Class TaskList _
    Inherits WebServicesClient
Visual C++
public ref class TaskList : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.TaskList

参照

TaskList メンバ


TaskList メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
TaskList クラス コンストラクタ メソッド フィールド プロパティ See Also

TaskList については メンバ を参照

コンストラクタ

名称 | 詳細
TaskList | オーバーロードされます

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetEndedTaskListWF | 処理済案件一覧を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetTaskListService | SOAP通信クライアントプロキシを取得します。
GetTaskListWF | 処理可能案件(未処理案件)一覧を取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

TaskList クラス


TaskList コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also

オーバーロード リスト

名称 | 詳細
TaskList()()() | コンストラクタ
TaskList(String) | コンストラクタ
TaskList(String, Int32) | コンストラクタ

参照

TaskList クラス
TaskList メンバ


TaskList コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TaskList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TaskList()

参照

TaskList クラス
TaskList オーバーロード


TaskList コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TaskList(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
TaskList(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

TaskList クラス
TaskList オーバーロード


TaskList コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TaskList(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
TaskList(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

TaskList クラス
TaskList オーバーロード


TaskList フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also

TaskList については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

TaskList クラス


TaskList メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also

TaskList については メソッド を参照

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetEndedTaskListWF | 処理済案件一覧を取得します。
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetTaskListService | SOAP通信クライアントプロキシを取得します。
GetTaskListWF | 処理可能案件(未処理案件)一覧を取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

TaskList クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

TaskList クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

TaskList クラス
TaskList メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

TaskList クラス
Dispose オーバーロード


GetEndedTaskListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
処理済案件一覧を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public EndTaskListResultModel GetEndedTaskListWF(
    UserInfo userInfo,
    SearchConditionModel model
)
Visual Basic (Declaration)
Public Function GetEndedTaskListWF ( _
    userInfo As UserInfo, _
    model As SearchConditionModel _
) As EndTaskListResultModel
Visual C++
public:
EndTaskListResultModel^ GetEndedTaskListWF(
    UserInfo^ userInfo,
    SearchConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: SearchConditionModel
検索情報

戻り値

処理済案件一覧

解説

処理済案件一覧を取得します。

処理済案件一覧情報は、処理済案件情報オブジェクトのリストです。

intra-martのワークフローモジュールのApproverクラスのgetEndTaskListメソッドをラッピング実装したサービスです。

このサービスを使うことで特定のユーザの処理（承認、否認、保留、差戻し）した案件一覧を取得することができます。

一覧を取得するための検索条件を指定することはできません。（すべて取得されます）

参照

TaskList クラス


GetTaskListService メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected TaskListService GetTaskListService()
Visual Basic (Declaration)
Protected Function GetTaskListService As TaskListService
Visual C++
protected:
TaskListService^ GetTaskListService()

戻り値

SOAP通信クライアントプロキシ

参照

TaskList クラス


GetTaskListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also
処理可能案件(未処理案件)一覧を取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public TaskListResultModel GetTaskListWF(
    UserInfo userInfo,
    SearchConditionModel model
)
Visual Basic (Declaration)
Public Function GetTaskListWF ( _
    userInfo As UserInfo, _
    model As SearchConditionModel _
) As TaskListResultModel
Visual C++
public:
TaskListResultModel^ GetTaskListWF(
    UserInfo^ userInfo,
    SearchConditionModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: SearchConditionModel
検索情報

戻り値

処理可能案件一覧

解説

処理可能案件(未処理案件)一覧を取得します。

処理可能案件(未処理案件)一覧情報は、処理可能案件情報オブジェクトのリストです。

intra-martのワークフローモジュールのApproverクラスのgetActivityTaskListメソッドをラッピング実装したサービスです。

このサービスを使うことで特定のユーザが処理（承認、否認、保留、差戻し）する必要がある未処理一覧を取得することができます。

処理する際に必要となる所属会社・組織情報も取得することができます。

参照

TaskList クラス


TaskList プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
TaskList クラス See Also

TaskList については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

TaskList クラス


UserInfo クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
ユーザ情報

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
[SerializableAttribute]
public class UserInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class UserInfo
Visual C++
[SerializableAttribute]
public ref class UserInfo

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.UserInfo

参照

UserInfo メンバ


UserInfo メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
UserInfo クラス コンストラクタ メソッド プロパティ See Also

UserInfo については メンバ を参照

コンストラクタ

名称 | 詳細
UserInfo | Initializes a new instance of the UserInfo class

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

プロパティ

名称 | 詳細
authType | 認証タイプ
loginGroupID | ログイングループID
password | パスワード
userID | ユーザID

参照

UserInfo クラス


UserInfo コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
UserInfo クラス See Also
Initializes a new instance of the UserInfo class

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public UserInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UserInfo()

参照

UserInfo クラス


UserInfo メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
UserInfo クラス See Also

UserInfo については メソッド を参照

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

UserInfo クラス


UserInfo プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
UserInfo クラス See Also

UserInfo については プロパティ を参照

プロパティ

名称 | 詳細
authType | 認証タイプ
loginGroupID | ログイングループID
password | パスワード
userID | ユーザID

参照

UserInfo クラス


authType プロパティ

[image]

intra-mart Wrokflow Client for .Net
UserInfo クラス See Also
認証タイプ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string authType { get; set; }
Visual Basic (Declaration)
Public Property authType As String
Visual C++
public:
property String^ authType {
    String^ get ();
    void set (String^ value);
}

参照

UserInfo クラス


loginGroupID プロパティ

[image]

intra-mart Wrokflow Client for .Net
UserInfo クラス See Also
ログイングループID

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string loginGroupID { get; set; }
Visual Basic (Declaration)
Public Property loginGroupID As String
Visual C++
public:
property String^ loginGroupID {
    String^ get ();
    void set (String^ value);
}

参照

UserInfo クラス


password プロパティ

[image]

intra-mart Wrokflow Client for .Net
UserInfo クラス See Also
パスワード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string password { get; set; }
Visual Basic (Declaration)
Public Property password As String
Visual C++
public:
property String^ password {
    String^ get ();
    void set (String^ value);
}

参照

UserInfo クラス


userID プロパティ

[image]

intra-mart Wrokflow Client for .Net
UserInfo クラス See Also
ユーザID

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string userID { get; set; }
Visual Basic (Declaration)
Public Property userID As String
Visual C++
public:
property String^ userID {
    String^ get ();
    void set (String^ value);
}

参照

UserInfo クラス


WebServicesClient クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
intra-mart Webサービスクライアントクラス

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public abstract class WebServicesClient : IDisposable
Visual Basic (Declaration)
Public MustInherit Class WebServicesClient _
    Implements IDisposable
Visual C++
public ref class WebServicesClient abstract : IDisposable

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.Approver
Intramart.Bpw.WebService.Client..::.CompanyManager
Intramart.Bpw.WebService.Client..::.Drafter
Intramart.Bpw.WebService.Client..::.DraftList
Intramart.Bpw.WebService.Client..::.Process
Intramart.Bpw.WebService.Client..::.TaskInfo
Intramart.Bpw.WebService.Client..::.TaskList
Intramart.Bpw.WebService.Client..::.WFInformation
Intramart.Bpw.WebService.Client..::.WFShortCutUrl

参照

WebServicesClient メンバ


WebServicesClient メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス コンストラクタ メソッド フィールド プロパティ See Also

WebServicesClient については メンバ を参照

コンストラクタ

名称 | 詳細
WebServicesClient | コンストラクタ

メソッド

名称 | 詳細
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (Object..::.Finalize()()()をオーバーロード)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報
Host | URLポート
Port | URLホスト名

参照

WebServicesClient クラス


WebServicesClient コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WebServicesClient()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebServicesClient()

参照

WebServicesClient クラス


WebServicesClient フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also

WebServicesClient については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ

参照

WebServicesClient クラス


CreateWebServiceInstance フィールド

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
SOAP使用時のクライアントプロキシ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected WebServicesClient..::.CreateWebServiceInstanceDelegate CreateWebServiceInstance
Visual Basic (Declaration)
Protected CreateWebServiceInstance As WebServicesClient..::.CreateWebServiceInstanceDelegate
Visual C++
protected:
WebServicesClient..::.CreateWebServiceInstanceDelegate^ CreateWebServiceInstance

参照

WebServicesClient クラス


WebServicesClient メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also

WebServicesClient については メソッド を参照

メソッド

名称 | 詳細
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (Object..::.Finalize()()()をオーバーロード)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

WebServicesClient クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

参照

WebServicesClient クラス
WebServicesClient メンバ


Dispose メソッド

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
使用されているすべてのリソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Dispose()
Visual Basic (Declaration)
Public Sub Dispose
Visual C++
public:
virtual void Dispose() sealed

インプリメント

IDisposable..::.Dispose()()()

参照

WebServicesClient クラス
Dispose オーバーロード


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected virtual void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overridable Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
)

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

WebServicesClient クラス
Dispose オーバーロード


Finalize メソッド

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
ファイナライザ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize
Visual C++
protected:
virtual void Finalize() override

参照

WebServicesClient クラス


GetSoapHttpClientProtocol メソッド

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
SOAP使用時のクライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected SoapHttpClientProtocol GetSoapHttpClientProtocol()
Visual Basic (Declaration)
Protected Function GetSoapHttpClientProtocol As SoapHttpClientProtocol
Visual C++
protected:
SoapHttpClientProtocol^ GetSoapHttpClientProtocol()

戻り値

プロキシオブジェクト。

参照

WebServicesClient クラス


GetWebService メソッド

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected virtual SoapHttpClientProtocol GetWebService()
Visual Basic (Declaration)
Protected Overridable Function GetWebService As SoapHttpClientProtocol
Visual C++
protected:
virtual SoapHttpClientProtocol^ GetWebService()

戻り値

プロキシオブジェクト。

参照

WebServicesClient クラス


WebServicesClient プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also

WebServicesClient については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報
Host | URLポート
Port | URLホスト名

参照

WebServicesClient クラス


Credentials プロパティ

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
Web クライアント認証の資格情報

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public ICredentials Credentials { get; set; }
Visual Basic (Declaration)
Public Property Credentials As ICredentials
Visual C++
public:
property ICredentials^ Credentials {
    ICredentials^ get ();
    void set (ICredentials^ value);
}

参照

WebServicesClient クラス


Host プロパティ

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
URLポート

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string Host { get; set; }
Visual Basic (Declaration)
Public Property Host As String
Visual C++
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}

参照

WebServicesClient クラス


Port プロパティ

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
URLホスト名

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public Nullable<int> Port { get; set; }
Visual Basic (Declaration)
Public Property Port As Nullable(Of Integer)
Visual C++
public:
property Nullable<int> Port {
    Nullable<int> get ();
    void set (Nullable<int> value);
}

参照

WebServicesClient クラス


WebServicesClient.CreateWebServiceInstanceDelegate デリゲート

[image]

intra-mart Wrokflow Client for .Net
WebServicesClient クラス See Also
プロキシを取得するデリゲート。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected delegate SoapHttpClientProtocol CreateWebServiceInstanceDelegate()
Visual Basic (Declaration)
Protected Delegate Function CreateWebServiceInstanceDelegate As SoapHttpClientProtocol
Visual C++
protected delegate SoapHttpClientProtocol^ CreateWebServiceInstanceDelegate()

戻り値

SoapHttpClientProtocolオブジェクト

参照

Intramart.Bpw.WebService.Client Namespace


WFInformation クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
ワークフロー情報関連の処理に使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class WFInformation : WebServicesClient
Visual Basic (Declaration)
Public Class WFInformation _
    Inherits WebServicesClient
Visual C++
public ref class WFInformation : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.WFInformation

参照

WFInformation メンバ


WFInformation メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
WFInformation クラス コンストラクタ メソッド フィールド プロパティ See Also

WFInformation については メンバ を参照

コンストラクタ

名称 | 詳細
WFInformation | オーバーロードされます

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetIMUniqueIDWF | intra-mart内で管理(生成)するユニークIDを取得します
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetWFInformationService | SOAP通信クライアントプロキシを取得します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

WFInformation クラス


WFInformation コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also

オーバーロード リスト

名称 | 詳細
WFInformation()()() | コンストラクタ
WFInformation(String) | コンストラクタ
WFInformation(String, Int32) | コンストラクタ

参照

WFInformation クラス
WFInformation メンバ


WFInformation コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFInformation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WFInformation()

参照

WFInformation クラス
WFInformation オーバーロード


WFInformation コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFInformation(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
WFInformation(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

WFInformation クラス
WFInformation オーバーロード


WFInformation コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFInformation(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
WFInformation(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

WFInformation クラス
WFInformation オーバーロード


WFInformation フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also

WFInformation については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

WFInformation クラス


WFInformation メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also

WFInformation については メソッド を参照

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetIMUniqueIDWF | intra-mart内で管理(生成)するユニークIDを取得します
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetWFInformationService | SOAP通信クライアントプロキシを取得します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

WFInformation クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

WFInformation クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

WFInformation クラス
WFInformation メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

WFInformation クラス
Dispose オーバーロード


GetIMUniqueIDWF メソッド

[image]

intra-mart Wrokflow Client for .Net
WFInformation クラス サンプル See Also
intra-mart内で管理(生成)するユニークIDを取得します

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public IMUniqueIDResultModel GetIMUniqueIDWF(
    UserInfo userInfo,
    IMUniqueIDParamModel model
)
Visual Basic (Declaration)
Public Function GetIMUniqueIDWF ( _
    userInfo As UserInfo, _
    model As IMUniqueIDParamModel _
) As IMUniqueIDResultModel
Visual C++
public:
IMUniqueIDResultModel^ GetIMUniqueIDWF(
    UserInfo^ userInfo,
    IMUniqueIDParamModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: IMUniqueIDParamModel
処理ユーザ情報

戻り値

ユニークID

解説

サンプル

GetIMUniqueIDWFメソッドの使用コード例です。
CopyC#
private string GetIMUniqueID(string userID, string loginGroupID)
{
    IMUniqueIDParamModel req = new IMUniqueIDParamModel();

    req.userID = userID;
    req.loginGroupID = loginGroupID;

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
    {
        userID = userID,
        loginGroupID = loginGroupID,
        authType = @"MOSSNTLM"
    };
    IMUniqueIDResultModel res;
    using (WFInformation c = new WFInformation(WebServiceHostName))
    {
        //HACK :
        c.Credentials = GetCredentials(ui.userID);

        res = c.GetIMUniqueIDWF(ui, req);
    }
    return res.imUniqueID;
}///

参照

WFInformation クラス


GetWFInformationService メソッド

[image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected WFInformationService GetWFInformationService()
Visual Basic (Declaration)
Protected Function GetWFInformationService As WFInformationService
Visual C++
protected:
WFInformationService^ GetWFInformationService()

戻り値

SOAP通信クライアントプロキシ

参照

WFInformation クラス


WFInformation プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
WFInformation クラス See Also

WFInformation については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

WFInformation クラス


WFShortCutUrl クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
ショートカットURL関連の処理に使用されるクラスです。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class WFShortCutUrl : WebServicesClient
Visual Basic (Declaration)
Public Class WFShortCutUrl _
    Inherits WebServicesClient
Visual C++
public ref class WFShortCutUrl : public WebServicesClient

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WebServicesClient
Intramart.Bpw.WebService.Client..::.WFShortCutUrl

参照

WFShortCutUrl メンバ


WFShortCutUrl メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス コンストラクタ メソッド フィールド プロパティ See Also

WFShortCutUrl については メンバ を参照

コンストラクタ

名称 | 詳細
WFShortCutUrl | オーバーロードされます

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetURL4AgentSettingListWF | 代理設定フォームのショートカットURLを取得します
GetURL4FlowInfoWF | ワークフロー情報フォームのショートカットURLを取得します
GetURL4HistoryInfoWF | ワークフロー履歴フォームのショートカットURLを取得します
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetWFShortCutUrlService | SOAP通信クライアントプロキシを取得します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

WFShortCutUrl クラス


WFShortCutUrl コンストラクタ

[image] [image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also

オーバーロード リスト

名称 | 詳細
WFShortCutUrl()()() | コンストラクタ
WFShortCutUrl(String) | コンストラクタ
WFShortCutUrl(String, Int32) | コンストラクタ

参照

WFShortCutUrl クラス
WFShortCutUrl メンバ


WFShortCutUrl コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFShortCutUrl()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WFShortCutUrl()

参照

WFShortCutUrl クラス
WFShortCutUrl オーバーロード


WFShortCutUrl コンストラクタ (String)

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFShortCutUrl(
    string hostname
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String _
)
Visual C++
public:
WFShortCutUrl(
    String^ hostname
)

パラメータ

hostname
Type: System..::.String
ホスト名

参照

WFShortCutUrl クラス
WFShortCutUrl オーバーロード


WFShortCutUrl コンストラクタ (String, Int32)

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also
コンストラクタ

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFShortCutUrl(
    string hostname,
    int port
)
Visual Basic (Declaration)
Public Sub New ( _
    hostname As String, _
    port As Integer _
)
Visual C++
public:
WFShortCutUrl(
    String^ hostname,
    int port
)

パラメータ

hostname
Type: System..::.String
ホスト名
port
Type: System..::.Int32
ポート名

参照

WFShortCutUrl クラス
WFShortCutUrl オーバーロード


WFShortCutUrl フィールド

[image] [image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also

WFShortCutUrl については フィールド を参照

フィールド

名称 | 詳細
CreateWebServiceInstance | SOAP使用時のクライアントプロキシ (WebServicesClientより継承)

参照

WFShortCutUrl クラス


WFShortCutUrl メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also

WFShortCutUrl については メソッド を参照

メソッド

名称 | 詳細
Close | リソースを解放します。
Dispose | オーバーロードされます
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | ファイナライザ (WebServicesClientより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetSoapHttpClientProtocol | SOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
GetURL4AgentSettingListWF | 代理設定フォームのショートカットURLを取得します
GetURL4FlowInfoWF | ワークフロー情報フォームのショートカットURLを取得します
GetURL4HistoryInfoWF | ワークフロー履歴フォームのショートカットURLを取得します
GetWebService | 指定したホスト情報を設定したSOAP使用時のクライアントプロキシを取得します。 (WebServicesClientより継承)
GetWFShortCutUrlService | SOAP通信クライアントプロキシを取得します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

WFShortCutUrl クラス


Close メソッド

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also
リソースを解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close
Visual C++
public:
void Close()

参照

WFShortCutUrl クラス


Dispose メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also

オーバーロード リスト

名称 | 詳細
Dispose()()() | 使用されているすべてのリソースを解放します。 (WebServicesClientより継承)
Dispose(Boolean) | 使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。 (WebServicesClient..::.Dispose(Boolean)をオーバーロード)

参照

WFShortCutUrl クラス
WFShortCutUrl メンバ


Dispose メソッド (Boolean)

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also
使用されているアンマネージ リソースを解放し、オプションでマネージ リソースも解放します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected override void Dispose(
    bool disposing
)
Visual Basic (Declaration)
Protected Overrides Sub Dispose ( _
    disposing As Boolean _
)
Visual C++
protected:
virtual void Dispose(
    bool disposing
) override

パラメータ

disposing
Type: System..::.Boolean
マネージ リソースとアンマネージ リソースの両方を解放する場合は true。アンマネージ リソースだけを解放する場合は false。

参照

WFShortCutUrl クラス
Dispose オーバーロード


GetURL4AgentSettingListWF メソッド

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス サンプル See Also
代理設定フォームのショートカットURLを取得します

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFShortCutUrlResultModel GetURL4AgentSettingListWF(
    UserInfo userInfo,
    WFShortCutUrlParamModel model
)
Visual Basic (Declaration)
Public Function GetURL4AgentSettingListWF ( _
    userInfo As UserInfo, _
    model As WFShortCutUrlParamModel _
) As WFShortCutUrlResultModel
Visual C++
public:
WFShortCutUrlResultModel^ GetURL4AgentSettingListWF(
    UserInfo^ userInfo,
    WFShortCutUrlParamModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: WFShortCutUrlParamModel
ショートカットURL取得情報

戻り値

ショートカットURL

解説

サンプル

GetURL4AgentSettingListWFメソッドの使用コード例です。
CopyC#
private void ShowAgentSettingForm()
{
    WFShortCutUrlParamModel req = new WFShortCutUrlParamModel();

    req.server = "imart71-sp";
    req.port = "80";

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
    {
        userID = @"ono",
        loginGroupID = @"default",
        authType = @"MOSSNTLM"
    };
    Intramart.Bpw.WebService.WFShortCutUrlServiceReference.WFShortCutUrlResultModel res;
    using (WFShortCutUrl c = new WFShortCutUrl(WebServiceHostName))
    {
        //認証情報を設定
        c.Credentials = new NetworkCredential("ono", "Password!", "example");
        res = c.GetURL4AgentSettingListWF(ui, req);
    }
    System.Diagnostics.Process.Start(res.shortCutUrl);
}

参照

WFShortCutUrl クラス


GetURL4FlowInfoWF メソッド

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス サンプル See Also
ワークフロー情報フォームのショートカットURLを取得します

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFShortCutUrlResultModel GetURL4FlowInfoWF(
    UserInfo userInfo,
    WFShortCutUrlParamModel model
)
Visual Basic (Declaration)
Public Function GetURL4FlowInfoWF ( _
    userInfo As UserInfo, _
    model As WFShortCutUrlParamModel _
) As WFShortCutUrlResultModel
Visual C++
public:
WFShortCutUrlResultModel^ GetURL4FlowInfoWF(
    UserInfo^ userInfo,
    WFShortCutUrlParamModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: WFShortCutUrlParamModel
ショートカットURL取得情報

戻り値

ショートカットURL

解説

サンプル

GetURL4FlowInfoWFメソッドの使用コード例です。
CopyC#
private string GetShorCutUrl(int mode,string processDefCd, string versionCd, string processCd)
{
    WFShortCutUrlParamModel req = new WFShortCutUrlParamModel();

    req.server = "imart71-sp";
    req.port = "80";

    req.processDefCd = processDefCd;
    req.versionCd = versionCd;
    req.processCd = processCd;

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
                      {
                          userID = @"ono",
                          loginGroupID = @"default",
                          authType = @"MOSSNTLM"
                      };

    Intramart.Bpw.WebService.WFShortCutUrlServiceReference.WFShortCutUrlResultModel res;
    using (WFShortCutUrl c = new WFShortCutUrl(WebServiceHostName))
    {
        //HACK :
        c.Credentials = GetCredentials(ui.userID);
        if (mode == 1)
        {

            res = c.GetURL4FlowInfoWF(ui, req);
        }
        else if (mode == 2)
        {
            res = c.GetURL4HistoryInfoWF(ui, req);

        }
        else
        {
            return string.Empty;
        }
    }

    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    return res.shortCutUrl;
}

参照

WFShortCutUrl クラス


GetURL4HistoryInfoWF メソッド

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス サンプル See Also
ワークフロー履歴フォームのショートカットURLを取得します

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WFShortCutUrlResultModel GetURL4HistoryInfoWF(
    UserInfo userInfo,
    WFShortCutUrlParamModel model
)
Visual Basic (Declaration)
Public Function GetURL4HistoryInfoWF ( _
    userInfo As UserInfo, _
    model As WFShortCutUrlParamModel _
) As WFShortCutUrlResultModel
Visual C++
public:
WFShortCutUrlResultModel^ GetURL4HistoryInfoWF(
    UserInfo^ userInfo,
    WFShortCutUrlParamModel^ model
)

パラメータ

userInfo
Type: Intramart.Bpw.WebService.Client..::.UserInfo
ユーザ情報
model
Type: WFShortCutUrlParamModel
ショートカットURL取得情報

戻り値

ショートカットURL

解説

サンプル

GetURL4HistoryInfoWFメソッドの使用コード例です。
CopyC#
private string GetShorCutUrl(int mode,string processDefCd, string versionCd, string processCd)
{
    WFShortCutUrlParamModel req = new WFShortCutUrlParamModel();

    req.server = "imart71-sp";
    req.port = "80";

    req.processDefCd = processDefCd;
    req.versionCd = versionCd;
    req.processCd = processCd;

    //WebServiceログイン情報
    UserInfo ui = new UserInfo
                      {
                          userID = @"ono",
                          loginGroupID = @"default",
                          authType = @"MOSSNTLM"
                      };

    Intramart.Bpw.WebService.WFShortCutUrlServiceReference.WFShortCutUrlResultModel res;
    using (WFShortCutUrl c = new WFShortCutUrl(WebServiceHostName))
    {
        //HACK :
        c.Credentials = GetCredentials(ui.userID);
        if (mode == 1)
        {

            res = c.GetURL4FlowInfoWF(ui, req);
        }
        else if (mode == 2)
        {
            res = c.GetURL4HistoryInfoWF(ui, req);

        }
        else
        {
            return string.Empty;
        }
    }

    //戻り値を表示します。
    System.Xml.Serialization.XmlSerializer x = new System.Xml.Serialization.XmlSerializer(res.GetType());
    System.IO.StringWriter sw = new StringWriter();
    x.Serialize(sw, res);
    System.Diagnostics.Trace.WriteLine(sw.ToString());

    return res.shortCutUrl;
}

参照

WFShortCutUrl クラス


GetWFShortCutUrlService メソッド

[image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also
SOAP通信クライアントプロキシを取得します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
protected WFShortCutUrlService GetWFShortCutUrlService()
Visual Basic (Declaration)
Protected Function GetWFShortCutUrlService As WFShortCutUrlService
Visual C++
protected:
WFShortCutUrlService^ GetWFShortCutUrlService()

戻り値

SOAP通信クライアントプロキシ

参照

WFShortCutUrl クラス


WFShortCutUrl プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
WFShortCutUrl クラス See Also

WFShortCutUrl については プロパティ を参照

プロパティ

名称 | 詳細
Credentials | Web クライアント認証の資格情報 (WebServicesClientより継承)
Host | URLポート (WebServicesClientより継承)
Port | URLホスト名 (WebServicesClientより継承)

参照

WFShortCutUrl クラス


WorkflowInfo クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
ワークフロー連携情報モデル

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
[SerializableAttribute]
public class WorkflowInfo
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WorkflowInfo
Visual C++
[SerializableAttribute]
public ref class WorkflowInfo

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WorkflowInfo

参照

WorkflowInfo メンバ


WorkflowInfo メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス コンストラクタ メソッド プロパティ See Also

WorkflowInfo については メンバ を参照

コンストラクタ

名称 | 詳細
WorkflowInfo | Initializes a new instance of the WorkflowInfo class

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
Parse | オーバーロードされます
ToString | Returns a String that represents the current Object. (Objectより継承)

プロパティ

名称 | 詳細
activityCd | アクティビティコード
agentUserId | 代理ユーザID
companyCd | 会社コード
departmentCd | 組織コード
departmentName | 組織名
processCd | プロセスコード
processDefCd | プロセス定義コード
userID | ユーザーID
versionCd | バージョンコード

参照

WorkflowInfo クラス


WorkflowInfo コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
Initializes a new instance of the WorkflowInfo class

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WorkflowInfo()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowInfo()

参照

WorkflowInfo クラス


WorkflowInfo メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also

WorkflowInfo については メソッド を参照

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
Parse | オーバーロードされます
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

WorkflowInfo クラス


Parse メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also

オーバーロード リスト

名称 | 詳細
Parse(array<WFInfoModel>[]()[]) | webサービス参照の連携情報モデルをローカルモデルに変換します。
Parse(array<WFInfoModel>[]()[]) | webサービス参照の連携情報モデルをローカルモデルに変換します。

参照

WorkflowInfo クラス
WorkflowInfo メンバ


Parse メソッド ([])

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
webサービス参照の連携情報モデルをローカルモデルに変換します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public static WorkflowInfo[] Parse(
    WFInfoModel[] wfInfoModelArray
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    wfInfoModelArray As WFInfoModel() _
) As WorkflowInfo()
Visual C++
public:
static array<WorkflowInfo^>^ Parse(
    array<WFInfoModel^>^ wfInfoModelArray
)

パラメータ

wfInfoModelArray
Type: array< WFInfoModel >[]()[]
承認連携情報モデルの配列

戻り値

承認連携情報モデル

解説

同一構造を持った名前空間の異なるコンテナクラスが存在する事による 参照の複雑さを回避します。

参照

WorkflowInfo クラス
Parse オーバーロード


Parse メソッド ([])

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
webサービス参照の連携情報モデルをローカルモデルに変換します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public static WorkflowInfo[] Parse(
    WFInfoModel[] wfInfoModelArray
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    wfInfoModelArray As WFInfoModel() _
) As WorkflowInfo()
Visual C++
public:
static array<WorkflowInfo^>^ Parse(
    array<WFInfoModel^>^ wfInfoModelArray
)

パラメータ

wfInfoModelArray
Type: array< WFInfoModel >[]()[]
起票連携情報モデルの配列

戻り値

承認連携情報モデル

解説

同一構造を持った名前空間の異なるコンテナクラスが存在する事による 参照の複雑さを回避します。

参照

WorkflowInfo クラス
Parse オーバーロード


WorkflowInfo プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also

WorkflowInfo については プロパティ を参照

プロパティ

名称 | 詳細
activityCd | アクティビティコード
agentUserId | 代理ユーザID
companyCd | 会社コード
departmentCd | 組織コード
departmentName | 組織名
processCd | プロセスコード
processDefCd | プロセス定義コード
userID | ユーザーID
versionCd | バージョンコード

参照

WorkflowInfo クラス


activityCd プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
アクティビティコード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string activityCd { get; set; }
Visual Basic (Declaration)
Public Property activityCd As String
Visual C++
public:
property String^ activityCd {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


agentUserId プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
代理ユーザID

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string agentUserId { get; set; }
Visual Basic (Declaration)
Public Property agentUserId As String
Visual C++
public:
property String^ agentUserId {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


companyCd プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
会社コード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string companyCd { get; set; }
Visual Basic (Declaration)
Public Property companyCd As String
Visual C++
public:
property String^ companyCd {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


departmentCd プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
組織コード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string departmentCd { get; set; }
Visual Basic (Declaration)
Public Property departmentCd As String
Visual C++
public:
property String^ departmentCd {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


departmentName プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
組織名

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string departmentName { get; set; }
Visual Basic (Declaration)
Public Property departmentName As String
Visual C++
public:
property String^ departmentName {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


processCd プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
プロセスコード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string processCd { get; set; }
Visual Basic (Declaration)
Public Property processCd As String
Visual C++
public:
property String^ processCd {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


processDefCd プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
プロセス定義コード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string processDefCd { get; set; }
Visual Basic (Declaration)
Public Property processDefCd As String
Visual C++
public:
property String^ processDefCd {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


userID プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
ユーザーID

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string userID { get; set; }
Visual Basic (Declaration)
Public Property userID As String
Visual C++
public:
property String^ userID {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


versionCd プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowInfo クラス See Also
バージョンコード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string versionCd { get; set; }
Visual Basic (Declaration)
Public Property versionCd As String
Visual C++
public:
property String^ versionCd {
    String^ get ();
    void set (String^ value);
}

参照

WorkflowInfo クラス


WorkflowResult クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
拡張結果クラス

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
[SerializableAttribute]
public class WorkflowResult
Visual Basic (Declaration)
<SerializableAttribute> _
Public Class WorkflowResult
Visual C++
[SerializableAttribute]
public ref class WorkflowResult

継承元

System..::.Object
Intramart.Bpw.WebService.Client..::.WorkflowResult

参照

WorkflowResult メンバ


WorkflowResult メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス コンストラクタ メソッド プロパティ See Also

WorkflowResult については メンバ を参照

コンストラクタ

名称 | 詳細
WorkflowResult | Initializes a new instance of the WorkflowResult class

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
HasError | エラーが存在するか返します。
IsFinished | プロセスが終了しているか返します。
IsRetry | プロセスが再起票状態か返します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
Parse | オーバーロードされます
ToString | Returns a String that represents the current Object. (Objectより継承)

プロパティ

名称 | 詳細
errorCode | エラーコード
finishedStatus | 終了ステータス
models | 連携情報モデル
runUserType | 処理者種別

参照

WorkflowResult クラス


WorkflowResult コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
Initializes a new instance of the WorkflowResult class

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WorkflowResult()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WorkflowResult()

参照

WorkflowResult クラス


WorkflowResult メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also

WorkflowResult については メソッド を参照

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
HasError | エラーが存在するか返します。
IsFinished | プロセスが終了しているか返します。
IsRetry | プロセスが再起票状態か返します。
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
Parse | オーバーロードされます
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

WorkflowResult クラス


HasError メソッド

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
エラーが存在するか返します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public bool HasError()
Visual Basic (Declaration)
Public Function HasError As Boolean
Visual C++
public:
bool HasError()

戻り値

エラーの場合true

参照

WorkflowResult クラス


IsFinished メソッド

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
プロセスが終了しているか返します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public bool IsFinished()
Visual Basic (Declaration)
Public Function IsFinished As Boolean
Visual C++
public:
bool IsFinished()

戻り値

ワークフローが終了している場合true

参照

WorkflowResult クラス


IsRetry メソッド

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
プロセスが再起票状態か返します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public bool IsRetry()
Visual Basic (Declaration)
Public Function IsRetry As Boolean
Visual C++
public:
bool IsRetry()

戻り値

再起票状態の場合true

参照

WorkflowResult クラス


Parse メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also

オーバーロード リスト

名称 | 詳細
Parse(WFResultModel) | webサービス参照の拡張結果モデルをローカルモデルに変換します。
Parse(WFResultModel) | webサービス参照の拡張結果モデルをローカルモデルに変換します。

参照

WorkflowResult クラス
WorkflowResult メンバ


Parse メソッド ()

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
webサービス参照の拡張結果モデルをローカルモデルに変換します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public static WorkflowResult Parse(
    WFResultModel wfResultModel
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    wfResultModel As WFResultModel _
) As WorkflowResult
Visual C++
public:
static WorkflowResult^ Parse(
    WFResultModel^ wfResultModel
)

パラメータ

wfResultModel
Type: WFResultModel
承認拡張結果モデル

戻り値

拡張結果モデル

参照

WorkflowResult クラス
Parse オーバーロード


Parse メソッド ()

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
webサービス参照の拡張結果モデルをローカルモデルに変換します。

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public static WorkflowResult Parse(
    WFResultModel wfResultModel
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    wfResultModel As WFResultModel _
) As WorkflowResult
Visual C++
public:
static WorkflowResult^ Parse(
    WFResultModel^ wfResultModel
)

パラメータ

wfResultModel
Type: WFResultModel
起票拡張結果モデル

戻り値

拡張結果モデル

参照

WorkflowResult クラス
Parse オーバーロード


WorkflowResult プロパティ

[image] [image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also

WorkflowResult については プロパティ を参照

プロパティ

名称 | 詳細
errorCode | エラーコード
finishedStatus | 終了ステータス
models | 連携情報モデル
runUserType | 処理者種別

参照

WorkflowResult クラス


errorCode プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
エラーコード

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string errorCode { get; set; }
Visual Basic (Declaration)
Public Property errorCode As String
Visual C++
public:
property String^ errorCode {
    String^ get ();
    void set (String^ value);
}

値

リターンコード（処理結果)
各属性に設定される値 | 設定される値の説明
0 | 正常
-1 | 異常(アプリケーション例外） 各種APIの処理で正しい処理ができなかった場合に発生する例外。 例：パラメータの不一致、処理する対象でないアクティビティの指定、存在しない組織コード、すでに処理されたアクティビティなど
-2 | 異常(システム例外） 各種APIの外部要因が発生する例外。 例：データベースが発生する例外、定義ファイルが存在しない、など
-3 | 異常(予期しない例外） アプリケーション例外、システム例外以外の例外。 その他の想定されていない障害。

参照

WorkflowResult クラス


finishedStatus プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
終了ステータス

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string finishedStatus { get; set; }
Visual Basic (Declaration)
Public Property finishedStatus As String
Visual C++
public:
property String^ finishedStatus {
    String^ get ();
    void set (String^ value);
}

値

終了ステータス
各属性に設定される値 | 設定される値の説明
0 | 処理中（承認や差戻しなどの処理を行う対象が存在する）
1 | 否認終了
2 | 取止め終了
3 | 途中終了【予約】
4 | 通常終了
-1 | リターンコードが「異常」のとき

参照

WorkflowResult クラス


models プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
連携情報モデル

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WorkflowInfo[] models { get; set; }
Visual Basic (Declaration)
Public Property models As WorkflowInfo()
Visual C++
public:
property array<WorkflowInfo^>^ models {
    array<WorkflowInfo^>^ get ();
    void set (array<WorkflowInfo^>^ value);
}

値

連携情報モデルの配列

参照

WorkflowResult クラス


runUserType プロパティ

[image]

intra-mart Wrokflow Client for .Net
WorkflowResult クラス See Also
処理者種別

Namespace: Intramart.Bpw.WebService.Client
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public string runUserType { get; set; }
Visual Basic (Declaration)
Public Property runUserType As String
Visual C++
public:
property String^ runUserType {
    String^ get ();
    void set (String^ value);
}

値

処理者の種別
各属性に設定される値 | 設定される値の説明
0 | 申請者 （プロセスの一番先頭＝起票者）
1 | 承認者（起票者以外）
2 | 対象者なし（否認終了,取止め終了,途中終了【予約】,通常終了）
-1 | リターンコードが「異常」のとき

参照

WorkflowResult クラス


Intramart.Bpw.WebService.Utilities Namespace

[image]

intra-mart Wrokflow Client for .Net
Intramart.Bpw.WebService.Utilities名前空間には、WebServiceの使用を支援する型が含まれています。

クラス

クラス | 詳細
ImagingUtilities | JPEG および PNG ファイル形式のイメージの操作を支援します。
WebServiceUtilities |


ImagingUtilities クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also
JPEG および PNG ファイル形式のイメージの操作を支援します。

Namespace: Intramart.Bpw.WebService.Utilities
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class ImagingUtilities
Visual Basic (Declaration)
Public Class ImagingUtilities
Visual C++
public ref class ImagingUtilities

継承元

System..::.Object
Intramart.Bpw.WebService.Utilities..::.ImagingUtilities

参照

ImagingUtilities メンバ
Intramart.Bpw.WebService.Utilities Namespace


ImagingUtilities メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
ImagingUtilities クラス メソッド See Also

ImagingUtilities については メンバ を参照

メソッド

名称 | 詳細
CreateBitmapImage | 指定したバイト配列に基づいてBitmapImageを作成します。
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

ImagingUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace


ImagingUtilities メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
ImagingUtilities クラス See Also

ImagingUtilities については メソッド を参照

メソッド

名称 | 詳細
CreateBitmapImage | 指定したバイト配列に基づいてBitmapImageを作成します。
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

ImagingUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace


CreateBitmapImage メソッド

[image]

intra-mart Wrokflow Client for .Net
ImagingUtilities クラス See Also
指定したバイト配列に基づいてBitmapImageを作成します。

Namespace: Intramart.Bpw.WebService.Utilities
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public static BitmapImage CreateBitmapImage(
    byte[] wfimg
)
Visual Basic (Declaration)
Public Shared Function CreateBitmapImage ( _
    wfimg As Byte() _
) As BitmapImage
Visual C++
public:
static BitmapImage^ CreateBitmapImage(
    array<unsigned char>^ wfimg
)

パラメータ

wfimg
Type: array< System..::.Byte >[]()[]
BitmapImageを作成する符号なしバイトの配列。

戻り値

バイトの配列から作成されたBitmapImage。

参照

ImagingUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace


WebServiceUtilities クラス

[image]

intra-mart Wrokflow Client for .Net
メンバ See Also

[Missing <summary> documentation for "T:Intramart.Bpw.WebService.Utilities.WebServiceUtilities"]

Namespace: Intramart.Bpw.WebService.Utilities
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public class WebServiceUtilities
Visual Basic (Declaration)
Public Class WebServiceUtilities
Visual C++
public ref class WebServiceUtilities

継承元

System..::.Object
Intramart.Bpw.WebService.Utilities..::.WebServiceUtilities

参照

WebServiceUtilities メンバ
Intramart.Bpw.WebService.Utilities Namespace


WebServiceUtilities メンバ

[image] [image]

intra-mart Wrokflow Client for .Net
WebServiceUtilities クラス コンストラクタ メソッド See Also

WebServiceUtilities については メンバ を参照

コンストラクタ

名称 | 詳細
WebServiceUtilities | Initializes a new instance of the WebServiceUtilities class

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ReplaceHost | URLのホスト名を変更します。
ReplacePort | URLのポートを変更します。
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

WebServiceUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace


WebServiceUtilities コンストラクタ

[image]

intra-mart Wrokflow Client for .Net
WebServiceUtilities クラス See Also
Initializes a new instance of the WebServiceUtilities class

Namespace: Intramart.Bpw.WebService.Utilities
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public WebServiceUtilities()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WebServiceUtilities()

参照

WebServiceUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace


WebServiceUtilities メソッド

[image] [image]

intra-mart Wrokflow Client for .Net
WebServiceUtilities クラス See Also

WebServiceUtilities については メソッド を参照

メソッド

名称 | 詳細
Equals | Determines whether the specified Object is equal to the current Object. (Objectより継承)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Objectより継承)
GetHashCode | Serves as a hash function for a particular type. (Objectより継承)
GetType | Gets the Type of the current instance. (Objectより継承)
MemberwiseClone | Creates a shallow copy of the current Object. (Objectより継承)
ReplaceHost | URLのホスト名を変更します。
ReplacePort | URLのポートを変更します。
ToString | Returns a String that represents the current Object. (Objectより継承)

参照

WebServiceUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace


ReplaceHost メソッド

[image]

intra-mart Wrokflow Client for .Net
WebServiceUtilities クラス See Also
URLのホスト名を変更します。

Namespace: Intramart.Bpw.WebService.Utilities
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public static string ReplaceHost(
    string baseUrl,
    string host
)
Visual Basic (Declaration)
Public Shared Function ReplaceHost ( _
    baseUrl As String, _
    host As String _
) As String
Visual C++
public:
static String^ ReplaceHost(
    String^ baseUrl,
    String^ host
)

パラメータ

baseUrl
Type: System..::.String
ベースのURL
host
Type: System..::.String
ホスト名

戻り値

URL文字列

解説

引数として渡されるベースのURLを使用してURIビルダを生成し、 ホスト名を変更したURL文字列を作成して返します。

参照

WebServiceUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace


ReplacePort メソッド

[image]

intra-mart Wrokflow Client for .Net
WebServiceUtilities クラス See Also
URLのポートを変更します。

Namespace: Intramart.Bpw.WebService.Utilities
Assembly: IntramartClient (IntramartClient.dll 内) バージョン: 1.0.0.0 (1.0.0.0)

構文

C#
public static string ReplacePort(
    string baseUrl,
    int port
)
Visual Basic (Declaration)
Public Shared Function ReplacePort ( _
    baseUrl As String, _
    port As Integer _
) As String
Visual C++
public:
static String^ ReplacePort(
    String^ baseUrl,
    int port
)

パラメータ

baseUrl
Type: System..::.String
ベースのURL
port
Type: System..::.Int32
ポート

戻り値

URL文字列

解説

引数として渡されるベースのURLを使用してURIビルダを生成し、 ホスト名を変更したURL文字列を作成して返します。

参照

WebServiceUtilities クラス
Intramart.Bpw.WebService.Utilities Namespace