OPRO X Browser

OPRO X Browser(略称OXB)は、OPRO X Server(略称OXS)で生成されたXMLフォーマットのオリジナルドキュメント形式(OXR/OPR/OFD)を表示・編集・印刷するためのブラウザアプリケーションです。ユーザがインターネット経由でOXSにリクエストを送ると、生成されたドキュメント(電子帳票)がクライアントにダウンロードされ、OXBによって自動的に開かれます。

OXRドキュメントは、Unicode対応のXMLドキュメントです。さまざまなフォントを使用した多国語対応の帳票の表示・印刷が可能です。また、パスワードによる暗号化、デジタルタイムスタンプや電子署名の埋め込みなどにも対応しています。OPRドキュメントは、OXRを圧縮したフォーマットで、すばやくダウンロードすることを目的としています。OFDドキュメントは、入力フォーム用のOXRに入力したデータを保存するためのフォーマットです。

概要
OXBの特徴やOPRO X Viewer、および、ショートカットキーなどについて説明しています。
セットアップ
OXBのシステム要件、および、インストール・アンインストール方法について説明しています。
インターフェイス
OXBのメニューやダイアログなどのインターフェイスについて説明しています。
よくある質問(FAQ)
よくある質問とその回答をまとめています。


概要

ここでは、OXBの特徴やOPRO X Viewer、および、ショートカットキーなどについて説明します。

特徴
OXBの特徴的な機能について説明しています。
OPRO X Viewer
ドキュメントの表示と印刷のみに特化したビューアアプリケーションOPRO X Viewerについて説明しています。
ドキュメント形式
OXB、および、OPRO X Viewerで開くことができるオリジナルドキュメント形式について説明しています。
ショートカットキー
OXBで使用可能なショートカットキーの一覧です。
略称一覧
ヘルプファイル等で使用する略称の一覧です。


特徴

OXBには、以下に示すユニークな機能があります。

ドキュメントセキュリティ

OXBは、パスワードによって保護されたドキュメントの閲覧、および、許可されていない印刷・コピーを防止するドキュメントセキュリティに対応しています。

デジタル署名の検証

デジタル署名は、OXSで生成したドキュメントの確実性を保証します。OXBにはデジタル署名を検証する機能があります。自己証明書、および、VeriSign社の証明書によるデジタル署名に対応しています。

タイムスタンプの検証

タイムスタンプの機能は、ドキュメントが特定の時刻に存在し、内容がそのとき以来変更されていないことを保証するために利用されます。OXBは、タイムスタンプの検証に対応しています。

Unicode対応と多言語フォント

Unicodeに対応しているので、多言語フォントの文字を使用でき、中国語・韓国語を含むドキュメントも閲覧・印刷できます。

ユーザ定義外字

ユーザ定義外字(EUDC)に対応しています。OPRO X Designer(OXD)で外字を含むテンプレートを作成すると、それから生成したドキュメントに含まれる外字をOXBで表示できます。

電子フォーム

ドキュメント上に電子フォームを作成することができます。HTTPプロトコルでのフォーム送信、および、XML形式でのデータの保存に対応しています。

証明書の管理

有効なデジタル証明書を確認するための管理ツールがあります。

直接印刷

直接印刷機能により、OXBのウィンドウを表示することなく、ODPファイルを指定したプリンタで印刷することができます。

縦書きテキスト表示

テキストを縦書き表示することが可能です。「ＭＳ明朝」「ＭＳ ゴシック」「ＭＳ Ｐ明朝」「ＭＳＰゴシック」「MS UI Gothic」で記述された日本語テキストの場合はフォントを回転させずに縦書き表示し、欧米フォントでは、回転させたフォントを使用して表示します。

オブジェクトの選択

ドキュメントにあるテキストオブジェクト(Label, PageNumber, DateTime等)をマウスクリックで選択し、コピーまたは一部のプロパティ値を変更することができます。また、画像オブジェクトを選択し、ファイルとして保存することができます。

総ページ数の表示

ドキュメントの総ページ数を表示します。ドキュメントに表示される総ページ数は、テンプレートの設計時に細かい調整が可能です。

サイドタブの機能

OXBのサイドタブは、「サムネイル」「添付ファイル」「プロパティ」の３つで構成されています。「サムネイル」タブは、ドキュメントの各ページの縮小画像を一覧表示します。「添付ファイル」タブは、ドキュメントに付属するファイルを表示します。「プロパティ」タブは、ドキュメント上で選択されているオブジェクトのプロパティを表示し、変更可能なプロパティ値であれば、値を変更することもできます。


OPRO X Viewer

OPRO X Viewer(略称 OXV)は、ドキュメントの表示と印刷のみに機能が絞られたOXBの機能限定版ビューアアプリケーションです。OXR形式・OPR形式のほか、OXBでは直接開くことができない拡張子を持つOXVドキュメントを開くことができます。


ドキュメント形式

OXR

OXRドキュメント(OPRO XML Report, 拡張子 .oxr)は、OXSによって生成されるXMLフォーマットのオリジナルドキュメント形式です。ドキュメントのデータとレイアウト構造を、XMLの要素、および、属性のプロパティとして含んでおり、XSLTなどのXML関連のツールによってアクセスすることが可能です。Unicode対応なので、さまざまなフォントを使用した多国語対応の帳票の表示・印刷が可能です。また、ドキュメントを保護するためのパスワードによる暗号化をサポートしており、デジタルタイムスタンプや電子署名の埋め込みなどにも対応しています。OXBを使用することによって、表示、編集、印刷することができます。MIMEタイプは「application/x-opro-oxr」です。

OPR

OPRドキュメント(OPRO Print Report, 拡張子 .opr)は、OXR形式のXMLをGZIP圧縮したものです。すばやいダウンロード、および、効率的な保存に適しています。OXRで利用可能なすべての機能を持っています。MIMEタイプは「application/x-opro-opr」です。

ODP

ODPドキュメント(OPRO Direct Print, 拡張子 .odp)は、OPRドキュメントと同じファイル形式ですが、拡張子が異なります。サーバからのダウンロードで、OXBのウィンドウを開かずに直接印刷させたい場合に使用します。MIMEタイプは「application/x-opro-odp」です。

OXBはODPドキュメント、および、ファイル名が「__oprodtp」(大文字小文字に依らない)から始まるOPRドキュメントを開いた場合、ウィンドウを開かずに直接印刷します。

OXV

OXVドキュメント(OPRO X Viewer, 拡張子 .oxv)は、OPRドキュメントと同じファイル形式ですが、拡張子が異なります。サーバからのダウンロードで、OPRO X Viewerを自動的に起動させたい場合に使用します。MIMEタイプは「application/x-opro-oxv」です。

OFD

OFDファイル(OPRO Form Data, 拡張子 .ofd)は、OXR/OPRドキュメント内の電子フォームに入力されたデータを保存するためのXMLフォーマットのオリジナルドキュメント形式です。データのみを含むのでサイズが小さく、多数のユーザがフォームを使用する場合やオフラインでデータの登録処理を迅速に行いたい場合に役立ちます。MIMEタイプは「application/x-opro-ofd」です。

OXBは電子フォームをサポートしています。OXB上で開かれた電子フォームにデータを入力し、OXSまたは、指定された宛先へ送信することができます。電子フォームに入力されたデータは、OFDファイルとして保存したり、読み込んだりすることができます。電子フォームに入力されたデータをOFDファイルとして保存するには、「データの保存」を参照してください。保存されたOFDファイルから電子フォームにデータを読み込むには、「データの読込」を参照してください。

OFDファイルを開くと、保存されているデータに関連した電子フォームがOXBによって開かれます。この機能による利点には、次のようなものがあります。例えば、ひとつの電子フォームに対して、ユーザ毎に異なる入力データをOFDファイルとして保存しておきます。ユーザは自分のOFDファイルをダブルクリックすると、それに関連付けられた電子フォームをデータ入力済の状態で呼び出すことができます。OFDファイルは、電子フォームを含んだOXR/OPRドキュメントよりもずっと小さいサイズなので、携帯も容易です。ユーザは、データを含んだ複数のOFDファイルを持ち歩き、ウェブにある電子フォームをどこからでも呼び出すことが可能になります。


ショートカットキー

メニュー | 呼び出される機能 | ショートカットキー
ファイル | ドキュメントを開く | Ctrl + O
 | ドキュメントを閉じる | Ctrl + F4
 | ドキュメントの保存 | Ctrl + S
 | 現在の状態を保存 | Shift + Ctrl + S
 | 印刷プレビュー | Ctrl + F2
 | 印刷 | Ctrl + P
編集 | 切り取り | Ctrl + X
 | コピー | Ctrl + C
 | 貼り付け | Ctrl + V
 | 検索 | Ctrl + F
 | 再検索 | F3
ドキュメント | 最初のページ | Ctrl + Page Up
 | 前のページ | Ctrl + Page Down
 | 次のページ | Ctrl + End
 | 最後のページ | Ctrl + Home
 | ドキュメントの再読み込み | F5
表示 | ドキュメントの拡大 | Num +
 | ドキュメントの縮小 | Num -
 | ウィンドウサイズに合わせる | Ctrl + 0
 | ウィンドウ幅に合わせる | Ctrl + 1
 | 実サイズ | Ctrl + 2
 | グレースケール | Ctrl + G
 | モノクロ | Ctrl + M
 | サイドタブを表示 | Ctrl + T
 | 全画面表示 | F11
ヘルプ | 目次とキーワード | F1


略称一覧

略称 | 正式名称
DP | Direct Print
HTML | HyperText Markup Language
XML | Extensible Markup Language
XSL | Extensible Stylesheet Language
ODP | OPRO Direct Print
OFD | OPRO Form Data
OPR | OPRO Print Report
OXR | OPRO XML Report
OXB | OPRO X Browser
OXD | OPRO X Designer
OXS | OPRO X Server
OXV | OPRO X Viewer


セットアップ

ここでは、OXBのセットアップに必要なシステム要件、および、インストール方法・アンインストール方法について説明します。

システム要件
OXBのセットアップに必要なハードウェア要件、ソフトウェア要件について説明しています。
インストール
OXBのインストール方法について説明しています。
アンインストール
OXBのアンインストール方法について説明しています。


システム要件

OXBをセットアップするには、以下のハードウェア要件、ソフトウェア要件が満たされている必要があります。

ハードウェア要件

（500 MHz以上を推奨）
ハードウェア | 要件
メモリ | 128 MB以上
CPU | Intel Pentium II, 233 MHz以上
ハードディスクの空き容量 | インストールには 30 MB以上の空き容量が必要 動作には 100 MB以上の空き容量を推奨

ソフトウェア要件

ソフトウェア | 要件
OS | Windows 7 Professional, Windows Server 2008 Standard/Enterprise Edition (SP1), Windows Vista Business (SP1, SP2), Windows Server 2003 Standard/Enterprise Edition (SP1, SP2, R2), Windows XP Professional (SP1, SP2, SP3), Windows 2000 Professional/Server/Advanced Server (SP4 以上) 但し、Internet Explorer 5.5 以上が必要です。 ※ Windows 98/98SE/Me での動作は保証しておりません。


インストール

システム要件を満たしていればOXBのインストールを開始できます。インストールの開始前にすべてのアプリケーションを終了しておくことを推奨します。日本オプロのウェブサイトからダウンロードしたOXBのインストーラ「oxb270xx.exe」(xxはパッチ番号)を実行し、画面の指示に従って作業を進めてください。インストールを実行するユーザにはインストールフォルダへの書き込み権限が必要です。

以降は、インストール画面について記述しています。実際の画面は、インストールするコンピュータの環境やOXBのバージョンによって異なる場合があります。

1. ウィザードへようこそ

「oxb270xx.exe」を実行すると、インストーラが起動し、「OPRO X Browser用のInstallShield ウィザードへようこそ」画面が開かれます。

「次へ」ボタンをクリックして、進めます。

2. 使用許諾契約

「使用許諾契約」画面で、製品の使用許諾契約の内容をすべて読み、同意する場合は「使用許諾契約の条項に同意します」オプションにチェックを入れ、「次へ」ボタンをクリックして先へ進めます。

3. ユーザ情報

「ユーザ情報」画面で、「ユーザ名」と「所属」を入力します。Windowsから取得した情報をインストーラがあらかじめ表示しています。必要なら変更し、「次へ」ボタンをクリックします。

4. インストール先のフォルダ

「インストール先のフォルダ」画面で、OXBのインストール先を指定します。変更する場合は「変更」ボタンをクリックし、インストール先フォルダを指定します。通常はデフォルトのまま、「次へ」ボタンをクリックします。

「変更」ボタンをクリックすると、「インストール先のフォルダの変更」ダイアログが現れます。インストールしたいフォルダを選択するか、フォルダ名を入力して新規フォルダを作成することもできます。

5. インストール準備完了

「プログラムをインストールする準備ができました」画面で、ここまでに指定したインストール設定を確認し、問題なければ、「インストール」ボタンをクリックして、インストールを開始します。

6. ウィザードの完了

無事インストールが完了すると、「InstallShield ウィザードを完了しました」画面になります。「完了」ボタンをクリックし、インストールウィザードを終了してください。

インストールを完了すると、Windowsのスタートメニューの「プログラム」⇒「OPRO X Browser」に、次の四つのショートカットが登録されます。
  • OPRO X Browser - OPRO X Browserを起動します。
  • OPRO X Browser Help - OPRO X Browserのヘルプファイルを開きます。
  • Read me - OPRO X BrowserのReadmeファイルを開きます。
  • OPRO X Viewer - OPRO X Viewerを起動します。


アンインストール

OXBは、コントロールパネルの「プログラムの追加と削除」(Windows 2000以前の場合、「アプリケーションの追加と削除」)からアンインストールできます。

「現在インストールされているプログラム」一覧から「OPRO X Browser」を選択し、「削除」ボタンをクリックします。

削除の確認ダイアログが現れ、「はい」ボタンをクリックすると、OXBが削除されます。


インターフェイス

OXBのインターフェイスは、大きく五つのエリアに機能が分かれています。

アプリケーションメニューバー
利用可能なすべてのコマンドが用意されています。
アプリケーションツール バー
一般的に使用頻度の高いコマンドが配置され、それらの機能をクリック一つで呼び出せます。
ドキュメントツールバー
ドキュメント閲覧操作用のコマンドが配置されています。
ドキュメントウィンドウ
開かれたドキュメント毎に用意されるウィンドウです。ドキュメント上で右クリックすると、ドキュメントポップアップメニューが表示されます。
サイドタブ
「サムネイル」「プロパティ」「添付ファイル」の三つのタブで構成されています。

ドキュメントプレビューツールバーは、ドキュメントを印刷プレビューモードにしたときに開かれます。前述のドキュメントツールバーの機能に加え、「グレースケール」「モノクロ」「検索」「画像の選択」等のオプションがあります。


アプリケーションメニューバー

アプリケーションメニューバーには七つの主要メニューがあり、それぞれにサブメニューが用意されています。

  • 「ファイル」メニュー
  • 「編集」メニュー
  • 「ドキュメント」メニュー
  • 「表示」メニュー
  • 「ツール」メニュー
  • 「ウィンドウ」メニュー
  • 「ヘルプ」メニュー


「ファイル」メニュー

「ファイル」メニューには、ドキュメントに対する操作(開く、閉じる、保存、印刷)、および、OXBの終了等があります。

開く

ドキュメントをOXBで開きます。OXBで開くことができるドキュメント形式は、OXRドキュメント、OPRドキュメント、OFDファイルの3種類です。最大25個のドキュメントを同時に開くことができます。

ドキュメントを開くには

  1. ツール バーにある「開く」ボタン [image] をクリックするか、「ファイル」メニューの「開く」オプションを選択します。

ショートカットキー： Ctrl + O

閉じる

現在アクティブなドキュメントを閉じます。

ドキュメントを閉じるには

  1. ドキュメントウィンドウの「閉じる」ボタン [image] をクリックするか、「ファイル」メニューの「閉じる」オプションを選択します。

ショートカットキー： Ctrl + F4

すべて閉じる

開いているすべてのドキュメントを閉じます。

すべてのドキュメントを閉じるには

  1. 「ファイル」メニューの「すべて閉じる」オプションを選択します。

名前を付けて保存

開いているドキュメントに別のファイル名を付けて保存します。開いているOPRドキュメントをOXRドキュメントとして保存すること、または、その逆も可能です。さらに、ドキュメントセキュリティで暗号化されたドキュメントについては、「ドキュメントの変更」が許可されていれば、セキュリティが適用されない「復号済みOXRドキュメント」として保存することが選択できます。

名前を付けて保存するには

  1. ツール バーにある「名前を付けて保存」ボタン [image] をクリックするか、「ファイル」メニューの「名前を付けて保存」オプションを選択します。

ショートカットキー： Ctrl + S

現在の状態を保存

ドキュメントに適用されたスタイルや、追加された添付ファイル等、変更された現在の状態を保存します。変更内容はXSLファイルとして保存され、ドキュメントファイルを開く際に自動的に適用されるスタイルシートになります。XSLスタイルシートはドキュメントと同じフォルダに保存されます。「現在の状態を保存」オプションは、ドキュメントに変更が加えられるまで無効になっており、変更が加えられると使用可能な状態になります。

現在の状態を保存するには

  1. ドキュメントに任意の変更を加えます。
  2. ツール バーにある「現在の状態を保存」ボタン [image] をクリックするか、「ファイル」メニューの「現在の状態を保存」オプションを選択します。

ドキュメントセキュリティで保護されたドキュメントを「現在の状態を保存」オプションで保存すると、セキュリティが適用されない「復号済みOXRドキュメント」として保存されます。ご注意ください。

印刷プレビュー

印刷前にドキュメントの印刷イメージを画面表示することができます。

ドキュメントを印刷プレビューするには

  1. ドキュメントを開きます。
  2. ツール バーにある「印刷プレビュー」ボタン [image] をクリックするか、「ファイル」メニューの「印刷プレビュー」オプションを選択します。

ショートカットキー： Ctrl + F2

印刷プレビューモードから抜けるには、再度「印刷プレビュー」ボタン [image] をクリックするか、ドキュメントウィンドウの「閉じる」ボタン [image] をクリックします。

印刷

開かれているドキュメントを印刷します。「ファイル」メニューから「印刷」オプションを選択すると、「ドキュメントの印刷」ダイアログが表示されます。

ドキュメントを印刷するには

  1. ツール バーの「ドキュメントの印刷」ボタン [image] をクリックするか、「ファイル」メニューの「印刷」オプションを選択します。

ショートカットキー： Ctrl + P

ツール バーにある「印刷」ボタン [image] をクリックすると、「ドキュメントの印刷」ダイアログは表示されずに「通常使うプリンタ」に指定されたプリンタで印刷されます。

OXR/OPR/ODPファイルを右クリックし、ポップアップメニューの「印刷」オプションを選択すると、OXBのウィンドウを開かずに直接印刷することができます。このとき、通常は「通常使うプリンタ」に指定されたプリンタが使われますが、特定の印刷設定が保存されていた場合は、その印刷設定にしたがって印刷されます。

OXR/OPR/ODPファイルをプリンタのアイコンにドラッグ＆ドロップし、特定のプリンタで印刷することもできます。

終了

開いているドキュメントをすべて閉じ、OXBを終了します。

終了するには

  1. 「ファイル」メニューの「終了」オプションを選択します。


「ドキュメントの印刷」ダイアログ

「ドキュメントの印刷」ダイアログには、プリンタに関する情報(プリンタ名、状態、種類、場所)の表示と、印刷方法に関する情報(印刷範囲、印刷部数、色)の設定項目があります。

「プリンタ」項目

プリンタ名
使用するプリンタを選択します。
プロパティ
選択されたプリンタのプロパティを変更できるダイアログを表示します。
拡張設定
さまざまなサイズの印刷指定や、複数のレイアウトをもつドキュメントを特定のプリンタ機種毎に印刷したい場合等、また、出力先トレイを個別に指定することもできるドキュメント印刷時の拡張設定機能です。このオプションを有効にするには、ベンダからDLLファイルを入手する必要があります。
ファイルへ出力
ドキュメントをプリンタではなくファイルに出力します。ドキュメントは、別のプリンタで使用できる書式で保存されます。例えば、PostScriptプリンタを選択していれば、PostScriptファイルとしてドキュメントを保存することができます。

「印刷範囲」項目

印刷するページの範囲を指定します。「すべて」を選択すると全ページが範囲になります。「現在のページ」では開かれているページのみ、「ページ指定」では「開始ページ」と「終了ページ」に指定された範囲が対象になります。「開始ページ」には、カンマ区切りでいくつかのページ番号を指定できます。「開始ページ」に指定したページ番号と、その最後のページ番号から「終了ページ」に指定したページ番号までが印刷範囲となります。さらに「印刷」で「奇数ページ」または「偶数ページ」を指定すると、奇数ページのみ、または、偶数ページのみを印刷できますので、片面専用のプリンタで両面印刷したい場合などに便利です。

「印刷部数」項目

同じドキュメントを複数印刷するには「部数」を2以上に指定します。「部単位」が有効な場合、ひとつのドキュメントを1ページずつ印刷してから次の部の印刷が行われ、個々のドキュメント単位に印刷できます。「部単位」が無効な場合、ひとつのページを「部数」で指定した枚数だけ印刷したあと、次のページを印刷します。

「色」項目

印刷する色数を指定します。「通常」はドキュメントのオリジナル色のままでプリンタの設定どおりに印刷することを意味します。その他、「グレースケール」(白黒諧調)、または、「モノクロ」(白黒２値)を指定できます。

「設定の保存」ボタン

「ドキュメントの印刷」ダイアログで設定した内容を保存することができます。あるドキュメントで印刷設定を保存しておくと、同じテンプレートから生成したドキュメントを印刷する際に、保存した設定が自動的に適用されますので、再び同じ種類のドキュメントを印刷する際に設定しなおす手間を省くことができます。

ドキュメントの元になるテンプレートの情報はドキュメント内に記述されています。マルチテンプレートリクエストで生成されたドキュメントの場合は、最初のページを生成したテンプレートの情報でどの設定を使用するかが決まります。(OXS 2.5.0 以前で生成されたドキュメントにはテンプレートの情報は含まれていませんので、ファイル名を元にどの設定を使用するかが決まります。)

設定の保存先は、ユーザプロファイル・フォルダ（例えば、Windows XP の場合、「C:\Documents and Settings\(ログオンユーザ名)」フォルダ）以下の「OPRO\OXB」フォルダ内にある「PrnSetInf.csv」ファイルです。このファイルを他のユーザ、または、他のコンピュータの該当する場所にコピーすることにより、他のユーザ、または、他のコンピュータでも同じ印刷設定を利用することができます。

「印刷」ボタン

指定した内容にしたがってドキュメントの印刷を実行します。

「キャンセル」ボタン

指定した内容を破棄して「ドキュメントの印刷」ダイアログを閉じます。


「編集」メニュー

「編集」メニューには、開かれたドキュメントの編集に関するオプションがあります。「検索」「再検索」「画像の選択」オプションは、印刷プレビューモード時のみ表示されます。

一部のオブジェクトでは使用できない編集機能があります。

切り取り

オブジェクトのプロパティから、選択範囲のテキストを切り取ってクリップボードに入れます。

テキストを切り取るには

  1. ドキュメントのオブジェクトをダブルクリックし、「プロパティ」タブを表示します。
  2. プロパティにあるテキストを範囲選択します。
  3. 「編集」メニューの「切り取り」オプションを選択します。

ショートカットキー： Ctrl + X

コピー

オブジェクトのプロパティから、選択範囲のテキストをクリップボードにコピーします。

テキストをコピーするには

  1. ドキュメントのオブジェクトをダブルクリックし、「プロパティ」タブを表示します。
  2. プロパティにあるテキストを範囲選択します。
  3. 「編集」メニューの「コピー」オプションを選択します。

ショートカットキー： Ctrl + C

貼り付け

クリップボードにあるテキストを、オブジェクトのプロパティに貼り付けます。

テキストを貼り付けるには

  1. ドキュメントのオブジェクトをダブルクリックし、「プロパティ」タブを表示します。
  2. テキストを貼り付けるプロパティを選択します。
  3. 「編集」メニューの「貼り付け」オプションを選択します。

ショートカットキー： Ctrl + V

検索

ドキュメントに含まれる、特定のテキストを検索します。

テキスト検索するには

  1. 印刷プレビューモードにします。
  2. ツール バーにある「検索」ボタン [image] をクリックするか、「編集」メニューの「検索」オプションを選択します。
  3. 「文字列の検索」ダイアログの「検索する文字列」に検索テキストを入力します。
  4. 「検索開始」ボタンをクリックします。

ショートカットキー： Ctrl + F

再検索

前に検索したテキストでドキュメントの残りページを検索します。

再検索するには

  1. 「編集」メニューの「再検索」オプションを選択します。

ショートカットキー： F3

画像の選択

ドキュメント上の一部の範囲を選択し、クリップボードに画像として格納します。

選択された範囲を画像としてコピーするには

  1. 印刷プレビューモードにします。
  2. ツール バーにある「画像の選択」ボタン [image] をクリックするか、「編集」メニューの「画像の選択」オプションを選択します。
  3. ドキュメント上でマウスカーソルをドラッグして範囲選択します。
  4. ドキュメント上で右クリックし、ポップアップされたメニューの「コピー」を選択します。


「ドキュメント」メニュー

「ドキュメント」メニューには、マージン(余白)の操作、ページの操作、ドキュメントの真正性検証等、多様な機能が用意されています。

マージン

ドキュメントの上辺と左辺にマージン操作の為のルーラーを表示します。

ルーラーを表示するには

  1. ツール バーにある「マージン」ボタン [image] をクリックするか、「ドキュメント」メニューの「マージン」オプションを選択します。

マージンの保存

ドキュメントのマージン設定を保存します。

マージン設定を保存するには

  1. ドキュメントにマージン設定を行います。
  2. ツール バーにある「マージンの保存」ボタン [image] をクリックするか、「ドキュメント」メニューの「マージンの保存」オプションを選択します。
  3. 保存の確認ダイアログが現れたら、「はい」ボタンを選択します。

「マージンの設定」オプションは、OPRO X Designer(OXD)のドキュメントプレビュー時には適用できません。ご注意ください。

マージンの設定

「マージンの設定」ダイアログでマージン値(Cm単位)を設定します。設定したマージン値を保存する場合は「保存」ボタンをクリックします。保存したマージン設定は、同じPCで、同じドキュメントを開いた場合にのみ有効となります。

マージンを設定するには

  1. 「ドキュメント」メニューから「マージンの設定」オプションを選択するか、ルーラーをダブルクリックします。
  2. 「マージンの設定」ダイアログでマージン値を指定します。
  3. 「保存」ボタンをクリックし、続いて「OK」ボタンをクリックします。

デジタル署名の検証

ドキュメントに付加されたデジタル署名の検証を行います。デジタル署名とは、ドキュメントに一意な署名を加えることにより、ドキュメントの作者によるオリジナルと違いの無いことを保証するしくみです。署名はドキュメント生成時に書き込まれ、作成後にドキュメントが変更されるか、署名の期間が満了すると無効となります。

デジタル署名には、自己署名と第三者(認証局)署名の二種類があり、前者の検証はOXSが、後者の検証は第三者が行います。第三者署名の検証には、その署名の証明書がPCに保存されている必要があります。自己署名の場合には、証明書がPCに保存されている必要はありません。

「デジタル署名の検証」ダイアログは「署名のプロパティ」「証明書の属性」の２つのタブで構成されています。

「署名のプロパティ」タブには、ドキュメント作者に関する詳細情報、ドキュメントの作成日時や署名地等について表示されます。

「証明書の属性」タブには、証明書に関する情報が表示されます。

デジタル署名の状態表示
 | 署名が未検証です。
 | 署名は有効です。
 | 署名は無効です。

直接印刷機能の使用時には、デジタル署名の検証は印刷前に自動的に行なわれ、有効であれば [image] マークが、無効であれば [image] マークが印刷されます。

デジタル署名を検証するには

  1. ドキュメントに表示されているデジタル署名をクリックするか、「ドキュメント」メニューの「デジタル署名の検証」オプションを選択します。

「デジタル署名の検証」オプションは、ドキュメントウィンドウのステータス バーにある「ドキュメントのセキュリティ設定」ボタン [image] をクリックすることでも表示できます。

※「セキュリティ設定の参照」オプションは、ドキュメントのセキュリティ設定情報を表示します。ドキュメントが暗号化されていて、操作の許可や動作の強制の設定が有効になっている場合に、このオプションは有効になります。

タイムスタンプの検証

ドキュメントに付加されたタイムスタンプの検証を行います。タイムスタンプは、ドキュメントが特定時刻に存在し、内容がその時刻以来変更されていないことを保証するしくみです。タイムスタンプ作成後にドキュメントが変更されるか、有効期限が切れた場合にタイムスタンプは無効となります。

「TimeStamp の詳細」ダイアログは「タイムスタンプ情報」「時刻監査証明書プロパティ」の２つのタブで構成されています。

「タイムスタンプ情報」タブには、タイムスタンプ検証のステータスや、タイムスタンプトークン情報等が表示されます。

「TSA証明書参照」ボタンをクリックすると、Windowsの証明書アプレットが開かれ、証明書情報を参照できます。

「時刻監査証明書プロパティ」タブには、証明書情報、時刻監査情報、時刻監査ポリシーに関する情報等が表示されます。

タイムスタンプの状態表示
 | タイムスタンプが未検証です。
 | タイムスタンプは有効です。
 | タイムスタンプは無効です。

タイムスタンプを検証するには

  1. ドキュメントに表示されているタイムスタンプをクリックするか、「ドキュメント」メニューの「タイムスタンプの検証」オプションを選択します。

「タイムスタンプの検証」オプションは、ドキュメントウィンドウのステータス バーにある「ドキュメントのセキュリティ設定」ボタン [image] をクリックすることでも表示できます。

最初のページ

ドキュメントの最初のページに移動します。

最初のページに移動するには

  1. ツール バーにある「最初のページ」ボタン [image] をクリックするか、「ドキュメント」メニューの「最初のページ」オプションを選択します。

ショートカットキー： Ctrl + Home

前のページ

ドキュメントの前のページに移動します。

前のページに移動するには

  1. ツール バーにある「前のページ」ボタン [image] をクリックするか、「ドキュメント」メニューの「前のページ」オプションを選択します。

ショートカットキー： Ctrl + PageUp

次のページ

ドキュメントの次のページに移動します。

次のページに移動するには

  1. ツール バーにある「次のページ」ボタン [image] をクリックするか、「ドキュメント」メニューの「次のページ」オプションを選択します。

ショートカットキー： Ctrl + PageDown

最後のページ

ドキュメントの最後のページに移動します。

最後のページに移動するには

  1. ツール バーにある「最後のページ」ボタン [image] をクリックするか、「ドキュメント」メニューの「最後のページ」オプションを選択します。

ショートカットキー： Ctrl + End

添付ファイルの挿入

ドキュメントにファイルを添付します。

添付ファイルを挿入するには

  1. 「添付ファイル」タブにある「添付ファイルの挿入」ボタン [image] をクリックするか、「ドキュメント」メニューの「添付ファイルの挿入」オプションを選択します。
  2. 添付するファイルを選択します。

または

  1. 「添付ファイル」タブに直接、添付したいファイルをドラッグ＆ドロップします。

※セキュリティで保護されたドキュメントを開いた場合、「添付ファイルの挿入」は使用不可になります。

ドキュメント情報

ドキュメントに関する情報を表示します。

ドキュメント情報を表示するには

  1. 「ドキュメント」メニューの「ドキュメント情報」オプションをクリックします。

ショートカットキー： Ctrl + D

再読み込み

ドキュメントを読み込み直後の状態に戻します。

ドキュメントを再読み込みするには

  1. 「ドキュメント」メニューの「再読み込み」オプションをクリックします。

ショートカットキー： F5


「表示」メニュー

「表示」メニューには、 OXR/OPRドキュメントの表示に関する様々な機能があります。「グレースケール」と「モノクロ」オプションは印刷プレビューモード時のみ表示されます。

ツール バー

ツール バーの表示／非表示を切り替えます。

ツール バーを表示／非表示するには

  1. 「表示」メニューの「ツール バー」オプションをクリックします。

ステータス バー

アプリケーションステータスバー、および、ドキュメントステータスバーの表示／非表示を切り替えます。アプリケーションステータスバーはアプリケーションの状態を、ドキュメントステータスバーはドキュメントの状態を表示します。

アプリケーションステータスバーの表示／非表示を切り替えるには

  1. 「表示」メニューの「ステータス バー」オプションを選択します。
  2. 「ステータス バー」オプションのサブメニューで「アプリケーション」をクリックします。

ドキュメントステータスバーの表示／非表示を切り替えるには

  1. 「表示」メニューの「ステータス バー」オプションを選択します。
  2. 「ステータス バー」オプションのサブメニューで「ドキュメント」をクリックします。

ズーム

「ズーム」ダイアログでドキュメントの表示サイズを調整します。

ドキュメント表示サイズを調整するには

  1. 「表示」メニューの「ズーム」オプションを選択します。
  2. 「ズーム」ダイアログで倍率を選択し、「OK」ボタンをクリックします。

ズームイン

ドキュメントを拡大表示します。

ドキュメントを拡大表示するには

  1. ツール バーにある「ズームイン」ボタン [image] をクリックするか、表示メニューの「ズームイン」オプションを選択します。

ショートカットキー： Num +

ズームアウト

ドキュメントを縮小表示します。

ドキュメントを縮小表示するには

  1. ツール バーにある「ズームアウト」ボタン [image] をクリックするか、表示メニューの「ズームアウト」オプションを選択します。

ショートカットキー： Num -

ウィンドウサイズに合わせる

ドキュメントウィンドウにドキュメント全体が入るように表示サイズを調整します。

ドキュメントをウィンドウサイズに合わせるには

  1. ツール バーにある「ウィンドウサイズに合わせる」ボタン [image] をクリックするか、「表示」メニューの「ウィンドウサイズに合わせる」オプションを選択します。

ショートカットキー： Ctrl + 0

ウィンドウ幅に合わせる

ドキュメントウィンドウの幅に合わせてドキュメントの表示サイズを調整します。

ドキュメントをウィンドウ幅に合わせるには

  1. ツール バーにある「ウィンドウ幅に合わせる」ボタン [image] をクリックするか、「表示」メニューの「ウィンドウ幅に合わせる」オプションを選択します。

ショートカットキー： Ctrl + 1

実サイズ

ドキュメントを実際のサイズで表示します。

ドキュメントを実サイズで表示するには

  1. ツール バーにある「実サイズ」ボタン [image] をクリックするか、「表示」メニューの「実サイズ」オプションを選択します。

ショートカットキー： Ctrl + 2

グレースケール

ドキュメントをグレースケール(濃淡のある灰色)に変換します。

ドキュメントをグレースケール表示するには

  1. ツール バーにある「グレースケール」ボタン [image] をクリックするか、「表示」メニューの「グレースケール」オプションを選択します。

ショートカットキー： Ctrl + G

※「グレースケール」オプションは印刷プレビュー時のみ使用可能です。

モノクロ

ドキュメントをモノクローム(白黒２色)に変換します。

ドキュメントをモノクロ表示するには

  1. ツール バーにある「モノクロ」ボタン [image] をクリックするか、「表示」メニューの「モノクロ」オプションを選択します。

ショートカットキー： Ctrl + M

※「モノクロ」オプションは印刷プレビュー時のみ使用可能です。

サイドタブ

サイドタブの表示／非表示を切り替えます。

サイドタブを表示／非表示するには

  1. ツール バーにある「サイドタブ」ボタン [image] をクリックするか、「表示」メニューの「サイドタブ」オプションを選択します。

ショートカットキー： Ctrl + T

ソースの表示

「メモ帳」や「ワードパッド」等のテキストエディタでドキュメントのソースを閲覧できます。

ドキュメントのソースを表示するには

  1. 「表示」メニューの「ソースの表示」オプションを選択するか、ドキュメント上で右クリックしてポップアップメニューの「ソースの表示」を選択します。

※「オプション」ダイアログの「アプリケーション」設定で、ソース表示に使用するエディタを指定しておく必要があります。

全画面表示

ドキュメントをディスプレイの全画面で閲覧します。画面上方にマウスカーソルを寄せるとコントロールバーが現れるので、全画面表示を解除するには「全画面表示を解除」ボタンをクリックしてください。

ドキュメントを全画面表示するには

  1. 「表示」メニューの「全画面表示」オプションを選択します。

ショートカットキー： F11


「ツール」メニュー

「ツール」メニューには、OXBやドキュメントの外観設定、証明書の管理等を行なう付加機能が用意されています。

オプション

「オプション」ダイアログを開いて、OXBの各種設定を行ないます。

「オプション」ダイアログは「全般」「テーマ」の二つのタブで構成されています。「全般」タブでは、インターネット接続、ドキュメントの削除、サーバメッセージ、Web ブラウザ、ソースの表示等の設定を行えます。「テーマ」タブではOXBの外観等の設定を行えます。

スタイルシート

ドキュメントにスタイルシートを適用して、ドキュメントの外観を変更することができます。

XSLとOPR形式の構造について知識のあるユーザであれば、誰でもスタイルシートを開発することが可能です。いくつかXSLスタイルシートがサンプルとしてOXBフォルダの「style sheet」フォルダに用意されているので参考にしてください。

用意されているスタイルシート
style1.xsl | ドキュメントのすべてのラベルの背景色を灰色にします。
style2.xsl | ドキュメントのすべてのラベルのフォント色を青色にします。
style3.xsl | すべてのラベルのフレーム(表示されている場合)を赤色にします。
style4.xsl | ドキュメントに上記の3つのスタイルをすべて適用します。

スタイルシートを選択するには

  1. 「ツール」メニューの「スタイルシート」オプションを選択し、「スタイルシート」ダイアログを開きます。
  2. 「スタイルシート選択」ドロップダウンで、必要なスタイルシートを選択します。
  3. 「OK」ボタンをクリックします。

スタイルシートを追加するには

  1. 「ツール」メニューの「スタイルシート」オプションを選択し、「スタイルシート」ダイアログを開きます。
  2. 「追加」ボタンをクリックし、「開く」ダイアログでスタイルシートのXSLファイルを選択します。

スタイルシートを削除するには

  1. 「ツール」メニューの「スタイルシート」オプションを選択し、「スタイルシート」ダイアログを開きます。
  2. 「XSLスタイルシートの削除」の「選択」ドロップダウンで、削除したいスタイルシートを選択します。
  3. 「削除」ボタンをクリックします。

証明書の管理

「個人」「中間認証局」「信頼されたルート認証局」の証明書を参照／追加／削除できる証明書管理ツールです。

証明書を追加するには

  1. ツール バーにある「証明書の管理」ボタン [image] をクリックするか、「ツール」メニューの「証明書の管理」オプションを選択します。
  2. 「追加」ボタンをクリックし、追加する証明書ファイルを選択します。

証明書を削除するには

  1. ツール バーにある「証明書の管理」ボタン [image] をクリックするか、「ツール」メニューの「証明書の管理」オプションを選択します。
  2. 削除する証明書を選択し、「削除」ボタンをクリックします。

証明書の詳細情報を表示するには

  1. ツール バーにある「証明書の管理」ボタン [image] をクリックするか、「ツール」メニューの「証明書の管理」オプションを選択します。
  2. 証明書を選択し、「表示」ボタンをクリックします。

「個人」「中間認証局」「信頼されたルート認証局」のいずれの場合も、上記の手順は同じになります。


「オプション」ダイアログ

「オプション」ダイアログでは、OXBの各種設定を行ないます。「全般」「テーマ」の二つのタブで構成されています。

「全般」タブ

「全般」タブでは、インターネット接続、ドキュメントの削除、サーバメッセージ、Web ブラウザ、ソースの表示等の設定を行えます。

「インターネット接続」の「設定」ボタンを押すと、Windowsの「インターネットのプロパティ」ダイアログを呼び出します。

「ドキュメントの削除」の「閉じた時にドキュメントを削除」を有効にすると、キャッシュにあるソースドキュメントをドキュメントを閉じた時に削除します。

「直接印刷後にドキュメントを削除」を有効にすると、キャッシュにあるソースドキュメント、および、ODPファイルを直接印刷後に削除します。

「サーバメッセージ」の「サーバメッセージを表示」を有効にすると、ドキュメント生成中にエラーが起きた場合、サーバからの警告メッセージをダイアログ表示できます。

「Web ブラウザ」の「OXB を Internet Explorer 内で表示」を有効にすると、HTMLからリクエストしたOPR/OXRドキュメントを Internet Explorer の中で開きます。

「ソースの表示」の「アプリケーション」には、ドキュメントソースを見るために使用するエディタを指定します。「追加オプション」には、指定したエディタに渡すパラメータを入力します。

「テーマ」タブ

「テーマ」タブではOXBの外観等の設定を行えます。

「ドキュメントウィンドウの背景色」では、カラーパレットを直接クリックして、ドキュメントウィンドウ内の背景色を指定できます。「色の設定」ボタンをクリックすると「色の選択」ダイアログが現れ、カラーパレット以外の多くの色から選択できます。「元に戻す」ボタンをクリックすると、デフォルト設定の色に戻します。

「サムネイルの背景色」では、カラーパレットを直接クリックして、サムネイル内の背景色を指定できます。「色の設定」ボタンをクリックすると「色の選択」ダイアログが現れ、カラーパレット以外の多くの色から選択できます。「元に戻す」ボタンをクリックすると、デフォルト設定の色に戻します。

「ツール バーの背景画像」ではツール バーの背景画像を設定します。

「読み込み」ボタンで背景用画像ファイルを選択。「編集」ボタンで「スキンエディター」ダイアログを呼び出し、背景用画像を加工できます。「クリア」ボタンで背景画像をクリアし、標準ウィンドウ色を表示。「元に戻す」ボタンでデフォルト背景画像に戻します。

スキン画像を作成するには

  1. 「赤」「緑」「青」のスライダでカラーバランス調整、「色を反転」ボタンや「ランダムな色を合成」ボタンを使って画像を好みの状態に加工します。
  2. 「OK」ボタンをクリックすると、スキン画像としてツール バーの背景色に適用されます。

「フォント」の「フォント」ドロップダウンで、OXBユーザインターフェースで通常使用するフォントを選択できます。「サイズ」でフォントサイズ、「フォントの色」でフォントの色を指定します。

「テーマ」ドロップダウンから、OXBの外観をまとめて変更するテーマを選択できます。選択したテーマを適用するには「適用」または「OK」ボタンをクリックします。「保存」ボタンをクリックすると、現在の設定にテーマ名を付けて保存することができます。


「ウィンドウ」メニュー

「ウィンドウ」メニューには、ドキュメントウィンドウの配置を整理するためのオプションが用意されています。

重ねて表示

開かれているすべてのドキュメントウィンドウをカスケード(縦列)表示します。

上下に並べて表示

開かれているすべてのドキュメントウィンドウを水平にタイル表示します。

左右に並べて表示

開かれているすべてのドキュメントウィンドウを垂直にタイル表示します。

最小化

開かれているすべてのドキュメントウィンドウを最小化します。

最小化ウィンドウの自動配列

開かれているすべてのドキュメントウィンドウを最小化し、さらに整列させます。

最大化

すべてのドキュメントウィンドウを最大化します。開かれているドキュメントが複数の場合、選択中のドキュメントが最も手前に表示されます。


「ヘルプ」メニュー

「ヘルプ」メニューには、ユーザヘルプ機能が用意されています。

目次とキーワード

オンラインヘルプを開きます。ヘルプは「目次」「キーワード」「検索」タブの３つで構成され、OXBに関するあらゆる情報を提供します。

「目次」タブでは、目次で階層化されたトピックを参照できます。

「キーワード」タブでは、アルファベット順にリストアップされたキーワードでトピックにアクセスできます。

「検索」タブでは、任意のワードでヘルプを全文検索し、トピックを表示できます。

クイックヘルプ

OXB画面内でクリックした部分についてのヘルプトピックを呼び出します。

マウスカーソルは「矢印と疑問符」 [image] に変化し、OXB画面内でクリックした部分についてのヘルプページを表示することができます。

OPRO X Browser のクイックヘルプはヘルプ画面を呼び出し、指示されたオプションの機能に対応した説明ページを表示します。この機能によって、アプリケーションツールバー、ドキュメントツールバー、またはサイドタブにあるオプションについての説明を素早く得ることができます。クイックヘルプ機能を選択すると、マウスポインタの形状が「矢印と疑問符」 [image] に変わります。

クイックヘルプを利用するには

  1. ツール バーにある「クイックヘルプ」ボタン [image] をクリックするか、「ヘルプ」メニューの「クイックヘルプ」オプションを選択します。
  2. マウスカーソルの形状が「矢印と疑問符」 [image] に変化するので、そのままOXB画面内の任意のオプションをクリックします。
  3. クリックしたオプションに関するヘルプトピックが呼び出されます。

バージョン情報

OXBのバージョンと著作権情報を表示します。


ドキュメントツールバー

開いたドキュメントウィンドウのツールバーで、ドキュメントのページ移動、ドキュメントの拡大表示、実サイズ表示、ウィンドウ幅の調整等の操作を行えます。


ドキュメントプレビューツールバー

ドキュメントツールバーの機能に加え、「グレースケール」「モノクロ」「検索」「画像の選択」等のオプションがあります。


サイドタブ

サムネイル

「サムネイル」タブは、ドキュメントの縮小ページを一覧表示します。縮小ページをクリックして各ページを選択することができます。

プロパティ

「プロパティ」タブは、選択したオブジェクトのプロパティを表示します。Label / URLLabel / Aggregate Funtion / DateTime / PageNumber等の一部のコンポーネントのプロパティが変更可能です。

添付ファイル

「添付ファイル」タブは、ドキュメントに付属するファイルを一覧表示します。


プロパティ

コンポーネントのプロパティ

OXBでは、「プロパティ」タブを表示して「Label」「URLLabel」「Page Number」「Date Time」「Aggregate Function」コンポーネントのプロパティ値を編集することができます。

「プロパティ」タブを表示するには

  1. コンポーネントをダブルクリックするか、コンポーネントを右クリックしてポップアップメニューの「プロパティ」を選択します。

「プロパティ」タブを非表示にするには

  1. 「プロパティ」タブが表示された状態で、コンポーネントを一回だけクリックします。

プロパティの種類

「全般」プロパティの値

「名前」
コンポーネントの識別名を指定します。
「位置とサイズ」
コンポーネントの位置とサイズを指定します。
「枠線」
「サイズ」
枠線のサイズ(太さ)を指定します。
「色」
枠線の色を指定します。
「外観」
「可視」
コンポーネントの表示／非表示を指定します。
「透過」
コンポーネントの透過透／不透過を指定します。

「フォント」プロパティの値

「フォント」
フォント名を指定します。
「文字飾り」
「サイズ」
フォントのサイズを指定します。
「色」
フォントの色を指定します。
「取り消し線」
取り消し線の表示／非表示を指定します。
「太字」
太字にするかどうかを指定します。
「下線」
下線の表示／非表示を指定します。
「イタリック」
イタリックにするかどうかを指定します。

「カスタム」プロパティの値

「配置」
コンポーネントに表示する内容の位置を指定します。
「背景色」
コンポーネントの背景色を指定します。
「縦書き」
内容を縦書きで表示します。
「スタイル」
「自動サイズ」
コンポーネントのサイズを、そこに表示される内容に合わせて自動的に変更するかどうかを指定します。
「均等」
コンポーネント内の文字間隔を拡大または縮小して、等間隔に並べます。
「文字幅と間隔」
「行間隔」
テキストの行間隔を指定します。
「文字間隔」
テキストの文字間隔を指定します。
「タブ幅」
文字間のタブ幅を指定します。

「内容」プロパティの値

「内容」
コンポーネントの内容を入力します。


ドキュメントポップアップメニュー

ドキュメント上で右クリックすると、ドキュメント、および、コンポーネントに対して可能な操作オプションがポップアップメニューで表示されます。

コピー

コンポーネントに含まれるテキストをクリップボードにコピーします。

テキストをコピーするには

  1. テキストを含むコンポーネント上で右クリックし、ポップアップメニューの「コピー」オプションを選択します。

プロパティ

コンポーネントのプロパティを表示します。

プロパティを表示するには

  1. コンポーネント上で右クリックし、ポップアップメニューの「プロパティ」オプションを選択します。

画像の保存

画像を保存します。

画像を保存するには

  1. ドキュメント上にある画像を右クリックし、ポップアップメニューの「コピー」オプションを選択します。
  2. 保存ダイアログから、保存する場所を指定し、「OK」ボタンをクリックします。

URLのコピー

コンポーネントで指定されたURLをクリップボードにコピーします。

URLをコピーするには

  1. URLを指定されたコンポーネント上で右クリックし、ポップアップメニューの「URLのコピー」オプションを選択します。

URLに移動

コンポーネントで指定されたURLに移動します。

URLに移動するには

  1. URLを指定されたコンポーネント上で右クリックし、ポップアップメニューの「URLに移動」オプションを選択します。

デジタル署名の検証

ドキュメントに施されたデジタル署名を検証します。

デジタル署名を検証するには

  1. ドキュメント上に表示された署名を右クリックし、ポップアップメニューの「デジタル署名の検証」オプションを選択します。

タイムスタンプの検証

ドキュメントに施されたタイムスタンプを検証します。

タイムスタンプを検証するには

  1. ドキュメント上に表示されたタイムスタンプを右クリックし、ポップアップメニューの「タイムスタンプの検証」オプションを選択します。

ソースの表示

メモ帳やワードパッドまたはインターネット エクスプローラ等を使用して、ドキュメントのソースを表示します。

ドキュメントのソースを表示するには

  1. ドキュメント上で右クリックし、ポップアップメニューの「ソースの表示」オプションを選択します。


よくある質問(FAQ)

カテゴリー

機能

  • ページ番号と総ページ番号を表示させたい
  • OXDとOXSで、禁則処理の方法が異なっている
  • 「TotalPageNumber」コンポーネントについて
  • クライアント印刷とサーバサイド印刷の違いは？
  • クライアントからのリクエストでプリンタに直接印刷できますか？
  • PDFとOPRで印刷結果が異なるのですが

設定

  • 起動時のスプラッシュウィンドウを非表示にしたい
  • 「ドキュメントの印刷」で設定した内容を保存したい
  • 「拡張設定」で設定した内容を保存したい
  • マージンの設定を保存したい
  • データタイプで通貨表現をしたい
  • OXB、OXDでスクロールバーが表示されてしまう

操作

  • バージョンの確認方法

その他

  • ドキュメントに外字を使用したい
  • ブラウザからの結果表示が乱れて表示される
  • OXBのインストール作業軽減について
  • バージョンの考え方について
  • クライアント側に必要なソフトウェアについて
  • OPR/OXRの特徴について


よくある質問 - 機能

ページ番号と総ページ番号を表示させたい

質問

帳票にページ番号と総ページ番号を表示させたいと考えています。
ページ番号は「PageNumber」コンポーネントで表示しますが、総ページ番号も「PageNumber」コンポーネントを使って表示できるのでしょうか？

回答

ページ番号では「PageNumber」コンポーネントを使用し、総ページ番号では「TotalPageNumber」コンポーネントを使用します。
※OXS+OXBの組み合わせが必須のため、PDFでは表示されません。(2.5.5以降の新機能)

OXDとOXSで、禁則処理の方法が異なっている

質問

「Label」の「折り返し」プロパティを有効にした場合の、OXD上での禁則処理と、そのテンプレートで作成したドキュメントでの禁則処理が異なっているようですが、なぜですか？

回答

OXS、OXD、OXB での禁則処理は、以下のようになっています。

[OXS]

  • 「折り返し」の行頭禁則文字は「,.、。，．」の六文字。
  • 「折り返し」の行末禁則処理は行わない。
  • 禁則処理をしないようにしたり、禁則文字を替えることはできない。
  • 生成ドキュメント形式には依存しない。
[OXD]
  • 「折り返し」は、MicrosoftのRichEditの仕様に従う。
  • 禁則処理をしないようにしたり、禁則文字を替えることはできない。
[OXB]
  • 禁則処理は行わない(「折り返し」は、OXSが決めた改行位置に改行コードが入ることによって折り返される)。
従って、OXD上とドキュメントでは折り返す文字が異なる場合があります。

「TotalPageNumber」コンポーネントについて

質問

「TotalPageNumber」コンポーネントを使用して、PDFで総ページ数を表示したいのですが。

回答

「TotalPageNumber」コンポーネントは、ドキュメントの形式やOXSの機能によって、使用できる場合と、できない場合があります。

「TotalPageNumber」を使用できる形式・機能

  • OPR形式
  • ODP形式
  • OXR形式
  • DocuWorks形式
  • サーバ印刷機能
  • FAX送信機能

「TotalPageNumber」を使用できない形式・機能

  • PDF形式
  • HTML形式
  • サーバ印刷機能

クライアント印刷とサーバサイド印刷の違いは？

質問

クライアント印刷とサーバサイド印刷の違いを教えてください。また、どのように使い分ければよいのでしょうか？
例えば、週次処理のバッチで外部アプリケーションから1つのOXSへとリクエストをかけ、特定のプリンタへと出力させる要件の場合、クライアント印刷とサーバサイド印刷のどちらが適切なのでしょうか？

回答

■クライアント印刷(直接印刷ともいいます)

クライアントに設定されているプリンタで、OPRを画面に表示させずに、印刷を行う印刷方式です。 クライアントの標準プリンタ(通常使うプリンタ)にスプールします。
例えば、印刷前にOPRドキュメントを開いて確認する必要がない場合、直接印刷を行うことで、OXBのメニューから印刷指示を行なう操作が不要になります。

■サーバサイド印刷

OXSのマシン(サーバ)で設定されているプリンタにスプールします。スプールするプリンタはリクエスト時にDNパラメータで指定します。
ローカル印刷とリモート印刷が可能となっています。
  • ローカル印刷
    • OXSが稼動しているマシンに設定されているプリンタにスプールします。
  • リモート印刷
    • OXSが複数存在する場合に可能な印刷方法です。 ドキュメントを生成したOXSとは別のOXSマシンで設定されているプリンタにスプールします。
    例えば、本店と複数拠点にそれぞれOXSがインストールされているシステムで、印刷指示は本店から行い、拠点のプリンタから印刷出力する、というような場合に使用することができます。
要件については、印刷指示をクライアントからではなく外部アプリケーションから行い、OXSは一つだけ存在するとのことなので、サーバサイド印刷のローカル印刷で行なうのが良いと思われます。

※注意

  • ODCAW.xmlの設定を変更した場合は、OXSの再起動が必要です。再起動しないと、変更が適用されません。
  • サーバサイド印刷を行うには、オプションであるPrintServiceまたはPrint Editionのライセンスが必要です。
  • OXSのOSはWindows限定です。

クライアントからのリクエストでプリンタに直接印刷できますか？

質問

クライアントからのリクエストで、プリンタに直接印刷することは可能ですか？

回答

OXBの機能により、クライアントに接続されたプリンタに直接印刷することが可能です。
また、オプション機能「Print Service」を追加することにより、OXSで生成したドキュメントを、OXSに接続されたプリンタに印刷することができます。
また、サーバサイド印刷用のオプション機能「Print Edition」を使うと、OXSで生成したドキュメントを、別のOXSに接続されたプリンタに印刷することができます。

PDFとOPRで印刷結果が異なるのですが

質問

PDFをダウンロードして印刷した場合と、直接印刷した場合とで、印刷された紙(帳票)を重ねてみると、同じテンプレートなのに線や文字などがずれているのですが。

回答

直接印刷(OP=dp)、サーバサイド印刷(OP=pr)、FAX送信(OP=fx)の処理には内部的にOXBが使用されます。OXBで印刷するフォーマット(OPR、ODP、OXR)と、PDFは異なるものですので、まったく同じ出力結果にはなりません。


よくある質問 - 設定

起動時のスプラッシュウィンドウを非表示にしたい

質問

OPRファイルを開くときに表示されるスプラッシュウィンドウを非表示にすることはできますか？

回答

残念ながら、OPRO X Browser、および、OPRO X Viewerでスプラッシュウィンドウを省略する機能はありません。

「ドキュメントの印刷」で設定した内容を保存したい

質問

OXBの「ドキュメントの印刷」で設定した内容を、ドキュメントごとに保存したいのですが。

回答

OXBの機能を使用して、以下のケースにおいて、ドキュメントごとに「ドキュメントの印刷」設定を保存することができます。

  • OPR(またはOXR)のダウンロード
  • クライアント直接印刷
  • サーバサイド印刷
「ドキュメントの印刷」の設定を保存するには、OXBで「PrnSetInf.csv」というファイルを作成し、印刷を行うクライアント側(サーバサイド印刷の場合はサーバ側)に配置します。

1.手順

  1. 印刷設定を保存したいテンプレートを使用してOPR形式(またはOXR形式)でドキュメントを生成します。
    このとき、OXDからのプレビューではなく、サンプルHTMLを利用するなどしてリクエストを行って帳票を生成してください。
  2. OXBの「ファイル」メニュー ⇒ 「印刷」で、「ドキュメントの印刷」ウィンドウを表示します。
  3. 印刷設定を行い、「設定の保存」をクリックします。
  4. "[ユーザ・プロファイル・フォルダ]/OPRO/OXB/"に「PrnSetInf.csv」が作成されたことを確認します。
▼ドキュメントの印刷

2.設定の保存単位について

生成ドキュメントは"OPRO__[ランダムな数値][テンプレート名].拡張子"というファイル名で保存されます。「ドキュメントの印刷」の設定は、このファイル名の[テンプレート名]単位で保存されます。マルチ テンプレート リクエストの場合は、最初に指定されたテンプレート名となります。

3.他ユーザでも同じ設定を適用するには

「PrnSetInf.csv」を他ユーザの"[ユーザ・プロファイル・フォルダ]/OPRO/OXB/"へ配置すると、他ユーザも同じ印刷設定を利用することができます。

4.サーバサイド印刷で「ドキュメントの印刷」の設定を適用するには

「PrnSetInf.csv」をOXS稼動マシンの"[OXS_HOME]/bin/oipsApps/"フォルダに配置します。 ただし、OXS稼動マシンの、OS起動ユーザのユーザ・プロファイル・フォルダに「PrnSetInf.csv」が配置されていた場合は、その設定が優先されます。
印刷部数については、NCパラメータを指定している場合、パラメータ値が優先されます。
スプール先はDNパラメータの値ではなく、「PrnSetInf.csv」に指定されているプリンタになります。

5.注意点

上記3.～4.の方法で「PrnSetInf.csv」を配置するとき、指定フォルダにすでに「PrnSetInf.csv」が存在する場合、以前の設定を上書きしてしまわないように注意してください。
ファイルごと上書きをせずに、「PrnSetInf.csv」を編集し、必要な設定を追加するとよいでしょう。

「拡張設定」で設定した内容を保存したい

質問

ドキュメントごとに「拡張設定」(トレイの指定)で設定した内容を保存したいのですが。

回答

OXBの機能を使用して、以下のケースにおいて、ドキュメントごとに印刷するトレイを指定することができます。

  • OPR(またはOXR)のダウンロード
  • クライアント直接印刷
  • サーバサイド印刷
トレイの指定を保存するには、OXBで「addset.xml」というファイルを作成し、これを印刷を行うクライアント側(サーバサイド印刷の場合はサーバ側)に配置します。

1.手順

  1. トレイを指定したいテンプレートを使用してOPR形式(またはOXR形式)でドキュメントを生成します。
    このとき、OXDからのプレビューではなく、サンプルHTMLを利用するなどしてリクエストを行って帳票を生成してください。
  2. OXBの「ファイル」メニュー ⇒ 「印刷」で、「ドキュメントの印刷」ウィンドウを表示します。
  3. 「拡張設定」ウィンドウでトレイを指定し、「保存」ボタンをクリックします。
  4. "[ユーザ・プロファイル・フォルダ]/OPRO/OXB/"に「addset.xml」が作成されたことを確認します。
▼「ドキュメントの印刷」ウィンドウ

▼「拡張設定」ウィンドウ

2.設定の保存単位について

生成ドキュメントは"OPRO__[ランダムな数値][テンプレート名].拡張子"というファイル名で保存されます。トレイの指定は、このファイル名の[テンプレート名]単位で保存されます。マルチ テンプレート リクエストの場合は、最初に指定されたテンプレート名となります。

3.他ユーザでも同じ設定を適用するには

「addset.xml」を他ユーザの"[ユーザ・プロファイル・フォルダ]/OPRO/OXB/"へ配置すると、他ユーザも同じ印刷設定を利用することができます。

4.サーバサイド印刷でトレイの指定を適用するには

「addset.xml」をOXS稼動マシンの"[OXS_HOME]/bin/oipsApps/"フォルダに配置します。ただし、OXS稼動マシンの、OS起動ユーザのユーザ・プロファイル・フォルダに「addset.xml」が配置されていた場合は、その設定が優先されます。

5.注意点

上記3.～4.の方法で「PrnSetInf.csv」を配置するとき、指定フォルダにすでに「addset.xml」が存在する場合、以前の設定を上書きしてしまわないように注意してください。
ファイルごと上書きをせずに、「addset.xml」を編集し、必要な設定を追加するとよいでしょう。

マージンの設定を保存したい

質問

ドキュメントごとにマージンを設定し、その設定を保存したいのですが。

回答

OXBの機能を使用して、以下のケースにおいて、ドキュメントごとにマージン設定を保存することができます。

  • OPR(またはOXR)のダウンロード
  • クライアント直接印刷
  • サーバサイド印刷
マージン設定を保存するには、OXBで「Margins.csv」というファイルを作成し、これを印刷を行うクライアント側(サーバサイド印刷の場合はサーバ側)に配置します。

1.手順

  1. マージン設定を保存したいテンプレートを使用してOPR形式(またはOXR形式)でドキュメントを生成します。
    このとき、OXDからのプレビューではなく、サンプルHTMLを利用するなどしてリクエストを行って帳票を生成してください。
  2. OXBの「ドキュメント」メニュー ⇒ 「マージン」または「マシーンの設定」で、マージンの設定を行います。
  3. OXBの「ドキュメント」メニュー ⇒ 「マージンの保存」で、マージン設定を保存します。
  4. "[ユーザ・プロファイル・フォルダ]/OPRO/OXB/"に「Margins.csv」が作成されたことを確認します。

2.設定の保存単位について

生成ドキュメントは"OPRO__[ランダムな数値][テンプレート名].拡張子"というファイル名で保存されます。マージン設定は、このファイル名の [テンプレート名]単位で保存されます。マルチ テンプレート リクエストの場合は、最初に指定されたテンプレート名となります。

3.他ユーザでも同じ設定を適用するには

「Margins.csv」を他ユーザの"[ユーザ・プロファイル・フォルダ]/OPRO/OXB/"へ配置すると、他ユーザも同じ印刷設定を利用することができます。

4.サーバサイド印刷でマージンの設定を適用するには

「Margins.csv」をOXS稼動マシンの"[OXS_HOME]/bin/oipsApps/"フォルダに配置します。ただし、OXS稼動マシンの、OS起動ユーザのユーザ・プロファイル・フォルダに「Margins.csv」が配置されていた場合は、その設定が優先されます。

5.「Margins.csv」について

1フィールド目がテンプレート名になっています。
また、上記3.～4.の方法で「Margins.csv」を配置するとき、指定フォルダにすでに「Margins.csv」が存在する場合、以前の設定を上書きしてしまわないように注意してください。
ファイルごと上書きをせずに、「Margins.csv」を編集し、必要な設定を追加するとよいでしょう。

データタイプで通貨表現をしたい

質問

データタイプに通貨の表現形式はありますか？

回答

データタイプには、特別に通貨を表現するものはありませんので、数値の表示形式を利用します。

設定方法

オブジェクトのプロパティで、「内容／表示形式」に以下を入力します。

例)
\#,##0

Datasetからクエリビルダを呼び出し、フィールドの表示形式に同様の設定を行なうと、フィールドを使用するオブジェクト作成時の初期値とすることができます。

※表示形式の詳細については、OXDの「ヘルプ」メニュー ⇒ 「キーワード」タブから「数値の表示形式」を参照してください。

OXB、OXDでスクロールバーが表示されてしまう

質問

OXB、OXDで意図せぬスクロールバーが表示されてしまうのですが、どうしたら消せますか？

回答

テーブルコンポーネント（Table、DatasetTable、HorizontalDatasetTable）上に配置したコンポーネントが範囲内に収まりきらない場合、OXB、OXD上でスクロールバーが表示されます。
はみ出ているコンポーネントのサイズを小さくするか、テーブルコンポーネントのカラム、バンドのサイズを大きくすることにより回避してください。
また、範囲内ぎりぎりのサイズでコンポーネントを配置している場合、OXBでは、表示倍率によってスクロールバーが表示されることがあります。このような場合は、表示倍率100%で表示してください。


よくある質問 - 操作

バージョンの確認方法

質問

OXB、OXD、OXSのバージョンを確認する方法を教えてください。

回答

OXD、および、OXBについては、アプリケーションメニューの 「ヘルプ」⇒「バージョン情報」 で、確認することができます。

OXSについては、 OXSが起動している状態で、ウェブブラウザからOXSのCGI/Servletに対し、「DO=sv&ES=odcaw」というパラメータでリクエストを実行。 または、 「[OXS_HOME]/bin/」フォルダにある「version.bat(またはversion.sh)」を実行することにより、確認できます。

※[OXS_HOME]はOPRO X Serverをインストールしたフォルダです。デフォルトでは「C:\Program Files\OPRO\OPRO X Server」にあります。


よくある質問 - その他

ドキュメントに外字を使用したい

質問

ドキュメントに外字は使用できますか？ 使用できるのであれば、その際の注意点も教えてください。

回答

OXBは、OPR/OXRドキュメントを表示・印刷する際、ローカルマシンのフォントを使用します。この為、「Label」コンポーネント等の「フォント」プロパティに指定した日本語フォントにユーザ定義の外字が正しく関連付けられていれば、その文字コードに対応する外字を表示・印刷することができます。

しかし、この方法では、OXBを起動するマシンすべてに外字をインストールする必要があり、また、個々のドキュメントによって、同じ文字コードに別々の外字設定がなされていた場合に、正しく表示できない等の問題が生じます。

OPR/OXRドキュメントに外字のフォントデータを埋め込むことによって、これらの問題を解決することができます。

外字フォントデータを埋め込むには

  1. テンプレート作成前に、あらかじめドキュメントで使用したい外字を、マシンにインストールしておきます。
  2. 外字を関連付けた日本語フォントを、外字を出力するコンポーネントの「フォント」プロパティで選択します。
  3. コンポーネントの値に、外字の文字コードを指定して、正しく表示されるどうかを確認します。
  4. コンポーネントの「フォント」プロパティの「ユーザ外字」にチェックマークを入れます。
  5. テンプレートを保存します(テンプレートに外字フォントデータが埋め込まれます)。
  6. このテンプレートでOPR/OXRドキュメントを生成すると、埋め込まれた外字フォントデータによって、外字が正しく表示されるドキュメントとなります。
OXBは、外字フォントデータが埋め込まれたドキュメントを表示・印刷する際、そのフォントを一時的にそのマシンに設定することで出力を可能にします。OXSでサーバ印刷・FAX送信を行う際には、内部的にOXBを使用していますので、外字フォントデータが埋め込まれたテンプレートを使用すれば、サーバ印刷やFAX送信においても外字を出力できます。ただし、フォントを一時的にそのマシンに設定する為、OXSサービスはローカル システム アカウント以外のユーザで起動する必要があります。

OXSで生成可能な、その他のドキュメント形式については、以下の通りです。

■PDF形式
  • テンプレートに外字フォントデータが埋め込まれている場合
    ドキュメント内にも外字フォントデータが埋め込まれ、外字を出力できます。
  • テンプレートに外字フォントデータが埋め込まれていない場合
    外字は出力できません(空白または文字化けします)。
■DocuWorks形式
  • サーバで内部的に印刷を行うので、サーバ印刷と同じ動作になります。
■HTML形式
  • ドキュメントを表示するクライアントに設定されている外字が使用されます。

ブラウザからの結果表示が乱れて表示される

質問

ブラウザからOPRを表示するとOXBが起動されず、ブラウザにOPRファイルが乱れて表示されるのですが。

回答

IMEタイプの設定が正しく行われていないことが考えられます。以下のリンク先を参照してください。

「OPRO X Server - リファレンス・マニュアル」 → IIS の設定例 → MIME タイプの設定

OXBのインストール作業軽減について

質問

OXBのインストールで、クリック動作や各項目の入力を不要にする方法はありますか？

回答

あります。OXBはサイレントモードでインストールすることが可能です。
サイレント インストールでは、コマンドライン パラメータで各項目を指定し、インストールを実行します。インストール実行中にインストール画面は表示されません。

サイレントインストールを実行するには

次のようなコマンドライン フォーマットで指定・実行します。

oxbxxxx.exe /s /v"/qn ALLUSERS=2 COMPANYNAME=\"会社名\" USERNAME=\"ユーザ名\" INSTALLDIR=\"インストール先フォルダパス\""

例えば、「oxb25548.exe」を次のような設定でインストールする場合は、
  • 会社名 … custname
  • ユーザ名 … customer_user
  • インストール先フォルダパス … "C:\Program Files\OPRO\OPRO X Browser"
次のように指定してインストールを実行します。

oxb25548.exe /s /v"/qn ALLUSERS=2 COMPANYNAME=\"custname\" USERNAME=\"customer_user\" INSTALLDIR=\"C:\Program Files\OPRO\OPRO X Browser\""

サイレント インストールでは、エラー発生時にエラーメッセージ等が表示されません。インストールが正常に終了したことを確認するためにはログファイルを出力する必要があります。ログファイルを出力するには、次のパラメータを追加してください。

/l*v \"ログファイルパス\"

ログファイルのパスを"C:\setup\oxbsetup.log"とする場合、

oxb25548.exe /s /v"/qn ALLUSERS=2 COMPANYNAME=\"custname\" USERNAME=\"customer_user\" INSTALLDIR=\"C:\Program Files\OPRO\OPRO X Browser\" /l*v \"C:\setup\oxbsetup.log\""

参考URL
Setup.exe and Update.exe Command-Line Parameters
Windows Installer Property Reference

バージョンの考え方について

質問

バージョンの考え方について教えてください

回答

[バージョン表記について]

例えば、OXSのバージョンは「OXS 2.5.0.0」のように表記されます。「2.5.0.0」の部分は、それぞれ「メジャーバージョン.マイナーバージョン.リビジョン.ビルド」を表しています。
  • メジャーバージョン … 製品を根本から変更する場合に変更されます。
  • マイナーバージョン … 大幅な仕様変更・機能追加をする場合に変更されます。
  • リビジョン … 仕様変更・機能追加をする場合に変更されます。
  • ビルド … 修正パッチごとに変更されます。
メジャーバージョン・マイナーバージョン・リビジョンが変更される場合は、より下位の変更・修正内容を含んでいます。

[アプリケーションの互換性について]

マイナーバージョン アップ、またはリビジョン アップ( = 仕様変更・機能追加)は、次のような考え方のもとで行なわれます。
OXD、OXBでは同一メジャーバージョン内での上位互換を保ちます。
例えば、メジャーバージョンが2である限り、最新のOXD、OXBでは常に過去のテンプレートやOPRファイルを読み込めるようにしますが、古いバージョンのOXD、OXBで、最新のテンプレートやOPRファイルを読み込めるかどうかは保証しません。

ビルドアップの場合、上記の考え方は適用されません。
ビルドアップは「修正」であり、「仕様変更・機能追加」ではありませんので、同一リビジョン内での下位・上位はありません。
例えば、「2.5.0.0」と「2.5.0.10」は同位となり、互換性は保たれることになります。

[具体例]

例1) OXS2.5.0.40 から OXS2.5.5.30 にバージョンアップする場合(リビジョン以上のバージョンアップ)
  • OXSは新規インストールとなります。
  • OXDも2.5.5.x(OXSと同一リビジョン)にバージョンアップする必要があります。
  • 既存テンプレートについてはバージョンアップ(バージョンアップ後のOXDでの上書き保存)が必要となります。
    (テンプレートはバージョンアップを行うと下位バージョンに戻すことができないので、バックアップをとっておくことを推奨します)
  • OXBも2.5.5.0以上(OXSと同じか、上位であるリビジョン)にバージョンアップする必要があります。
※アップデートサイトの「注意事項」を必ずご参照ください。

例2) OXS2.5.0.0 から OXS2.5.0.40 にバージョンアップする場合(ビルドアップ)
  • OXSにはアップデートパッチを適用します。
    (アップデートパッチの適用方法については、ZIPファイル内の「readme.txt」を参照してください)
  • OXDは、2.5.0.x(OXSと同一リビジョン)であれば問題ありません。
  • 既存テンプレートのバージョンアップは必要ありません。
  • OXBについては、2.5.0.0以上(OXSと同じか、上位のリビジョン)であれば問題ありません。

クライアント側に必要なソフトウェアについて

質問

クライアント側に必要なソフトウェアについて教えてください

回答

PDFを使用する場合は「Adobe(Acrobat) Reader」が必要になります。
OPR/OXR(日本オプロ独自XMLフォーマット)を使用する場合は、OPRO X Browser(OXB)が必要になります(OXBは無償でダウンロードできます)。
また、テンプレート開発用クライアントにはOPRO X Designer(OXD)が必要になります。

OPR/OXRの特徴について

質問

OPR/OXRには、どのような特徴がありますか？

回答

OPRはOXRを圧縮したものでOXR同様、OXBでの閲覧・印刷が可能なフォーマットです。XML形式のままでは、ファイルサイズが大きくなりすぎるような場合にOPRを使用することで、ネットワークの負荷を軽減することが可能です。


IDH_OXB0001=html\overview.html
IDH_OXB0002=html\File.html#Open
IDH_OXB0003=html\File.html#Close
IDH_OXB0004=html\File.html#CloseAll
IDH_OXB0006=html\File.html#SaveAs
IDH_OXB0007=html\File.html#Exit
IDH_OXB0008=html\Edit.html#Cut
IDH_OXB0009=html\Edit.html#Copy
IDH_OXB0010=html\Edit.html#Paste
IDH_OXB0011=html\Window.html#Cascade
IDH_OXB0012=html\Window.html#TileHorizontally
IDH_OXB0013=html\Window.html#TileVertically
IDH_OXB0014=html\Window.html#MinimizeAll
IDH_OXB0015=html\Window.html#ArrangeAll
IDH_OXB0016=html\PrintDocument.html
IDH_OXB0017=html\View.html#Grayscale
IDH_OXB0018=html\View.html#Monochrome
IDH_OXB0019=html\doc_toolbar.html
IDH_OXB0020=html\Edit.html#Find
IDH_OXB0021=html\Edit.html#SelectGraphic
IDH_OXB0022=html\Document.html#Margin
IDH_OXB0023=html\Document.html#SaveMargin
IDH_OXB0024=html\Document.html#SetMargin
IDH_OXB0025=html\Document.html#FirstPage
IDH_OXB0026=html\Document.html#PreviousPage
IDH_OXB0027=html\Document.html#NextPage
IDH_OXB0028=html\Document.html#LastPage
IDH_OXB0029=html\doc_toolbar.html
IDH_OXB0030=html\View.html#ZoomIn
IDH_OXB0031=html\View.html#ZoomOut
IDH_OXB0032=html\View.html#Zoom
IDH_OXB0033=html\View.html#FitInWindow
IDH_OXB0034=html\View.html#FitWidth
IDH_OXB0035=html\View.html#ActualSize
IDH_OXB0036=html\View.html#SideTabs
IDH_OXB0037=html\Window.html
IDH_OXB0039=html\Edit.html#FindAgain
IDH_OXB0106=html\feature.html
IDH_OXB0108=html\Tools.html#Options
IDH_OXB0109=html\Document.html#VerifyDigitalSignature
IDH_OXB0122=html\Tools.html#Stylesheet
IDH_OXB0130=html\Document.html#DocumentInformation
IDH_OXB0131=html\View.html#Toolbar
IDH_OXB0132=html\Help.html#ContentsAndIndex
IDH_OXB0133=html\File.html#PrintPreview
IDH_OXB0134=html\View.html#Source
IDH_OXB0136=html\doc_popupmenu.html#GotoURL
IDH_OXB0137=html\View.html#StatusBar
IDH_OXB0158=html\Options.html#BrowserTheme
IDH_OXB0168=html\document_format.html#ofd
IDH_OXB0191=html\SideTab.html#Thumbnails
IDH_OXB0193=html\SideTab.html#Attachments
IDH_OXB0197=html\interface.html
IDH_OXB0198=html\interface.html
IDH_OXB0199=html\Window.html#Maximize
IDH_OXB0200=html\doc_popupmenu.html#SavePictureAs
IDH_OXB0202=html\View.html#FullScreen
IDH_OXB0206=html\doc_popupmenu.html#CopyURL
IDH_OXB0211=html\doc_popupmenu.html#Property
IDH_OXB0212=html\document_format.html#oxr
IDH_OXB0213=html\SaveData.html
IDH_OXB0215=html\File.html#SaveCurrentDisplayed
IDH_OXB0217=html\Tools.html#CertificateManager
IDH_OXB0219=html\Document.html#InsertAttachment
IDH_OXB0225=html\Options.html#General
IDH_OXB0240=html\Document.html#Reload
IDH_OXB0241=html\Property.html
IDH_OXB0242=html\Additional.html
IDH_OXB0244=html\LoadData.html
IDH_OXB0255=html\Document.html#Margin
IDH_OXB0256=html\Document.html#Margin
IDH_OXB0259=html\Edit.html
IDH_OXB0260=html\Edit.html
IDH_OXB0261=html\Edit.html
IDH_OXB0262=html\Help.html#About
IDH_OXB0263=html\document_format.html#opr
IDH_OXB0264=html\about_oxd.html
IDH_OXB0300=html\doc_popupmenu.html#VerifyTimeStamp
IDH_OXB0301=html\Help.html


.topic 38
変更したマージンの値を保存すると同時に、現在開かれているドキュメントに適用します。

.topic 40
ドキュメントを印刷するプリンタを選択します。

.topic 41
ドキュメントのすべてのページを印刷します。

.topic 42
現在選択されているページだけを印刷します。

.topic 43
「ページ指定」に入力されたページを印刷します。

.topic 44
印刷を開始するページを指定します。

.topic 45
印刷を終了するページを指定します。

.topic 46
印刷する部数を指定します。

.topic 47
通常色でドキュメントを印刷します。

.topic 48
ドキュメントの色をグレースケール値に変換します。

.topic 49
ドキュメントの色をモノクロ値に変換します。

.topic 50
選択したドキュメントを印刷します。

.topic 51
ドキュメントの印刷をキャンセルします。

.topic 52
アプリケーションのフォントタイプを変更します。

.topic 53
ドキュメントの背景色を変更します。

.topic 54
サムネイルの背景を変更します。

.topic 55
背景色を、横のパレットにない色から選択します。

.topic 56
デフォルトの背景色を選択します。

.topic 57
サムネイルの背景色を、横のパレットにない色から選択します。

.topic 58
サムネイルのデフォルトの背景色を選択します。

.topic 59
ログファイルに記録するエラーメッセージの行数を選択します。ログファイルの行数がここで指定した値を超えると、最初の行から上書きします。

.topic 60
クリックすると、エラーメッセージのログを保存できます。エラーログファイルは、OXBのアプリケーションディレクトリに、「OXBError.log」という名前で作成されます。ダイレクトプリント機能を使用する場合、発生したエラーはこのログファイルに記録されるので、この機能を使用することが重要になります。

.topic 61
選択を確認します。

.topic 62
選択をキャンセルします。

.topic 63
ドキュメントを検索するテキストを入力します。

.topic 64
完全に一致する単語だけを検索します。

.topic 65
大文字と小文字を区別して検索します。

.topic 66
ドキュメントを下から上に向かって検索します。

.topic 67
選択された検索結果を確認します。

.topic 68
入力した検索条件をキャンセルします。

.topic 69
ページの左端のマージンのサイズを入力します。

.topic 70
ページの右端のマージンのサイズを入力します。

.topic 71
ページの上端のマージンのサイズを入力します。

.topic 72
ページの下端のマージンのサイズを入力します。

.topic 73
以前保存したマージンに戻します。

.topic 74
マージンの設定を確認します。

.topic 75
マージンの設定をキャンセルします。

.topic 76
ドキュメントの指定されたページを印刷します。

.topic 87
検索するテキストを入力してください。

.topic 107
証明書の名前を表示します。

.topic 110
ドキュメントに署名したユーザが表示されます。

.topic 111
デジタル署名の認証日付が表示されます。

.topic 112
認証の理由が表示されます。

.topic 113
認証地が表示されます。

.topic 114
ユーザの連絡先情報が表示されます。

.topic 115
「デジタル署名の検証」ダイアログを閉じます。

.topic 116
シリアル番号が表示されます。

.topic 117
証明書が有効になる日付が表示されます。

.topic 118
証明書が無効になる日付が表示されます。

.topic 119
ユーザの識別名が表示されます。

.topic 120
証明書の発行者の識別名が表示されます。

.topic 121
キーのアルゴリズムが表示されます。

.topic 123
ドキュメントに適用するスタイルシートを選択します。

.topic 124
新しいスタイルシートを追加します。

.topic 125
削除するスタイルシートを選択します。

.topic 126
選択したスタイルシートを削除します。

.topic 127
選択を確認します。

.topic 128
選択をキャンセルします。

.topic 138
OPRO X Browserでアプリケーションのフォント名を変更します。

.topic 139
OPRO X Browserでアプリケーションのフォントサイズを変更します。

.topic 140
OPRO X Browserの「サムネイル」の背景色を変更します。

.topic 141
OPRO X Browserのツールバーの背景を変更します。

.topic 142
OPRO X Browserのツールバーのデフォルトの背景を選択します。

.topic 143
OPRO X Browserのツールバーの背景に使用する画像をロードします。

.topic 144
ツールバーの背景画像を消去します。

.topic 145
OPRO X Browserの標準のツールバーのボタンを選択または選択解除します。

.topic 146
Select or deselect Address Toolbar buttons from from the OPRO X Browser.

.topic 147
Select or deselect Toolbar buttons from the OPRO X Browser.

.topic 148
OPRO X Browserのアプリケーションステータスバーを選択または選択解除します。

.topic 149
OPRO X Browserのドキュメントステータスバーを選択または選択解除します。

.topic 150
選択すると、OPRO X Browserでプロキシサーバを有効にします。

.topic 151
プロキシサーバのIPアドレスを指定します。

.topic 152
プロキシサーバのポート番号を指定します。

.topic 153
Specify the Home Page address for the OPRO X Browser. This address will load when clicking the home page button in OXB.

.topic 154
ハッシュ値を生成するアルゴリズムの一つで、ファイルまたは文字列で与えられたデータを使用して、ハッシュ値を生成します。

.topic 155
ハッシュ値を生成するアルゴリズムの一つで、ファイルまたは文字列で与えられたデータを使用して、ハッシュ値を生成します。

.topic 156
選択したドキュメント(複数可)を閉じるときに削除します。閉じるときに、削除するかどうかを確認するウィンドウが表示されます。

.topic 157
変更したマージンの値を現在開かれているドキュメントに適用します。

.topic 159
bmpファイルを読み込み、開きます。

.topic 160
bmpファイルを保存します。

.topic 161
スキンに対して実行した変更を取り消し、デフォルトのスキンをロードします。

.topic 162
ブラウザで現在選択されているスキンが表示されます。

.topic 163
選択されているスキンが表示されます。

.topic 164
選択されているスキンの色を反転します。

.topic 165
ランダムな色を生成します。

.topic 166
スキンのプレビューを表示します。

.topic 167
赤、緑、青の強度を変更します。

.topic 169
選択すると、OXBのプロキシサーバを有効にします。

.topic 170
プロキシサーバのIPアドレスまたはドメイン名を入力します。

.topic 171
プロキシサーバのポート番号を入力します。

.topic 172
Allows typing the home page web address. The specified IP address will be activated when clicking the home icon.

.topic 173
このオプションを有効にすると、ユーザプロファイルの「OPRO\OXB」フォルダに「OXBError.log」というファイル名でログファイルを作成します。「直接印刷」使用時にエラーが発生した場合、唯一のエラー情報がこのログファイルに記録されるので、エラーの原因を追跡する場合には重要な機能となるでしょう。

.topic 174
ログファイルに記録するエラーメッセージの行数を選択します。ログファイルの行数がここで指定した値を超えると、最初の行から上書きします。

.topic 175
キャッシュに保存されているドキュメントを削除します。

.topic 176
OXBのドキュメントウィンドウの色を、パレットにない色から選択します。

.topic 177
OXBのドキュメントウィンドウのデフォルトの背景色を選択します。

.topic 178
サムネイルの背景色を、横のパレットにない色から選択します。

.topic 179
サムネイルのデフォルトの背景色を選択します。

.topic 180
ツールバーの背景画像を選択できます。

.topic 181
「スキンエディター」ダイアログウィンドウで、ロードしたツールバーの背景画像を編集できます。

.topic 182
ツールバーの背景画像色を消去し、標準のウィンドウ色を表示します。

.topic 183
ツールバーの背景画像のデフォルトの色を選択します。

.topic 184
OXBのフォント名を選択できます。

.topic 185
OXBのフォントサイズを選択できます。

.topic 186
OXBのフォントの色を選択できます。

.topic 187
ドキュメントの色テーマを選択します。これにより、ドキュメントウィンドウの背景色など、OXBの外観を変更できます。

.topic 188
選択したテーマを保存できます。

.topic 189
選択したテーマをドキュメントに適用します。

.topic 190
「サムネイル」に表示されるすべてのテキストを選択します。

.topic 201
プリンタの設定を保存します。プリンタの設定を保存したドキュメントを、そのコンピュータでもう一度印刷リクエストすると、OXBは保存されているプリンタの設定を読み出して適用します。この機能は「ダイレクトプリント」リクエストを使用する場合に特に有効です。

.topic 203
印刷範囲内のすべてのページ、奇数ページのみ、偶数ページのみを印刷できます。

.topic 204
複数部数のドキュメントを1部ずつの組で印刷します。

.topic 205
ドキュメントをファイルに出力します。

.topic 207
ドキュメントウィンドウの背景色を選択します。

.topic 208
サムネイルの背景色を選択します。

.topic 209
フォントの色を選択します。

.topic 210
選択すると、すべてのサーバメッセージを表示します。

.topic 214
プリンタの設定を表示します。

.topic 218
技術的には、証明書はデジタル証明書として知られ、メッセージ送信者またはドキュメントの署名者の身元を認証するために使用可能な識別情報が含まれています。また、伝達されたメッセージまたはドキュメントの元の内容が改変されていないことの確認にも使用できます。証明書は認証局(CA)と呼ばれる信頼された第三者によって発行されます。

.topic 226
ここで指定したアプリケーションでドキュメントを開くことができます。

.topic 227
アプリケーションに渡す一般的なパラメータを入力できます。

.topic 228
選択したタブおよび目的ごとにコンピュータに保存されている証明書のリストを表示します。

.topic 229
証明書を追加します。

.topic 230
使用しているコンピュータから証明書を削除します。

.topic 231
証明書を表示します。

.topic 232
ウィンドウを閉じます。

.topic 233
コンピュータにインストールされているアプリケーションを選択します。

.topic 234
保存する添付ファイルを選択します。

.topic 235
保存するすべてのファイルを選択します。

.topic 236
ファイルを保存するフォルダを選択します。

.topic 237
ファイルを保存するパスを入力します。

.topic 238
選択したファイルを保存します。

.topic 239
OXBを介してWebブラウザ内でOXR,OPRを開きます。

.topic 243
ページの振り分けの細かい条件を設定する拡張設定ダイアログを開きます。

.topic 245
クリックするとプリンタ機種を表示します。

.topic 246
テンプレート ドキュメント名を表示します。 レイアウト ドキュメントに含まれる全てのレイアウトを一覧表示します。 1ページ目のトレイ 最初の１ページ目を印刷するプリンタおよび用紙トレイを指定します。利用可能な全てのプリンタから用紙トレイを一覧表示し、そこから選択できます。 他のページのトレイ ２ページ目以降を印刷するプリンタおよび用紙トレイを指定します。利用可能な全てのプリンタから用紙トレイを一覧表示し、そこから選択できます。 拡張モジュール クリックすると、より多くのプリンタプロパティを選択することができます。

.topic 247
クリックすると設定をクリアします。

.topic 248
クリックすると指定した設定を保存します。

.topic 249
クリックすると拡張設定を閉じます。

.topic 250
----------

.topic 251
印刷拡張名を表示します。

.topic 252
----------

.topic 253
選択した画像を枠に合わせて表示します。

.topic 254
印刷拡張の説明を表示します。

.topic 257
この項目に対応するヘルプ トピックはありません。

.topic 265
直接印刷後にドキュメントを削除する機能を有効／無効に指定するために使用します。

.topic 266
プロキシサーバのアドレスとポートを設定する「インターネットのプロパティ」ダイアログを呼び出します。

.topic 267
タイムスタンプの有効期限が切れたかどうか等、タイムスタンプのステータス情報を提供します。

.topic 268
タイムスタンプ生成時間をUTCで提供します。

.topic 269
タイムスタンプされた現在のドキュメントのパスを表示します。

.topic 270
タイムスタンプトークン(TST)ファイルの場所を提供します。

.topic 271
タイムスタンプ局のポリシーオブジェクトIDを表示します。

.topic 272
タイムスタンプトークンのバージョンを表示します。

.topic 273
タイムスタンプ生成用のハッシュアルゴリズムを表示します。

.topic 274
タイムスタンプされたデータのハッシュ値を表示します。

.topic 275
タイムスタンプ局によりタイムスタンプトークンに割り当てられたシリアル番号を表示します。

.topic 276
タイムスタンプ生成中の順序性が守られたかどうかを表示します。

.topic 277
タイムスタンプ署名時からの時間偏差を表示します。

.topic 278
リクエスト・レスポンス間の適時性を確認するための乱数を表示します。

.topic 279
タイムスタンプ局の識別情報を表示します。

.topic 280
時刻監査証明書(TAC)のバージョンを表示します。

.topic 281
時刻監査証明書(TAC)のシリアル番号を表示します。

.topic 282
時刻監査証明書(TAC)の有効期間の表示

.topic 283
時刻監査証明書(TAC)の発行先情報を表示します。

.topic 284
時刻監査証明書(TAC)のハッシュ値を表示します。

.topic 285
ハッシュ関数の識別子を表示します。

.topic 286
ハッシュ関数の名前を表示します。

.topic 287
ハッシュ関数のハッシュ値のビット長を表示します。

.topic 288
時刻監査証明書(TAC)の発行者情報を表示します。

.topic 289
時刻監査証明書(TAC)の署名値を表示します。

.topic 290
署名に使われたアルゴリズムのオブジェクト識別子を表示します。

.topic 291
署名アルゴリズム識別子に定義されたアルゴリズムの名前を表示します。

.topic 292
署名値のビット長を表示します。

.topic 293
オフセット値を秒単位で表示します。

.topic 294
ネットワーク遅延を秒単位で表示します。

.topic 295
時刻監査情報をUTCで表示します。

.topic 296
監査時刻の有効期限をUTCで表示します。

.topic 297
時刻監査のポリシー識別子を表示します。

.topic 298
別個のWindows証明書アプレットによってタイムスタンプ証明書を参照できます。

.topic 299
「TimeStamp の詳細」ダイアログを閉じます。


OPRO X Designer

OPRO X Designer(OXD)はテンプレート設計ツールです。このツールを使用して、OXSで生成する様々なドキュメントやレポートを開発できます。


OPRO X Server

OPRO X Server(略称OXS)は、ウェブ対応のマルチ電子ドキュメント生成帳票サーバです。ウェブ上でのPDF生成、各種データベースとの連携はもちろん、生成したドキュメントをプリンタから直接印刷したり、メールやFAXで配信したり、といったことが可能です。アプリケーションからは、製品の一部であるCGIもしくはサーブレットに対するHTTPリクエストによって呼び出すことができます。URL一本で呼び出せますので、既存のシステムにも容易に組み込むことができ、疎結合で独立したレポートサーバとして利用できます。

出力するドキュメントのテンプレート開発には、専用のGUI開発ツールOPRO X Designerを使用します。画面上に様々な機能を持ったコンポーネント(テキスト、画像、罫線、バーコード、署名、フォームなど)を配置し、プレビュー(OPR、PDF、DocuWorks, HTML)しながら開発を進めることが可能です。OPRO X Designerで作成したひとつのテンプレートから、リクエストパラメータをかえるだけで帳票出力シーンに合わせた最適なドキュメント形式でドキュメントの生成・配信を行うことができます。

主な特徴


拡張設定

「拡張設定」はドキュメント印刷時の追加設定です。様々なサイズの印刷指定、多様なレイアウトを持ったドキュメントなどを、特定のプリンタ機種毎に印刷したり、トレイを指定して印刷出力先を指定することができる大変有効な機能です。

「プリンタ機種で指定する」
このオプションがチェックされている場合は、プリンタ機種名で設定を維持し、未チェックの場合には、プリンタ名で設定を維持します。従って、設定はプリンタ名とプリンタ機種により保存されます。
「テンプレート」
ドキュメント名を表示します。「ワイルドカード」オプションは、名前の類似したドキュメントをまとめて指定するために使います。類似する名前の部分以外をワイルドカードで指定すると、条件に一致するすべてのドキュメントが指定されます。
「レイアウト」
ドキュメントに含まれるすべてのレイアウトを一覧表示します。重複するレイアウトは表示しません。
1ページ目のトレイ
最初の1ページ目を印刷するプリンタ、および、用紙トレイを指定します。利用可能なすべてのプリンタから用紙トレイを一覧表示し、そこから選択できます。
他のページのトレイ
2ページ目以降を印刷するプリンタ、および、用紙トレイを指定します。利用可能なすべてのプリンタから用紙トレイを一覧表示し、そこから選択できます。
「拡張モジュール」
トレイを選択する以外の方法で、より多くのプリンタ プロパティを選択できます(「印刷拡張モジュール」を参照)。
「クリア」
設定内容をクリアします。
「保存」
同じドキュメントを開いた際、同じ設定を利用できるように、設定内容を保存します(「プリンタ機種で指定する」を参照)。
「閉じる」
拡張設定を閉じます。

印刷拡張モジュール

このオプションでは、さらに多くのプリンタ プロパティを追加することができます。

プリンタ機種名がウィンドウ上部に表示されます。サポートされる印刷拡張一覧と、その中から１つだけ選択できるチェック オプションが表示されます。

「プロパティ」
プリンタのプロパティ設定機能を呼び出します。

「印刷拡張モジュール」を表示するには

  1. 「拡張設定」ダイアログで「拡張設定モジュール」の「...」ボタンをクリックします。


データの読込

「データの読込」オプションは、電子フォームの入力データをOFDファイルから読み込みます。

フォームに入力データを読み込むには

  1. 電子フォームと「OFD I/O」コンポーネントをもつOPR/OXRドキュメントを開きます。
  2. 電子フォーム上で右クリックし、現れたメニューの「データの読込」オプションを選択します。
  3. 「開く」ダイアログで、フォームの入力データをもつOFDファイルを選択します。

※電子フォームの入力データを保存したOFDファイルをあらかじめ用意しておく必要があります。

参照：OFD、データの保存


データの保存

「データの保存」オプションは、電子フォームに入力されたデータをOFDファイルとして保存します。

フォームに入力されたデータを保存するには

  1. 電子フォームと「OFD I/O」コンポーネントをもつOPR/OXRドキュメントを開きます。
  2. 電子フォーム上で右クリックし、現れたメニューの「データの保存」オプションを選択します。
  3. 「保存」ダイアログでファイル名を入力して、OFDファイルを保存します。

※「データの保存」オプションは、「InterfaceGroup」コンポーネント内に「OFD I/O」コンポーネントが含まれる場合にのみ使用可能となります。

参照：OFD、データの読込